SageTV Community  

Go Back   SageTV Community > General Discussion > General Discussion

General Discussion General discussion about SageTV and related companies, products, and technologies.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-09-2003, 01:22 PM
Narflex's Avatar
Narflex Narflex is offline
Sage
 
Join Date: Feb 2003
Location: Redondo Beach, CA
Posts: 5,456
Easy Performance Increase for Hauppauge Users

I just found a nifty registry setting that cut my CPU usage in half and made the deinterlacing beautiful when using the Intervideo NonCSS Video Decoder for Hauppauge as the selected Video Decoder in SageRecorder/SageTV.

I'd highly recommend trying this if you have the Hauppauge hardware; I'd also like to hear results. The only requirement is that your video card has some sort of MPEG2 acceleration. Nearly all of them do now.

Just change these registry settings to 1 while SageTV is asleep or you're not watching video in SageRecorder, or they both are shutdown:

HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec\Dxva
HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec\Hwmc

For the newer decoders the location is:

HKLM\Software\IviSDK4Hauppauge\Common\VideoDec\Dxva
HKLM\Software\IviSDK4Hauppauge\Common\VideoDec\Hwmc
__________________
Jeffrey Kardatzke
Google
Founder of SageTV
Reply With Quote
  #2  
Old 04-09-2003, 02:13 PM
edmc edmc is offline
Sage Aficionado
 
Join Date: Feb 2003
Location: Pleasanton, CA
Posts: 325
Another thing that helped me was to decrease the quality a notch (from 3GB/hr down to 2GB/hr). Can't tell the difference on my 480p LCD RPTV and it operates smoother from my cursory viewing.

I'm running a "lowly" 1.6GHz P4. Maybe with these settings, I'll be able to go back up to the 3GB/hr quality...

Will post my results later tonight...
Reply With Quote
  #3  
Old 04-09-2003, 02:21 PM
SHS's Avatar
SHS SHS is offline
Moderator
 
Join Date: Mar 2003
Location: Vinita, Oklahoma
Posts: 3,365
Send a message via ICQ to SHS
Keep mind in that this only useful with some video card not all.
The video must support DxVA (DirectX Video Acceleration) and HwMC (Hardware Motion Compensation) Like let say nVidia GeForce4 Go/MX Series cards

Some other stuff
MicroSoft DirectX
VPE (Video Port Extensions)
DxVA (DirectX Video Acceleration)

nVidia
VPE (Video Processing Engine) Think DScaler

MPEG Stuff
All Video support start with first SVGA card.
CSC (Color Space Conversion)

Some support one or two or all
MC (Motion Compensation) or HwMC (Hardware Motion Compensation)
iDCT (inverse Discrete Cosine Transform)
IQ (Inverse Quantization)

No video card support this
VLD (Variable Length Decode)

Last edited by SHS; 04-09-2003 at 02:29 PM.
Reply With Quote
  #4  
Old 04-09-2003, 02:29 PM
JJarmoc JJarmoc is offline
Sage Aficionado
 
Join Date: Apr 2003
Location: Hanover Park, IL
Posts: 265
Doesn't DxVA also require Directx 9?
__________________
---
There are 10 kinds of people in the world, those who understand binary, and those who don't.
Reply With Quote
  #5  
Old 04-09-2003, 02:31 PM
Narflex's Avatar
Narflex Narflex is offline
Sage
 
Join Date: Feb 2003
Location: Redondo Beach, CA
Posts: 5,456
Nope. DirectX9 is not required for DXVA.
__________________
Jeffrey Kardatzke
Google
Founder of SageTV
Reply With Quote
  #6  
Old 04-09-2003, 02:38 PM
SHS's Avatar
SHS SHS is offline
Moderator
 
Join Date: Mar 2003
Location: Vinita, Oklahoma
Posts: 3,365
Send a message via ICQ to SHS
DxVA require DirectX 8 and Video drv that support it.

Last edited by SHS; 04-09-2003 at 02:42 PM.
Reply With Quote
  #7  
Old 04-09-2003, 03:40 PM
edmc edmc is offline
Sage Aficionado
 
Join Date: Feb 2003
Location: Pleasanton, CA
Posts: 325
DxVA is also required for HD S/W Decoders like DViCo's FusionHDTV I (unless you are willing to live with quarter-resolution and have a very fast CPU).
Reply With Quote
  #8  
Old 04-09-2003, 08:41 PM
edmc edmc is offline
Sage Aficionado
 
Join Date: Feb 2003
Location: Pleasanton, CA
Posts: 325
I did discover that I was set to Default for the Video/Audio Renderers. I switched to the InterVideo NonCSS Video/Audio Renderers - no apparent difference so I guess the "Merit System" was already selecting those....

But I did not see a repeatable difference with flipping these settings. It seems the TaskMgr's Performance Numbers are very content dependent. I suppose I could playback the same content of a pre-recorded program, but even that would be hard to get accurate readings. But in no way did I see a 50% reduction in CPU Utilization.

In any event, watching a colorful music video in either mode consumed around 30% of my 1.6GHz Pentium4 CPU.
Reply With Quote
  #9  
Old 05-01-2003, 04:44 PM
laurenglenn's Avatar
laurenglenn laurenglenn is offline
Sage Expert
 
Join Date: Mar 2003
Location: Levittown, PA
Posts: 601
Send a message via AIM to laurenglenn Send a message via MSN to laurenglenn
I gave it a try and noticed that the video seems smoother in terms of frame rate. It just looked like I was watching regular TV. No problems as of yet.

BTW, I'm running XP with an Athlon 1400 and 768MB of RAM. The video card is a Radeon 8500LE and I have a PVR-250
Reply With Quote
  #10  
Old 05-26-2003, 06:06 AM
comprat comprat is offline
Sage User
 
Join Date: May 2003
Posts: 35
Re: Easy Performance Increase for Hauppauge Users

Quote:
Originally posted by Narflex
I just found a nifty registry setting that cut my CPU usage in half and made the deinterlacing beautiful when using the Intervideo NonCSS Video Decoder for Hauppauge as the selected Video Decoder in SageRecorder/SageTV.

I'd highly recommend trying this if you have the Hauppauge hardware; I'd also like to hear results. The only requirement is that your video card has some sort of MPEG2 acceleration. Nearly all of them do now.

Just change these registry settings to 1 while SageTV is asleep or you're not watching video in SageRecorder, or they both are shutdown:
HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec\Dxva
HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec\Hwmc

Let me know how it goes, I just found this out a little while ago.

Thanks,
I went to try this, but there is no "Intervideo" folder on my computer in the registry paths you gave. I am running WinXP and have a PVR-350 card. What gives?

Thanks!
Reply With Quote
  #11  
Old 05-26-2003, 09:45 AM
laurenglenn's Avatar
laurenglenn laurenglenn is offline
Sage Expert
 
Join Date: Mar 2003
Location: Levittown, PA
Posts: 601
Send a message via AIM to laurenglenn Send a message via MSN to laurenglenn
Re: Re: Easy Performance Increase for Hauppauge Users

Quote:
Originally posted by comprat
I went to try this, but there is no "Intervideo" folder on my computer in the registry paths you gave. I am running WinXP and have a PVR-350 card. What gives?

Thanks!
Go to this site ( http://www.hauppauge.com/html/sw_pvr_250.htm ) and download the newest version of the Hauppauge Video Decoder. Hopefully that will install the WinDVD decoder and the registry keys for you.

Lauren
Reply With Quote
  #12  
Old 05-28-2003, 08:30 AM
comprat comprat is offline
Sage User
 
Join Date: May 2003
Posts: 35
Re: Re: Re: Easy Performance Increase for Hauppauge Users

Quote:
Originally posted by laurenglenn
Go to this site ( http://www.hauppauge.com/html/sw_pvr_250.htm ) and download the newest version of the Hauppauge Video Decoder. Hopefully that will install the WinDVD decoder and the registry keys for you.

Lauren
Thanks laurenglenn, that did the trick! I probably should have thought of that first, but I just figured I already had it installed. I was fiddling with the Hauppauge software trying to get my scheduler to work right. Guess I must of uninstalled it then. That was before I found out about SageTV.

Anyway, I changed the settings but it did not seem to decrease my CPU usage. It still hovers around 35-40%, although my video is output via my PVR-350 instead of my videocard. Hopefully we will be able to disable the local video through SageTV soon. I am running WinXP, Athlon XP 1800, 768MB RAM, Hauppauge PVR-350, Ti4200 Nvidia GeForce 4.

comprat
Reply With Quote
  #13  
Old 10-20-2003, 12:11 AM
jw1248 jw1248 is offline
Sage User
 
Join Date: Oct 2003
Posts: 5
make sure you check if registry settings exist for new version

mine had both old and new registry settings.
changing the old registry settings had no effect.
after changing new registry settings, got a 33% cpu decrease

for geforce2 and p4 2.4

sagetv 45% cpu
w/ hack 35% cpu
no sagetv 15% cpu

overall a 33% decrease
Reply With Quote
  #14  
Old 11-11-2003, 07:11 AM
ditohead ditohead is offline
Sage User
 
Join Date: Oct 2003
Posts: 11
I'm a recent convert to Sage and the PVR-250. I just received my hardware bundle from Frey yesterday, so I'm still fumbling around trying to figure stuff out. Previously I had the ATI 8500DV. I was not at all pleased with its picture quality or the fact that my PC was pretty much useless because of CPU utilization when trying to record something with it. That's when I found the great info here and decided to give Sage and the PVR-250 a try. After getting everything hooked up and installed last night from the bundle I can say that the picture quality is awesome compared to what I had before and my computer is still very useable even while watching/recording.

The reason I'm responding here is because I tried the hack mentioned above but did not see any difference on my system. I have a Pentium 4 1.6 with 256mb ram and nvidia card (I'll have to look up the model number later). My cpu utilization hovers around 60% with only SageTV running both with and without the hack. I see a post from edmc above where he has the same cpu with much lower cpu utilization, so my problem must not be the cpu. Any other ideas on how I could lower my cpu utilization?
Reply With Quote
  #15  
Old 11-11-2003, 08:11 AM
dkardatzke's Avatar
dkardatzke dkardatzke is offline
SageTV Co-Founder
 
Join Date: Feb 2003
Location: Chicago, IL
Posts: 1,220
I'm assuming you have the Intervideo NonCSS decoder selected in Detailed Setup > Video? If so, have you tried the different Modes, A,B,C,D to see if there's any difference?
__________________
Dan Kardatzke, Co-Founder
SageTV, LLC
Reply With Quote
  #16  
Old 11-11-2003, 08:16 AM
ditohead ditohead is offline
Sage User
 
Join Date: Oct 2003
Posts: 11
Thanks for the quick follow-up.

Yes, I have the Intervideo NonCSS decoder selected in Detailed Setup. I have not yet tried the different modes but will give them a try tonight. I'll let you know what happens.
Reply With Quote
  #17  
Old 11-11-2003, 08:13 PM
ditohead ditohead is offline
Sage User
 
Join Date: Oct 2003
Posts: 11
I tried the different modes this evening both with and without the hack and none of them made any difference. In fact, with the hack in place and trying the different modes I received the error message "There was an error with the MPEG-2 video setup. Failed connecting MPEG2 video stream using DirectX Video Acceerlation media type. ErrCode=0x80070057" and had audio but no video.

Don't know if this makes any difference or not... I am running Windows XP Professional. For rendering filter if I use "Overlay" sometimes I only see a small portion of what is being broadcast and do not see any more of it even if I resize the window. Other times with "Overlay" for the rendering filter I see the entire screen. With "Overlay", my CPU utilization hovers around 40%, but obviously it is a problem if I do not consistently see the full screen. If I use the "Default (Uses VMR on XP)" rendering filter I consistently see the full screen but that's when my utilization hovers around 60%.
Reply With Quote
  #18  
Old 11-11-2003, 08:17 PM
ditohead ditohead is offline
Sage User
 
Join Date: Oct 2003
Posts: 11
Should have mentioned in my previous post that I have ONLY tried the hack with the "Default (Uses VMR on XP)" rendering filter. I have not yet tried it with the "Overlay" rendering filter since I have had some inconsistency with that one.
Reply With Quote
  #19  
Old 11-12-2003, 08:12 AM
Mike Young Mike Young is offline
Sage Aficionado
 
Join Date: Sep 2003
Posts: 287
From my experience, once you enable the Hack the intervideo will ONLY work in VMR mode. Dont know if that holds true for your setup, I have also found that only Default mpeg mode and default interlacing will work, but the quality is real nice and CPU util. should be in the 10% range.
also make sure you dont have both sets of registry keys and edited only one :

HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec
\Dxva
HKLM\Software\Intervideo\Custom\Hauppauge\VideoDec
\Hwmc

For the newer decoders the location is:

HKLM\Software\IviSDK4Hauppauge\Common\VideoDec\Dxv
a
HKLM\Software\IviSDK4Hauppauge\Common\VideoDec\Hwm
c


Also, I have noticed sometimes you have to close Sage down and restart to get the setting to take, particularly when you have changed codec or rendering mode.
Reply With Quote
  #20  
Old 11-12-2003, 09:45 PM
ditohead ditohead is offline
Sage User
 
Join Date: Oct 2003
Posts: 11
Thanks for the input. Yes, I checked for both sets of reg keys but only had the new ones. I don't know what I was doing the past couple of days that had the "overlay" rendering filter behaving inconsistently, but now it is not giving me any problems. And my cpu utilization now hovers around 30% while watching live or recorded TV with the rendering filter set to "overlay" and with the hack applied when. The "Default (Uses VMR on XP)" setting still gives me around 60% utilization when watching live or recorded TV. I have also tried all of the different "mode" options with the "overlay" rendering filter (no errors for any of them) but none of them made any difference. 30% is a lot better than 60% but I'd still like to get it lower.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.