SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Linux (http://forums.sagetv.com/forums/forumdisplay.php?f=38)
-   -   Multiple Installed, how to select Java Version for Sage Use (http://forums.sagetv.com/forums/showthread.php?t=66737)

phantomii 05-30-2021 05:14 AM

Multiple Installed, how to select Java Version for Sage Use
 
I have two versions of Java installed on my SageTV Server (ubuntu 18). THey are versions 11 and 8. 11 was installed when I built the server but wanted to switch to 8 to test some things. I found this command line and it appears to work.

sudo update-alternatives --config javac

After running this I see these results:

sagetv@SageTV-Server:~$ sudo update-alternatives --config javac
[sudo] password for sagetv:
There are 2 choices for the alternative javac (providing /usr/bin/javac).

Selection Path Priority Status
------------------------------------------------------------
0 /usr/lib/jvm/java-11-openjdk-amd64/bin/javac 1111 auto mode
1 /usr/lib/jvm/java-11-openjdk-amd64/bin/javac 1111 manual mode
* 2 /usr/lib/jvm/java-8-openjdk-amd64/bin/javac 1081 manual mode

Press <enter> to keep the current choice[*], or type selection number:

Even though it appears that Java 8 is the active version, when looking at the info tab in the sage client GUI on the Android Mini Client, it still shows version 11.11. Is there something else that need to be done to get this to switch???

stuckless 05-30-2021 05:49 AM

javac the java "compiler" so what you want is just 'java'.

phantomii 05-30-2021 06:57 AM

Thanks so much for the quick response.


All times are GMT -6. The time now is 06:05 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.