SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Software (http://forums.sagetv.com/forums/forumdisplay.php?f=6)
-   -   SageTV Failed To Start Recording - Many Errors In Log (http://forums.sagetv.com/forums/showthread.php?t=65426)

peternm22 03-04-2018 12:32 PM

SageTV Failed To Start Recording - Many Errors In Log
 
2 Attachment(s)
I had something scheduled to record at 5:05am this morning. My SageTV server woke up a few minutes before the recording, but the recording never occurred. SageTV kept the computer "awake" despite not recording anything.

I went to the web interface, and it still listed the movie as the Next Upcoming Recording (despite it being hours after it was suppose to finish):

https://forums.sagetv.com/forums/att...1&d=1520188237


I opened a SageTV client on Windows and checked the schedule there, but it was completely blank.

I then went to the service control and tried to stop the SageTV service and it failed to do that. I went to the Windows task manager and attempted to stop sagetvservice.exe there, but it gave me an access denied message.

I restarted the computer, and SageTV appears to be functioning again.

My SageTV server is Windows 10 Home 64 bit (current on patches), and I'm running SageTV 9.1.7.0

I've attached the log file. Can anyone see what went wrong?

Thanks.

peternm22 03-08-2018 08:05 PM

1 Attachment(s)
This just happened again. Same error message in the log:

"ERROR - Seeker has been hung for more than 60 seconds...system appears deadlocked...dumping thread states"

This is the 2nd time in less than a week that my SageTV completely hung on me.

Can anyone look at the logs and see if they can tell what is happening?

The situation is the same as last time. The computer woke from sleep 5 minutes before a scheduled recording (at 3pm), and then the error messages start showing up.

I've attached the most recent log file.

This has happened twice in a short period, so I'm guessing it's going to keep occurring.

I'm running Java 1.8 update 131 (same version I've been using since Summer of last year when I built this system).

Another interested side effect, is that when the hang occurs, it prevents the PC from going to sleep again.

peternm22 04-15-2018 02:56 PM

1 Attachment(s)
Another day, another SageTV lockup.

I've stopped using sleep mode on the server, since that seemed to be causing the problems. Instead, I just power down the server each night and I have a WOL script that turns it back on the next day.

Today, I turned on my HD300 and it was just frozen on the startup screen. I went to the web interface, and there was some java error next to the upcoming recording section (I should have screen capped it, but I didn't).

I unplugged the HD300, and then went to the SageTV service control to shut down the SageTV service. It sat for a while before eventually saying it was taking too long to respond. I ended the SageTV service in task manager, and then started it again.

I think this lock up is different than the others. From the log, it looks like everything was running fine until the HD300 tried to connect.

See attached for the log file.

Gathering from the lack of responses to this thread so far, it seems like the SageTV user base continues to dwindle. If anyone is ready this who knows a bit of the inner workings of SageTV, could you take a look at the log files I've been posting?


All times are GMT -6. The time now is 04:28 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.