SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Software (http://forums.sagetv.com/forums/forumdisplay.php?f=6)
-   -   Trouble importing old MPG files (http://forums.sagetv.com/forums/showthread.php?t=604)

rrussell 05-20-2003 06:38 AM

Trouble importing old MPG files
 
So as a result of switching to SageTV, I have a couple of dozen old MPG files from my WinTV days, named things like "Show001.mpg", "Show002.mpg", "Show003.mpg" etc.

I plopped them into the "import" directory, and the prog dutifully imported two of them into the library. But, no matter what I do, it won't import the rest:

I've tried moving them and resetting the import dir option.

I've tried moving them out and back into the same import dir.

I've tried it one at a time, and all at once.

Any suggestions? Is the naming convention an issue? It doesn't seem to be a date/timestamp thing...

??

R

Narflex 05-20-2003 07:06 PM

If you're using the beta version, the log file will tell you why it rejected any imports. Just look for the file name. Let me know why, and then I can help more. :)

rrussell 05-21-2003 06:07 AM

Roger that. I'm using 1.2.8 so no log. I'll see if I can't get to it this weekend (or, hopefully, sooner).

rrussell 05-21-2003 03:33 PM

1 Attachment(s)
Aha! I got to it sooner than this weekend.


I'm attaching the txt file.

A quick search for "import" led me to lines like:

Wed 5/21 17:19:38.835 testFile=D:\Program Files\Frey Technologies\SageTV\Import\1000000 Years BC.MPG
Wed 5/21 17:19:39.065 MF Failed Init:MediaFile[FA[BAD AIRING] host=pvr D:\Program Files\Frey Technologies\SageTV\Import\1000000 Years BC.MPG, Seg0[Sun 3/2 15:02:00.820-Sun 3/2 15:02:00.820]]

Are the mpgs corrupt?

LMK what you found...

Thanks!
Rob

Narflex 05-21-2003 06:39 PM

If you open one of those MPG files in WMP what's the duration on it?

That failure occurs when the file is reported as being of zero length duration (so it assumes the MPG file's corrupted).

rrussell 05-21-2003 07:26 PM

Well, for example, 10000000 years BC reports 2:02:16 in length.

The "Enterprise" episodes all say somewhere around 1 hour, which is right where they should be.

Can I send you one somehow? They're sizeable, as you can imagine.

Narflex 05-22-2003 05:47 PM

How about you just cut off the first couple minutes of one, and then try to import that. It it still fails, and WMP reports a couple minute duration, you can then send me that file easily.

rrussell 05-23-2003 06:43 AM

Sure... um.

Care to recommend a tool for that?

Narflex 05-23-2003 11:38 AM

1 Attachment(s)
Here's one I wrote for it. Just put the .class file in the same folder as what you want to copy.

Then go to DOS, cd into that directory and type:

java HeadCopy sourceFile.mpg destinationFile.mpg 200000

That'll copy the first 200000 bytes from sourceFile.mpg to destinationFile.mpg

rrussell 05-26-2003 11:59 AM

OK, done - still didn't import.

The (apparently) relevant segment of SageTV_0.txt reads:

Mon 5/26 13:42:06.220 MARK 1 currRecord=null enc=Hauppauge WinTV PVR PCI II Capture clients=[]
Mon 5/26 13:42:06.230 Seeker in AUTOMATIC mode nextRecord=A[193015,192256,"Treasure Makers",14902@0527.10:30,30] nextTTA=74873780
Mon 5/26 13:42:06.230 newRecord=null
Mon 5/26 13:42:06.230 NOTHING TO RECORD FOR NOW...
Mon 5/26 13:42:06.230 VF processing job null nPlayin=false
Mon 5/26 13:42:06.230 VF thread is now waiting for 0:00:00.000
Mon 5/26 13:42:06.531 testFile=D:\Program Files\Frey Technologies\SageTV\Import\enterprise_clipped.mpg
Mon 5/26 13:42:10.576 UIManager.gotoSleep(false) isTaskbar=true
Mon 5/26 13:42:10.636 setUI(sage.t@126ecd2)
Mon 5/26 13:42:12.429 setUI(sage.t@243e61)
Mon 5/26 13:42:12.559 MF Failed Init:MediaFile[FA[BAD AIRING] host=pvr D:\Program Files\Frey Technologies\SageTV\Import\enterprise_clipped.mpg, Seg0[Mon 5/26 13:41:51.008-Mon 5/26 13:41:51.008]]
Mon 5/26 13:42:12.559 testFile=D:\Program Files\Frey Technologies\SageTV\Import\HeadCopy.class
Mon 5/26 13:42:14.752 MF Failed Init:MediaFile[FA[BAD AIRING] host=pvr D:\Program Files\Frey Technologies\SageTV\Import\HeadCopy.class, Seg0[Thu 3/27 13:47:28.000-Thu 3/27 13:47:28.000]]
Mon 5/26 13:42:16.795 Seeker waiting for 1245 mins.

At this point, WMP doesn't recognize any length in that file, though, or play anything beyond the first couple of frames, it seems. I clipped the first 200K bytes as suggested from enterprise001.mpg. Also tried with a 2meg chunk. Also tried changing directories. Nothin's working... yet! :)

Do you need the whole log file?

Thanks!
Rob

rrussell 05-27-2003 01:05 PM

Quote:

Originally posted by Narflex
How about you just cut off the first couple minutes of one, and then try to import that. It it still fails, and WMP reports a couple minute duration, you can then send me that file easily.
Actually, so - it is still failing to import, but WMP is reporting no duration. What can I do next?

Narflex 05-27-2003 07:56 PM

Email that small MPG file to support@freytechnologies.com that's what I need.

Thanks,

rrussell 05-28-2003 07:53 AM

Will do. I'll try to get to it tonight, or next monday at the latest. (ha)

FWIW I was looking through those old mpg files and none of them are ones that I really NEED to keep. If this has not yet become an o-fish-al bug that you want to fix, I'm happy to let it drop.

OTOH if you wanna fix it (and who wouldn't) I'm also happy to send you the file.

Narflex 05-28-2003 03:02 PM

No one else is currently reporting a problem with it. But a bug is a bug and should be fixed regardless of it currently affects anyone. Send me the file when you get around to it.

rrussell 05-29-2003 06:18 AM

OK, it is on its way. Enjoy! (?)

Lester Jacobs 06-07-2003 06:44 PM

I'm also having problems importing files. I put two files in the import directory, stopped and restarted SageTV and the files were not imported. These same files play fine in PowerDVD and can be read and processed by Ulead without any problems. They are SVCD compliant mpeg-2 files.


Any ideas on what could be wrong?

UPDATE: Just tried SageRecorder and it can see and play the files. This seems to prove that the files themselves are not corrupt. Therefore I don't know why SageTV is rejecting the files.

Lester

Omegadsl 06-08-2003 08:17 AM

Quote:

Originally posted by Lester Jacobs
I'm also having problems importing files. I put two files in the import directory, stopped and restarted SageTV and the files were not imported. These same files play fine in PowerDVD and can be read and processed by Ulead without any problems. They are SVCD compliant mpeg-2 files.


Any ideas on what could be wrong?

UPDATE: Just tried SageRecorder and it can see and play the files. This seems to prove that the files themselves are not corrupt. Therefore I don't know why SageTV is rejecting the files.

Lester

Is this with all mpeg-2 files or only the ones that are SVCD compliant? For me, it's all mpeg-2 files that won't import.

Narflex 06-08-2003 01:32 PM

Create this registry variable as a DWORD and see if any error messages come up when you run SageTV:
HKLM\Software\Frey Technologies\Common\consolewin=1

Lester Jacobs 06-08-2003 08:55 PM

Quote:

Originally posted by Narflex
Create this registry variable as a DWORD and see if any error messages come up when you run SageTV:
HKLM\Software\Frey Technologies\Common\consolewin=1

I get the following when I start up SageTV (with or without files in the import directory;

Sun 6/8 22:52:18.357 Failed to find:\\?\display#ntativrv26#5&2f4fd774&0&80000008&01&00#

Cheers
Lester

Omegadsl 06-09-2003 09:43 AM

Jeff, are all three of us having the same problem or are different things messed up on each of our systems? I want to help find what is causing this but if it can not be fixed I might attempt a clean install (of XP, etc.). The reason I am reluctant to do that, is because I have no idea what caused this and I am not sure it won't happen again (since I'll probably install the conflicting software again).


All times are GMT -6. The time now is 08:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.