SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageMC Custom Interface (http://forums.sagetv.com/forums/forumdisplay.php?f=41)
-   -   Video Library Cover Art Refresh (http://forums.sagetv.com/forums/showthread.php?t=36610)

Nutball 11-01-2008 05:10 PM

Video Library Cover Art Refresh
 
I recently updated my SageTV and SageMC versions to 6.4.8.184 and 6.3.8 respectively.

Since the switch, my video library acts odd. When I select "my videos" (all the files in my videos are ripped DVDs by the way) I see a graphic of a DVD with the DVD logo momentarily before the cover art pops in. This usually takes a couple of seconds.

As I scroll down the list of movies, this slow replacement of each dvd graphic with a cover art continues.

However, if I scroll back up the list to the cover art images that had previously been loaded, the simple DVD graphic is back and the cover art must be reloaded.

With my old version of SageTV and SageMC this process of loading the cover art only happened once after a reboot of the computer (or extender). Subsequent viewings of the "my videos" library kept the cover art images visible.

This behavior does not occur with the "my pictures" or "My music" libraries.

This is probably a simple setting somewhere but I am stumped.

Anybody have any ideas?

Thanks,
NB

Brent 11-01-2008 05:32 PM

Try this.

Go to the SageMC settings page

Select SageMC>Enhancements>Cache Album Art
and select "enabled"

Exit to the home screen and then shut down that SageTV instance (don't need to shut down SageTV Server) and it should cache the cover art thumbnails and load much faster after the first view. It does require more system memory to do this of course, but works very well as long as you have the system memory to spare.

Nutball 11-04-2008 05:00 PM

Didn't work
 
Thanks for the suggestion,

I checked my settings but I already had SageMC set to cache album art and it is still not working. I also tried increasing the size of the cache to no effect. I restarted SageTV several times as well to no avail. I also restarted the entire computer with no effect.

After some further checking, it seems that only about 64 DVD covers are sticking in memory. If I scroll down the library beyond about 64 movies, the early movies (for example those starting with the letter "A") will be removed from the cache.

Also, if I switch to "my music" and scroll through the music library, my DVD covers will be removed from memory.

Interestingly, I never see the CD album art load in. It always acts properly.

Anybody have any further guesses?

Thanks,
NB

Added Note: This effect happens both in SageMC and in the default stv. It started happening after the switch to 6.4.8.184

gplasky 11-05-2008 11:38 AM

Go into Settings-Customizations (I think) And find the OSD on screen time. Change it from a default of 1500 to somethuing like 5 or 1. The DVD covers will show immediately.

Gerry

Nutball 11-05-2008 05:09 PM

Victory...Thanks for the help
 
Genius!!!

FYI, You were correct about the settings location:

-Detailed Settings
-Customize
-Inactivity Timeout and OSD AutoHide

Thanks so much,
NB

QueOnda 11-05-2008 05:49 PM

This should be a sticky or in the sagemc manual. Is there one??

Brent 11-05-2008 05:55 PM

Quote:

Originally Posted by QueOnda (Post 313361)
This should be a sticky or in the sagemc manual. Is there one??

I agree - I didn't know how to do this completely. Nice tip Gerry!
Keep in mind this is really more of a SageTV overall tip as it applies to all STV's


There is a sticky post with SageMC tips and tricks
And a SageMC wiki that is a work in progress (mostly not done yet) - if you have time and want to contribute to the wiki please do. Its on my very long list of things to do. Needs to be simple to understand tips and instructions in the wiki of course.

I did add this tip to the wiki.

mickp 11-06-2008 03:06 AM

Quote:

Originally Posted by gplasky (Post 313263)
Go into Settings-Customizations (I think) And find the OSD on screen time. Change it from a default of 1500 to somethuing like 5 or 1. The DVD covers will show immediately.

Gerry

Thanks so much. This has been annoying me for the last two weeks.

Mick.

OferL 11-06-2008 06:41 AM

I have been living with this annoyence for months and thought it was due to sub par hardware....

THANK YOU!!!:jump:

Brent 11-09-2008 05:34 PM

Does this work with the HD100? It seems to slightly help, but still a little slow loading album art for large collections.

talbot3 11-10-2008 07:37 AM

It works on my PC client, server, but the images on the HD100 still load slowly for me.

KJake 11-15-2008 04:51 PM

Did this on my HD Extender today, THANK YOU! The thumbnails are there immediately now :)

KJake 11-15-2008 05:43 PM

Oh man, now I set the ui/enable_hardware_scaling_cache=true in my sage.properties and scrolling is tons faster!! I'm in love with my HD100 again!!! :D

popechild 12-08-2008 10:02 PM

I have nothing to add, but I'm replying so that in the future, when I have to re-install Sage and I can't figure out how to get this to work properly again, hopefully I'll at least think to search the forums for all the threads I've participated in and I'll stumble on the solution again.

Thank you, and the future me says thank you as well!

naburleson 12-09-2008 10:23 PM

Hello everyone that for the tip on loading cover art faster, but I have another question, and have look around for the answer, anyways I have video files(.avi type) in "My Videos" and I want to set the movie cover art as the thumbnail image, I have saved the imdb image after doing a search but it still gives me a thumbnail of the start of the video file, any help??? Thanks

VikingCrown 12-18-2008 07:14 PM

I have a question. I was trying to figure out why the DVD covers that were displaying looked a little fuzzy. I am using DVD Profiler(paid version), so my covers should be a nice high resolution, but when I look in the video_ts folders the folder.jpeg images are 176X252. So I deleted all the images and then re-imported my dvd's and refreshed the dvd profiler data and the images are re-created in the video_ts folders at the same lower resolution. Am I missing something? I did look in the directory where DVD Profiler stores the images and they are all much higher resolution. Please any help is much appreciated.

~ Brian

Rogue9 12-18-2008 10:32 PM

Quote:

Originally Posted by naburleson (Post 320825)
Hello everyone that for the tip on loading cover art faster, but I have another question, and have look around for the answer, anyways I have video files(.avi type) in "My Videos" and I want to set the movie cover art as the thumbnail image, I have saved the imdb image after doing a search but it still gives me a thumbnail of the start of the video file, any help??? Thanks

I have this working on my setup. You have to match the name of the video file (avi, mpg, etc) exactly. So if you have "Heroes - S01E02.mpg" then the thumbnail has to be "Heroes - S01E02.jpg" for it to work. Everything has to match except the file extension.

That's how I have mine setup. If it doesn't work after doing this, you may have to go into "Program Files\SageTV\SageTV\GeneratedThumbnails\" and delete the thumbnails associated with the shows you are creating the thumbnails for.

Naylia 12-19-2008 12:29 AM

Quote:

Originally Posted by VikingCrown (Post 323429)
I have a question. I was trying to figure out why the DVD covers that were displaying looked a little fuzzy. I am using DVD Profiler(paid version), so my covers should be a nice high resolution, but when I look in the video_ts folders the folder.jpeg images are 176X252. So I deleted all the images and then re-imported my dvd's and refreshed the dvd profiler data and the images are re-created in the video_ts folders at the same lower resolution. Am I missing something? I did look in the directory where DVD Profiler stores the images and they are all much higher resolution. Please any help is much appreciated.

~ Brian

I've noticed the same thing, need to ping the SageMC guys about it.

KJake 12-19-2008 07:01 AM

Quote:

Originally Posted by VikingCrown (Post 323429)
I have a question. I was trying to figure out why the DVD covers that were displaying looked a little fuzzy. I am using DVD Profiler(paid version), so my covers should be a nice high resolution, but when I look in the video_ts folders the folder.jpeg images are 176X252. So I deleted all the images and then re-imported my dvd's and refreshed the dvd profiler data and the images are re-created in the video_ts folders at the same lower resolution. Am I missing something? I did look in the directory where DVD Profiler stores the images and they are all much higher resolution. Please any help is much appreciated.

~ Brian

This is because the import uses the images from the DVD Profiler thumbnails folder.

VikingCrown 12-19-2008 09:56 AM

kjake,

that's interesting. i would think that the import would use the actual images and not the thumbnails. do you know of any way to change it?

KJake 12-30-2008 09:18 PM

I could change the DVDPro2Sage java to use the main image, but SageMC doesn't scale those images in the playback screen, so the HQ image will take up the entire screen when you first begin a movie, or pause it (or some other cases). I'll ping this for a bug fix / feature request for the next version of SageMC and when/if it gets put in, then I will definately change the Java code that copies the DVD cover.

voorhees 01-01-2009 06:40 PM

Brent and Gerry,

Thanks so much. This has really improved my WAF. :clap:


All times are GMT -6. The time now is 03:02 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.