SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Software (http://forums.sagetv.com/forums/forumdisplay.php?f=6)
-   -   service only accepting connections from localhost? (http://forums.sagetv.com/forums/showthread.php?t=37222)

Xytrix 11-29-2008 01:55 AM

service only accepting connections from localhost?
 
Hi,

I recently installed the 6.4.8 trial of SageTV Media Center on this PC, and 6.4.8 trial of SageTV Client on my laptop. The two computers are within the same local network and I've disabled the firewall for now, but I'm having problems getting the SageTV service to accept connections from the laptop. If I disable the service and just run SageTV.exe, then the laptop can connect just fine.

So far I've kept the "SageTV Server" option set to Enabled in the 'Detail Setup' menu and I've tried switching the service's user from LocalSystem to an administrator to no avail. If I start the service while SageTV.exe is closed, I can see that it is listening on ports 7818, 31099, and 42024. If I telnet to 42024 from the local machine, it'll connect, but from the laptop it won't respond. I can see on this machine that the laptop's connection request packets are coming through though.

The service will handle scheduled recordings in the background, so it seems to be working fine otherwise. Could there be something I missed in the setup?

Xytrix 11-29-2008 10:53 AM

Hmm, well boy is my face red. I disabled my personal firewall, but since this is a new server, forgot about the default Windows firewall. Looks like SageTV creates itself an exception in the Windows firewall exception list, but not for the service.

Hope no one wasted time on this one :x


All times are GMT -6. The time now is 04:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.