SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV for unRAID/Docker (http://forums.sagetv.com/forums/forumdisplay.php?f=59)
-   -   Recording Issues With HDPVR (http://forums.sagetv.com/forums/showthread.php?t=66573)

Striker:WG 11-07-2020 09:43 AM

Recording Issues With HDPVR
 
I'm continuing to notice issues with my HDPVR units especially around Live TV.

1. Sometimes the transition from one scheduled program to the next (same channel, continuous stream) just causes the playback to halt. I have to stop and start live playback to get the show going. Has anyone else experienced this?

2. Sometimes playback will just stop. I've specifically noticed this on CNN while trying to follow some of the election footage. If I watch direct on an STB, there will be a slight stutter in the video signal. I think this is tripping up the HDPVR. Other channels appear to be fine, this just seems to happen with CNN. Any suggestions on how to make it more resilient / recover from these kinds of stutters?

I had previously posted about some audio sync issues here: https://forums.sagetv.com/forums/showthread.php?t=66569 which I'm still trying to sort out as well.

Thanks in advance for any suggestions!

tvmaster2 11-07-2020 09:57 AM

Thank you, I thought I was nuts. My HDPVR is doing exactly this - while watching or recording live TV, the time counter stops shy of the hour mark, or scheduled, tv-guide program change. Then everything stops, video goes black (but audio often continues), and then, eventually, live video returns.

Something in one of the latest updates to Sage or Java must have caused this, as no one is updating Hauppauge drivers again.

Are you seeing any time readout anomalies with old recordings? That’s also happening to my recordings, some not actually that old. The show is fine, but the time readout is split between negative and positive times. It makes me wonder if this guide, show-change video error is screwing up recordings too.

Does your video stop at the top of the clock if the recording/guide info is continuous and runs through the clock/hour change?

Striker:WG 11-07-2020 10:46 AM

That sounds different than what I am experiencing.

I notice that while the live TV is playing, the progress bar is not actually showing progress. When I reach the end of the scheduled program time everything stops and it doesn't recover.

A scheduled recording seems to work as we record the local news every night and we are able to watch it 99% of the time.

I've been noticing these issues with PC client based playback, so a windows update or Java update certainly isn't out of the realm of possibilities if the issue is client side.

JustFred 11-07-2020 09:45 PM

I used to have a LOT of flaky behavior from my two HDPVRs back when I used the STB's HDMI output. The connection was STB HDMI out -> HDMI/component converter -> HDPVR component input. This resulted in repeated HDPVR lockups and bad recordings (especially near the program/commercial transitions). Trying all the recommended fixes (external fan on the HDPVR, new drivers, new power supply, daily reboots, etc, etc) never really seemed to help.

But (three years ago) stability dramatically improved when I stopped using HDMI altogether and connected the STB's component and L/R stereo outputs directly into the HDPVR. Since that change, about the only time the HDPVRs ever go out into the weeds is when the cable company reboots the STB (like for a firmware update). Apparently the HDPVR chokes trying to encode "no video input", but I have ways of managing **that**.

Striker:WG 11-08-2020 08:42 AM

As far as connections go:
  • Straight out of the STB's into the HDPVR using component and optical spdif cables.
  • Firewire connections from a PCI Firewire card to the STB's.
  • USB connections from the HDPVR's to USB 3.0 ports on the motherboard.
  • The STB's are locked at 720p.
  • The STB's, HDPVR's, and Unraid server are all in a closet along with some other equipment (PFsense router, switch, cable modem).

UgaData 11-08-2020 09:44 AM

Maybe You've already tried this, but you're not going to like this suggestion.

Try removing the optical cable and use stereo. (I wouldn't like it either).

It could also be the optical connection isn't perfect, re-seating the cable may help.

Striker:WG 11-08-2020 10:12 AM

Yeah, I've thought about that a lot!

Really don't like the idea, but as a temporary test, it could be worth trying to see if things improve.

I've always thought that any optical cable is just as good as the next one. Right now I'm pretty sure the ones I'm using are from Monoprice.

Any thoughts on whether or not upgrading the cable might help or is it just an issue of my STB's and HDPVR's not playing nice with the optical signal and the cable itself is irrelevant?

Striker:WG 11-08-2020 11:12 AM

OK, so I tried testing with stereo audio. No luck, same issues.

Tried locking the STB to different settings (eg. 1080 vs 720, Stereo vs Stereo Matrix) and no luck.

The things I'm noticing:
  1. Live TV progress bar does not show progress
  2. When Live TV fails, the bling light (blue ring light) and the red record light on the HDPVR turns off
  3. This is happening on PC based clients.
  4. If I tell the server to record the program, then start playback the progress bar works.

KryptoNyte 11-08-2020 12:18 PM

I've never had super smooth sailing with HDPVR's. There seems to be two primary issues:

1) Tuning time. It takes anywhere from 5 to 10 seconds to tune a channel and in Sage settings I've always had to tell SageTV to wait at least 10 seconds before it actually starts playing the channel when selecting a channel for live TV. If Sage attempts to play it too quickly, strange things happen.

2) I've heard rumor that Hauppauge doesn't do a great job creating a quality media file. I've had numerous experiences where I have to run an HDPVR file through Videoredo repair to fix it.

When I moved from the HDPVR to the HDPVR2, I changed the way I watched TV. With the HDPVR2, tuning live television results in no audio about 50% of the time, so I never actually watch live TV anymore, rather if there is a live TV station I want to watch, I just tell it to record, wait about 15 seconds, and start watching.

tvmaster2 11-08-2020 12:25 PM

Definitely try a different optical cable if you havenít already, and a power supply.

UgaData 11-08-2020 01:40 PM

Yeah, I feel your pain. Just to be sure, when you tried to go to stereo, you completely removed the optical cable from the HDPVR?

It may not make a difference, but changing the optical cable may make a difference. It sucks if it doesn't work, but that's part of troubleshooting.

And like TVMaster2 mentioned a new power supply.

Striker:WG 11-08-2020 03:27 PM

Quote:

Originally Posted by UgaData (Post 627945)
Yeah, I feel your pain. Just to be sure, when you tried to go to stereo, you completely removed the optical cable from the HDPVR?

It may not make a difference, but changing the optical cable may make a difference. It sucks if it doesn't work, but that's part of troubleshooting.

And like TVMaster2 mentioned a new power supply.

Yup, I completely removed the optical cable from both the STB and the HDPVR. I even replaced the component cable with the one that came with the HDPVR as it also had the stereo audio cables. Sadly, it didn't seem to help so I went back to optical.

Since that didn't work, and because things seem to work better from my HD200, I figured I'd try some troubleshooting on the PC client side.

I completely nuked SageTV off of one of my PC clients, reinstalled Sage and updated LAV from 73.1 to 74.1.

On that client, the live TV progress bar is now working. If I hit a glitch in a broadcast, at least the HDPVR seems to keep recording as I can skip forward and the playback resumes. That's a huge improvement from before the HDPVR recording would just die.

Unfortunately, the same process on my other PC client did not resolve the issue, and that is my main TV for watching!

KryptoNyte 11-08-2020 04:54 PM

Regarding the audio sync issue, I seem to recall having that problem more when the STB was set to 720p than I did with it set to 1080i ... errr was it the other way around ... something like that. Video via component RGB, audio via optical.

wayner 11-08-2020 10:00 PM

Quote:

Originally Posted by UgaData (Post 627945)
And like TVMaster2 mentioned a new power supply.

Try this. I have had flakey behaviour with HD-PVRs due to the power supply. And every power supply I have used on them has failed after a handful of years. If you can try the PC power supply hack.

Striker:WG 11-11-2020 01:08 AM

So I went and dropped a nuke on the offending PC. Reinstalled Windows and now Sage is back to behaving on that box. The progress bar displays proper progress on Live TV.

Of course, nothing is simple and the saga continues.

Things got glitchy on a recording, so I thought I might restart the docker container. When I tried to restart the Sage docker, I got a 403 error.

I found this thread on the Unraid forums and followed the suggestion to delete the docker image file and re-install my docker containers.

https://forums.unraid.net/topic/7863...ion-error-403/

All my other docker containers started up fine, however, its been 24 minutes of up time on my Sage docker container and while it says its running, my clients can't connect to it!

Anyone seen anything like this before?

Zogg 11-11-2020 02:29 PM

I'm pretty new to Unraid so I'm not sure what your current problem is.

But I thought I'd share that my HDPVR didn't work all that great when connected to my Unraid Sage docker. I moved it over to a Windows VM, that I was using to record from HDPVR2s that aren't supported in the docker, and it is much more stable now.

I passed through a USB-PCIe card to the Windows VM, and all three are connected to it. I run SageTV on the Win VM just as a network tuner and it's been very stable and the recordings are very good.

Striker:WG 11-11-2020 05:21 PM

that's an interesting idea to run the HDPVR's as a network encoder in a VM. I may give that a try at some point.

I've noticed in my Unraid logs that I'm getting messages like this:

Nov 11 17:16:23 Hal9000 nginx: 2020/11/11 17:16:23 [crit] 4588#4588: *58316 connect() to unix:/var/tmp/stuckless-sagetv-server-java8.sock failed (2: No such file or directory) while connecting to upstream, client: 10.0.100.50, server: , request: "GET /dockerterminal/stuckless-sagetv-server-java8/token HTTP/1.1", upstream: "http://unix:/var/tmp/stuckless-sagetv-server-java8.sock:/token", host: "hal9000", referrer: "http://hal9000/dockerterminal/stuckless-sagetv-server-java8/"

wayner 11-11-2020 10:53 PM

I have had two HD-PVRs connected up to SageTV for years. I used to run Win7 but for the last 2-3 years my main server has been unRAID and I have not had any issues. Mind you I have not bothered to upgrade my unRAID server in quite a while and am running 6.4.1 so maybe there are issues in newer versions.

Striker:WG 11-13-2020 01:05 AM

So my latest issue with Unraid was related to a failed drive in my cache pool.

Repaired the cache pool (pulled the bad drive, built a new pool, reloaded cache data) and things are working again!


All times are GMT -6. The time now is 05:50 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.