SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Github Development (http://forums.sagetv.com/forums/forumdisplay.php?f=53)
-   -   Sage Server Hang 3 days after successful V7->V9 Upgrade on Windows 7 (http://forums.sagetv.com/forums/showthread.php?t=64789)

WellThen 07-17-2017 08:42 PM

Sage Server Hang 3 days after successful V7->V9 Upgrade on Windows 7
 
3 Attachment(s)
Hi All,

On Friday, I upgraded from V7 to V 9 on Windows 7 64 bit. The upgrade went smoothly. (FWIW, I run sage in a Windows 7 VM on an esxi host.)

This evening (Monday), I found the Sage UI non-responsive from Clients. When I tried to exit Sage on the Server (I'm not running Sage as a Service) it hung on the "Are you sure you want to exit SageTV?" prompt (spinning circle of death).

I found that Task Manager showed that SageTV was using 1GB of RAM (screen clip attached.) After waiting 3-4 minutes (memory usage slowly rising), I tried to kill the Sage process, but could not.

I tried to restart the Windows 7 VM, but after showing the normal Windows restarting messages, the restart just hung. I finally had to reset the VM running the Sage Server.

I grabbed the SageTV_1.txt file after the machine restarted, and am attaching it here (It was huge - I had to split it into 2 zipped files to get under the 750KB limit.) Any thoughts about what might be happening?

Thanks!

wnjj 07-17-2017 10:07 PM

I think you are running out of heap space:

Code:

Mon 7/17 16:20:00.005 [Seeker@1e48d0c] MemStats: Used=611MB Total=805MB Max=805MB
If you upgraded from V7, any change you may have made to the registry in the past for heap size likely isn't there. Your system is using the default 768MB.

Thread about heap on V9 here: https://forums.sagetv.com/forums/showthread.php?t=64043


All times are GMT -6. The time now is 05:59 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.