SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   Phoenix (http://forums.sagetv.com/forums/forumdisplay.php?f=49)
-   -   Issue with Wiz.Bin (http://forums.sagetv.com/forums/showthread.php?t=60394)

QueOnda 06-02-2013 12:19 AM

Issue with Wiz.Bin
 
I'm having an issue where my wiz.bin is being corrupted. I loose my watched and favorites. I've noticed after I installed Phoenix 2 but I also removed my cable and added air content. I need help trouble shooting and finding what the issue could me. Maybe sagetv is not shutting down correctly or maybe I'm starting to have a hardware failure. :bang: Here is SageTV from a computer cold start:

Quote:

Sat 6/1 20:53:40.885 [main@1f42b49] user.dir2=C:\Program Files (x86)\SageTV\SageTV
Sat 6/1 20:53:40.898 [main@1f42b49] classpath=C:\Program Files (x86)\SageTV\SageTV\Sage.jar;C:\Program Files (x86)\SageTV\SageTV\xerces.jar;C:\Program Files (x86)\SageTV\SageTV\plugin.jar;C:\Program Files

(x86)\SageTV\SageTV\;.;C:\Program Files (x86)\Java\jre6\lib\ext\QTJava.zip;JARs\ant.jar;JARs\cling-core-2.0.jar;JARs\cling-support-2.0.jar;JARs\CommercialDetector.jar;JARs\commons-codec-1.3.jar;JARs

\commons-dbutils-1.3.jar;JARs\commons-io-1.4.jar;JARs\commons-jxpath-1.1.jar;JARs\commons-lang-2.4.jar;JARs\commons-net-1.4.1.jar;JARs\core-3.1.1.jar;JARs\dom4j-1.6.1.jar;JARs\Gemstone.jar;JARs

\gkusnick.sagetv.jar;JARs\GoogleWeather.jar;JARs\groovy-all-2.0.5.jar;JARs\gson-1.7.1.jar;JARs\gtools.jar;JARs\htmlparser-1.6.jar;JARs\jackson-annotations-2.1.4.jar;JARs\jackson-core-2.1.4.jar;JARs\jackson-

databind-2.1.4.jar;JARs\jcifs-1.1.6.jar;JARs\jdic.jar;JARs\jetty-6.1.19.jar;JARs\jetty-ajp-6.1.19.jar;JARs\jetty-rewrite-handler-6.1.19.jar;JARs\jetty-sslengine-6.1.19.jar;JARs\jetty-starter.jar;JARs\jetty-

util-6.1.19.jar;JARs\json.jar;JARs\jsoup.jar;JARs\jsp-2.1-jetty-6.1.19.jar;JARs\jsp-2.1.jar;JARs\jsp-api-2.1.jar;JARs\log4j-1.2.15.jar;JARs\lucene-core-3.0.1.jar;JARs\nielm_sageimdb.jar;JARs

\nielm_sageutls.jar;JARs\nielm_sagewebserver.jar;JARs\nielm_sagexmlinfo.jar;JARs\phoenix.jar;JARs\sagex-api.jar;JARs\salicense.jar;JARs\sbbi-upnplib-1.0.3.jar;JARs\seamless-http-1.0.jar;JARs\seamless-util-

1.0.jar;JARs\seamless-xml-1.0.jar;JARs\servlet-api-2.5-6.1.19.jar;JARs\servlet.jar;JARs\slf4j-api-1.6.0.jar;JARs\themoviedb-3.0.0.jar;JARs\vecmath.jar
Sat 6/1 20:53:40.911 [main@1f42b49] JVM version=1.6.0_29
Sat 6/1 20:53:40.912 [main@1f42b49] OS=Windows 7 6.1
Sat 6/1 20:53:40.913 [main@1f42b49] locale=en_US
Sat 6/1 20:53:40.942 [main@1f42b49] SageTV V7.1.9.256
Sat 6/1 20:53:41.425 [main@1f42b49] hostname=MediaServer-PC
Sat 6/1 20:53:41.427 [main@1f42b49] Splash: User Interface Manager is initializing...
Sat 6/1 20:53:41.892 [main@1f42b49] Splash: Object Database is initializing...
Sat 6/1 20:53:42.187 [main@1f42b49] dbFile=C:\Program Files (x86)\SageTV\SageTV\Wiz.bin dbBackupFile=C:\Program Files (x86)\SageTV\SageTV\Wiz.bak
Sat 6/1 20:53:42.202 [main@1f42b49] Wizard starting to load database info...
Sat 6/1 20:53:42.203 [main@1f42b49] Splash: Object Database Source is initializing...
Sat 6/1 20:53:42.230 [main@1f42b49] java.io.IOException: Invalid DB file, only partially saved.
Sat 6/1 20:53:42.231 [main@1f42b49] sage.av.cP(Unknown Source)
Sat 6/1 20:53:42.232 [main@1f42b49] sage.av.h(Unknown Source)
Sat 6/1 20:53:42.233 [main@1f42b49] sage.av.a(Unknown Source)
Sat 6/1 20:53:42.234 [main@1f42b49] sage.av.cR(Unknown Source)
Sat 6/1 20:53:42.234 [main@1f42b49] sage.SageTV.<init>(Unknown Source)
Sat 6/1 20:53:42.235 [main@1f42b49] sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
Sat 6/1 20:53:42.236 [main@1f42b49] sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
Sat 6/1 20:53:42.236 [main@1f42b49] sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
Sat 6/1 20:53:42.237 [main@1f42b49] java.lang.reflect.Constructor.newInstance(Unknown Source)
Sat 6/1 20:53:42.237 [main@1f42b49] java.lang.Class.newInstance0(Unknown Source)
Sat 6/1 20:53:42.237 [main@1f42b49] java.lang.Class.newInstance(Unknown Source)
Sat 6/1 20:53:42.238 [main@1f42b49] sage.Sage.e(Unknown Source)
Sat 6/1 20:53:42.238 [main@1f42b49] sage.Sage.b(Unknown Source)
Sat 6/1 20:53:42.255 [main@1f42b49] Error with DB file:java.io.IOException: Invalid DB file, only partially saved., attempting to restore backup.
Sat 6/1 20:53:42.339 [main@1f42b49] Wizard starting to load database info...
Sat 6/1 20:53:42.339 [main@1f42b49] Splash: Object Database Source is initializing...
Sat 6/1 20:53:42.341 [main@1f42b49] java.io.IOException: Invalid DB file, only partially saved.
Sat 6/1 20:53:42.341 [main@1f42b49] sage.av.cP(Unknown Source)
Sat 6/1 20:53:42.342 [main@1f42b49] sage.av.h(Unknown Source)
Sat 6/1 20:53:42.343 [main@1f42b49] sage.av.h(Unknown Source)
Sat 6/1 20:53:42.343 [main@1f42b49] sage.av.a(Unknown Source)
Sat 6/1 20:53:42.343 [main@1f42b49] sage.av.cR(Unknown Source)
Sat 6/1 20:53:42.344 [main@1f42b49] sage.SageTV.<init>(Unknown Source)
Sat 6/1 20:53:42.344 [main@1f42b49] sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
Sat 6/1 20:53:42.345 [main@1f42b49] sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
Sat 6/1 20:53:42.345 [main@1f42b49] sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
Sat 6/1 20:53:42.345 [main@1f42b49] java.lang.reflect.Constructor.newInstance(Unknown Source)
Sat 6/1 20:53:42.346 [main@1f42b49] java.lang.Class.newInstance0(Unknown Source)
Sat 6/1 20:53:42.347 [main@1f42b49] java.lang.Class.newInstance(Unknown Source)
Sat 6/1 20:53:42.361 [main@1f42b49] sage.Sage.e(Unknown Source)
Sat 6/1 20:53:42.361 [main@1f42b49] sage.Sage.b(Unknown Source)
Sat 6/1 20:53:42.362 [main@1f42b49] Error accessing file system:java.io.IOException: Invalid DB file, only partially saved.
Sat 6/1 20:53:42.375 [main@1f42b49] Splash: EPG is initializing...
Sat 6/1 20:53:42.517 [main@1f42b49] Increased hash set pool to size=1
Sat 6/1 20:53:42.727 [main@1f42b49] Splash: Profiler is initializing...
Sat 6/1 20:53:42.900 [main@1f42b49] Loaded 76 messages from system message log file
Sat 6/1 20:53:42.973 [main@1f42b49] Splash: Acquisition System is initializing...
Sat 6/1 20:54:13.024 [main@1f42b49] MMC calling detectCaptureDevices on sage.cl@10ab323
Sat 6/1 20:54:13.049 [main@1f42b49] devices detected=[SageDCT-HDHomeRun Prime Tuner 13200F77-0 on 127.0.0.1:7032, SageDCT-HDHomeRun Prime Tuner 13200DE0-0 on 127.0.0.1:7027, SageDCT-HDHomeRun Prime Tuner

13200DE0-1 on 127.0.0.1:7038, SageDCT-HDHomeRun Prime Tuner 13200F77-2 on 127.0.0.1:7020, SageDCT-HDHomeRun Prime Tuner 13200DE0-2 on 127.0.0.1:7023, SageDCT-HDHomeRun Prime Tuner 13200F77-1 on

127.0.0.1:7018]
Sat 6/1 20:54:13.050 [main@1f42b49] EncoderMap={SageDCT-HDHomeRun Prime Tuner 13200F77-2 on 127.0.0.1:7020=SageDCT-HDHomeRun Prime Tuner 13200F77-2 on 127.0.0.1:7020, SageDCT-HDHomeRun Prime Tuner 13200F77-0

on 127.0.0.1:7032=SageDCT-HDHomeRun Prime Tuner 13200F77-0 on 127.0.0.1:7032, SageDCT-HDHomeRun Prime Tuner 13200DE0-1 on 127.0.0.1:7038=SageDCT-HDHomeRun Prime Tuner 13200DE0-1 on 127.0.0.1:7038, SageDCT-

HDHomeRun Prime Tuner 13200DE0-0 on 127.0.0.1:7027=SageDCT-HDHomeRun Prime Tuner 13200DE0-0 on 127.0.0.1:7027, SageDCT-HDHomeRun Prime Tuner 13200F77-1 on 127.0.0.1:7018=SageDCT-HDHomeRun Prime Tuner

13200F77-1 on 127.0.0.1:7018, SageDCT-HDHomeRun Prime Tuner 13200DE0-2 on 127.0.0.1:7023=SageDCT-HDHomeRun Prime Tuner 13200DE0-2 on 127.0.0.1:7023}
Sat 6/1 20:54:13.051 [main@1f42b49] MMC calling detectCaptureDevices on sage.bd@12ad19e

QueOnda 06-02-2013 10:33 AM

If I have a good wiz.bin. Is there a way to export data (watched and favorites) and then import them into the current?

I'm going to try to recover from previous but if I'm starting up SageTV server it's going to corrupt and I'm back to square one.

I need something getting me going again (with my favorites). than starting from scratch. I'll save that till I have more time.

nyplayer 06-02-2013 11:39 AM

If you had a good wiz.bin you could export the favorites and recordings to an xml file using the webserver. Then import them into an empty wiz.bin. ... but you cannot do that without Sage Running.

stuckless 06-03-2013 06:47 AM

Quote:

java.io.IOException: Invalid DB file, only partially saved.
This leads me to believe that your SageTV process is being forcibly shut down (ie, crashes). I'm not sure what would cause this... but if you have other sagetv_X.txt files then there might be something in those files that show what happened just before it died.

If sagetv shut itself down (for whatever reason), it would have synced to the Wiz.bin before shutting down.

As for P2... Like any plugin, it could be the culprit... but most likely when you see "hard" failured like this, it's usually hardware related, or possibly, out of memory... but even out of memory errors can be handled by the JVM, and allow for a clean shutdown (usually).

You might want to check to see if you've increased the memory for your sagetv server, since the out of the box settings are for SageTV only... and when you start adding plugins, you'll need to increase the memory.

QueOnda 06-03-2013 03:39 PM

Quote:

Originally Posted by nyplayer (Post 552885)
If you had a good wiz.bin you could export the favorites and recordings to an xml file using the webserver. Then import them into an empty wiz.bin. ... but you cannot do that without Sage Running.

How do you export? I found where you import. http://localhost:8080/sage/XMLImporter

QueOnda 06-03-2013 03:43 PM

Quote:

Originally Posted by stuckless (Post 552897)
This leads me to believe that your SageTV process is being forcibly shut down (ie, crashes). I'm not sure what would cause this... but if you have other sagetv_X.txt files then there might be something in those files that show what happened just before it died.

If sagetv shut itself down (for whatever reason), it would have synced to the Wiz.bin before shutting down.

As for P2... Like any plugin, it could be the culprit... but most likely when you see "hard" failured like this, it's usually hardware related, or possibly, out of memory... but even out of memory errors can be handled by the JVM, and allow for a clean shutdown (usually).

You might want to check to see if you've increased the memory for your sagetv server, since the out of the box settings are for SageTV only... and when you start adding plugins, you'll need to increase the memory.

Thanks for the pointers: Could be out of memory issue. Need to find out what program is causing.

Did MEMTEST and memory is fine. Shut down SAGETV and thought I had a good Wiz.bin but and started with same issue with corrupted wiz.bin.

stuckless 06-04-2013 06:10 AM

Quote:

Originally Posted by QueOnda (Post 552910)
Thanks for the pointers: Could be out of memory issue. Need to find out what program is causing.

Did MEMTEST and memory is fine. Shut down SAGETV and thought I had a good Wiz.bin but and started with same issue with corrupted wiz.bin.

Did your hardware change on the computer? I had an issue (linux) when I updated the hardware, and then when I would restart sagetv the Wiz.bin would become corrupt. I had to revalidate my license and all was well... I lost a couple weeks of "watched" statuses in the process.

QueOnda 06-04-2013 02:42 PM

Quote:

Originally Posted by stuckless (Post 552925)
Did your hardware change on the computer? I had an issue (linux) when I updated the hardware, and then when I would restart sagetv the Wiz.bin would become corrupt. I had to revalidate my license and all was well... I lost a couple weeks of "watched" statuses in the process.

Nope. Same old computer I've been using stable for years. I have a full backup a year back and actually thinking of going back a year and starting from there.

re-asking this question:
Quote:

Originally Posted by QueOnda (Post 552908)
How do you export? I found where you import. http://localhost:8080/sage/XMLImporter


nyplayer 06-04-2013 03:17 PM

To export click on the XML graphic I believe it is orange. You can export your favorites. If you browse recordings you can export the metadata. Just browse to what ever you want to export.

QueOnda 06-05-2013 10:06 PM

Quote:

Originally Posted by nyplayer (Post 552953)
To export click on the XML graphic I believe it is orange. You can export your favorites. If you browse recordings you can export the metadata. Just browse to what ever you want to export.

OMG! Thanks. Never knew that. Guess still learning about sagetv.

tvmaster2 07-17-2013 10:05 AM

Quote:

Originally Posted by nyplayer (Post 552953)
To export click on the XML graphic I believe it is orange. You can export your favorites. If you browse recordings you can export the metadata. Just browse to what ever you want to export.

hi. I am trying to do the same thing, but don't see any orange graphic. is it possible I am having a java issue?

EDIT...ok, did a page refresh and the graphic appeared. weird. thanks

QueOnda 07-17-2013 12:49 PM

My wiz.bin file still get corrupted every time I restart the sage tv server. So, I have to reload my favorites but I loose my watched. What should I be looking for in the log file to see what is causing this.

nyplayer 07-17-2013 01:32 PM

Have you tried running without any plugins?

doc 07-17-2013 02:39 PM

Quote:

Originally Posted by nyplayer (Post 554442)
Have you tried running without any plugins?

Where's the +1 button?

I had a similar issue so reinstalled with just the web interface and it's been fine since.

tvmaster2 07-17-2013 07:40 PM

wow...a lot of us are having problems with this. The Windows Updates looms. Maybe I'll have to start installing them one at a time

QueOnda 07-18-2013 10:32 AM

You know, I believe I could of maybe updated windows. I don't remember. Could be the culprit. :bang:

nyplayer 07-18-2013 10:36 AM

I guess I do not quite get what windows updates has to do with a corrupted wiz.bin? All my Sage servers and clients are all up to date as far as windows updates and Java updates and I have never seen a corrupted wiz bin file. Windows updates is not going to be writing to the wiz bin file so I cannot see it being the cause of the problem.


Ps this is what I would check.

Exclude Sagetv folder from antivirus... and or Defender
Exclude SageTV folder from Indexing (no need to ever Search Sagetv Folder)

bialio 07-18-2013 03:00 PM

The last time I let windows update run on my server was Dec 29th of 2011. It's doing OK from what I can tell.

btl.

nyplayer 07-18-2013 03:38 PM

Quote:

Originally Posted by bialio (Post 554482)
The last time I let windows update run on my server was Dec 29th of 2011. It's doing OK from what I can tell.

btl.

That is ok too I prefer to keep my servers up to date... but to blame wiz bin corruption on a windows update makes no sense. I would look into what plugins are being used... if anything. Maybe updating Java incorrectly can but a windows update I just do not see it.

bialio 07-18-2013 07:26 PM

There were times back in the day where a Windows update messed up Sage. When it was a live product that wasn't so bad - they'd fix it when that happened. These days I take the 'better safe than sorry' route.

I think a java update is way more likely to break sage...


All times are GMT -6. The time now is 06:06 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.