SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Github Development (http://forums.sagetv.com/forums/forumdisplay.php?f=53)
-   -   Sage V9 & Windows 10 - No loive TV viewing via UI (http://forums.sagetv.com/forums/showthread.php?t=63933)

brandypuff 01-10-2017 02:38 PM

Sage V9 & Windows 10 - No loive TV viewing via UI
 
1 Attachment(s)
I am running V9 server on Win10. I get the attached message when trying to play a recorded video using the Sage UI. the file plays fine via VLC. I tried it on two different computers. One computer has the version 6 client installed, the other is a fresh install of v9 server. Both have the same problem.

Also, the win10 computer can't watch live TV through the UI. if i run the sagetv v6 client on my other desktop, i can view live tv but can't playback files because of a message that says "there is a problem accessing the filesystem for playback." Maybe because the file is located on anothersagtv server and isn't local?

I am mostly concerned about why live TV doesn't work through the UI with v9. is it something to do with the mpeg encoders not being installed?

nyplayer 01-10-2017 03:04 PM

Quote:

Originally Posted by brandypuff (Post 598518)
I am running V9 server on Win10. I get the attached message when trying to play a recorded video using the Sage UI. the file plays fine via VLC. I tried it on two different computers. One computer has the version 6 client installed, the other is a fresh install of v9 server. Both have the same problem.

Also, the win10 computer can't watch live TV through the UI. if i run the sagetv v6 client on my other desktop, i can view live tv but can't playback files because of a message that says "there is a problem accessing the filesystem for playback." Maybe because the file is located on anothersagtv server and isn't local?

I am mostly concerned about why live TV doesn't work through the UI with v9. is it something to do with the mpeg encoders not being installed?

Install Lav Filters.

https://github.com/Nevcairiel/LAVFilters/releases

brandypuff 01-10-2017 06:58 PM

tried that i installed both 32/64 bit and still get the playback error.
install_audio
install_video
install_splitter

nyplayer 01-10-2017 07:27 PM

Quote:

Originally Posted by brandypuff (Post 598552)
tried that i installed both 32/64 bit and still get the playback error.
install_audio
install_video
install_splitter

Did you set the lav Video and Audio decoder in SageTV ? and make sure the renderer is EVR ... I think SageTV defaults to Overlay.

PS Lav filters can be configured to use hardware decoding.

brandypuff 01-13-2017 10:55 AM

Thanks. It works now.

brandypuff 01-13-2017 10:58 AM

btw, how do you configure the LAV filter? I don't see any way to.

Fuzzy 01-13-2017 11:25 AM

Quote:

Originally Posted by brandypuff (Post 598789)
btw, how do you configure the LAV filter? I don't see any way to.

Should be in your Start Menu. 'LAV Video Configuration' and 'LAV Audio Configuration'.

brandypuff 01-13-2017 12:55 PM

i installed manually from the zip files so those options weren't available to me. After i installed LAVFilters-0.69-Installer.exe, the menu items appeared.

brandypuff 02-11-2019 11:04 AM

PROBLEM ACCESSING the file system for playback?
 
3 Attachment(s)
This used to work but now it doesn't.
I have the LAV decoder installed.

The SageTV service is started as the local system account. Sage records fine.

jusjoken 02-11-2019 01:13 PM

Quote:

Originally Posted by brandypuff (Post 619837)
This used to work but now it doesn't.
I have the LAV decoder installed.

The SageTV service is started as the local system account. Sage records fine.

Are you sure Local System account has enough access to where the media is? Typically it does not. You need to change it to a specific account that has access to the media locations.

k

brandypuff 02-11-2019 01:16 PM

But why would Sage be able to record shows to the same location, then? Haven't touched the account for years. I can try changing it to my user account which has admin rights but i doubt that will fix it.

brandypuff 02-12-2019 07:38 AM

as expected, that wasn't the issue. So what does this message mean? It is very frustrating not to be able to view live TV or any recordings through the Sage clients, now. Some developer here must know.

JustFred 02-12-2019 09:36 AM

Try using some program other than Sage for playback. VLC is a good choice. That might give you some clues. Posting the sagetv_*.txt logfile might be helpful.

wnjj 02-12-2019 10:15 AM

Googling for the error code in your posted screenshot (0x8007007e) it appears to be something to do with a Windows Creators Update. I’d say Windows 10 strikes again. See what there was for updates between when it last worked and now and try rolling them back.

EDIT: It may not be the Creators Update but seems to happen a lot during it since most google responses mention it. I think the error code is more generic that it can’t access a file or COM object.

The function that’s throwing the error code above is https://github.com/google/sagetv/blo...rData.cpp#L253 in case any other Windows/DirectShow guys want to speculate.

brandypuff 02-12-2019 10:41 AM

figures. This used to work OK. Other programs play the videos OK. I don't have a non-win10 wo/creator's update installed to try it, though. A couple years ago i read the a windows media update also broke this. Is anyone else having the same issue? I'm sure i can't be the only one.

wnjj 02-12-2019 10:46 AM

Quote:

Originally Posted by brandypuff (Post 619855)
figures. This used to work OK. Other programs play the videos OK. I don't have a non-win10 wo/creator's update installed to try it, though. A couple years ago i read the a windows media update also broke this. Is anyone else having the same issue? I'm sure i can't be the only one.

I edited my post and now am not sure if it’s the update or not. That error is also for missing COM objects (like DShow filters). As was suggested, post the log file and it may reveal where it’s failing.


All times are GMT -6. The time now is 02:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.