SageTV Community

SageTV Community (
-   SageTV Software (
-   -   STV suddenly stopped playing MKV files (

fbures 09-26-2020 08:06 AM

STV suddenly stopped playing MKV files
STV V9.1.9.778
Windows 10-64bit
Java 1.8.0_261

It happened couple of days ago. I have not changed anything, nor I installed any new SW. With the exception of Windows updates there were no installations on this system for a very long time.

Any attempt to play any MKV file returns:

sage.PlaybackException: ERROR (-3,0x80040241): There was a problem accessing the filesystem for playback.

I can play the same MKVs with VLC with no problem. I can access the files normally by any other means.

The problem is 100% repeatable.

Any advice would be greatly appreciated. My whole video archive is in MKV format.


KryptoNyte 09-26-2020 08:42 AM

1 Attachment(s)
Hi, Frank. Please grab and post a screenshot of the screen that I'm showing on the attached. Then click on "Default" for H.264 Video Decoder Filter and grab another screenshot of the options that appear there.

Just to clarify, are you attempting to play this while sitting at the server itself, or from another PC client on the network?

KryptoNyte 09-26-2020 08:45 AM

Whoops, the above post probably won't help, maybe ignore it.

Check here:

KryptoNyte 09-26-2020 08:51 AM

Similar issue here:

fbures 09-26-2020 09:09 AM

I updated to STV 9.2.2 and the problem disappeared.


BigSwifty 09-22-2021 12:16 PM

1 Attachment(s)
Bumping an older thread.
I have the same problem. Some MKVs will not play due to "problem with video portion..."
Same error on the server/client and dedicated client PC.
I have converted these to mpeg with another utility but it is getting old.

I have EnableSagetvStreamDemux set to 0.

Please see the attachment.

Any ideas?

BigSwifty 09-22-2021 12:23 PM

1 Attachment(s)
Here is the graph for one of the offending files.

Do I have to change merits?
How do I accomplish this?

UgaData 09-22-2021 01:15 PM

Have you tried explicitly setting both audio and video decoders in SageTV to LAV Filters?

May not matter but I use LAV filters for both. And definitely use the LAV Splitter.

BigSwifty 09-22-2021 01:32 PM

TY for the response.

There is no joy with both LAV A/V decoders utilized.

Where do I specify the LAV splitter?

Striker:WG 09-22-2021 04:52 PM

The LAV splitter should be used by virtue of the registry setting you already made. Assuming that the LAV splitter has a high enough merit value to be used by default.

If you look in the Sage TV log files, you should see references to the graph being built and called. Might give you a clue to what is being used that shouldn't be.

BigSwifty 09-22-2021 05:21 PM

1 Attachment(s)
Thank you.

Originally Posted by Striker:WG (Post 631078)
The LAV splitter should be used by virtue of the registry setting you already made. Assuming that the LAV splitter has a high enough merit value to be used by default.

OK. I'm not clear how merit value is determined.

This is the only log that has any relevant info (that i can determine). Not sure if it sheds any light on the issue.

UgaData 09-23-2021 08:29 AM


I have EnableSagetvStreamDemux set to 0.
Setting the above registry setting to 0 should allow for the use of LAV Splitter (I presume LAV Video, Audio, & Splitter were all installed together).
I don't wish to confuse things but that registry setting may show up twice if running 64 bit SageTV. One of the settings doesen't matter but I make sure both are set to zero.

I was unable to play MKV files without disabling the SageDemxer.

I suggested setting the LAV filters explicitly in Sage
1. so you shouldn't have to worry about merit settings for the
decoders/filters(as much) (changing the decoder/filter merits isn't done
through Sage and can be frustrating at times.)
2. and I noticed the graph was using the Microsoft Audio decoder.
it isn't wrong but everything works better for me when I use all LAV stuff.

The audio portion of your graph shows the AC3 filter going into DEFAULT DirectSound Device. I can't say that is wrong but I find if I get more specific with that setting, things work better.

It doesn't seem right but even though the message is about Video playback, the audio settings can be involved with that error.

BigSwifty 09-24-2021 09:34 AM


I set both registry values to 0 *and set audio to LAV (previously had used LAV for all video and default for audio).

Since I did both at the same time I'm not sure which change "fixed" my issue.

There is JOY in Mudville; MKVs play fine now.

Thank you for the help.

All times are GMT -6. The time now is 04:04 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.