SageTV Community

SageTV Community (http://forums.sagetv.com/forums/index.php)
-   SageTV Software (http://forums.sagetv.com/forums/forumdisplay.php?f=6)
-   -   Wiz.bin not updated for 6 days - What is Wiz.bin.tmp? (http://forums.sagetv.com/forums/showthread.php?t=65607)

graywolf 07-28-2018 08:48 AM

Wiz.bin not updated for 6 days - What is Wiz.bin.tmp?
 
1 Attachment(s)
What is Wiz.bin.tmp?

Today is 7/28/2018 and it looks like Wiz.bin hasn't been updated for 6 days.

Wiz.bin.tmp 7/22/2018 3:00 pm
Wiz.bak 7/22/2018 3:00 pm
Wiz.bin 7/22/2018 3:00 pm

Do not have a sagetv_##.txt file that goes back to then.
Latest I have is 7/26/2018 1:08am

What could cause Wiz.bin not to update?
Would restarting Sage cause any "updates" (Flag status i.e. watched/archived ; scheduled recordings ; etc.) since 7/22/2018 to be lost?

I collected info on watched/archived status for past week and what is currently scheduled.

Performed reboot of SageTV PC
Attached the sagetv_0.txt file from startup in case that shows any clues.

graywolf 08-03-2018 02:54 PM

Happened again - NullPointerException
 
1 Attachment(s)
This time 8/2/2018 20:23

Any help would be appreciated. WAF taking a hit.

Log fiile attached.

snippet where the error occurred
Code:

Thu 8/2 20:23:36.140 [EPG@a386b8] Wizard writing out table info for SeriesInfo
Thu 8/2 20:23:36.478 [EPG@a386b8] Exception during Maintenance:java.lang.NullPointerException
Thu 8/2 20:23:36.478 [EPG@a386b8] java.lang.NullPointerException
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.SeriesInfo.write(SeriesInfo.java:201)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.Wizard.saveDBFile(Wizard.java:7930)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.Wizard.maintenance(Wizard.java:2369)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.EPG.run(EPG.java:645)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at java.lang.Thread.run(Unknown Source)
Thu 8/2 20:23:36.479 [EPG@a386b8] sage.epg.sd.SDRipper@1f6b7c6 needs an update in 16:33:26
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG needs an update in 993 minutes
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG's works is done. Waiting...


JREkiwi 08-03-2018 06:19 PM

I'm seeing the same problem on a semi regular basis with an exception following "Wizard writing out table info for SeriesInfo"

A restart of SageTV restores the wiz.bin from wiz.bak and then it will be fine again for a while.

Haven't been able to identify a pattern, but it's certainly been a problem for me over the last few builds.

John

wnjj 08-03-2018 09:13 PM

Quote:

Originally Posted by graywolf (Post 616198)
This time 8/2/2018 20:23

Any help would be appreciated. WAF taking a hit.

Log fiile attached.

snippet where the error occurred
Code:

Thu 8/2 20:23:36.140 [EPG@a386b8] Wizard writing out table info for SeriesInfo
Thu 8/2 20:23:36.478 [EPG@a386b8] Exception during Maintenance:java.lang.NullPointerException
Thu 8/2 20:23:36.478 [EPG@a386b8] java.lang.NullPointerException
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.SeriesInfo.write(SeriesInfo.java:201)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.Wizard.saveDBFile(Wizard.java:7930)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.Wizard.maintenance(Wizard.java:2369)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at sage.EPG.run(EPG.java:645)
Thu 8/2 20:23:36.479 [EPG@a386b8]        at java.lang.Thread.run(Unknown Source)
Thu 8/2 20:23:36.479 [EPG@a386b8] sage.epg.sd.SDRipper@1f6b7c6 needs an update in 16:33:26
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG needs an update in 993 minutes
Thu 8/2 20:23:36.479 [EPG@a386b8] EPG's works is done. Waiting...


The line thatís crashing is attempting to access an array of people associated with the series and one of them is null. Tracing back, the person object it can be null if the name has 0 length. I wonder if SD has some funky data and the EPG code isnít filtering it?

graywolf 08-04-2018 11:21 AM

Quote:

Originally Posted by JREkiwi (Post 616199)
I'm seeing the same problem on a semi regular basis with an exception following "Wizard writing out table info for SeriesInfo"

A restart of SageTV restores the wiz.bin from wiz.bak and then it will be fine again for a while.

Haven't been able to identify a pattern, but it's certainly been a problem for me over the last few builds.

John

Yes. Restart of Sage does fix it temporarily but then again, you lose stuff between when it "locks/freezes" and you do the restart.
i.e. Flag settings, manual Scheduled Recordings that you have set, etc.

While Recordings do occur, any after the "lock/freeze" of wiz.bin updates and the restart of Sage all become Archived so have to try to remember what they were so as to Unarchive them

Also Glad/Sad that I'm not the only one.
Glad that it isn't my setup per se
Sad others also afflicted

JREkiwi 08-04-2018 01:05 PM

Quote:

Originally Posted by wnjj (Post 616201)
The line thatís crashing is attempting to access an array of people associated with the series and one of them is null. Tracing back, the person object it can be null if the name has 0 length. I wonder if SD has some funky data and the EPG code isnít filtering it?

I'm getting the same issue with XMLTV EPG, so it's not SD specific. I feel it's more likely to be associated with data that BMT is pulling in for shows and the wiz.bin writing code should handle it rather than crashing.

John


All times are GMT -6. The time now is 02:30 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.