SageTV Community

SageTV Community (
-   SageTV Software (
-   -   Having trouble importing content from NAS box (

smdear 04-14-2018 09:54 PM

Having trouble importing content from NAS box
I have SageTV v9.1.7.757 installed on my Windows 10 server, I have recently upgraded from SageTV 7.

After the upgrade, I noticed that my import directories on my network-attached storage box were not getting picked up into my library.

Although I have the directory \\\DearMedia mapped to drive X:\, I do not see this drive as an available choice when entering import directories.

I tried entering the directory manually like "\\\DearMedia\BluRayRipsNas" but Sage told me that it could not find this directory and asked me if I wanted to create it (entering the exact same path on my Windows search bar brought up the intended directory).

Can anybody suggest steps I could follow to debug this issue?

I do have a username/password configured on my NAS that I had to enter when mapping the drive via Windows, please help me figure out what I'm missing. I would really like to get this content accessible again.

The following procedure appears to allow me to register the import directories I want, but they are still not being pulled into the library.

Procedure I'm following:

Setup->Detailed Setup->Media Center Import Directories->Modify
Add new directory
Select Up repeatedly until the drive list shows
Select import directory to add
DearMedia (top level directory on my NAS box)
Select particular directory (for example, BluRayRipsNas)
Select Current
Import videos only (not pictures, not music)
Done (add the path)
Setup->Scan Imported Media, wait 20 minutes
Videos -> DVD/BD - No DVDs/DBs were found in any of the Media Center Import Directories for Videos

Files containing other kinds of media (neither Blu Ray nor DVD) are not showing up in the library either.

smdear 04-28-2018 05:46 PM

No content being imported from NAS import directories
Hello, does anybody know how I can once again access my NAS files on Sage? I'm missing a significant portion of my library and would really like to watch my personal ripped DVD/BluRays on Sage again. I'm at a loss as to what to do next. Thanks.

JustFred 04-28-2018 07:27 PM

This issue has been frequently addressed in these forums. For example, have a look at

smdear 06-29-2018 05:43 PM

Additional logs to help narrow down the problem
I rechecked today, and my NAS boxes are set up for guest/read access.

Although I am able to play conventional videos from Sage stored on my NAS, I still cannot play BluRay or DVD content, while I can play them with typical Windows players.

I'm seeing the following in my Sage logfile, does this give anybody a hint as to what may be wrong?


Fri 6/29 19:36:37.766 [Seeker@11e8b86] DONE clearing unwanted and partial files.
Fri 6/29 19:36:37.768 [MediaServerConnection@19fe1]
Fri 6/29 19:36:37.768 [MediaServerConnection@19fe1] at sage.MediaServer$Connection.readLineBytes(
Fri 6/29 19:36:37.769 [MediaServerConnection@19fe1] at sage.MediaServer$
Fri 6/29 19:36:37.769 [MediaServerConnection@19fe1] at sage.Pooler$


Fri 6/29 19:36:47.661 [MediaServerConnection@380db8] Error in MediaServerConnection of
Fri 6/29 19:36:47.663 [MediaServerConnection@380db8]
Fri 6/29 19:36:47.663 [MediaServerConnection@380db8] at sage.MediaServer$Connection.readLineBytes(
Fri 6/29 19:36:47.663 [MediaServerConnection@380db8] at sage.MediaServer$
Fri 6/29 19:36:47.663 [MediaServerConnection@380db8] at sage.Pooler$
Fri 6/29 19:36:47.933 [MediaServerConnection@17f67d8] Error in MediaServerConnection of An existing connection was forcibly closed by the remote host
Fri 6/29 19:36:47.934 [MediaServerConnection@17f67d8] An existing connection was forcibly closed by the remote host
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at Method)
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at Source)
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at Source)
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at Source)
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at Source)
Fri 6/29 19:36:47.935 [MediaServerConnection@17f67d8] at sage.MediaServer$Connection.readLineBytes(
Fri 6/29 19:36:47.936 [MediaServerConnection@17f67d8] at sage.MediaServer$
Fri 6/29 19:36:47.936 [MediaServerConnection@17f67d8] at sage.Pooler$

All times are GMT -6. The time now is 10:16 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.