SageTV Community

SageTV Community (
-   SageTV HD Theater - Media Player (
-   -   HD200 Network Traffic (

Striker:WG 05-10-2021 08:23 PM

HD200 Network Traffic
Does anyone know exactly how the HD200 communicates over the network to the Sage TV server?

I have a couple of VLAN's setup and I can packet capture the traffic coming from my PC based clients to the server without issue. When I try to capture the same traffic from my HD200 units I get 0 activity logged even though the unit is actively streaming recorded TV. I've tried capturing both when monitoring the server IP (I see activity to the PC clients but not to the HD200) and monitoring the HD200 IP (I see 0 activity). I've triple checked the IP of the HD200. I think my VLANs are setup properly because I can use SageTV, and if I ping the HD200 I can see the ping response in the packet capture.

I'm monitoring by IP address and i'm looking for any type of packets (although i'm expecting to see TCP packets). Does anyone have any experience or knowledge around these things? Ideally I want to setup some restrictive firewall rules to lock down my IOT VLAN to only the ports that need to be open.

stuckless 05-11-2021 05:25 AM

From the docker container configuration, it has this information regarding ports...


# Client (TCP 42024 for connecting, TCP 7818 for streaming, UDP 8270 for finding servers)
# All extenders (UDP 31100 for discovery, TCP 31099 for connections?)
# Hauppage extender (all UDP) 16867 16869 16881
# Web Server 8080
# jstatd is port 9010
EXPOSE 42024 7818 8270 31100 31099 16867 16869 16881 8080 9010

Striker:WG 05-11-2021 06:50 AM

Yeah, i've tried monitoring those ports, but I'm not seeing any traffic though. Maybe it's a limitation of the pfsense packet capture tool, or maybe the traffic is going direct from the HD200 to the docker since it doesn't need to traverse a vlan. I thought that all traffic had to talk to pfsense though to confirm if the traffic was allowed to pass or not.

The information you posted though conflicts with what I see the container doing. The container is only using TCP ports, but the note indicates that some should be UDP. I guess that means my docker isn't setup correctly?

All times are GMT -6. The time now is 04:40 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.