SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations

Notices

SageTV Customizations This forums is for discussing and sharing user-created modifications for the SageTV application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss customizations for SageTV version 6 and earlier, or for the SageTV3 UI.

Reply
 
Thread Tools Search this Thread Display Modes
  #141  
Old 01-24-2009, 10:36 PM
megamojo's Avatar
megamojo megamojo is offline
Sage Advanced User
 
Join Date: Apr 2006
Posts: 173
Quote:
Originally Posted by Halstead View Post
Made the change to theTVDB_episodeInfo.scrape and deleted the .properties files, but no joy:
Encode CLI #1 =($$episodeTitle$$[^<:]*)</title>

Still gives me:
Terminator The Sarah Connor Chronicles 2x10 - The Sarah Connor Chronicles Strange Things Happen at the One Two Point.mkv

I'm happy to keep testing...
I tried the fix and it's working perfectly for me. Check to make sure you don't have any typos.
Reply With Quote
  #142  
Old 01-24-2009, 11:46 PM
mickp's Avatar
mickp mickp is offline
Sage Aficionado
 
Join Date: Oct 2006
Posts: 468
Quote:
Originally Posted by megamojo View Post
But I do have a separator. My file South Park 12x01 Tonsil Trouble.avi became South Park 2x01 Cartman Gets an Anal Probe.avi.
Does "South Park S12E01 - Tonsil Trouble.avi" work any better?

Mick.
Reply With Quote
  #143  
Old 01-24-2009, 11:50 PM
mickp's Avatar
mickp mickp is offline
Sage Aficionado
 
Join Date: Oct 2006
Posts: 468
Hi E.P.

I've been experimenting with processing metadata for various media shares around my network and have been running into problems with the naming of the various images which are downloaded.

My appologies if I'm missing something obvious with this:

First up you should know that I'm not using a central fanart folder. At least for this scenario the naming/desired destination file names seem to be backwards.

Files for dvd's end up with MovieName_background.jpg and MovieName.jpg files in the root of the share rather than in the same directory as video_ts where they need to be to work (named as background.jpg and folder.jpg)

TV Shows in the root end up not named after the show filename blatting the same folder.jpg, background.jpg and banner.jpg files over and over.

There seems to be an assumption that TV shows will always be in a directory together, and the files appear to always be downloaded as folder.jpg and background.jpg which causes problems when episodes from different series are in the same directory.

Would it be possible to provide a command line option to do the following?

When gathering metadata for a file which is not a dvd:

Download fanart to filename_background.jpg in the same directory as the file
Download poster to filename.jpg in the same directory as the file
Download .properties file to filename.properties in the same directory as the file

For dvd's:

Download fanart to moviedir\background.jpg (in the same directory as video_ts)
Download poster to moviedir\folder.jpg (in the same directory as video_ts)

NB: I'm not sure where the .properties file should go for dvd's. There's a post here which discusses this. From this post it sounds like .properties files for dvd's should go exactly where you're putting them though I haven't seen any of them applying to my collection. This is probably just that they are all in my dvd profiler db at the moment.


Mick.
Reply With Quote
  #144  
Old 01-24-2009, 11:56 PM
megamojo's Avatar
megamojo megamojo is offline
Sage Advanced User
 
Join Date: Apr 2006
Posts: 173
Quote:
Originally Posted by mickp View Post
Does "South Park S12E01 - Tonsil Trouble.avi" work any better?

Mick.
Good idea, but no, that doesn't change anything. It still gets changed to South Park 2x01 Terrance Phillip in Not Without My Anus.avi. (I mistakenly before said it was the title of 1x01, but it's always been 2x01.)
Reply With Quote
  #145  
Old 01-25-2009, 12:05 AM
mickp's Avatar
mickp mickp is offline
Sage Aficionado
 
Join Date: Oct 2006
Posts: 468
Quote:
Originally Posted by megamojo View Post
Good idea, but no, that doesn't change anything. It still gets changed to South Park 2x01 Terrance Phillip in Not Without My Anus.avi. (I mistakenly before said it was the title of 1x01, but it's always been 2x01.)
I only ask because just today I renamed the files in my South Park Season 11 directory. They were something like "Southpark - [1102] - Cartman Sucks.avi" and were receiving no hits. Renaming to "South.park.S11E02 - Cartman Sucks.avi" did the trick. I've double checked the description for each episode and it appears correct.

Mick.

Edit: Come to think of it it was probably changing southpark to south.park that fixed the no hits.

Last edited by mickp; 01-25-2009 at 12:15 AM.
Reply With Quote
  #146  
Old 01-25-2009, 06:48 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Quote:
Originally Posted by megamojo View Post
Good idea, but no, that doesn't change anything. It still gets changed to South Park 2x01 Terrance Phillip in Not Without My Anus.avi. (I mistakenly before said it was the title of 1x01, but it's always been 2x01.)
Make sure you delete the .properties file or it won't even try to get the info again.
Reply With Quote
  #147  
Old 01-25-2009, 08:09 PM
megamojo's Avatar
megamojo megamojo is offline
Sage Advanced User
 
Join Date: Apr 2006
Posts: 173
Quote:
Originally Posted by evilpenguin View Post
Make sure you delete the .properties file or it won't even try to get the info again.
I did that, and I renamed them back to what they should be, and I also tried renaming it to "South Park S12E01 - Tonsil Trouble.avi". It still took the 1 off the 12, changing it to season 2, episode 1, and changed the title and got metadata for season 2, episode 1 instead of season 12, episode 1. I also tried taking out the /organizeFiles switch, and now i have a file called "South Park 12x01 Tonsil Trouble.avi.properties" that, when you open it up, says "Title=South Park 2x01 Terrance & Phillip in Not Without My Anus."

Last edited by megamojo; 01-25-2009 at 08:13 PM.
Reply With Quote
  #148  
Old 01-25-2009, 08:21 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
I'll need the scraper.log to figure it out, go ahead and post it.
Reply With Quote
  #149  
Old 01-25-2009, 08:59 PM
megamojo's Avatar
megamojo megamojo is offline
Sage Advanced User
 
Join Date: Apr 2006
Posts: 173
Here you go.
Attached Files
File Type: txt scraper.txt (602.3 KB, 147 views)
Reply With Quote
  #150  
Old 01-25-2009, 09:17 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Thanks, looks like I already fixed that and didn't realize it. It'll be in the next update, hopefully tonight.
Reply With Quote
  #151  
Old 01-25-2009, 09:54 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Quote:
Originally Posted by mickp View Post
Hi E.P.

I've been experimenting with processing metadata for various media shares around my network and have been running into problems with the naming of the various images which are downloaded.
That's a how it should be working, can you post a log file?

Edit- Minus the VIDEO_TS folders, I fixed that for this version
Reply With Quote
  #152  
Old 01-25-2009, 10:25 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Beta7: Fix a few, make a few new ones

Beta 7's all about the little issues. Hopefully we're starting to run out of 'em.

mediaScraper 1.0 beta7
  • Show titles with () now work ex: The Office (US)
  • Re-enabled imdb first popular search for TV. Not sure why I removed this in the last version
  • Fixed fanart with VIDEO_TS folders
  • Fixed an issue where seasons 10+ weren't working.
  • IMDB was handing UTF-8 weird, so I had to do some manual translations.
Reply With Quote
  #153  
Old 01-26-2009, 03:38 AM
mickp's Avatar
mickp mickp is offline
Sage Aficionado
 
Join Date: Oct 2006
Posts: 468
Quote:
Originally Posted by evilpenguin View Post
That's a how it should be working, can you post a log file?

Edit- Minus the VIDEO_TS folders, I fixed that for this version
Hi E.P.

Thanks for version seven. It's working much better with my video_ts movies. I also like that it's now detecting Doctor Who (2005). Thanks heaps.

I'm still seeing the problem with shows not in a dedicated directory downloading a folder.jpg and background.jpg rather than the filename.jpg and filename_background.jpg versions.

I'll upload and pm the link for a log file showing this.

Could there be an option (or default behavior) when not using a central fan art directory to download fanart and posters as filename.jpg and filename_background.jpg regardless of whether they are in an episode directory?

Also, I notice that on thetvdb.com many episodes have an episode image. Would it be possible to download the episode image if it exists as filename.jpg?

Mick.
Reply With Quote
  #154  
Old 01-26-2009, 07:59 AM
jaminben jaminben is offline
Sage Icon
 
Join Date: Sep 2007
Location: Norwich, UK
Posts: 1,754
Send a message via MSN to jaminben
Hi E.P.

I've still got issues with Battlestar Galatica as it keeps grabbing data from the original series with Dirk Benedict and not the most recent version. I've tried using an override.folder and naming the containing folder Battlestar Galatica (2003). However if I rename each file Battlestar Galatica(2003)S04E011.mkv then it grabs the correct show. I also renamed all my Star Wars The Clone Wars with the year contained in the file name and that also grabs the correct data, but without the year it doesn't get anything.

Any ideas on how to fix this? Or is just one of those things that we have to live with.

Regards

Ben

edit:

On a different note, what other info can you grab using .my file and TVDB\IMDB. I see in your first post that you list what it can currently support but I've been playing with studio and found a few other things that you maybe able to take advantage of like TV rating, language, first run etc. Maybe TVDB\IMDB dont support all these items and its not possible or maybe its just over-kill, I dont know. Anyway I've attached an image showing a list of all available attribute widgets that hopefully should work with SageMC and the ones that I've already got working.
Attached Images
File Type: jpg myFileInfo.jpg (371.9 KB, 156 views)
__________________
Server - Win7 64bit, 2.4Ghz Intel Core 2 Duo, TBS 6284 PCI-E Quad DVB-T2 Tuner, 3 x HD200 & 1 x HD300 extenders

Last edited by jaminben; 01-26-2009 at 08:30 AM.
Reply With Quote
  #155  
Old 01-26-2009, 09:08 AM
megamojo's Avatar
megamojo megamojo is offline
Sage Advanced User
 
Join Date: Apr 2006
Posts: 173
Quote:
Originally Posted by jaminben View Post
I've tried using an override.folder...
Well, the override file should be named folder.override, not override.folder. Could this be your problem?
Reply With Quote
  #156  
Old 01-26-2009, 10:14 AM
jaminben jaminben is offline
Sage Icon
 
Join Date: Sep 2007
Location: Norwich, UK
Posts: 1,754
Send a message via MSN to jaminben
Quote:
Originally Posted by megamojo View Post
Well, the override file should be named folder.override, not override.folder. Could this be your problem?
No, sorry that was a typo. I did use folder.override.
__________________
Server - Win7 64bit, 2.4Ghz Intel Core 2 Duo, TBS 6284 PCI-E Quad DVB-T2 Tuner, 3 x HD200 & 1 x HD300 extenders
Reply With Quote
  #157  
Old 01-26-2009, 11:23 AM
Halstead Halstead is offline
Sage Advanced User
 
Join Date: Jul 2005
Location: Portland, Or
Posts: 183
Intersting issue w/ v.7- it doens't seem to wat to recongize Flight of the Chonchords, whereas v.6 did. Let me know if you want me to post anything.
__________________
Halstead York

HTPC/Server: A8 3850; Win 7 Home x86 + Java 1.6.0_26; Sage 7.1.9; Driving Epson 8500 pj @ 1080p | Office: Core2Duo E8500 w/ EFI-X running OS X 10.5 & Win 7 Pro x64 (dual boot) + Java 1.6.0_20; Sage 7.0.23; Driving 30" Samsung 1900x1200 monitor
Reply With Quote
  #158  
Old 01-26-2009, 12:33 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Quote:
Originally Posted by Halstead View Post
Intersting issue w/ v.7- it doens't seem to wat to recongize Flight of the Chonchords, whereas v.6 did. Let me know if you want me to post anything.
Flight Of The Conchords is in my test directory, so it should be working.

FYI to everyone, I need you to post file names and\or scraper.log with bugs otherwise I have to do a lot of guess work.
Reply With Quote
  #159  
Old 01-26-2009, 01:30 PM
jaminben jaminben is offline
Sage Icon
 
Join Date: Sep 2007
Location: Norwich, UK
Posts: 1,754
Send a message via MSN to jaminben
Quote:
Originally Posted by evilpenguin View Post
FYI to everyone, I need you to post file names and\or scraper.log with bugs otherwise I have to do a lot of guess work.
Oops, forgot about that.

I've attached my log for Battlestar Galatica.

Many Thanks

Ben
Attached Files
File Type: txt scraper.txt (280.6 KB, 138 views)
__________________
Server - Win7 64bit, 2.4Ghz Intel Core 2 Duo, TBS 6284 PCI-E Quad DVB-T2 Tuner, 3 x HD200 & 1 x HD300 extenders
Reply With Quote
  #160  
Old 01-26-2009, 01:44 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Code:
          + Checking: EXISTS:\\SAGEWHS\TV Shows\Battlestar Galatica\folder.override
            - Does file (\\SAGEWHS\TV Shows\Battlestar Galatica\folder.override) exist?
              + False
Ahh, UNC paths, that might be the issue. I'll test that out.
Reply With Quote
Reply

Tags
fanart, imdb, metadata, themoviedb, thetvdb


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Utility: Batch Metadata Importer 3.x stuckless Batch Metadata Tools 2416 09-20-2011 08:03 PM
STV Import: Read & Write Metadata files for Default STV 5/6 (v2.2.9 18/Feb./2010) JREkiwi SageTV Customizations 249 10-26-2010 12:15 AM
manually edit video metadata loomdog32 SageMC Custom Interface 8 01-04-2009 12:34 AM
Runningtime not populated in Metadata mycorona SageMC Custom Interface 2 11-30-2008 01:08 PM
Keeping custom metadata for imports via AddShow() Opus4 SageTV Studio 9 02-20-2008 06:35 PM


All times are GMT -6. The time now is 02:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.