SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-18-2021, 01:34 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
USB-UIRT Doesn't Work After Upgrading to 9.2.4

I just upgraded to 9.2.4 in order to get the recent EPG image fix that was released. Now my USB-UIRT does not work at all. It was working fine for years and even a few hours before updating, but now it doesn't tune.

Details: Was running version 9.1.7.757 prior to upgrading.
System: Windows 10 64 bit - Running 32 bit version of SageTV

USB-UIRT is only used as a transmitter. I do not use it as a receiver.

Using two Unisheen B3000 HDMI capture devices with OpenDCT.

Any ideas how to fix this? I checked the Tuner Control in the Source Setup, and it has a DLL path that I'm pretty sure wasn't there before updating.

I tried going to "Test Infrared Code" to manually send digits, but the entire list is empty. So I suspect it can't find my .IR file. "Change Tuning Device" also shows a blank list.

All of my .IR files are located in "C:\Program Files (x86)\SageTV\Common\RemoteCodes\USB-UIRT Transceiver" I'm guessing SageTV isn't looking in this directory any more for .IR files?

Any ideas? Do I need to put my .IR files somewhere else?
Reply With Quote
  #2  
Old 04-18-2021, 01:36 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
See attached for screenshots of problem.
Attached Images
File Type: png 2021-04-18 12_32_58-Window.png (221.6 KB, 14 views)
File Type: png 2021-04-18 12_29_22-Window.png (451.3 KB, 19 views)
File Type: png 2021-04-18 12_30_49-Window.png (220.6 KB, 12 views)
Reply With Quote
  #3  
Old 04-18-2021, 01:52 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
It looks like I was missing uu_irsage.dll, which seems to be a problem with the installer? I found the DLL file here: https://forums.sagetv.com/forums/sho...&postcount=191

The DLL didn't fix the problem though. The path to the DLL looks correct now (see attached screenshot) but all of the other menus are still blank and I still can't tune channels.

I tried replacing the uuirtdrv.dll in system32 with the one attached in the above link but that didn't fix it either.

Since I'm running 32 bit SageTV, I'm wondering if these might be the incorrect (64 bit) DLL's I'm trying?
Attached Images
File Type: png 2021-04-18 12_49_23-SageTV.png (444.0 KB, 13 views)
Reply With Quote
  #4  
Old 04-18-2021, 01:53 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
Running in Service Mode if it makes a difference. I'm restarting the service after each DLL change I am trying, still nothing.
Reply With Quote
  #5  
Old 04-18-2021, 02:13 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
Does anyone know where I can download the old version 9.1.7? Bintray doesn't have it any longer and the new Github release page doesn't go back that far.

I'd prefer not having to do a full system restore to get SageTV working again but I will if there is no other option.
Reply With Quote
  #6  
Old 04-18-2021, 02:30 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
Fixed!!!!!!!

Upgrading to 9.2.4 removed uu_irsage.dll from SageTV completely. This seems like a pretty bug in the installer.

The version of uu_irsage.dll that I linked to is the 64 bit version, so putting it into SageTV obviously didn't work.

I looked through my backups and found an earlier version of uu_irsage.dll and tried that, success!

I can tune channels again.

https://decider.com/wp-content/uploa...nny-glover.png
Reply With Quote
  #7  
Old 04-19-2021, 10:51 AM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,391
Quote:
Originally Posted by peternm22 View Post
Fixed!!!!!!!

Upgrading to 9.2.4 removed uu_irsage.dll from SageTV completely. This seems like a pretty bug in the installer.

The version of uu_irsage.dll that I linked to is the 64 bit version, so putting it into SageTV obviously didn't work.

I looked through my backups and found an earlier version of uu_irsage.dll and tried that, success!

I can tune channels again.

https://decider.com/wp-content/uploa...nny-glover.png
Good work getting that sorted out. The missing uu_irsage.dll is a mystery indeed. Itís handled very simply by the installer the same as TunerStub.dll and EXEMultiTunerPlugin.dll. Iíve read online about other applications suffering from a missing DLL after updating due to a bug in Windows installer. Ideally the installer is supposed to install anything with a newer version and leave everything else intact. The thing is, none of the dllís in SageTV have versioning so perhaps thatís a clue.

I think I can make a change to force install of the dllís, regardless of version and perhaps that will fix this ongoing nagging issue. I have someone who is going to try to reproduce the issue.
__________________
Windows Installer
Reply With Quote
  #8  
Old 04-19-2021, 11:46 AM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 688
I saw this is the release notes for 9.2.1:

Quote:
New: Add EXEMultiTunerPlugin, HCWIRBlaster & USB-UUIRT VS projects (Windows)
I was updating from a relatively older version (9.1.7), so I wonder if that might be related? Searching the forums I found a few other people who had their USB-UIRT's stop working after 9.2.1 as well.
Reply With Quote
  #9  
Old 04-19-2021, 01:56 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,391
Quote:
Originally Posted by peternm22 View Post
I saw this is the release notes for 9.2.1:

I was updating from a relatively older version (9.1.7), so I wonder if that might be related? Searching the forums I found a few other people who had their USB-UIRT's stop working after 9.2.1 as well.
Yeah, I made those projects when I built 64-bit support and needed to build them as 64-bit objects. Previous installers merely included the dll we already had from the V7 days. So I just checked the old dll (by hovering over it) and it has version info with 1.0.0.1. The newly-complied 32-bit one doesn't have any version info. It looks like we are triggering the installer bug where it deletes it in preparation for updating but then considers the un-versioned one to be older and skips the install.

I can either figure out how to add versioning to the DLL or I think I can have it just ignore versioning on that DLL when installing.

Thanks for the comments. I think we're on to something here.
__________________
Windows Installer
Reply With Quote
  #10  
Old 04-19-2021, 11:52 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,391
Testing has shown that the lack of version info in the 9.2.1 - 9.2.4 versions of the 32-bit uu_irsage.dll causes it to be deleted when upgrading from 9.1.x

This can be remedied by rerunning the installer and selecting the repair option.

I plan to release a 9.2.5 update soon which corrects this.
__________________
Windows Installer
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading to 9.2.1 32bit breaks USB-UIRT laberet SageTV Downloads & Instructions 6 10-28-2019 10:14 PM
Sage doesn't see my USB UIRT rwc Hardware Support 2 10-13-2012 10:08 PM
Why doesn't sage see my USB-UIRT? loonsailor SageTV Linux 4 07-27-2009 06:00 PM
Got HD-PVR, remote doesn't work (new irremote.ini doesn't fix) nightlyraver Hardware Support 1 03-31-2009 04:29 PM
Usb Uirt doesnīt work in Sagetv Service mode in V4 Nadim Hardware Support 3 12-08-2005 12:32 AM


All times are GMT -6. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.