SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-26-2010, 11:32 PM
setherd setherd is offline
Sage Advanced User
 
Join Date: Jun 2004
Posts: 212
missing some JAR's.....

Sean from the great BMT plugin has been helping me with some issues with his BMT plugin and from my logs he realized I am missing 2 important JAR's commons-io and htmlparser.

I was going to just reinstall 7.0.15 on top of itself and see if that helps things. I thought I'd post here first as I don't know if that's something the dev's want to hear about.

so if anyone has any comments or ideas let me know!
__________________
Take care,
Seth
Reply With Quote
  #2  
Old 08-27-2010, 07:49 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,635
Seth's issue is really kind of odd. While it appears that he's installed the bmtweb plugin, many of the dependency jars are simply not installed. At this point, I'm not sure if they were they, and they got removed, or if the plugin installed failed to write them (ie, persmissions, etc).
Reply With Quote
  #3  
Old 08-27-2010, 11:14 AM
GKusnick's Avatar
GKusnick GKusnick is offline
SageTVaholic
 
Join Date: Dec 2005
Posts: 5,083
Is it just the JARs themselves that have gone missing? Do the dependency plugins those JARs belong to still show up in the Installed Plugins list?

If so, then it sounds to me like it could be a packaging error somewhere. Suppose there's a Plugin X out there that includes those JARs directly as part of its plugin package, rather than as dependencies. Then installing and uninstalling Plugin X could have the effect of first overwriting and then removing JARs needed as dependencies by other plugins (such as BMT).

I'm not sure how you would find out if such a Plugin X exists, short of downloading all available plugins and inspecting their zips for redundant JARs. Maybe the plugin installer could be improved to detect attempts by Plugin X to overwrite or remove files owned by Plugin Y. But I don't think it currently keeps track of which files belong to which plugins.

In any case, it seems unlikely that re-running the 7.0.15 installer would do anything to repair this state, since those missing JARs are obviously not part of that installer.
__________________
-- Greg
Reply With Quote
  #4  
Old 08-27-2010, 12:48 PM
Narflex's Avatar
Narflex Narflex is offline
Sage
 
Join Date: Feb 2003
Location: Redondo Beach, CA
Posts: 6,315
Greg,

The plugin installer logic is smart enough to detect when multiple plugins install the same file; so if there was such a Plugin X, installing/removing it would not wipe out the JAR files from another plugin even if they both referenced the same filename. So that's probably not the issue.

He'll just need to uninstall and reinstall those plugins to fix the problem (and would have to remove anything dependent on those plugins before it would even allow him to uninstall them as well, so he may have to remove a lot of things).
__________________
Jeffrey Kardatzke
Google
Founder of SageTV
Reply With Quote
  #5  
Old 08-27-2010, 09:05 PM
setherd setherd is offline
Sage Advanced User
 
Join Date: Jun 2004
Posts: 212
thanks everyone, I was thinking the jars missing were ones that should have been installed by default.
__________________
Take care,
Seth
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CS missing dwycoff SageTV v7 Customizations 2 05-30-2010 01:24 PM
I am missing something here.... David HVR1600 SageTV Customizations 12 06-27-2008 08:26 AM
Corrupted video files? Missing data - randomly CHANGING missing data? BlueRidgeMark SageTV Software 31 04-02-2007 04:24 AM
Accessing JAR's From Within Sage aperry SageTV Studio 7 03-24-2006 07:33 AM
missing channels doox00 SageTV Software 0 11-07-2004 08:36 PM


All times are GMT -6. The time now is 02:03 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.