SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Studio

Notices

SageTV Studio Discussion related to the SageTV Studio application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the Studio software application should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-09-2007, 11:10 PM
Wirenut Wirenut is offline
Sage Advanced User
 
Join Date: Jun 2006
Posts: 183
A "Void" API

So my imported STV written for Sage Version 4 has this call....

From the Sage API Call Weblist;

PlaySound

public void PlaySound(java.lang.String SoundFile) Plays the specified sound file (used for sound effects, don't use for music playback)

Parameters:
SoundFile - the path of the sound resource to play back

It's from Bohica's HAL Home Automation STV...

PlaySound(halVMDir + "\\" + GetElement(ListItem, 5))


...it is used to play back voicemail from the server. It just stopped working around the version 6 upgrade. There is probably a new way of doing this. The old method worked fine. The voicemails are tiny .wma files... but could be .wav if needed.

I would like to know the best way to replace the old PlaySound call with a new similar API call. ...without stopping or discarding a currently playing media file.

Peace,

Wirenut
Reply With Quote
  #2  
Old 12-09-2007, 11:18 PM
GKusnick's Avatar
GKusnick GKusnick is offline
SageTVaholic
 
Join Date: Dec 2005
Posts: 5,083
PlaySound still works. I can't say I ever tried it on WMA files, but it definitely works on WAVs.

If it suddenly stopped working, I'd suspect either your path calculation is messed up, the file isn't where you think it is, or you've switched clients from SageTVClient to Placeshifter or MVP. In the latter two cases, the sound will play on the server's soundcard, not on the client.

My suggestion would be to do some more troubleshooting via Expression Evaluator using known good file paths to narrow down the cause of the problem.
__________________
-- Greg
Reply With Quote
  #3  
Old 12-09-2007, 11:31 PM
Opus4's Avatar
Opus4 Opus4 is offline
Administrator
 
Join Date: Sep 2003
Location: NJ
Posts: 19,619
Greg already said more than I was going to suggest, so I'll just add that "void" just means the call doesn't return anything, not that it was removed.

- Andy 13,000
__________________
SageTV Open Source v9 is available.
- Read the SageTV FAQ. Older PDF User's Guides mostly still apply: SageTV V7.0 & SageTV Studio v7.1.
- Hauppauge remote help: 1) Basics/Extending it 2) Replace it 3) Use it w/o needing focus
- HD Extenders: A) FAQs B) URC MX-700 remote setup
Note: This is a users' forum; see the Rules. For official tech support fill out a Support Request.
Reply With Quote
  #4  
Old 12-10-2007, 11:45 AM
Wirenut Wirenut is offline
Sage Advanced User
 
Join Date: Jun 2006
Posts: 183
Okay.

I'll keep looking in other directions as you mentioned.

Thanks a lot,

Wirenut
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DVP API support andmalc SageTV Linux 4 08-24-2007 05:33 PM
Console outputting, and stopping playback via the API. beelzerob SageTV Studio 9 08-02-2006 04:29 PM
Renaming Sage recordings through API jominor SageTV Studio 4 03-07-2006 05:46 AM
Studio API question lotus298 SageTV Studio 2 12-07-2005 01:01 PM
Sage API RMI Server drjava SageTV Customizations 11 11-23-2005 11:35 AM


All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.