SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-24-2015, 04:22 PM
troycheek's Avatar
troycheek troycheek is offline
Sage Advanced User
 
Join Date: Feb 2008
Posts: 148
Hauppauge USB-Live2 working with SageTV v7 (so far)

My brother needed a composite capture device to save some old home movies on VHS tapes. The first one he bought (EZCAP or something like that) never worked, so I spent some actual money and got a Hauppauge USB-Live 2 off Amazon. Just for giggles, I decided to see if it would work as a SageTV tuner. Short version: I think so.

I installed the drivers and a "Hauppauge Capture" program from the included CD (I skipped WinTV V8, which I think is a DVR program). After rebooting a couple times and playing with the settings, I was able to record a 720x480i test video with Hauppage Capture. SageTV source setup saw it as "Hauppauge Cx23100 Video Capture," could not get a preview, and recorded a 480x480i test video (left 2/3 of screen). Color calibration only works if SageTV is already using the device, otherwise "null capture." But it did record! I noticed that SageTV was ignoring my default video recording quality setting of Best and actually had this tuner set to Fair. I changed that to Best and got a test video at 720x480i.

I went ahead and recorded a full half hour of one of my favorite shows. Compared to composite video capture on my Hauppauge PVR-500 (the one tuner that works), picture and sound quality are about the same. The Live2 might be a tad more "jaggy." The Live2 might be losing some frames as I think I see some jerkiness now and then. It's hard to tell because the Comcast STB isn't the best video source. (I'd have to somehow wire them both up to the same source at the same time to get a proper comparison, I guess.) The video plays and converts with ffmpeg just fine, no mangled audio stream like the bad tuner on my PVR-500, no loss of A/V sync.

What did not work: The 500 somehow captures Closed Caption data through the composite inputs which I can extract with CCExtractor and play back later with SageTV or VLC. The Live2 does not. The video on the 500 has a black gap on the left of 10-12 pixels and on the right of 2-4 pixels. The autocrop settings on HandBrake usually add up to 14 or 16. The Live2 has a gap on the right of 16 pixels and I'm pretty sure I'm losing a few pixels of the image on the left side. Things don't seem quite centered. Again, I need to do more testing.

Neither of these are deal breakers, as I usually turn the captions off and I've had black gaps or uncentered video on every Hauppauge device I've ever tried. I wish there was a setting or registry entry or something I could change.

There are newer (I think) drivers on the Hauppauge support page, so I'll be testing them next to see if there's a quality difference. First, I have to finish recording this movie for my brother.

Update: Updated drivers, reboot, still shows as generic Hauppauge device, but now SageTV can get a preview, can adjust color settings, is recording at 720x480i right off the bat, etc. I think video quality is still slightly inferior (jaggies, frame rate) to the 500. Sound sounds the same. Recording more tests.

Update 2: Oh, all the above is on a system with Windows 7 Pro 32 bit.

Last edited by troycheek; 12-24-2015 at 04:58 PM.
Reply With Quote
Reply

Tags
hauppauge, live2, usb


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Live2 Tunner? Skybolt Hardware Support 0 11-01-2011 12:47 PM
hauppauge dvb-t not working paulie Hardware Support 2 06-24-2010 03:11 PM
Hauppauge USB-Live2 dbstv Hardware Support 0 03-16-2010 09:11 PM
My Hauppauge HD PVR IR Blaster stopped working in SageTV johnwmreed Hardware Support 4 02-11-2010 07:40 PM
SageTV - Hauppauge PVR-250 - PAL_N not working Monrad SageTV Recorder Software 9 05-02-2003 06:33 PM


All times are GMT -6. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.