SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-21-2017, 10:53 PM
Monedeath Monedeath is offline
Sage Expert
 
Join Date: Sep 2009
Location: Idaho
Posts: 513
Hauppauge 2250, Ubuntu and SageTV

I'm noticing on my test system that after placing a 2250 in the Ubuntu 16.04 system, that SageTV 9.0.13 only recognizes one of the tuners. (And claims it's a Samsung?)

Code:
[    2.906878] saa7164 0000:05:00.0: enabling device (0000 -> 0002)
[    2.906979] CORE saa7164[0]: subsystem: 0070:8891, board: Hauppauge WinTV-HVR2250 [card=7,autodetected]
[    2.906983] saa7164[0]/0: found at 0000:05:00.0, rev: 129, irq: 16, latency: 0, mmio: 0xef000000
[    3.105125] saa7164_downloadfirmware() no first image
[    3.105136] saa7164_downloadfirmware() Waiting for firmware upload (NXP7164-2010-03-10.1.fw)
[    3.113711] saa7164_downloadfirmware() firmware read 4019072 bytes.
[    3.113712] saa7164_downloadfirmware() firmware loaded.
[    3.113715] saa7164_downloadfirmware() SecBootLoader.FileSize = 4019072
[    3.113721] saa7164_downloadfirmware() FirmwareSize = 0x1fd6
[    3.113722] saa7164_downloadfirmware() BSLSize = 0x0
[    3.113722] saa7164_downloadfirmware() Reserved = 0x0
[    3.113722] saa7164_downloadfirmware() Version = 0x1661c00
[   10.241291] saa7164_downloadimage() Image downloaded, booting...
[   10.349292] saa7164_downloadimage() Image booted successfully.
[   13.429355] saa7164_downloadimage() Image downloaded, booting...
[   14.833373] saa7164_downloadimage() Image booted successfully.
[   14.882461] saa7164[0]: Hauppauge eeprom: model=88061
[   15.537535] DVB: registering new adapter (saa7164)
[   15.537538] saa7164 0000:05:00.0: DVB: registering adapter 0 frontend 0 (Samsung S5H1411 QAM/8VSB Frontend)...
[   18.966574] DVB: registering new adapter (saa7164)
[   18.966577] saa7164 0000:05:00.0: DVB: registering adapter 1 frontend 0 (Samsung S5H1411 QAM/8VSB Frontend)...
[   19.002155] saa7164[0]: registered device video0 [mpeg]
[   19.250213] saa7164[0]: registered device video1 [mpeg]
[   19.493566] saa7164[0]: registered device vbi0 [vbi]
[   19.493609] saa7164[0]: registered device vbi1 [vbi]
So it seems that Ubuntu knew it was there, but Sage thinks there's just one. Which from what I've seen on this forum, isn't the normal experience, so I'm trying to get suggestions on what's possibly going on here. (Beyond my being cursed)
Attached Images
File Type: gif samsung.gif (80.5 KB, 107 views)
Reply With Quote
  #2  
Old 02-22-2017, 09:20 AM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,165
I can't help with the 1 versus 2 but according to this site, there are Samsung chips in the latest rev of a 2250.

https://www.linuxtv.org/wiki/index.p...WinTV-HVR-2250
Reply With Quote
  #3  
Old 02-22-2017, 07:00 PM
BobPhoenix BobPhoenix is offline
SageTVaholic
 
Join Date: Oct 2004
Posts: 3,151
My HVR-2250s show up as Samsung. My HVR-2255s show up as LG. Basically Linux is just reporting the tuner that is installed on the card not the manufacturer of the card. You also should see the analog tuner: "Hauppauge WinTV-2250" which would record from sVideo and composite.
__________________
"Keep your goals away from the trolls"
Reply With Quote
  #4  
Old 02-23-2017, 05:16 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,580
It's interesting, because in the logs it's showsing video0 and video1, and my understanding is that sagetv uses v4l (video for linux) so I would think it would see 2 tuners. does /dev/video0 and /dev/video1 exist?
Reply With Quote
  #5  
Old 02-23-2017, 11:45 AM
Monedeath Monedeath is offline
Sage Expert
 
Join Date: Sep 2009
Location: Idaho
Posts: 513
Quote:
Originally Posted by stuckless View Post
It's interesting, because in the logs it's showsing video0 and video1, and my understanding is that sagetv uses v4l (video for linux) so I would think it would see 2 tuners. does /dev/video0 and /dev/video1 exist?
Yes, it does. Which just puzzled me further.

But as it is, it will be sometime next month before I get back to it, if I even do so then. If Ubuntu 17 is in release at that point, I will be upgrading to get to the Linux 4.9 kernel and start focusing on the Quad PCI-E Tuner Hauppauge has, the 2250 was going to be a stop-gap to do some tentative testing(by another) while I'm not there.

This was as much, if not more so, a fishing expedition to see if someone had already encountered and resolved this issue, as I wasn't coming up with anything in my forum searching.
Reply With Quote
  #6  
Old 02-25-2017, 10:53 AM
uggie uggie is offline
Sage User
 
Join Date: Nov 2007
Posts: 23
I have this card and the setup actually offers 3 possible tuners (digital, digital #2, and a PCI entry which I assume is the for the analog input that curiously v4l doesn't register...).

Are you hitting the max video sources limit? What do you have set in Sage.properties for:

linux/max_video_dev_num?
Reply With Quote
  #7  
Old 02-25-2017, 07:16 PM
Monedeath Monedeath is offline
Sage Expert
 
Join Date: Sep 2009
Location: Idaho
Posts: 513
Quote:
Originally Posted by uggie View Post
I have this card and the setup actually offers 3 possible tuners (digital, digital #2, and a PCI entry which I assume is the for the analog input that curiously v4l doesn't register...).

Are you hitting the max video sources limit? What do you have set in Sage.properties for:

linux/max_video_dev_num?
Whatever the default is? I more than a few miles away from there, and never setup a VPN to get there remotely. Will be a few weeks before I'm back.

That is possibly what is doing it in, as it is also picking on the 2 HDHomerun Network tuners, both directly, and again through OpenDCT(so we're at 8 tuners from that duplication alone). Then there were 6 more Tuners showing through OpenDCT because of the Ceton Tuner. Which would have made the 2250 Tuner #15 and #16 respectively, so if the tuner limit was set to default at 15, that would certainly do it.
Reply With Quote
Reply

Tags
16.04, 2250


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hauppauge 2250 Lessons Learned Sagetv 7 attrib1 Hardware Support 1 06-22-2011 06:14 AM
Ubuntu 10.04.1 - Sage Server for Linux - Haupaugge 2250 shugrue SageTV Beta Test Software 3 10-15-2010 01:28 AM
SageTv v7 Beta - Hauppauge 2250 Tv Tuner Bill1426 SageTV Beta Test Software 0 05-23-2010 05:55 PM
Is there support for Hauppauge HVR-2250 for SageTV running on Windows Home Server? monkeydooh Hardware Support 21 04-27-2009 06:10 AM
SageTV and Hauppauge 2250 codiac Hardware Support 4 09-20-2008 08:36 AM


All times are GMT -6. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.