SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Batch Metadata Tools

Notices

Batch Metadata Tools This forums is for discussing the user-created Batch Metadata Tools for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-21-2011, 10:27 PM
wmstonetn wmstonetn is offline
Sage User
 
Join Date: Apr 2005
Posts: 10
MediaTitles not Working

I am having trouble getting bmt to recognize NCIS. I tried to enter the info in mediatitles.xml to force it to match, but I can't get it too work.

I am running SageTV 7 on Windows 7

FileName: G:\SageTV\NCIS - S03E11 - Model Behaviour.avi

MediaTitles.xml:
<match>
<regex>[\\/]NCIS\s-</regex>
<title>NCIS</title>
<year>2003</year>
<metadata type="tv" name="tvdb">72108</metadata>
</match>

phoenix-metadata.log:
2011-02-21 23:21:16,162 - ERROR; G:\SageTV\NCIS - S03E11 - Model Behaviour.avi; NCIS - S03E11 - Model Behaviour; 247647; Metadata lookup failed for NCIS
Reply With Quote
  #2  
Old 02-22-2011, 07:34 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,510
Quote:
Originally Posted by wmstonetn View Post
I am having trouble getting bmt to recognize NCIS. I tried to enter the info in mediatitles.xml to force it to match, but I can't get it too work.

I am running SageTV 7 on Windows 7

FileName: G:\SageTV\NCIS - S03E11 - Model Behaviour.avi

MediaTitles.xml:
<match>
<regex>[\\/]NCIS\s-</regex>
<title>NCIS</title>
<year>2003</year>
<metadata type="tv" name="tvdb">72108</metadata>
</match>

phoenix-metadata.log:
2011-02-21 23:21:16,162 - ERROR; G:\SageTV\NCIS - S03E11 - Model Behaviour.avi; NCIS - S03E11 - Model Behaviour; 247647; Metadata lookup failed for NCIS
Unfortunately, I'm going to need more information. The "failed" error could be anything. it could be that the media titles worked but there was a network error, etc. If you have the log file, could you email it to metadatatools at gmail dot com.

When you changed the media titles did you reload them or restart the server? Also, if the title of the show is NCIS on tvdb, then you probably don't need a media titles entry for this show. (I don't and I record NCIS and NCIS LA)
Reply With Quote
  #3  
Old 02-22-2011, 08:53 AM
wmstonetn wmstonetn is offline
Sage User
 
Join Date: Apr 2005
Posts: 10
Thanks for the feedback. I will send you the log file tonight. But here are some answers in the meantime.

Is there a setting to turn up the log level for more details.

I have reloaded the MediaTitles file both from within BMT web interface and by restarting Sagetv.

I am not sure what is going on, but phoenix/bmt will not match any of my NCIS or NCIS LA files, neither the sage recorded (in that format) or the acquired ones (in the format above). I agree that is should not need anything in MediaTitles to work. When I look at them in bmt under missing metadata they are all set as movie. My bmt settings are pretty much set at the default.

Thanks for your help.

I also have trouble with shows like Castle and Human Target that had an earlier series in the database (like 2009 or 1995). How is the best way to fix that.
Reply With Quote
  #4  
Old 02-22-2011, 08:56 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,510
I'm currently investigating items like human target... so hopefully I'll know more after I get a little further along. (btw... mediatitles should work for human target, as well, but I'm validating to see if there is an underlying issue)
Reply With Quote
  #5  
Old 02-22-2011, 10:06 AM
razrsharpe razrsharpe is offline
Sage Icon
 
Join Date: Sep 2008
Location: Boston, MA
Posts: 2,111
i use the following for castle in sagetv recorded format... works great

Code:
    <match>
        <regex>[\\/]Castle-.*</regex>
        <title>Castle</title>
        <year>2009</year>
        <metadata type="tv" name="tvdb">83462</metadata>
    </match>
__________________
Server 2003 r2 32bit, SageTV9 (finally!)
2x Dual HDHR (OTA), 1x HD-PVR (Comcast), 1x HDHR-3CC via SageDCT (Comcast)
2x HD300, 1x SageClient (Win10 Test/Development)
Check out TVExplorer
Reply With Quote
  #6  
Old 07-03-2015, 03:06 PM
SWKerr SWKerr is offline
Sage Icon
 
Join Date: Jun 2008
Posts: 1,178
Quote:
Originally Posted by wmstonetn View Post
I am having trouble getting bmt to recognize NCIS. I tried to enter the info in mediatitles.xml to force it to match, but I can't get it too work.

I am running SageTV 7 on Windows 7

FileName: G:\SageTV\NCIS - S03E11 - Model Behaviour.avi

MediaTitles.xml:
<match>
<regex>[\\/]NCIS\s-</regex>
<title>NCIS</title>
<year>2003</year>
<metadata type="tv" name="tvdb">72108</metadata>
</match>

phoenix-metadata.log:
2011-02-21 23:21:16,162 - ERROR; G:\SageTV\NCIS - S03E11 - Model Behaviour.avi; NCIS - S03E11 - Model Behaviour; 247647; Metadata lookup failed for NCIS
Did anyone ever get NCIS to work?

I am trying to clean up my Library in anticipation of coming back to SageTV.
I am having trouble with NCIS. I have an xml exception but still can't my NCIS recordings to import into SageTV via BMT.
The files are named like the example below which seems to work fine for Kodi and Plex:
\\HomeServer\DVR\NCIS\Season10\NCIS.S10E08.Gone.ts
__________________

Retired SageTV in favor of Plex\Emby and YouTubeTV.
Reply With Quote
  #7  
Old 07-03-2015, 06:16 PM
Skirge01's Avatar
Skirge01 Skirge01 is offline
SageTVaholic
 
Join Date: Jun 2007
Location: New Jersey
Posts: 2,599
Quote:
Originally Posted by SWKerr View Post
Did anyone ever get NCIS to work?

I am trying to clean up my Library in anticipation of coming back to SageTV.
I am having trouble with NCIS. I have an xml exception but still can't my NCIS recordings to import into SageTV via BMT.
The files are named like the example below which seems to work fine for Kodi and Plex:
\\HomeServer\DVR\NCIS\Season10\NCIS.S10E08.Gone.ts
I have no exceptions for NCIS; they just work. However, mine would be as follows:

NCIS.S10E08 - Gone.ts

I'm not sure if that would make a difference, but I've seen strange things with BMT. Make sure you remove any manually added BMT matchers before trying other variations. If that doesn't fix it, try it like so:

NCIS - S10E08 - Gone.ts

If that doesn't work, then something is really weird.
__________________
Server: XP, SuperMicro X9SAE-V, i7 3770T, Thermalright Archon SB-E, 32GB Corsair DDR3, 2 x IBM M1015, Corsair HX1000W PSU, CoolerMaster CM Storm Stryker case
Storage: 2 x Addonics 5-in-3 3.5" bays, 1 x Addonics 4-in-1 2.5" bay, 24TB
Client: Windows 7 64-bit, Foxconn G9657MA-8EKRS2H, Core2Duo E6600, Zalman CNPS7500, 2GB Corsair, 320GB, HIS ATI 4650, Antec Fusion
Tuners: 2 x HD-PVR (HTTP tuning), 2 x HDHR, USB-UIRT
Software: SageTV 7
Reply With Quote
  #8  
Old 07-04-2015, 05:36 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,510
Here's my matcher fro NCIS

Code:
  <match>
    <regex>[\\/]NCIS[\\/]</regex>
    <metadata type="TV" name="tvdb">72108</metadata>
  </match>
Your regex (if you even need one) should not be
Code:
<regex>[\\/]NCIS\s-</regex>
Since that is looking for NCIS with a space (\s is space)

So either try nothing... or try...
Code:
<regex>[\\/]NCIS\\.</regex>
for your filename of
NCIS.S10E08.Gone.ts
Reply With Quote
  #9  
Old 07-04-2015, 10:52 AM
SWKerr SWKerr is offline
Sage Icon
 
Join Date: Jun 2008
Posts: 1,178
Quote:
Originally Posted by stuckless View Post
Here's my matcher fro NCIS

Code:
  <match>
    <regex>[\\/]NCIS[\\/]</regex>
    <metadata type="TV" name="tvdb">72108</metadata>
  </match>
Your regex (if you even need one) should not be
Code:
<regex>[\\/]NCIS\s-</regex>
Since that is looking for NCIS with a space (\s is space)

So either try nothing... or try...
Code:
<regex>[\\/]NCIS\\.</regex>
for your filename of
NCIS.S10E08.Gone.ts
I used this and it appears to be working perfectly.
Never tried the /s since I did not know what it meant but good info for future issues. Really I could swear I tried this combination already but it must have been user error cause this worked an nothing before it has.

<match>
<regex>[\\/]NCIS[\\/]</regex>
<metadata type="TV" name="tvdb">72108</metadata>
</match>

Thanks!
__________________

Retired SageTV in favor of Plex\Emby and YouTubeTV.
Reply With Quote
  #10  
Old 07-08-2015, 02:15 AM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
Just make sure that the regex you end up using doesn't also match with NCIS Los Angels or NCIS New Orleans.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A few hints needed for MediaTitles.xml davidk21770 Batch Metadata Tools 47 07-26-2016 11:00 AM
MediaTitles.xml and how to read it razrsharpe Batch Metadata Tools 28 01-22-2011 07:57 AM
MediaTitles.xml failed, how do I see what went wrong? davidk21770 Batch Metadata Tools 5 09-28-2010 11:47 AM
Quick MediaTitles.xml question davidk21770 Batch Metadata Tools 3 09-24-2010 01:48 PM
Problem with MediaTitles.xml cmaloney Batch Metadata Tools 12 08-17-2010 07:44 PM


All times are GMT -6. The time now is 11:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.