SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations

Notices

SageTV Customizations This forums is for discussing and sharing user-created modifications for the SageTV application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss customizations for SageTV version 6 and earlier, or for the SageTV3 UI.

Closed Thread
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-27-2009, 07:13 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Arrow Plugin: PlayOn in Online Services (Hulu, Netflix, Amazon VOD, etc.)

I'm having Andy lock down this thread in favor of the v7 version. Please don't repost old issues in new thread, i'm aware of them and i'll get to them when I have the time.


Description

This plug-in takes the videos that PlayOn makes available over UPnP (Hulu, Netflix, etc.) and lets you view them from within Sage's Online Services on a PC or Extender.



Known Issues:
  • @SageTV - TV shows aren't working via Netflix.. Handling this will require the ability to specify dynamic sub folders from within the podcast feed. Feature request has already been submitted and Sage sees the benefit, but its not trivial to implements so it'll prolly be a while for this one.
  • @SageTV - Sometimes .flv's in %TEMP% aren't getting deleted. This occurs when you power down your extender while watching any progressively downloading online services video. Bug has already been submitted to Sage and it'll probably be fixed in the next beta cycle. If you've got a small OS drive and this is a huge problem, see this post for a workaround.
  • @SageTV - Special characters (',/&) sometimes aren't being displayed properly. While UPnP2Podcast is outputting UTF-8 properly, its getting lost when Sage writes the info file back to the tempFeed.xml. I'll ask Sage about this when they get a chance to look at the dynamic subcategories issue.
  • @SageTV - Timebar doesn't advance when playing back the videos. Bug has been submitted to Sage and they say its an easy fix so we'll probably see it in the next beta cycle.

Requirements:
Installation:
  1. From detailed settings (Detailed Setup -> Advanced -> Check for STV Update), update yourself to the lastest default STV (2009120901 or later). The updates don't all install at once so you may need to do this 5+ times.
  2. Download the plug-in and unzip it into "C:\Program Files\SageTV\SageTV"
  3. DONE! Navigate to the Online Services menu and start enjoying your new content!

Release History
Troubleshooting:
  • Don't see any of the new menus (Hulu, Netflix, ABC, NBC, etc.) - Either your STV isn't fully updated or the feed files are in the wrong folder.
  • When you select a show (ABC->Better Off Ted) it finds no episodes - The most likely cause of this is my tool being unable to communicate with PlayON. First, check to see if the PlayON Service is started, then try disabling firewalls to see if that helps. If neither of those work, please post UPnP2Podcast.log on this thread and I can take a look.
  • When you select a video it goes to a blank screen - Try just pressing play, sometimes videos (especially hulu) just start paused.

Once you've double checked that you followed all of the install steps correctly, check out the 2nd post for debugging information.

64-Bit Windows Users:

First of all, why the hell are you using a 64-bit OS? Secondly, you'll run into some problems with Netflix by default. See this post for the fix.

Non-US Users:

Some services like Hulu and Netflix either don't work or have limited functionality from outside of the US. I have no expereince with this myself, but this post recommends a good , non-free, VPN service that can use to get around that.

WHS Users:

From PlayON FAQ:
Quote:
PlayOn for Windows Home Server and Windows Server 2003
PlayOn generally works great on WHS and Windows Server 2003. You may, however, need to disable "Internet Explorer Enhanced Security Configuration". See below for specific instructions.
Disabling "Internet Explorer Enhanced Security Configuration"

1. Click Start > Control Panel > Add/Remove Programs.
2. Click Add/Remove Windows Components.
3. After a few seconds a window will pop-up. Click the check mark next to Internet Explorer Enhanced Security Configuration (to make it unchecked). If you'd like to only disable it for Administrators or only for Users you can click Details and do so.
4. Press Next, let it finish, and it's complete. Verify that it's disabled by opening Internet Explorer. You should see a message: "Caution: Internet Explorer Enhanced Security Configuration is not enabled".
Warnings, Known Issues, Misc.:
  • A few people have found that they are missing a few .dll files required for PlayOn. If nothing is working for you check this post.
  • Amazon VOD requires that you first play a video through IE on the PlayON server.
  • Simonen found a nice UPnP server file browser you can use to explore whats available in PlayOn.

Bug List:
  • @SageTV - Sometimes .flv's in %TEMP% aren't getting deleted. This occurs when you power down your extender while watching any progressively downloading online services video. Bug has already been submitted to Sage and it'll probably be fixed in the next beta cycle. If you've got a small OS drive and this is a huge problem, see this post for a workaround.
  • @SageTV - TV shows aren't working via Netflix.. Handling this will require the ability to specify dynamic sub folders from within the podcast feed. Feature request has already been submitted and Sage sees the benefit, but its not trivial to implements so it'll prolly be a while for this one.
  • @SageTV - Special characters (',/&) sometimes aren't being displayed properly. While UPnP2Podcast is outputting UTF-8 properly, its getting lost when Sage writes the info file back to the tempFeed.xml. I'll ask Sage about this when they get a chance to look at the dynamic subcategories issue.
  • @SageTV - Timebar doesn't advance when playing back the videos. Bug has been submitted to Sage and they say its an easy fix so we'll probably see it in the next beta cycle.

Compiling Perl Scripts: (Devs only)
All my code comes pre-compiled and ready to rock, but if you feel the urge to tinker with it yourself, compiling perl scripts into standalone executables is easily accomplished using PAR::Packer.

LINUX: (Tested using Ubuntu 9.10 in VMware Player)
From a fresh install of Ubuntu 9.10 open a terminal and run these commands...
Code:
>sudo apt-get libperl-dev
>sudo apt-get subversion
>sudo CPAN PAR:Packer
>sudo CPAN MD5
>sudo CPAN SKONNO/Net-UPnP-1.4.2.tar.gz
>svn checkout http://upnp2podcast.googlecode.com/svn/trunk/ upnp2podcast-read-only
>sudo cp -r ./upnp2podcast/upnp2podcast/UPNP.pm/* /usr/local/share/perl/5.10.0/Net/.
>./upnp2podcast/upnp2podcast/build_OUTs.pl ./upnp2podcast/upnp2podcast/UPnP2Podcast.pl
Windows:
  1. Download and install ActivePerl 5.10.
  2. Open Perl Package Manager
  3. Add Bribes repository
  4. Find PAR-Packer and install
  5. Open a Command Prompt and run this command...
    Code:
    pp -c -M PerlIO.pm -o ./script.exe ./script.pl
Screenshots:




Attached Images
File Type: jpg PlayOn_Main.jpg (46.3 KB, 24755 views)
File Type: jpg PlayOn_NBC.jpg (94.1 KB, 25971 views)
File Type: jpg PlayOn_Naruto_Episodes.jpg (82.4 KB, 24242 views)
File Type: jpg PlayOn_Netflix_Queue.jpg (96.3 KB, 24395 views)
File Type: jpg PlayOn_Account.jpg (84.7 KB, 2489 views)

Last edited by evilpenguin; 06-07-2010 at 02:13 PM.
  #2  
Old 09-27-2009, 07:13 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Debugging Issues:

Symptom #1: No videos are appearing when you select a menu item.
  1. Try navigating to ABC->Lost, let it try and generate the video list.
  2. Look in ...\SageTV\STVs\SageTV3\OnlineVideos\ and see if there is a file named tempFeed.xml
  3. Open up tempFeed.xml and check to see if there are any <item></item> tags that contain long URL's to .mpg files.
    Code:
        <item> 
          <title>Apollo, Apollo</title> 
          <description>Season 3 Episode 16 - With Jack's 50th birthday looming, he questions his happiness. Liz's ex-boyfriend Dennis "The Beeper King" decides to come clean to Liz about an addiction, stirring up drama between Liz and Jenna.</description> 
          <pubDate>2009-03-26</pubDate> 
          <itunes:subtitle>Season 3 Episode 16 - With Jack's 50th birthday looming, he questions his happiness. Liz's ex-boyfriend Dennis "The Beeper King" decides to come clean to Liz about an addiction, stirring up drama between Liz and Jenna.</itunes:subtitle>
          <itunes:duration>0:21:32</itunes:duration>
          <enclosure url="http://10.0.1.2:63478/hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7/1-hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7.mpg" length="991408000" type="video/mpeg2" /> 
          <media:content duration="1292" medium="video" fileSize="991408000" url="http://10.0.1.2:63478/hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7/1-hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7.mpg" type="video/mpeg2"> 
           <media:title>Apollo, Apollo</media:title> 
            <media:description>Season 3 Episode 16 - With Jack's 50th birthday looming, he questions his happiness. Liz's ex-boyfriend Dennis "The Beeper King" decides to come clean to Liz about an addiction, stirring up drama between Liz and Jenna.</media:description> 
            <media:thumbnail url="http://10.0.1.2:63478/hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7/1-hulu-43cc0389-bb62-4fd2-afc4-c2345f1141b7.mpg?albumArt=true"/> 
          </media:content> 
        </item>
  • If no tempFeed.xml file exists then it probably means the import wasn't successful. First of all, make sure you extracted the installer zip to the correct folder (Program Files\SageTV\SageTV\). Then revert back to a clean SageTV3.xml and apply all of the available STV updates and then try importing again. Once you've done that redo this test.
  • If tempFeed.xml exists but is an empty file or contains no <item></item> tags please move onto Symptom #2.
Symptom #2: tempFeed.xml is an empty file or contains no items.
  1. Open up a command prompt
  2. Navigate to "C:\Program Files\SageTV\SageTV"
  3. Run this exact command...
    Code:
    UPnP2Podcast.exe "PlayOn:Hulu:+2" debug
  • If the output looks like this then you're able to connect/navigate the PlayON server from that machine. Therefore your tempFeed.xml should be getting made correctly. Please verify that you're using the most recent version of PlayOn.
  • If it hangs or fails to find the "UPnP Device" move onto Symptom #3.
Symptom #3: UPnP2Podcast fails to connect to the PlayOn server
  1. Open Up you're playOn Settings and verify that the server is currently running.
  2. Open up the windows firewall settings and completely disable it.
  3. Shut down any anti-virus software you may have.
  4. Re-run the test from Symptom #2.
  • If it succeeds this time then the problem is either with your Firewall or Anti-Virus. Check the PlayOn forums for information about how to set those up properly for PlayON.
  • If it still doesn't work... well, i'm not sure yet
Symptom #4: Can see the videos but they fail when you try to play them back
  1. Try navigating to ABC->Lost, let it generate the video list.
  2. Look in ...\SageTV\STVs\SageTV3\OnlineVideos\ and and open tempFeed.xml.
  3. Copy one of the long .mpg links and attempt to open it in a web browser.

Same PC as the PlayON Server
  • If it still doesn't work please verify that you have the latest version of PlayOn installed and also try installing Windows Media Player 11.

Extender or Different PC than PlayOn server
  • Verify that you have the latest version of PlayOn installed and also try installing Windows Media Player 11 on the PlayOn server machine.
  • Turn off the Firewall on both the PlayOn server and, if applicable, the client PC.
  • Try playing back the video again.
Attached Images
File Type: jpg PlayOn_Version.jpg (73.4 KB, 2475 views)
File Type: jpg playOn_debug_output.jpg (117.8 KB, 1529 views)
File Type: jpg playOnPropertiesFiles.jpg (165.4 KB, 1336 views)

Last edited by evilpenguin; 02-18-2010 at 04:27 PM.
  #3  
Old 09-27-2009, 07:29 PM
LehighBri LehighBri is offline
Sage Expert
 
Join Date: Sep 2006
Posts: 694
Amazing amazing job. And I love how you pre-populated the custom properties files with most of the useful content that could be played via PlayOn. People are going to love this plugin... especially since all of this content is playable on extenders!
__________________
Server: Sage 7.1.9 beta; Dell Inspiron 530; Windows 7 Ultimate 32-bit (UAC turned off); 2TB Internal SATA (TV Recordings)
Storage: Synology DiskStation DS411+, RAID 5, 5x 2TB SATA for (DVDs/Music/Other Videos)
Tuners: Ceton InfiniTV w/ Verizon FIOS cablecard (using babgvant's SageDCT plugin)
Clients: 1x STP-HD300; 1x Acer Aspire Revo 3610 (Atom/Ion) w/ SageTV client (Win 7, EVR, FSE on)
  #4  
Old 09-27-2009, 07:34 PM
Slipshod's Avatar
Slipshod Slipshod is offline
Sage Aficionado
 
Join Date: Feb 2008
Location: San Francisco Bay Area
Posts: 474
Have you seen this chicken? He rocks.
__________________
SageTV V7 (WHS), Diamond UI
Server: WHS with Xeon X3350, 4GB ECC, ASUS P5BV-C/4L, recording into a 6.6TB Drive pool
Tuners: 4 (2x HDHR)
Clients: 2x HD300, 1x HD200 Extenders, 1x Placeshifter
2x Roku XD
  #5  
Old 09-27-2009, 07:43 PM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
thanks for the work EP. How come this won't work in SageMC? I thought it just reverted to the stock STV for the online services?

Matt
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
  #6  
Old 09-27-2009, 07:54 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Quote:
Originally Posted by matt91 View Post
thanks for the work EP. How come this won't work in SageMC? I thought it just reverted to the stock STV for the online services?

Matt
It does, but it reverts directly to SageTV3.xml which doesn't have any imports applied to it.

SageMC Users:
  1. Follow the instructions and get the plug-in working in the default STV
  2. Figure out what the name of the modified default STV you're using is (check the SageTV Settings->Advanced).
  3. On the server, copy the modified STV file, and overwrite SageTV3.xml with it.
  4. Load up SageMC again, and everything should work.

Last edited by evilpenguin; 09-27-2009 at 08:58 PM.
  #7  
Old 09-27-2009, 08:11 PM
ybrew ybrew is offline
Sage Expert
 
Join Date: Jun 2006
Posts: 633
Awesome.

Thank you very much!
  #8  
Old 09-27-2009, 08:42 PM
Mitch G Mitch G is offline
Sage Aficionado
 
Join Date: Jan 2008
Posts: 322
Quote:
Originally Posted by evilpenguin View Post
It does, but it reverts directly to SageTV3.xml which doesn't have any imports applied to it.

... now that I think about it, a quick work around would be to load SageTV3.xml on the SageTV Server, import the STVi, open up Studio, and then save it as SageTV3.xml. That would work
I actually run the standard Sage interface on my server and only run SageMC on my extenders.
Does that mean if I just go and install this add-on on my server, everything will work just fine?


Mitch
  #9  
Old 09-27-2009, 08:56 PM
Zippster's Avatar
Zippster Zippster is offline
Sage Aficionado
 
Join Date: Jun 2008
Location: Buffalo NY
Posts: 314
Quote:
Originally Posted by Mitch G View Post
I actually run the standard Sage interface on my server and only run SageMC on my extenders.
Does that mean if I just go and install this add-on on my server, everything will work just fine?


Mitch
I do the same, I just installed this without doing the load and save method as described for extenders, all EP's menus etc are there, just "no videos found" when I click on something.
  #10  
Old 09-27-2009, 09:06 PM
evilpenguin's Avatar
evilpenguin evilpenguin is offline
SageTVaholic
 
Join Date: Aug 2003
Location: Seattle, WA
Posts: 3,696
Quote:
Originally Posted by Mitch G View Post
I actually run the standard Sage interface on my server and only run SageMC on my extenders.
Does that mean if I just go and install this add-on on my server, everything will work just fine?


Mitch
Quote:
Originally Posted by Zippster View Post
I do the same, I just installed this without doing the load and save method as described for extenders, all EP's menus etc are there, just "no videos found" when I click on something.
You need to overwrite SageTV3.xml file with a version that contains the import. I've updated the first post with instructions.
  #11  
Old 09-27-2009, 09:17 PM
Zippster's Avatar
Zippster Zippster is offline
Sage Aficionado
 
Join Date: Jun 2008
Location: Buffalo NY
Posts: 314
Yes sir, I overwrote it now and videos are there. Will play with it some more tonight and see how it all goes.

Great work and Thanks!
  #12  
Old 09-27-2009, 09:20 PM
wado1971's Avatar
wado1971 wado1971 is offline
Sage Aficionado
 
Join Date: Feb 2006
Location: Stamford, CT
Posts: 345
Lets recap

9-21-09 "Need help testing something for playon"

9-27-09 - Penguin delivers two of the most desired contents to SageTV in one very nice looking stvi.

Great job!
  #13  
Old 09-27-2009, 10:45 PM
shardinite shardinite is offline
Sage User
 
Join Date: Nov 2006
Location: Honolulu, HI
Posts: 12
Send a message via AIM to shardinite Send a message via MSN to shardinite Send a message via Yahoo to shardinite
EP, is it wrong I luv you?
  #14  
Old 09-28-2009, 12:29 AM
Nick_W Nick_W is offline
Sage Advanced User
 
Join Date: Aug 2007
Posts: 215
Unhappy

I'm soooooo jealous.

UK User
  #15  
Old 09-28-2009, 12:38 AM
jaminben jaminben is offline
Sage Icon
 
Join Date: Sep 2007
Location: Norwich, UK
Posts: 1,754
Send a message via MSN to jaminben
Quote:
Originally Posted by Nick_W View Post
I'm soooooo jealous.

UK User
Yep, I'm with you Nick.....

__________________
Server - Win7 64bit, 2.4Ghz Intel Core 2 Duo, TBS 6284 PCI-E Quad DVB-T2 Tuner, 3 x HD200 & 1 x HD300 extenders
  #16  
Old 09-28-2009, 05:26 AM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,779
EP - If you ever need a place to live I have an extra bedroom and place at the dinner table.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
  #17  
Old 09-28-2009, 07:11 AM
gplasky's Avatar
gplasky gplasky is offline
SageTVaholic
 
Join Date: Jul 2003
Location: Howell, MI
Posts: 9,198
Good work and nice job. I threw this on in 5 minutes before leaving for work this morning and it just worked for the default STV. Just simply amazing. Thanks for this.

Gerry
__________________
Big Gerr
_______
Server - WHS 2011: Sage 7.1.9 - 1 x HD Prime and 2 x HDHomeRun - Intel Atom D525 1.6 GHz, Acer Easystore, RAM 4 GB, 4 x 2TB hotswap drives, 1 x 2TB USB ext Clients: 2 x PC Clients, 1 x HD300, 2 x HD-200, 1 x HD-100 DEV Client: Win 7 Ultimate 64 bit - AMD 64 x2 6000+, Gigabyte GA-MA790GP-DS4H MB, RAM 4GB, HD OS:500GB, DATA:1 x 500GB, Pace RGN STB.
  #18  
Old 09-28-2009, 07:18 AM
razrsharpe razrsharpe is offline
Sage Icon
 
Join Date: Sep 2008
Location: Boston, MA
Posts: 2,111
man... looks like im going to have buy a PlayOn license now looks good EP, thanks
__________________
Server 2003 r2 32bit, SageTV9 (finally!)
2x Dual HDHR (OTA), 1x HD-PVR (Comcast), 1x HDHR-3CC via SageDCT (Comcast)
2x HD300, 1x SageClient (Win10 Test/Development)
Check out TVExplorer
  #19  
Old 09-28-2009, 07:21 AM
gibsonpa gibsonpa is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: STL, Mo
Posts: 202
Just to be sure I am clear....

This 1 plug-in eliminates the need to have upnp2podcast.exe run periodically and put XML files on a webserver for the CustomOnline property files to reference. I have that working very well...but want to be sure I understand this plug-in correctly.
  #20  
Old 09-28-2009, 07:27 AM
Mitch G Mitch G is offline
Sage Aficionado
 
Join Date: Jan 2008
Posts: 322
Correct.
Plus it creates feeds for things other than just your queues (e.g. newly added movies in Hulu, or a list of all movies in Netfilx watch instantly).


Mitch
Closed Thread

Tags
amazon vod, hulu, internet video streaming, netflix, online content, online services, online videos, playon


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HD200 - Playon - Netflix & Hulu import file issues - FIXED! Crunch SageTV HD Theater - Media Player 30 06-23-2010 01:24 PM
Using Playon Hulu Plugin For SageTV ? squeed SageTV Customizations 5 06-04-2010 09:42 AM
PlayOn on HD200 Amazon VOD (Unbox) Works! Brent SageTV HD Theater - Media Player 15 04-23-2009 07:05 AM
Hulu: Possible to Use XBMC Hulu Plugin to create SageTV Plugin? Brent SageTV Customizations 8 02-24-2009 04:16 PM
SageTV and online content - hulu, netflix ... Hari_Seldon General Discussion 65 11-17-2008 05:34 PM


All times are GMT -6. The time now is 11:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.