SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Github Development

Notices

SageTV Github Development Discussion related to SageTV Open Source Development. Use this forum for development topics about the Open Source versions of SageTV, hosted on Github.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-28-2016, 11:58 AM
Zogg Zogg is online now
Sage Advanced User
 
Join Date: May 2011
Location: Frisco, TX
Posts: 123
SageTV EXE files mysteriously vanished

I have no idea what happened. I had Sage running, I believe just the EXE and not the service, and it was minimized. I restored it to look at something and the menu was all blurry, although I could still see what to do. I went through some menus to see if it would clear up but it didn't.

Then I started a recording and it seemed to be playing okay, so I stopped playback and the menus were still blurry. So I exited out of Sage thinking I would just restart it.

When it exited, it's like it uninstalled itself. No EXE files at all, no desktop icon, doesn't appear in Control Panel->Programs. The other files seem to mostly be there, but most got moved up from C:\PF (x86)\SageTV\SageTV to C:\PF (x86)\SageTV. A few files are still further down.

There is nothing in the Windows log files. The only thing I see in the logs that might be related is that one of my hard drives disappeared, which has been happening a bit for some reason. It's a secondary drive but it's where I put my Sage recordings folder, just for testing. There was no recording activity going on though, or playback, when I exited, but the previously mentioned recording I played a few seconds of was on this drive.

Could the drive disappearing have caused a major issue? Any other ideas?

I haven't tried to reinstall yet. Wanted to see if anyone had any advice on this issue first. EDIT: I'm running 9.0.8.423.

Last edited by Zogg; 09-28-2016 at 12:07 PM.
Reply With Quote
  #2  
Old 09-29-2016, 08:49 AM
Zogg Zogg is online now
Sage Advanced User
 
Join Date: May 2011
Location: Frisco, TX
Posts: 123
Okay, after trying a few things I'm starting to see multiple files get written to C:\Program Files (x86)\SageTV rather than the proper folder one level below.

Is there some issue with letting Sage be installed into the (x86) folder in 64-bit Winders?
Reply With Quote
  #3  
Old 09-29-2016, 04:42 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,135
No, Sage installing to an x86 folder on a 64bit system has been the norm, for version 7 at least.

If you are having problems with a disappearing hard drive on your system, you need to chase that down before troubleshooting any issues that may be a result of that in Sage.
Reply With Quote
  #4  
Old 09-29-2016, 06:31 PM
Zogg Zogg is online now
Sage Advanced User
 
Join Date: May 2011
Location: Frisco, TX
Posts: 123
The disappearing drive was just a backup drive that I had created a temporary recording folder on. I'm not using it now. But it wasn't C:\ or in the installation path in any way, so I wouldn't think it would affect the program itself.

I did discover when looking at my properties file that all the paths specified in it had moved up a level, consistent with the files being there all of a sudden.

I deleted the folder, ran CCleaner on the system, rebooted, then reinstalled Sage and restored my properties files and now it's all working again. I'll keep an eye on it.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recordings have vanished - poof! tvmaster2 SageTV Software 3 09-15-2016 08:05 PM
Computer turn on/off mysteriously wildgoose SageTV Software 9 10-16-2012 06:38 PM
Placeshifter connects then vanished Zetavu SageTV Placeshifter 5 04-12-2009 06:32 AM
Closed Captions Mysteriously Appeared werneral SageTV Software 16 03-15-2009 09:33 AM
Favorite Being Recorded, then Mysteriously Deleted by Sage? geogecko SageTV Beta Test Software 7 11-28-2006 08:33 PM


All times are GMT -6. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.