SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations > Gemstone for v9

Notices

Gemstone for v9 This forum is for discussing the user-created Gemstone custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-04-2019, 08:23 AM
RonBoyd's Avatar
RonBoyd RonBoyd is offline
Sage Aficionado
 
Join Date: Aug 2009
Location: Denver, Colorado
Posts: 349
Gemstone Install FAILED

I installed SageTV v9 (from scratch). I have forgotten how to install Gemstone. When I go to Plugins>Gemstone for Default SageTV9 (Previously Diamond) and click on Install, I get this message:

Quote:
Plugin Install Progress: Done - FAILED
Dependency Install Phoenix-core: Done - FAILED
Dependency Install Phoenix-api- FAILED
Dependency Install Phoenix--io- FAILED
Resource Download
http://central.maven.org/mave2/commons-io/commons-io-2.5.jar
I tried to install the Phoenix Plugins which resulted in the same results.

I have JAVA v8 (Build 1.8.0_221-B11) installed on this Windows 10 machine.

What am I missing?
Reply With Quote
  #2  
Old 08-04-2019, 07:57 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
Quote:
Originally Posted by RonBoyd View Post
I installed SageTV v9 (from scratch). I have forgotten how to install Gemstone. When I go to Plugins>Gemstone for Default SageTV9 (Previously Diamond) and click on Install, I get this message:

I tried to install the Phoenix Plugins which resulted in the same results.

I have JAVA v8 (Build 1.8.0_221-B11) installed on this Windows 10 machine.

What am I missing?
Make sure its the 64 bit version of Java 8

k
Reply With Quote
  #3  
Old 08-05-2019, 04:08 AM
RonBoyd's Avatar
RonBoyd RonBoyd is offline
Sage Aficionado
 
Join Date: Aug 2009
Location: Denver, Colorado
Posts: 349
Quote:
Originally Posted by jusjoken View Post
Make sure its the 64 bit version of Java 8

k
Near as I can tell, that version is both 32 bit and 64 bit. At least in Setup the Architecture is listed as x86_64. The Help About screen doesn't show either.
Reply With Quote
  #4  
Old 08-05-2019, 09:56 AM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,251
Quote:
Originally Posted by RonBoyd View Post
Near as I can tell, that version is both 32 bit and 64 bit. At least in Setup the Architecture is listed as x86_64. The Help About screen doesn't show either.
x86_64 is 64 bit. i686 is 32.

64-bit programs are also installed under “Program Files” and not “Program Files (x86)” so that’s another way you can tell.
Reply With Quote
  #5  
Old 08-05-2019, 10:48 AM
RonBoyd's Avatar
RonBoyd RonBoyd is offline
Sage Aficionado
 
Join Date: Aug 2009
Location: Denver, Colorado
Posts: 349
Quote:
Originally Posted by wnjj View Post
x86_64 is 64 bit. i686 is 32.

64-bit programs are also installed under “Program Files” and not “Program Files (x86)” so that’s another way you can tell.
Okay, I uninstalled all versions of Java (v191 & v221). Rebooted. Installed 64 bit Java v221 (jre-8u221-windows-x64.exe).

Java.exe and javaw.exe are found here:

C:\Program Files(86)\common\oracle\java\javapath_target_405296
C:\Program Files\java\jre1.8.0.221\bin

Gemstone Plugin still fails to install..
Reply With Quote
  #6  
Old 08-05-2019, 05:50 PM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,195
Quote:
Originally Posted by RonBoyd View Post
Okay, I uninstalled all versions of Java (v191 & v221). Rebooted. Installed 64 bit Java v221 (jre-8u221-windows-x64.exe).

Java.exe and javaw.exe are found here:

C:\Program Files(86)\common\oracle\java\javapath_target_405296
C:\Program Files\java\jre1.8.0.221\bin

Gemstone Plugin still fails to install..
Another thought...did you copy your .properties from a 32 bit install? If so then there is old plugin info in the properties file but not in the install folder so that may cause issues.

Best next step may be to restart and the post the sagetv log file so we can see the errors

K
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install Gemstone panteragstk Gemstone for v7 2 09-01-2016 04:32 PM
Gemstone install error CUTIGER91 Gemstone for v7 5 12-29-2015 09:44 AM
Gemstone API Failed Joebob Gemstone for v7 2 09-29-2012 12:16 PM
Jetty download failed, BMT won't install farscapesg1 Batch Metadata Tools 2 11-28-2011 09:50 AM
Broken install - can't reinstall - SMM API Failed uberpixel Sage My Movies 2 12-05-2010 11:10 PM


All times are GMT -6. The time now is 04:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.