SageTV Community  

Go Back   SageTV Community > Hardware Support > Hardware Support

Notices

Hardware Support Discussions related to using various hardware setups with SageTV products. Anything relating to capture cards, remotes, infrared receivers/transmitters, system compatibility or other hardware related problems or suggestions should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-13-2010, 05:11 PM
SMWinnie SMWinnie is offline
Sage User
 
Join Date: Aug 2009
Location: East Lansing, MI
Posts: 10
HDHomerun to STV 6.6.2 for WHS - audio program issue

I'm running an HDHomerun to pipe an ATSC feed (both inputs) to SageTV 6.6.2 running on my Acer Easystore Windows Home Server box.

I have been getting an intermittent problem where I'm occasionally getting audio program 2 instead of audio program 1 on a recording. The local PBS affiliate runs Descriptive Video Service for the vision-impaired on program 2. Not knowing this, and not knowing that I was having a configuration issue, I got pretty darned freaked out by some guy chatting rapidly about the show my kids were watching.

Any pointers on how to control which audio programs get recorded? I presume the other place to post this is on the HDHomerun forums and have done so there as well.
Reply With Quote
  #2  
Old 03-13-2010, 05:30 PM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
I've seen this as well on my PBS stations. I'm not sure how the HDHomeRun, or sage's muxer, determines the primary audio track. I think part of the problem is that both audio tracks are listed as english. It SHOULD select the tracks by PID (0x81-primary, 0x82-secondary) as the default. That said, I'm not sure if the problem lies on the recording/muxing side, or the playback side. I have since deleted those recordings, and I haven't seen it crop up in a while. Only show I saw it on was Caillou, and it wasn't all the time, though I don't know if it affects other PBS programming.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #3  
Old 03-14-2010, 03:59 PM
SMWinnie SMWinnie is offline
Sage User
 
Join Date: Aug 2009
Location: East Lansing, MI
Posts: 10
Quote:
Originally Posted by Fuzzy View Post
I've seen this as well on my PBS stations. I'm not sure how the HDHomeRun, or sage's muxer, determines the primary audio track. I think part of the problem is that both audio tracks are listed as english. It SHOULD select the tracks by PID (0x81-primary, 0x82-secondary) as the default. That said, I'm not sure if the problem lies on the recording/muxing side, or the playback side. I have since deleted those recordings, and I haven't seen it crop up in a while. Only show I saw it on was Caillou, and it wasn't all the time, though I don't know if it affects other PBS programming.
Good idea to help me debug. I'll try a few shows on a few different nets and see if I can isolate the problem. (Nothing more fun than debugging intermittent faults...)
Reply With Quote
Reply

Tags
audio, hdhomerun, sap


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WHS - HDHomerun - SageTV MARudge SageTV United Kingdom 8 03-16-2010 10:54 AM
STV Import: Alternative Program Guide & Mini Guide for Default STV wado1971 SageTV Customizations 24 09-13-2009 01:32 PM
(another) HDHomerun, WHS and processor spec question buymysoul Hardware Support 6 03-25-2009 09:32 AM
MVP won't play Audio from HDHomeRun shows with 5.1 audio. mechling-burgh SageTV Media Extender 1 12-08-2008 03:52 PM
HDHomeRun Program Stream clarenceb5 SageTV Software 0 02-08-2008 10:10 AM


All times are GMT -6. The time now is 09:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.