SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-07-2012, 05:02 AM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
Want to rebuild my wiz.bin - the easy way

Hey guys my SageTV installation is running poorly. Real poorly. I want to reinstall and recreate my wiz.bin but I want to export and import my favorites if possible. I think everything else I Can re-import in such a way by finding movies and recordings, and reinstall / setup my tuners. Anyone used anything to do this?

Also anyone do any type of custom EPG export and import so my selected channels won't be forgotten? I have directv and it seems like every other channel is an advertising crap channel that I have to unselect...

Thanks!

Neil
Reply With Quote
  #2  
Old 08-07-2012, 05:34 AM
KeithAbbott KeithAbbott is online now
Sage Icon
 
Join Date: Oct 2009
Location: Southeastern Michigan
Posts: 1,026
Quote:
Originally Posted by heffneil View Post
Also anyone do any type of custom EPG export and import so my selected channels won't be forgotten? I have directv and it seems like every other channel is an advertising crap channel that I have to unselect...
Maybe this: http://forums.sagetv.com/forums/showthread.php?t=50378
__________________
Server: MSI Z270 SLI Plus ATX Motherboard, Intel i3-7100T CPU, 16GB Memory, unRAID 6.3.2, SageTV & OpenDCT Dockers
Tuners: 2 x SiliconDust HDHomeRun Prime Cable TV Tuners, 2 x Hauppauge WinTV-HVR-2250 Dual TV Tuner Boards
Clients: Multiple HD300 Extenders
Miscellaneous: Multiple Sony RM-VLZ620 Universal Remote Controls
Reply With Quote
  #3  
Old 08-07-2012, 07:19 AM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
That is very interesting! I will test it out. Thanks for the heads up.

Anyone know about a favorites importer exporter?
Reply With Quote
  #4  
Old 08-07-2012, 07:47 AM
nyplayer nyplayer is online now
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,054
You might want to also take a look at this thread.

http://forums.sagetv.com/forums/showthread.php?t=58510
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
  #5  
Old 08-07-2012, 10:18 AM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Quote:
Originally Posted by heffneil View Post
Hey guys my SageTV installation is running poorly. Real poorly. I want to reinstall and recreate my wiz.bin but I want to export and import my favorites if possible. I think everything else I Can re-import in such a way by finding movies and recordings, and reinstall / setup my tuners. Anyone used anything to do this?

Also anyone do any type of custom EPG export and import so my selected channels won't be forgotten? I have directv and it seems like every other channel is an advertising crap channel that I have to unselect...

Thanks!

Neil

Before you do that, make sure that you don't have Sage looking for "rogue" files that no longer exist. When I was having performance issues it ended up being because I had Sage looking for a lot of stuff that didn't exist (was looking at an old network path that no longer existed).

Jeff suggested using the (probably won't spell it right) "disable_root_path_check" set to true to have sage clean out all the stuff that doesn't exist, just make sure everything that should exist does appear to sage.
Reply With Quote
  #6  
Old 08-07-2012, 12:26 PM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
When I tune a channel I will hear the audio for at least 30 seconds before the video will begin to show. The screen shows the tuning prompt for the channel. When I stop watching a show or a recording I get the spinning wheel of death for at least 30 seconds until I get back to the videos list or the guide. I think I am pushing sage passed its capabilities with the number of videos and tuners I have but I want to test on a second installation to confirm that it isn't a corrupt / screwed up wiz.bin.

In the meantime I changed that setting to true. Not sure exactly what it does or if it will take time to clean up the crap. any ideas there?

Thanks,

Neil
Reply With Quote
  #7  
Old 08-07-2012, 02:46 PM
razrsharpe razrsharpe is offline
Sage Icon
 
Join Date: Sep 2008
Location: Boston, MA
Posts: 2,111
Quote:
Originally Posted by stanger89 View Post
Before you do that, make sure that you don't have Sage looking for "rogue" files that no longer exist. When I was having performance issues it ended up being because I had Sage looking for a lot of stuff that didn't exist (was looking at an old network path that no longer existed).

Jeff suggested using the (probably won't spell it right) "disable_root_path_check" set to true to have sage clean out all the stuff that doesn't exist, just make sure everything that should exist does appear to sage.
Is there a way to tell if sage is failing at finding files? I moved my pictures and music to a nas device and am wondering if that could be causing recent slowness in my system...
__________________
Server 2003 r2 32bit, SageTV9 (finally!)
2x Dual HDHR (OTA), 1x HD-PVR (Comcast), 1x HDHR-3CC via SageDCT (Comcast)
2x HD300, 1x SageClient (Win10 Test/Development)
Check out TVExplorer
Reply With Quote
  #8  
Old 08-07-2012, 03:37 PM
stanger89's Avatar
stanger89 stanger89 is offline
SageTVaholic
 
Join Date: May 2003
Location: Marion, IA
Posts: 15,186
Quote:
Originally Posted by heffneil View Post
When I tune a channel I will hear the audio for at least 30 seconds before the video will begin to show. The screen shows the tuning prompt for the channel. When I stop watching a show or a recording I get the spinning wheel of death for at least 30 seconds until I get back to the videos list or the guide. I think I am pushing sage passed its capabilities with the number of videos and tuners I have but I want to test on a second installation to confirm that it isn't a corrupt / screwed up wiz.bin.
Well the simple test is to just delete the wiz.bin (back it up first ) and see if it's better. If it is, you know it's something with the wiz.bin.

Quote:
In the meantime I changed that setting to true. Not sure exactly what it does or if it will take time to clean up the crap. any ideas there?
I believe it should be done by the time Sage is running, or at least by the time the first import scan completes.

Quote:
Originally Posted by razrsharpe View Post
Is there a way to tell if sage is failing at finding files? I moved my pictures and music to a nas device and am wondering if that could be causing recent slowness in my system...
Seems to me when I saw it I was seeing a lot of hangs, in the log, but I think Jeff had to send me a special jar with some debug stuff to actually see for sure that it was hanging while looking for "bad" files. For me it was the comskip plugin looking for files on nonexistant paths.
Reply With Quote
  #9  
Old 08-07-2012, 04:51 PM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
I changed it to true but then it looks like sage made it back to false is that typical?
Reply With Quote
  #10  
Old 08-07-2012, 04:57 PM
nyplayer nyplayer is online now
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,054
Quote:
Originally Posted by heffneil View Post
I changed it to true but then it looks like sage made it back to false is that typical?
Yes when it is done it goes back to false.
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
  #11  
Old 08-07-2012, 04:58 PM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
I ran it - I don't think it helped despite I wanted it to. In the archive it referenced another flag to set to true as well - I didn't try it.

I did notice that some of my recordings seem to now be in my videos <shrug? how do I fix that?
Reply With Quote
  #12  
Old 08-09-2012, 10:46 AM
egeller egeller is offline
Sage Advanced User
 
Join Date: Feb 2006
Location: Drexel Hill, PA
Posts: 237
Quote:
Originally Posted by heffneil View Post
I did notice that some of my recordings seem to now be in my videos <shrug? how do I fix that?
The short answer is through the web interface.
__________________
Server:UnRaid;2x Intel Xeon E5; SuperMicro moboard;Also:BM3000 w/ WMC; 2x Ceton ETH 6; OpenDCT
SageTV Extender:3x HD200 1x HD300
Sage TV: 9.1.10, Standard STVi, Comskip Playback, Web Interface, 24 Hour Clock, SRE, YouTube2015, Playon
All in lovely Drexel Hill, PA
Reply With Quote
  #13  
Old 08-09-2012, 12:02 PM
panteragstk's Avatar
panteragstk panteragstk is offline
SageTVaholic
 
Join Date: Oct 2008
Location: New Braunfels, TX
Posts: 3,311
Quote:
Originally Posted by heffneil View Post
When I tune a channel I will hear the audio for at least 30 seconds before the video will begin to show. The screen shows the tuning prompt for the channel. When I stop watching a show or a recording I get the spinning wheel of death for at least 30 seconds until I get back to the videos list or the guide. I think I am pushing sage passed its capabilities with the number of videos and tuners I have but I want to test on a second installation to confirm that it isn't a corrupt / screwed up wiz.bin.

In the meantime I changed that setting to true. Not sure exactly what it does or if it will take time to clean up the crap. any ideas there?

Thanks,

Neil
Do you use extenders or clients? I have that issue on my main client, but I have a crapload of plugins running (diamond seems to be a big part of the problem). On a bare client with a base sage v7 install that doesn't happen. I don't watch live tv often enough for it to bother me. I'm planning a complete reinstall just to refresh everything.
__________________
SageTV Server: unRAID Docker v9, S2600CPJ, Norco 24 hot swap bay case, 2x Xeon 2670, 64 GB DDR3, 3x Colossus for DirecTV, HDHR for OTA
Living room: nVidia Shield TV, Sage Mini Client, 65" Panasonic VT60
Bedroom: Xiomi Mi Box, Sage Mini Client, 42" Panasonic PZ800u
Theater: nVidia Shield TV, mini client, Plex for movies, 120" screen. Mitsubishi HC4000. Denon X4300H. 7.4.4 speaker setup.
Reply With Quote
  #14  
Old 08-22-2012, 08:28 PM
heffneil heffneil is offline
Sage Expert
 
Join Date: Feb 2008
Posts: 747
I just setup my first client and I am stilling having the slowness. I think a big part of my problem is that my recordings and movies all sit on unraid which has its disks spun down. I don't know why stopping a recording (which is to a local disk) would cause the guide to render so poorly.

I do have a TON of sources as well all within my guide. I have 3 HD-PVR's tuning directv and a Avermedia tuning comcast and an HDHomeRun tuning comcast as well...

Neil
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hosed DB and can't rebuild... kkelley929 Sage My Movies 7 12-27-2011 03:33 PM
What OS for server rebuild? nettech_gt General Discussion 31 01-18-2011 07:35 PM
Favorites gone after a rebuild dadavo SageTV Software 7 12-31-2010 09:44 AM
How to rebuild database? Wified Sage My Movies 10 11-19-2010 12:09 PM
Time to rebuild the box... Kanati Hardware Support 0 06-19-2005 10:06 PM


All times are GMT -6. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.