SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Phoenix

Notices

Phoenix This forum is for discussing the user-created Phoenix custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-02-2013, 04:46 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,682
New Phoenix Core 2.5.8

The TMDB v3 api relied on a Java 7 api. I've reworked the code so that it no longer depends on Java 7, but come on... Java 6 has been EOLed as of Feb 2013... It's time to move on

So, 2.5.8, just has a small change to TMDB v3 provider and it should work with Java 6 or 7.
Reply With Quote
  #2  
Old 10-02-2013, 05:46 PM
mdnttoker mdnttoker is offline
Sage Aficionado
 
Join Date: Aug 2006
Posts: 445
Works perfectly, thanks...guess I should finally take the leap to java 7 on the sage server...
Reply With Quote
  #3  
Old 10-02-2013, 07:53 PM
will will is offline
Sage Fanatic
 
Join Date: Jul 2009
Location: New York
Posts: 797
I've been rocking Java 6 for a long time too. Why change what works...
__________________
Will

OS: Windows 7
Hardware: Intel Core i7-920 with 12GB RAM & an Adaptec 5805 with a Chenbro 36-port SAS Expander
Case: Antec 1200 with 4 iStarUSA trayless hot-swap cages (20 drives max)
Drives: 8 Toshiba/Hitachi 2TB drives in a RAID 6 & 7 Toshiba 3TB drives in a RAID 6
Capture Cards: HDHomeRun Connect Quatro 4, Hauppauge 60 HD-PVR
Players: 5 HD300s, 2 HD200s
Reply With Quote
  #4  
Old 10-03-2013, 05:44 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,682
Quote:
Originally Posted by will View Post
I've been rocking Java 6 for a long time too. Why change what works...
I understand that on Windows... upgrading Java has been a pain for many people.

Just a word of caution... while I was able to roll out the changes, this time, to make this work in Java 6... There may be other times where I simply won't have the time or will to do so ie, if there's a new feature in Java 7 that makes my life easier as a developer, then I'm going to use it
Reply With Quote
  #5  
Old 10-03-2013, 07:52 AM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,039
I've been using Java 7 for a while with my W7 32 bit install...no problems, but I don't use as many plugins as some
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #6  
Old 10-03-2013, 09:44 AM
PhilH's Avatar
PhilH PhilH is offline
Sage Advanced User
 
Join Date: Feb 2009
Location: Edinburg, TX (Deep South Texas)
Posts: 95
Thanks stuckless. Your work is always appreciated.

Looks like I need to upgrade my Java on my WHS server..

Sorry for the extra work I gave you..

Phil
__________________
SageTV v7.1.9 Gemstone WHS + 3 HD200's, 1 Client & 1 Placeshifter
WHS - Dual Xeon 2.8ghz - 3gig ECC Ram - 25 Drives - 30 Terabytes
Blu-ray Titles 498
HD-DVD Titles 166
DVD Titles - Too Many To Count..
Reply With Quote
  #7  
Old 10-03-2013, 09:54 AM
routerunner's Avatar
routerunner routerunner is offline
Sage Icon
 
Join Date: May 2008
Location: Wiltshire, UK
Posts: 1,383
Quote:
Originally Posted by stuckless View Post
I understand that on Windows... upgrading Java has been a pain for many people.

Just a word of caution... while I was able to roll out the changes, this time, to make this work in Java 6... There may be other times where I simply won't have the time or will to do so ie, if there's a new feature in Java 7 that makes my life easier as a developer, then I'm going to use it
Thanks Sean, however if you plan to make any future update that will require upgrading to Java 7, then I kindly ask you to specify the minimum required JVM version in the plugin manifest, this way the user will have, at least, the option to decide whether it is worthwhile make the JVM upgrade without creating any incompatibility issues with the existing setup

Eddy
__________________

Automatic Power Off | Squeezeslave | DVB-S Importer | DVB Decrypter & Card Client | Tuner Preroll


Every man is a damn fool for at least five minutes every day; wisdom consists in not exceeding the limit. ~ Elbert Hubbard
Reply With Quote
  #8  
Old 10-03-2013, 12:55 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,682
Quote:
Originally Posted by routerunner View Post
Thanks Sean, however if you plan to make any future update that will require upgrading to Java 7, then I kindly ask you to specify the minimum required JVM version in the plugin manifest, this way the user will have, at least, the option to decide whether it is worthwhile make the JVM upgrade without creating any incompatibility issues with the existing setup

Eddy
That's a great idea... I'll add that into the next release. This is important, especially since I wasn't aware that I had used a Java 7 api, I just don't have anything else installed except for Java 7. Next release will include Java 7 manifest entry. (I forgot about that option in the plugin definition)
Reply With Quote
  #9  
Old 10-03-2013, 03:54 PM
sflamm sflamm is offline
Sage Icon
 
Join Date: Mar 2009
Posts: 1,653
FYI - Java 7 works fine with SageTV on all platforms... I am currently running Java 7 update 40 on all of my clients (Win XP, Win 7, Win 8) and my server (Win 2012). No problems whatsoever.

In fact - it is a significant performance improvement over Java 6.... a google search will quickly show the qualitative/measurable details of the performance difference.
Reply With Quote
  #10  
Old 10-03-2013, 03:56 PM
sflamm sflamm is offline
Sage Icon
 
Join Date: Mar 2009
Posts: 1,653
Is this latest update safe? Does it have all the old functionality working or is there something we should make note of?
Reply With Quote
  #11  
Old 10-04-2013, 06:32 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,682
Quote:
Originally Posted by sflamm View Post
Is this latest update safe? Does it have all the old functionality working or is there something we should make note of?
It's as safe as any release... the 2.5.6+ releases was done to address an issue in the movie metadata lookups... and as such it uses a new library for accessing tmdb.
Reply With Quote
  #12  
Old 10-04-2013, 08:03 AM
PhilH's Avatar
PhilH PhilH is offline
Sage Advanced User
 
Join Date: Feb 2009
Location: Edinburg, TX (Deep South Texas)
Posts: 95
It works fine here. All of my troubles went away with this release..
__________________
SageTV v7.1.9 Gemstone WHS + 3 HD200's, 1 Client & 1 Placeshifter
WHS - Dual Xeon 2.8ghz - 3gig ECC Ram - 25 Drives - 30 Terabytes
Blu-ray Titles 498
HD-DVD Titles 166
DVD Titles - Too Many To Count..
Reply With Quote
  #13  
Old 10-04-2013, 08:43 AM
mdnttoker mdnttoker is offline
Sage Aficionado
 
Join Date: Aug 2006
Posts: 445
Quote:
Originally Posted by sflamm View Post
Is this latest update safe? Does it have all the old functionality working or is there something we should make note of?
Better than safe, fixed all IMDB and TMDB issues for me...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Phoenix Core 2.5.6 stuckless Phoenix 17 10-02-2013 04:47 PM
New Phoenix Core 2.5.7 stuckless Phoenix 0 10-01-2013 06:04 PM
Phoenix 2.5.0 Update (api, core, and UI) stuckless Phoenix 38 05-15-2013 03:49 PM
URGENT: Please Update to Phoenix Core 2.3.41 stuckless Batch Metadata Tools 1 09-01-2011 07:24 PM
URGENT: Please Update to Phoenix Core 2.3.41 stuckless Phoenix 0 09-01-2011 07:14 PM


All times are GMT -6. The time now is 03:26 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.