SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Clients Development

Notices

SageTV Clients Development This forum is for discussions relating to SageTV Open Source Clients Development.

Reply
 
Thread Tools Search this Thread Display Modes
  #261  
Old 02-18-2016, 07:49 PM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
What amazes me is the lack of standardization in the video formats and containers. I read that Netflix encodes every video 120 different ways to deal with this issue. And more recently, they encode each title differently to improve quality.

Now, one would think that the hardware decoders out there would be on top of the curve with respect to this, but I wouldn't be surprised if phones and tablets don't necessarily have the top-of-the-line hardware decoders, which is where Android's bread and butter is.
Reply With Quote
  #262  
Old 02-19-2016, 03:06 AM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,145
That Netflix situation really gives a good picture of the challenge that this project is (just the video side). I suppose Jeff was going through similar head scratching when trying to assemble extender hardware, but fortunately for him in that scenario, he had complete control over which hardware was being used to play it, and I have to admit that the HD300 is a remarkably capable device, playing darn near every file I've thrown at it.

Thanks for sticking with this, Sean.
Reply With Quote
  #263  
Old 02-19-2016, 06:06 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by KryptoNyte View Post
This question is probably a bit simplistic, but maybe it ought to be - what exactly is the reason that Android is so incapable of successfully playing the array of video file types (and accompanying surround sound audio) in the year 2016?
Just wait until an iOS client emerges to see even less support for video formats

I will say that video specs are quite extensive and it takes a special kind of person to enjoy writing decoders, etc

If there was just a single container and a single video format, then maybe we'd have this licked by now, but sadly, that is not the case, and there is quite a bit that happens when a video processed... I find it mind boggling, to be honest. I'm sure given enough time, I could come to understand it, like Jeff does, but I'm not sure I can invest that much time (I'm already old)

Quote:
Originally Posted by Dargason View Post
What amazes me is the lack of standardization in the video formats and containers. I read that Netflix encodes every video 120 different ways to deal with this issue. And more recently, they encode each title differently to improve quality.

Now, one would think that the hardware decoders out there would be on top of the curve with respect to this, but I wouldn't be surprised if phones and tablets don't necessarily have the top-of-the-line hardware decoders, which is where Android's bread and butter is.
Video playback is certainly a challenge... and if Netflix struggles with this, then these is little hope for us

I've always maintained that I think the Android MiniClient will suit 'most' cases, but that that we'll never reach 100%.

Part of the reason why ExoPlayer is so flaky is that it's not really flaky, but it maintains that it will not code around bad streams. So if it sees something in the stream that it doesn't like, it will abort. Sometimes it's a bug in ExoPlayer and then you have to show that it not processing it as per spec, sometimes, it's the stream.

Quote:
Originally Posted by KryptoNyte View Post
That Netflix situation really gives a good picture of the challenge that this project is (just the video side). I suppose Jeff was going through similar head scratching when trying to assemble extender hardware, but fortunately for him in that scenario, he had complete control over which hardware was being used to play it, and I have to admit that the HD300 is a remarkably capable device, playing darn near every file I've thrown at it.

Thanks for sticking with this, Sean.
I think it does become a little easier when you control everything on the box, like the HD300... and I suspect that Jeff worked with this for a bit before he was happy with everything.

Interesting side note... As you might be aware, but I've packed in the HD300s, and I've been using the Android MiniClient quite some time now. Most of my issues are actually around video playback, but other little interaction nuances. But last night, I had a situation whereby when I was watching a recorded show (.ts file), I would be a short video issue about every 3 seconds... it was like it would skip frames, but, audio was fine. It was a minor annoyance and it's first time it's happened. So I connected to the running processes on the box and noticed that about every 3 seconds I'd see a "chomium" log statement at pretty much the same time that I'd get this video issue. I don't use chromium, but, somehow, something else on the box was interfering. I rebooted and the issue went away. But, just goes to show, when dealing with multi-purpose hardware like this, you run into all kinds of challenges, and not all of them are yours, but just side effects of other things running.
Reply With Quote
  #264  
Old 02-19-2016, 06:48 AM
phantomii phantomii is offline
Sage Advanced User
 
Join Date: Mar 2009
Location: North Carolina
Posts: 151
Just a thought, is there any value in reaching out to the Kodi Team and seeing if their video processing/playback could be lifted from that app and dropped into the sage app??? It seems to play most everything I throw at it? And I realize nothing is just that simple but if they have the knowledge and have solved some of the issues we see it might present options?
Reply With Quote
  #265  
Old 02-19-2016, 08:12 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by phantomii View Post
Just a thought, is there any value in reaching out to the Kodi Team and seeing if their video processing/playback could be lifted from that app and dropped into the sage app??? It seems to play most everything I throw at it? And I realize nothing is just that simple but if they have the knowledge and have solved some of the issues we see it might present options?
I think that there is a good illusion that KODI has no issues, but I think if spend enough time on the forums, etc, you'll probably see, they have issues as well. Not saying it isn't light years ahead of this project in terms of video playback, but I would bet just about anything that, if I spent 1-2 years doing what you proposed that I might get a marginal benefit... but I'd still get "hey, my file xxx.mpg" doesn't play well. When I ran KODI, I ran into playback issues on some files. I run into playback issues in the HD300 from time to time. I've had video files that would just stop, or refused to play, etc. I don't know for sure, I suspect that KODI is using ffmpeg under the hood. IJKPlayer using ffmpeg under the hood. It passes off h264, mpeg2, and hevc files to the hardware decoder, etc. That being said, KODI wtih 13 years of development, has likely tweaked the crap out of their player.

I'm not objecting if anyone wants to fork this project and build a KODI/SAGETV hybrid of sorts, but it's nothing that I'd ever consider. I think your time would be better spent, though, building a PVR add-on for KODI.
Reply With Quote
  #266  
Old 02-19-2016, 08:25 AM
n9cqs n9cqs is offline
Sage User
 
Join Date: Apr 2007
Posts: 68
Working on Samsung Galaxy Note?

Sean,
First, let me add my appreciation to all those who have already said so here. Thanks so much for taking on this work. Placeshifting is one of the wonders of SageTV that no other platform has been able to get very close to.

I installed the beta of the android placeshifter on my Samsung Galaxy Note 10.4 (now two years old... just out of contract) and also on my phone, a Samsung Galaxy note 4. On each device, the app came up, recognized the SageTV server(s) (I run two) in my house, and allowed me to connect. When I connected, the screen went black and I could not get any controls or other information to show. Edit: I am running SageTV version 7

When I went to another device and looked at the SageTV Web interface, the android device was identified as having connected as a placeshifter. Further, when I went to a show using the Web Interface and selected "Play on ... placeshifter" (or whatever the wording is), I was able to hear the audio, but no picture.

I am wondering if I need to install something on my phone/tablet in addition to the .apk file that you have on the download? Are there video drivers or other things? I know that all this is beta, but are there installation instructions that I missed? (I have looked through much of this forum thread, but not completely).

Thanks again for the good work, Sean, Jeff, and all the community that is contributing to this.

Jeff

Last edited by n9cqs; 02-19-2016 at 08:30 AM.
Reply With Quote
  #267  
Old 02-19-2016, 08:42 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by n9cqs View Post
Sean,
First, let me add my appreciation to all those who have already said so here. Thanks so much for taking on this work. Placeshifting is one of the wonders of SageTV that no other platform has been able to get very close to.

I installed the beta of the android placeshifter on my Samsung Galaxy Note 10.4 (now two years old... just out of contract) and also on my phone, a Samsung Galaxy note 4. On each device, the app came up, recognized the SageTV server(s) (I run two) in my house, and allowed me to connect. When I connected, the screen went black and I could not get any controls or other information to show. Edit: I am running SageTV version 7

When I went to another device and looked at the SageTV Web interface, the android device was identified as having connected as a placeshifter. Further, when I went to a show using the Web Interface and selected "Play on ... placeshifter" (or whatever the wording is), I was able to hear the audio, but no picture.

I am wondering if I need to install something on my phone/tablet in addition to the .apk file that you have on the download? Are there video drivers or other things? I know that all this is beta, but are there installation instructions that I missed? (I have looked through much of this forum thread, but not completely).

Thanks again for the good work, Sean, Jeff, and all the community that is contributing to this.

Jeff

Good old Samsung Are you running the latest build RC1 build, if I recall. This issue was similar to what someone else had noted, but I thought it was "fixed" (or rather, went away, since I didn't really do anything to fix it, since I can't reproduce it).

I wish I had better news. I have a samsung galaxy s2, and I was able to run this on that device I really don't think it's a device issue, per se, but rather something to do with the connection and timing of events. I could never see anything in the logs as to why it was not rendering the UI.
Reply With Quote
  #268  
Old 02-19-2016, 12:50 PM
n9cqs n9cqs is offline
Sage User
 
Join Date: Apr 2007
Posts: 68
Quote:
Originally Posted by stuckless View Post
Good old Samsung Are you running the latest build RC1 build, if I recall. This issue was similar to what someone else had noted, but I thought it was "fixed" (or rather, went away, since I didn't really do anything to fix it, since I can't reproduce it).

I wish I had better news. I have a samsung galaxy s2, and I was able to run this on that device I really don't think it's a device issue, per se, but rather something to do with the connection and timing of events. I could never see anything in the logs as to why it was not rendering the UI.
Sean,
Attached is my log file from a recent attempt. I'm at work, and so this was done over 4G using VPN, which explains the "discovery" error at the beginning. Also, I blanked ('x) the locator ID, server name and server IP.

Thanks.
Attached Files
File Type: txt sagetv-miniclient.txt (20.0 KB, 84 views)
Reply With Quote
  #269  
Old 02-19-2016, 01:24 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by n9cqs View Post
Sean,
Attached is my log file from a recent attempt. I'm at work, and so this was done over 4G using VPN, which explains the "discovery" error at the beginning. Also, I blanked ('x) the locator ID, server name and server IP.

Thanks.
Nothing seems out of place in the logs...

One thing to try... In the Preferences, there's a setting to set the screen size to half native resolution. Try enabling that, and then reconnecting.
Reply With Quote
  #270  
Old 02-20-2016, 09:00 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 2,145
Quote:
Originally Posted by n9cqs View Post
Sean,
First, let me add my appreciation to all those who have already said so here. Thanks so much for taking on this work. Placeshifting is one of the wonders of SageTV that no other platform has been able to get very close to.

I installed the beta of the android placeshifter on my Samsung Galaxy Note 10.4 (now two years old... just out of contract) and also on my phone, a Samsung Galaxy note 4. On each device, the app came up, recognized the SageTV server(s) (I run two) in my house, and allowed me to connect. When I connected, the screen went black and I could not get any controls or other information to show. Edit: I am running SageTV version 7

When I went to another device and looked at the SageTV Web interface, the android device was identified as having connected as a placeshifter. Further, when I went to a show using the Web Interface and selected "Play on ... placeshifter" (or whatever the wording is), I was able to hear the audio, but no picture.

I am wondering if I need to install something on my phone/tablet in addition to the .apk file that you have on the download? Are there video drivers or other things? I know that all this is beta, but are there installation instructions that I missed? (I have looked through much of this forum thread, but not completely).

Thanks again for the good work, Sean, Jeff, and all the community that is contributing to this.

Jeff
Sean accidentally fixed this problem for me in 0.09-BETA (Galaxy S4). Because I had tried numerous other versions prior to this, I made sure to delete this client's properties file on the server before installing and running the newer version.
Reply With Quote
  #271  
Old 02-21-2016, 10:09 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Release Candidate 2



Not a big release, but, basically I worked on some of the seeking/resuming issues for TS/PS streams.

I might spend some time today working on the Play Store release.. Maybe I can get this released this week... maybe
Reply With Quote
  #272  
Old 02-22-2016, 10:08 AM
Bucsfan2008 Bucsfan2008 is offline
Sage User
 
Join Date: Jan 2008
Posts: 29
No Icons when hard press enter on Remote. Can't tell what they are....

Hi, one of my FireTV's I can see the icons to play FF guide when holding the enter button on the FireTV remote, but my other one doesn't and shows up as blobs of white. I upgraded and did a clean install on both clients. What's wrong?
Reply With Quote
  #273  
Old 02-22-2016, 10:13 AM
Bucsfan2008 Bucsfan2008 is offline
Sage User
 
Join Date: Jan 2008
Posts: 29
[QUOTE=stuckless;584952]That is odd. I do know that some MKV/MP4 files will skip to the end, and then start again from the beginning (because the metadata is at the end of the file). So I've seen this happen, but it resets to the beginning by itself. I actually haven't found a MKV that doesn't play, yet. If you want to share a file, I'd be happy to test.



Sorry for the delayed response. Horrible break up with the GF and she moved out this week, will get those files over to you once I get some things organized on the homefront. I can tell you I was able to test a few more files. While it wouldn't play the video, it did play DD in passthrough and would play video on DTS but no audio on the DTS.. Will get back to you on those files.
Reply With Quote
  #274  
Old 02-22-2016, 08:58 PM
kklee kklee is offline
Sage User
 
Join Date: Jul 2013
Posts: 5
My Shield TV was updated to 3.0 today.

The RC2 mini client is working perfectly using the Exo player, whereas before the 3.0 upgrade, it would get totally confused by comskip resulting in the Shield TV's audio disappearing until the unit was restarted.

Thanks again for all the great work you've done on the mini client
Reply With Quote
  #275  
Old 02-24-2016, 12:39 AM
Jabroni's Avatar
Jabroni Jabroni is offline
Sage Aficionado
 
Join Date: Mar 2006
Posts: 251
Quote:
Originally Posted by stuckless View Post


Not a big release, but, basically I worked on some of the seeking/resuming issues for TS/PS streams.

I might spend some time today working on the Play Store release.. Maybe I can get this released this week... maybe
Just to let you know that I just tried this version on my mobile and I can confirm that the Aspect Ratio issue I posted earlier seems to be fixed here

Heres some suggestions for when using placeshifting mode:

- Would be nice if there would be some feedback on the placeshifter network performance (ie show the current kbps rate rendered on top of the video like current PS renders it on the Windows TitleWindow)
- A way to have the Streaming options for placeshifting as in the windows client
* Use SageTV Dynamic Streaming System (which I suppose as its currently implemented)
* Playback media without transcoding
* Manually specify the encoding parameters (Video Bitrate/Video Resolution/Audio Bitrate)

That way we can force like in cases when using a cell phone with 4g coverage but maybe we just want to use 1mbit stream instead of eating all available BW Or force to specific resolution if we know the BW is available

__________________
SageTV 7.1.9 / Phoenix
Captures: 1x Genpix Skywalker DVB4Sage / 1x 7500 Prof DVBS2 Tunner DVB4Sage / 1x HD HomeRun / 1x Slingbox M1 / 1x Colossus HD
Extender: 2x HD200 / 1x HD300


Last edited by Jabroni; 02-24-2016 at 02:55 AM.
Reply With Quote
  #276  
Old 02-24-2016, 05:48 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by Jabroni View Post
Just to let you know that I just tried this version on my mobile and I can confirm that the Aspect Ratio issue I posted earlier seems to be fixed here

Heres some suggestions for when using placeshifting mode:

- Would be nice if there would be some feedback on the placeshifter network performance (ie show the current kbps rate rendered on top of the video like current PS renders it on the Windows TitleWindow)
- A way to have the Streaming options for placeshifting as in the windows client
* Use SageTV Dynamic Streaming System (which I suppose as its currently implemented)
* Playback media without transcoding
* Manually specify the encoding parameters (Video Bitrate/Video Resolution/Audio Bitrate)

That way we can force like in cases when using a cell phone with 4g coverage but maybe we just want to use 1mbit stream instead of eating all available BW Or force to specific resolution if we know the BW is available

Those are all great suggestings. Can you add them to the GitHub issue tracker (I can tag them as enhancements). I've done almost no work on the placeshifting side of things (mainly because I've never used it).
Reply With Quote
  #277  
Old 02-24-2016, 10:40 AM
Jabroni's Avatar
Jabroni Jabroni is offline
Sage Aficionado
 
Join Date: Mar 2006
Posts: 251
Quote:
Originally Posted by stuckless View Post
Those are all great suggestings. Can you add them to the GitHub issue tracker (I can tag them as enhancements). I've done almost no work on the placeshifting side of things (mainly because I've never used it).
Sure Ill add them in a sec..

Two other things ive encontered while playing more with the Android MiniClient:

- Do you think there could be a way to add a GUI numpad for fast channel changing on big channel lists?? I currently have 3 different providers so its like ~500 channels, kinda difficult to navigate with just the Up,Down,PgUp,PgDown. Currrently I can use the virtual keyboard, then try input, but its more trouble and sometimes hit/miss (android keyboard tries to autocorrect). Maybe that we could map from where we launch that numpad, like long press right, or from the mini menu from long select

- I got a tuner I create from a Slingbox. So far its been working great on SageTV Client,placeshifter, extenders. I just started testing it on the Android MiniClient, however heres the strange thing. On the Shield TV it did playback correctly (upgraded to Marshmallow w/1.0RC2 AMC) and on my Note 5 (still on 5.1.1 w/ 1.0RC AMC) video wont play back, but audio does playback. I'll record some clips from it to share it to you to see if you can look up whats up if u have a chance, it was an original unindexed ASF content, but on my network encoder I pass it thru a ffmpeg process and output as H264 video on a mpeg2ts container w/ AAC audio



Other than that the client has been working really great for livetv. Ive thrown OTA tuners content (MPEG2 480i/720p/1080i SD/HD), Hauppauge HDPVR content, Comskip skips. Later on I'll try activating my DN Satellite Network Encoder and see if those channels play back correctly (H264 recorded directly from SAT, so lets see how the player reacts to some 'dirty' H264s ;p)
__________________
SageTV 7.1.9 / Phoenix
Captures: 1x Genpix Skywalker DVB4Sage / 1x 7500 Prof DVBS2 Tunner DVB4Sage / 1x HD HomeRun / 1x Slingbox M1 / 1x Colossus HD
Extender: 2x HD200 / 1x HD300

Reply With Quote
  #278  
Old 02-24-2016, 11:28 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,521
Quote:
Originally Posted by Jabroni View Post
Sure Ill add them in a sec..
- Do you think there could be a way to add a GUI numpad for fast channel changing on big channel lists?? I currently have 3 different providers so its like ~500 channels, kinda difficult to navigate with just the Up,Down,PgUp,PgDown. Currrently I can use the virtual keyboard, then try input, but its more trouble and sometimes hit/miss (android keyboard tries to autocorrect). Maybe that we could map from where we launch that numpad, like long press right, or from the mini menu from long select
Seems like this should be handled in the STV. If you have "full remote" it's not an issue, but, with a dumb remote, I'm guessing you have to bring up the full keyboard to use the #s there. I never do anything with live tv and channel changes, so not even sure that works. My sagetv setup is more like a netflix setup... I only watch pre-recorded content (or stuff that has been recording for 20+ minutes)

Quote:
- I got a tuner I create from a Slingbox. So far its been working great on SageTV Client,placeshifter, extenders. I just started testing it on the Android MiniClient, however heres the strange thing. On the Shield TV it did playback correctly (upgraded to Marshmallow w/1.0RC2 AMC) and on my Note 5 (still on 5.1.1 w/ 1.0RC AMC) video wont play back, but audio does playback. I'll record some clips from it to share it to you to see if you can look up whats up if u have a chance, it was an original unindexed ASF content, but on my network encoder I pass it thru a ffmpeg process and output as H264 video on a mpeg2ts container w/ AAC audio
Seems odd... you should get a mediainfo dump of the file. It might be a format that is forcing a transcode on the server.
Reply With Quote
  #279  
Old 02-24-2016, 12:48 PM
Jabroni's Avatar
Jabroni Jabroni is offline
Sage Aficionado
 
Join Date: Mar 2006
Posts: 251
Quote:
Originally Posted by stuckless View Post
Seems odd... you should get a mediainfo dump of the file. It might be a format that is forcing a transcode on the server.
Heres the mediainfo of the file

Code:
General
ID                                       : 1 (0x1)
Complete name                            : \\192.168.5.106\media\SageTV\Veep-Season1Episode07FullDisclosure-42642487-0.mpg
Format                                   : MPEG-TS
File size                                : 40.9 MiB
Duration                                 : 1mn 14s
Overall bit rate mode                    : Variable
Overall bit rate                         : 4 577 Kbps

Video
ID                                       : 256 (0x100)
Menu ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 2 frames
Codec ID                                 : 27
Duration                                 : 1mn 14s
Bit rate                                 : 4 124 Kbps
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 29.970 (30000/1001) fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : MBAFF
Scan type, store method                  : Interleaved fields
Scan order                               : Top Field First
Bits/(Pixel*Frame)                       : 0.066
Stream size                              : 36.9 MiB (90%)

Audio
ID                                       : 257 (0x101)
Menu ID                                  : 1 (0x1)
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Mode extension                           : CM (complete main)
Format settings, Endianness              : Big
Codec ID                                 : 129
Duration                                 : 1mn 15s
Bit rate mode                            : Constant
Bit rate                                 : 224 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 32.0 KHz
Frame rate                               : 20.833 fps (1536 spf)
Compression mode                         : Lossy
Delay relative to video                  : -105ms
Stream size                              : 2.00 MiB (5%)

Menu
ID                                       : 4096 (0x1000)
Menu ID                                  : 1 (0x1)
Duration                                 : 1mn 14s
List                                     : 256 (0x100) (AVC) / 257 (0x101) (AC-3)
Service name                             : Slingbox
Service provider                         : FFmpeg
Service type                             : digital television
And an output of the log on my Note5 (which just outputs audio but no video), and strange as it did playback on my ShieldTV with video/audio

https://dl.dropboxusercontent.com/u/...miniclient.txt

Short recording (~20megs) used for this test, not sure if you want to try it on your enviroment

https://dl.dropboxusercontent.com/u/...42642487-0.mpg
__________________
SageTV 7.1.9 / Phoenix
Captures: 1x Genpix Skywalker DVB4Sage / 1x 7500 Prof DVBS2 Tunner DVB4Sage / 1x HD HomeRun / 1x Slingbox M1 / 1x Colossus HD
Extender: 2x HD200 / 1x HD300


Last edited by Jabroni; 02-24-2016 at 12:50 PM.
Reply With Quote
  #280  
Old 02-24-2016, 07:46 PM
KarylFStein KarylFStein is offline
Sage Fanatic
 
Join Date: Apr 2006
Location: Westland, Michigan, USA
Posts: 998
More buttons?

I've been playing with RC1 on my SHIELD and tablet. It's looking really good! Playback is still not 100% smooth on my tablet, but there is no pixelation anymore and skipping works great. (And even though it was a little stuttery it wasn't bad enought to make me pull up Phoenix Remote instead.) The SHIELD on the other hand looks/operates perfectly.

I do not have a nVidia remote. Instead I use the nVidia gamepad or a Harmony. What I would like to see, (which I don't think would be too hard, but what do I know), is have more button mappings. I know it was mentioned before that there might be a button mapping setup option in the future, but for now I'm just talking about a few more hardcoded ones. For example:

* Right stick up/down = Channel (page) up/down
* Right stick right/left = Chapter next/prev
* Right bumper = Delete
* Right trigger = Home

Those are the main buttons I'm missing, but could also use say right/left stick buttons set to guide/info.
__________________
Home Network: https://karylstein.com/technology.html
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MiniClient Information Taddeusz SageTV Github Development 5 09-10-2015 11:11 AM
Miniclient? BobbyDing General Discussion 3 09-08-2015 11:53 AM
OSD doesn't work in Linux miniclient 6.6 Grant.Edwards SageTV Linux 1 08-27-2011 04:37 PM
Linux Placeshifter/Miniclient Fails scsever SageTV Linux 1 08-23-2011 10:20 PM
Does miniclient work with SageTV 7? bkbonner SageTV Beta Test Software 1 09-10-2010 12:54 AM


All times are GMT -6. The time now is 04:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.