SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-06-2018, 10:35 AM
craigap craigap is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Madison, WI
Posts: 337
Unable to install several plugins

Did a fresh OS install and decided to do a fresh install of SageTV v9.1.9 as well. Went to install my usual plugins and some of them are failing.
Complimentary Metadata Tools
Comskip playback
Commercial Detector UI (Commercial Detector DID install)
Phoenix Fanart for Sagetv 7 (Phoenix core services DID install)
Jetty Web server
Serenity theme DID install

So a couple would install and the others I can't seem to get to install. Each that faild shows me an error with a path to the file and I believe a couple are failing because of a dependency that fails to install first.

Any help would be appreciated.
Reply With Quote
  #2  
Old 09-06-2018, 10:57 AM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
I had this problem earlier this week. You need to update the java.
Reply With Quote
  #3  
Old 09-06-2018, 11:15 AM
craigap craigap is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Madison, WI
Posts: 337
I have not been active on the forums in quite a few years. I seem to recall some issues with newer versions of Java in combination with Sagetv. Is this still the case or should I just install the latest version?

Thanks

EDIT: I went ahead and just updated to the latest version. It helped but Commercial Detector and Phoenix Core services say "Failed" in the UI for installed plugins. I did say that they installed in the first post but I must have been mistaken. They did not.

Last edited by craigap; 09-06-2018 at 12:39 PM.
Reply With Quote
  #4  
Old 09-06-2018, 03:30 PM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
I checked when I got home from work. I'm running Java 1.7.0_60 on the server, and whatever the latest is on the client (1.8.0_161 I think) on the client.

There was a post on here that clued me into this issue, but I can't seem to find it now...

There was (is?) an issue with the Jetty webserver plugin if you update to 1.8, but I think there's a workaround, or maybe it's been fixed.

https://forums.sagetv.com/forums/sho...+version+jetty

I was having problems with the Phoenix Core Services installing, but that went away when I uninstalled SageTV (and deleted the SageTV folder), updated Java, and then reinstalled everything.
Reply With Quote
  #5  
Old 09-06-2018, 10:14 PM
craigap craigap is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Madison, WI
Posts: 337
I'll look at going backward in Java.

I went through the "All" plugins and noted a few of them had "update available", so I updated them. Commercial detector seems to work now. However, Phoenix core services does not still. I was backtracking through all the dependencies and found that the phoenix-api has a dependency of "themoviedb"4.1.0+ but this dependency is nowhere to be found. Although the Phoenix -api appears to be installed, I can't help but wonder if this could be causing issues.
Reply With Quote
  #6  
Old 09-08-2018, 02:41 PM
phelme's Avatar
phelme phelme is offline
Sage Icon
 
Join Date: Dec 2006
Posts: 1,027
I'm running intro this as well because of the IMDB plugin not updating.

speaking of jetty, anyone know if it's possible too turn off the request logs it makes? i just noticed I'm getting huge 50mb files daily because of Phoenix requests.

Edit: looks like i may have solved this by commenting out the "configure request log" section in the jetty/etc/jetty.xml file.

Last edited by phelme; 09-10-2018 at 01:45 PM.
Reply With Quote
  #7  
Old 09-08-2018, 09:11 PM
oldfolkie oldfolkie is offline
Sage User
 
Join Date: Mar 2009
Location: California
Posts: 28
I posted this in the other thread, but another issue with Java v8 is that the SageTV add-on for Kodi only works with Java v7.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
V9 newbie - Is there a way to install plugins manually? Everdraed SageTV v9 Customizations 12 07-19-2017 09:17 AM
Which plugins should we include as core plugins, if we were to auto-install plugins? stuckless SageTV Github Development 35 07-08-2016 04:01 PM
Is there a way to programmatically install plugins? SageWizdom SageTV Github Development 29 06-20-2016 11:41 AM
Trying to install a few plugins but some of the dependencies are failing to download craigap SageTV v7 Customizations 5 07-17-2015 09:23 PM
How/Where to install plugins on the Mac? cnr1089 SageTV Mac Edition 0 04-10-2009 10:40 AM


All times are GMT -6. The time now is 01:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.