SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Batch Metadata Tools

Notices

Batch Metadata Tools This forums is for discussing the user-created Batch Metadata Tools for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-23-2014, 09:46 PM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
MediaTitles.xml Help

I know this has been asked before, but I am not quite getting this right. I have this in my MediaTitles.XML file:

Code:
<titles>
  <match>
    <regex>[\\/]Doctor Who.*</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who Confidential.*</regex>
	<title>Doctor Who Confidential</title>
    <metadata type="TV" name="tvdb">79298</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who (2005).*</regex>
	<title>Doctor Who (2005)</title>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
</titles>
But all of these episodes end up being seen as the original 1963 series. I have the files named like:

Doctor Who - S01E01 - An Unearthly Child.mkv
Doctor Who (2005) - S01E01 - Rose.mkv
Doctor Who Confidential - S01E01 - Some Name.mkv

There are also Specials which I have named as above, but using S00Exx.

Anyone see what I'm missing here?
Reply With Quote
  #2  
Old 02-24-2014, 10:04 AM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,167
Wonder if the order matters?

put the following AFTER the others? Or possibly remove it?
Wouldn't Doctor Who.* match Doctor Who (2005) and Doctor Who Confidential ?

Code:
  <match>
    <regex>[\\/]Doctor Who.*</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
Another possibility IF you have them in different folders, ie for folder Doctor Who (2005)
Code:
  <match>
    <regex>[\\/]Doctor Who (2005)[\\/]</regex>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
Reply With Quote
  #3  
Old 02-24-2014, 10:12 AM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
I hadn't thought of reordering them. But the folder idea may be the best way to do this, since I do have them separated in their own folders. I'll see what happens.
Reply With Quote
  #4  
Old 02-24-2014, 08:40 PM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Argh. So I changed it to:

Code:
<titles>
    <match>
    <regex>[\\/]Doctor Who (2005)</regex>
    <title>Doctor Who (2005)</title>
    <year>2005</year>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
    <match>
    <regex>[\\/]Doctor Who Confidential[\\/]</regex>
	<title>Doctor Who Confidential</title>
    <metadata type="TV" name="tvdb">79298</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who[\\/]</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
</titles>
I also tried to ad th .* and then this l[\\/] to the Doctor Who (2005) section. The others are working correctly now, but all of the 2005 imports are being seen as movies now. They used to work.

I won't even start on Specials....
Reply With Quote
  #5  
Old 02-25-2014, 06:45 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,519
Quote:
Originally Posted by samgreco View Post
Argh. So I changed it to:

Code:
<titles>
    <match>
    <regex>[\\/]Doctor Who (2005)</regex>
    <title>Doctor Who (2005)</title>
    <year>2005</year>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
    <match>
    <regex>[\\/]Doctor Who Confidential[\\/]</regex>
	<title>Doctor Who Confidential</title>
    <metadata type="TV" name="tvdb">79298</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who[\\/]</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
</titles>
I also tried to ad th .* and then this l[\\/] to the Doctor Who (2005) section. The others are working correctly now, but all of the 2005 imports are being seen as movies now. They used to work.
The easiest way to set this up, is to do the following...
1. delete your current dr who entries in the mediafiles xml.
2. restart sagetv (to ensure that all entries are unloaded)
3. go into bmt, browse and find a dr who episode... click find metadata, select the "right" dr who entry for the show you have loaded.
4. click Add Matcher
5. Use a "Folder" based matcher, click OK (or done, not sure which).
6. Save.
7. Repeat for a different episode of DR Who for different dr who show.

Keep in mind you are doing this 3 times... once for each type of dr who espisode.

Next, rescan your dr who files -- with force update/overwrite.

I never manually modify the mediatitles xml (except to clean it out), I just use BMT's "Add Matcher".

Quote:
I won't even start on Specials....
That's good.. .because there's no support for them.
Reply With Quote
  #6  
Old 02-25-2014, 06:54 AM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,167
Can you try this

Code:
  <match>
    <regex>[\\/]Doctor Who (2005)[\\/]</regex>
    <metadata type="TV" name="tvdb">78804</metadata>
    <title>Doctor Who (2005)</title>
  </match>
Leave off the YEAR tag. Maybe the YEAR tag might be throwing BMT off to think it is a Movie and not a show?
Maybe even leave off the <title> ?

I haven't bothered with the YEAR tag for my shows that have different years.

For Example, my Hawaii Five-O work well with this configuration

Code:
  <match>
    <regex>[\\/]Hawaii Five-0 (2010)[\\/]</regex>
    <metadata type="TV" name="tvdb">164541</metadata>
  </match>
  <match>
    <regex>[\\/]Hawaii Five-0 (1968)[\\/]</regex>
    <metadata type="TV" name="tvdb">71223</metadata>
  </match>
Reply With Quote
  #7  
Old 02-25-2014, 07:15 AM
nyplayer nyplayer is offline
SageTVaholic
 
Join Date: Sep 2005
Posts: 4,028
Hawaii five-o is a bit different one has an alpha O and the other has a numeric 0 in the TVDB. Sage groups them all together ...

Hawaii Five-O
Hawaii Five-0
__________________
Windows 10 I3 Dual Core 3.0 Server, SageTV9... OpenDCT with 2 HDHRPrimes and 4 HDHRconnects for a total of 14 Tuners.
Reply With Quote
  #8  
Old 02-25-2014, 08:21 AM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Quote:
Originally Posted by stuckless View Post
That's good.. .because there's no support for them.
Thanks stuckless.
Reply With Quote
  #9  
Old 02-25-2014, 08:57 AM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Hmmm. Where do I find?:
Next, rescan your dr who files -- with force update/overwrite.
Reply With Quote
  #10  
Old 02-25-2014, 12:10 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,519
Quote:
Originally Posted by samgreco View Post
Hmmm. Where do I find?:
Next, rescan your dr who files -- with force update/overwrite.
I was paraphrasing the actions

Browser -> Sage Video Imports by Folder -> (the navigate to the dr who folder to scan)
Click "UPdate Metadata..."
Check first 3 options, uncheck last two...
Click Scan


Repeat for the other 2 dr who folders
Attached Images
File Type: png Selection_162.png (74.3 KB, 143 views)
Reply With Quote
  #11  
Old 02-25-2014, 12:16 PM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
OK. That's what I thought. Just wanted to be sure.

Didn't work. What's so confusing is that it used to work for both DW and DW 2005. Even after I restored the original MediaTitles.XML file, it never worked again.

How can I completely remove any metadata info from those files and start over?
Reply With Quote
  #12  
Old 02-25-2014, 12:25 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,519
Quote:
Originally Posted by samgreco View Post
OK. That's what I thought. Just wanted to be sure.

Didn't work. What's so confusing is that it used to work for both DW and DW 2005. Even after I restored the original MediaTitles.XML file, it never worked again.

How can I completely remove any metadata info from those files and start over?
Could you email me your complete mediatitles.xml file? (metadatatools at gmail dot com)
Reply With Quote
  #13  
Old 02-25-2014, 12:43 PM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Actually, this is all there is.

Code:
<titles>
    <match>
    <regex>[\\/]Doctor Who (2005)</regex>
    <title>Doctor Who (2005)</title>
    <year>2005</year>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
    <match>
    <regex>[\\/]Doctor Who Confidential[\\/]</regex>
	<title>Doctor Who Confidential</title>
    <metadata type="TV" name="tvdb">79298</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who[\\/]</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
</titles>
Reply With Quote
  #14  
Old 02-25-2014, 03:14 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,519
Quote:
Originally Posted by samgreco View Post
Actually, this is all there is.

Code:
<titles>
    <match>
    <regex>[\\/]Doctor Who (2005)</regex>
    <title>Doctor Who (2005)</title>
    <year>2005</year>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
    <match>
    <regex>[\\/]Doctor Who Confidential[\\/]</regex>
	<title>Doctor Who Confidential</title>
    <metadata type="TV" name="tvdb">79298</metadata>
  </match>
  <match>
    <regex>[\\/]Doctor Who[\\/]</regex>
    <title>Doctor Who</title>
    <year>1963</year>
    <metadata type="TV" name="tvdb">76107</metadata>
  </match>
</titles>
So, is it failing for all 3 shows... ie, which of the 3 matchers is it using when you scan, now?
Reply With Quote
  #15  
Old 02-25-2014, 03:40 PM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Sorry for the confusion Sean. It's only failing currently on Doctor Who (2005).
Reply With Quote
  #16  
Old 02-26-2014, 06:07 AM
JerryB JerryB is offline
Sage Aficionado
 
Join Date: Aug 2008
Posts: 273
Just a thought but do you mean to have 2 spaces between "Who" and "(2005)" and does your actual title match this?
Reply With Quote
  #17  
Old 02-26-2014, 08:34 AM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
JerryB - Funny I saw that thinking it was 2 spaces. It's not. I have triple checked it because it still looks like too much space.
Reply With Quote
  #18  
Old 05-08-2014, 06:16 AM
silkshadow's Avatar
silkshadow silkshadow is offline
Sage Expert
 
Join Date: Oct 2004
Location: Philippines
Posts: 550
Necro thread but you need to escape your "(" and ")". Here is my Dr Who:

Code:
  <match>
    <regex>[\\/]Doctor Who \(2005\)[\\/]</regex>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
Reply With Quote
  #19  
Old 05-08-2014, 11:33 AM
samgreco samgreco is offline
Sage Expert
 
Join Date: Jul 2004
Location: Villa Park, IL (Outside Chicago)
Posts: 609
Quote:
Originally Posted by silkshadow View Post
Necro thread but you need to escape your "(" and ")". Here is my Dr Who:

Code:
  <match>
    <regex>[\\/]Doctor Who \(2005\)[\\/]</regex>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>
Thanks for this! That seems to have fixed it for me.

I had gotten busy and not returned to this problem until I got the notification of a response to remind me.
Reply With Quote
  #20  
Old 05-08-2014, 12:19 PM
graywolf's Avatar
graywolf graywolf is offline
Sage Icon
 
Join Date: Oct 2009
Location: NC
Posts: 1,167
Quote:
Originally Posted by silkshadow View Post
Necro thread but you need to escape your "(" and ")". Here is my Dr Who:

Code:
  <match>
    <regex>[\\/]Doctor Who \(2005\)[\\/]</regex>
    <metadata type="TV" name="tvdb">78804</metadata>
  </match>

Interesting. I will need to try this out.

BTW, what other characters should be escaped?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MediaTitles not Working wmstonetn Batch Metadata Tools 9 07-08-2015 02:15 AM
Help with MediaTitles.xml Phydeaux Batch Metadata Tools 3 12-04-2012 01:47 PM
Help with mediatitles.xml, please? silkshadow Batch Metadata Tools 5 10-22-2012 08:26 AM
MediaTitles.xml and how to read it razrsharpe Batch Metadata Tools 28 01-22-2011 07:57 AM
Problem with MediaTitles.xml cmaloney Batch Metadata Tools 12 08-17-2010 07:44 PM


All times are GMT -6. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.