SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-03-2018, 10:44 AM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
Fanart causes client to hang

I've recently acquired a SFF computer, which I thought would be a great SageTV client.

HP ProDesk 600 G1 DM
ChipSet i5-4590T @ 2.0GHz
Graphics Intel HD Graphics 4600
Connectivity WLAN a/b/g/n, Ethernet
Operating System Windows 10 Professional
Virus Protection Windows Defender
Hard Drive 500 GB Standard
Memory DDR3 8 GB
Power Supply Included

I installed and updated the OS, installed the LAV Filters, and installed SageTV Client 9.1.9. I ran into some problems installing plugins, so I uninstalled Sage, then updated Java, and reinstalled SageTV again. After configuring the audio/video settings, I had everything working in the default STV.

I've never used a PC client before, but I've been using Gemstone on extenders for years. So I installed Gemstone on the client, and it worked fine. Then I imported the settings I had been using on my extenders and that caused my menu navigation to be really, really slow. The log file showed a lot of "Hang detected".

I tried installing on my desktop also. In this case, I don't have the lagging menus (at least not as bad) but there is no fanart. So I tried starting all over and trying Phoenix3 this time instead of Gemstone. Now I can't get past the 'User Interface Manager is initializing' splash screen.

If I try that on my desktop, I can bring up the Phoenix3 UI but there is no fanart.

Attached is a log file from the SFF client. Any ideas?
Attached Files
File Type: txt sagetvclient_0.txt (90.1 KB, 16 views)
Reply With Quote
  #2  
Old 09-03-2018, 11:19 AM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
I saw some references to DX9 in the log, so I updated DX9 per the Web Installer linked here: https://answers.microsoft.com/en-us/...5-3889aae764c1

Doesn't appear to have fixed anything, but maybe I'll try updating the video drivers.
Reply With Quote
  #3  
Old 09-08-2018, 07:39 PM
trk2 trk2 is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Maine
Posts: 340
For fanart on a full client you need to link back to the fanart folder on the server. To set this in Gemstone you need to right click while in menu and then select image options and you'll find a setting for fanart folder location. I share my fanart folder so the address becomes \\server_ip\fanart. I assume the process is similar in when using the Phoenix UI.
Reply With Quote
  #4  
Old 09-09-2018, 03:39 PM
Dargason Dargason is offline
Sage Expert
 
Join Date: Oct 2003
Posts: 516
Thanks!

That seems to have been most of the problem. It works perfectly on my desktop computer, and the SFF computer client runs, though it's not showing the fanart. I'm pretty sure a complete reinstall would solve the problem though.

I love how much faster a real PC Client is!

Mike
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fanart not showing up on client. WakkoJacko Batch Metadata Tools 1 04-25-2015 01:24 PM
Client works but Extenders hang after autoconnection emotionnotion SageTV Beta Test Software 3 04-27-2011 06:33 AM
SageMC, SageTV7, Fanart on client JonTom SageMC Custom Interface 2 01-13-2011 12:57 AM
Client hang (6.5.8) jvfff SageTV Customizations 0 02-02-2009 11:33 AM


All times are GMT -6. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.