SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV EPG Service

Notices

SageTV EPG Service Discussion related to the SageTV EPG Service used within SageTV. Questions about service area coverage, channel lineups, EPG listings, XMLTV, or anything else related to the service or programming guide data for SageTV should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-25-2021, 06:59 PM
jandru jandru is offline
New Member
 
Join Date: Apr 2021
Location: sf nm
Posts: 1
program guide not updating

Long time user. Still on v9.1.9.778.
Last week the program guide stopped updating on my sagetv server. As of today there is no guide data.
I have not made any changes on my system for some time, occasional reboots and the system has bee working great.
I am using
I could not find any info for the problem in the logs but I might not be looking in the right place.
I am using EPG linup Dish Albuquerque (SDEPG).

Anybody have suggestions on a course of action to troubleshoot?
I have verified my SD account is in good standing.
Thanks!
Reply With Quote
  #2  
Old 08-11-2021, 05:40 PM
ASegredo ASegredo is offline
Sage Advanced User
 
Join Date: Jun 2005
Posts: 141
Same here in the Chicago suburbs

Has the schedules direct interface gone dark? I tried deleting and adding a channel.
Nothing shown past 7:00PM CDT tonight.
Reply With Quote
  #3  
Old 08-11-2021, 05:47 PM
KeithAbbott KeithAbbott is offline
Sage Icon
 
Join Date: Oct 2009
Location: Southeastern Michigan
Posts: 1,354
My program guide has data thru August 28th, so it's not a global problem.
__________________
Server: MSI Z270 SLI Plus ATX Motherboard, Intel i7-7700T CPU, 32GB Memory, Unraid 6.10.3, sagetvopen-sagetv-server-opendct-java11 Docker (version 2.0.6)
Tuners: 2 x SiliconDust HDHomeRun Prime Cable TV Tuners, SiliconDust HDHomeRun CONNECT 4K OTA Tuner
Clients: Multiple HD300 Extenders, Multiple Fire TV Stick 4K Max w/MiniClient
Miscellaneous: Multiple Sony RM-VLZ620 Universal Remote Controls
Reply With Quote
  #4  
Old 08-11-2021, 09:16 PM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 4,172
Mine seems to be working…. 16 days of listing
__________________
Sage 9 server = Gigabyte AMD quad-core - 4 gigs - integrated ATI HD4200 chipset - SSD boot, Hitachi Deskstar show drives. HD-PVR - Colossus - Win7 32 bit. HD200/300ís networked. HDHomerun tuner. "If you've given up on Weird Al, you've given up on life" - Homer Simpson

Last edited by tvmaster2; 08-13-2021 at 11:52 AM.
Reply With Quote
  #5  
Old 08-13-2021, 10:33 AM
sic0048 sic0048 is offline
Sage Icon
 
Join Date: Nov 2007
Posts: 1,384
Mine seems to be working as well. The only thing I can think of is to log into your Schedule Direct account and make sure you are current.
__________________
i7-6700 server with about 10tb of space currently
SageTV v9 (64bit)
Ceton InfiniTV ETH 6 cable card tuner (Spectrum cable)
OpenDCT
HD-300 HD Extenders (hooked to my whole-house A/V system for synched playback on multiple TVs - great during a Superbowl party)
Amazon Firestick 4k and Nvidia Shield using the MiniClient
Using CQC to control it all
Reply With Quote
  #6  
Old 11-22-2021, 07:08 AM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 396
My epg doesn't update unless I restart SageTV or reboot the computer. This has been going on for some months. I can attempt to force it from the web UI, and it does get logged but doesn't work. I've been using a scheduled task to trigger a reboot on Monday mornings.
__________________
ASRock B450M Pro4 AM4 MB, Ryzen 5 2600 3.4ghz, Crucial Ballistix Gaming 32GB (2 x 16GB) DDR4-3200, EVGA GT 1030SC, WD Black NVMe SSD 250GB, 1x WD120EFAX 12TB, 1x WD80EFAX 8TB, 1x WDBH2D0040HNC 4TB, USB-UIRT, Colossus 2, WinTV-DualHD USB, Windows 11 64bit
Reply With Quote
  #7  
Old 03-06-2022, 04:33 PM
laberet laberet is offline
Sage User
 
Join Date: Jun 2008
Posts: 32
Did you resolve this? Having similar issues...
__________________
Server: Win10 Pro 64b 19041.1237, ASUS STRIX X299-E, Intel i9-7940X 14c 28t, 32GB@3200, GTX 1080 Ti Storage: NVMe boot, 2x 4TB HD data, NAS data
SageTV: v9.2.5.936 (32b), Java 1.8.0_301 Plugins: Gemstone, Web Interface, Mobile Web Interface, Batch Metadata Tools, Java Heap Monitor
Sources: 4x ATSC OTA HDHR5-4US, 2x Sat (Dish), HDPVR(1.7.1.30059.1)<-->VIP211K, USB-UIRT(2.12.26.0 2/24/2017) Extenders: 6xHD300
Other: Homeseer HS3 w/plugins (Zwave, JowiHue, Ecobee, MeiHarmonyHub), Shairport4w,
Reply With Quote
  #8  
Old 08-30-2022, 07:06 AM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 396
It still doesn't update. I get the files and it shows it updated in the log and in system information, but my schedule doesn't update.
__________________
ASRock B450M Pro4 AM4 MB, Ryzen 5 2600 3.4ghz, Crucial Ballistix Gaming 32GB (2 x 16GB) DDR4-3200, EVGA GT 1030SC, WD Black NVMe SSD 250GB, 1x WD120EFAX 12TB, 1x WD80EFAX 8TB, 1x WDBH2D0040HNC 4TB, USB-UIRT, Colossus 2, WinTV-DualHD USB, Windows 11 64bit
Reply With Quote
  #9  
Old 09-03-2022, 08:30 AM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 396
Does anyone else have their schedule fail to update even though the EPG polls Schedules Direct and updates the files? Mine only updates when I restart SageTV.
__________________
ASRock B450M Pro4 AM4 MB, Ryzen 5 2600 3.4ghz, Crucial Ballistix Gaming 32GB (2 x 16GB) DDR4-3200, EVGA GT 1030SC, WD Black NVMe SSD 250GB, 1x WD120EFAX 12TB, 1x WD80EFAX 8TB, 1x WDBH2D0040HNC 4TB, USB-UIRT, Colossus 2, WinTV-DualHD USB, Windows 11 64bit
Reply With Quote
  #10  
Old 09-03-2022, 11:39 AM
TGsell TGsell is offline
Sage Advanced User
 
Join Date: Mar 2011
Location: Glen Head
Posts: 108
Mine is working fine (Schedules Direct) Zip COde 11545
Reply With Quote
  #11  
Old 09-03-2022, 01:16 PM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 396
Quote:
Originally Posted by TGsell View Post
Mine is working fine (Schedules Direct) Zip COde 11545
There is nothing wrong with Schedules Direct. I'm just having issues importing the schedule from the files on the drive.
__________________
ASRock B450M Pro4 AM4 MB, Ryzen 5 2600 3.4ghz, Crucial Ballistix Gaming 32GB (2 x 16GB) DDR4-3200, EVGA GT 1030SC, WD Black NVMe SSD 250GB, 1x WD120EFAX 12TB, 1x WD80EFAX 8TB, 1x WDBH2D0040HNC 4TB, USB-UIRT, Colossus 2, WinTV-DualHD USB, Windows 11 64bit
Reply With Quote
  #12  
Old 09-03-2022, 04:34 PM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,999
I donít actually look at the guide all that often. But I do keep an eye on my recording schedule, and Sage is having no trouble scheduling and recording my favorites, so the guide data must be ok.
__________________
Server: Ryzen 2400G with integrated graphics, ASRock X470 Taichi Motherboard, HDMI output to Vizio 1080p LCD, Win10-64Bit (Professional), 16GB RAM
Capture Devices (7 tuners): Colossus (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast/Xfinity X1 Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250, HD-PVR
Reply With Quote
  #13  
Old 09-04-2022, 05:15 AM
Malfunction Malfunction is offline
Sage Aficionado
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 396
Quote:
Originally Posted by Tiki View Post
I donít actually look at the guide all that often. But I do keep an eye on my recording schedule, and Sage is having no trouble scheduling and recording my favorites, so the guide data must be ok.
The way mine works is I load SageTV on Monday and the schedule shows 7 days when I check it. On Tuesday, it shows 6 days, On Wednesday it shows 5, etc, counting down to zero if I let it run through Monday.
__________________
ASRock B450M Pro4 AM4 MB, Ryzen 5 2600 3.4ghz, Crucial Ballistix Gaming 32GB (2 x 16GB) DDR4-3200, EVGA GT 1030SC, WD Black NVMe SSD 250GB, 1x WD120EFAX 12TB, 1x WD80EFAX 8TB, 1x WDBH2D0040HNC 4TB, USB-UIRT, Colossus 2, WinTV-DualHD USB, Windows 11 64bit
Reply With Quote
  #14  
Old 09-30-2022, 12:28 PM
TGsell TGsell is offline
Sage Advanced User
 
Join Date: Mar 2011
Location: Glen Head
Posts: 108
EPG not updating via Schedules Direct

Looks like SD-JSON is having issues - an issue report was posted on their site earlier but now it's been taken down even though my EPG isnt updating. This has happened before and they eventually fix it before the guide runs dry...Anyone else experiencing?
Reply With Quote
  #15  
Old 09-30-2022, 04:07 PM
KryptoNyte's Avatar
KryptoNyte KryptoNyte is offline
SageTVaholic
 
Join Date: Dec 2006
Posts: 2,719
I start to see missing guide data for Oct 16th. That seems normal to me. What else would I be looking for? Specific errors in the logs?
Reply With Quote
  #16  
Old 10-01-2022, 06:01 AM
TGsell TGsell is offline
Sage Advanced User
 
Join Date: Mar 2011
Location: Glen Head
Posts: 108
Yes -- heres today's log and failure - its true of all three WMCs I have running so I am kind of assuming that SAGE also has potential problem. I can just wait it out but thought someone else was experiencing the same (I should have been clear the only known error is on WMC) . Will keep an eye on SAGE. thanks


[10/1/2022 7:58:08 AM] ===============================================================================
[10/1/2022 7:58:08 AM] [ INFO] Beginning epg123 client execution. 2022-10-01 11:58:08Z
[10/1/2022 7:58:08 AM] [ INFO] Import: True , Match: True , NoLogo: False , Force: False , ShowProgress: True , NoGC: True , NoVerify: True , Verbose: False
[10/1/2022 7:58:09 AM] Entering ImportMxfFile() for file "c:\programdata\garyan2\epg123\output\epg123.mxf".
[10/1/2022 7:58:27 AM] [ INFO] Successfully imported .mxf file into Media Center database. Exit code: 0
[10/1/2022 7:58:27 AM] Exiting ImportMxfFile(). SUCCESS.
[10/1/2022 7:58:29 AM] [ INFO] Skipped matching CHARGE to channel 148 due to channel already having an assigned listing.
[10/1/2022 7:58:29 AM] [ INFO] Skipped matching WPIXDT4 to channel 151 due to channel already having an assigned listing.
[10/1/2022 7:58:29 AM] [ INFO] Completed the automatch of lineup stations to tuner channels.
[10/1/2022 7:58:30 AM] [ INFO] Completed lineup refresh.
[10/1/2022 7:58:30 AM] Entering RunWmcIndexTask(PvrScheduleTask)
[10/1/2022 7:58:30 AM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\PvrScheduleTask".
[10/1/2022 7:58:30 AM] [ INFO] Successfully started the PvrScheduleTask task. Exit code: 0
[10/1/2022 7:58:30 AM] Exiting RunWmcIndexTask(PvrScheduleTask). SUCCESS.
[10/1/2022 7:58:30 AM] Entering RunWmcIndexTask(ReindexSearchRoot)
[10/1/2022 7:58:30 AM] [ INFO] SUCCESS: Attempted to run the scheduled task "Microsoft\Windows\Media Center\ReindexSearchRoot".
[10/1/2022 7:58:30 AM] [ INFO] Successfully started the ReindexSearchRoot task. Exit code: 0
[10/1/2022 7:58:30 AM] Exiting RunWmcIndexTask(ReindexSearchRoot). SUCCESS.
[10/1/2022 7:58:31 AM] [ INFO] MXF file was created on 10/1/2022 7:57:56 AM
[10/1/2022 7:58:31 AM] [ERROR] The imported MXF file contained an ERROR in its status field.
[10/1/2022 7:58:31 AM] [ INFO] Completed EPG123 client execution.
[10/1/2022 7:58:31 AM] [ INFO] EPG123 client execution time was 00:00:22.6706456.
Reply With Quote
  #17  
Old 10-01-2022, 10:53 AM
TGsell TGsell is offline
Sage Advanced User
 
Join Date: Mar 2011
Location: Glen Head
Posts: 108
might be fixed....

I updated to the latest EPG123 version and the problem seems to be fixed for my WMCs.... for those who didnt update yet my experience might help you.
Reply With Quote
  #18  
Old 10-04-2022, 08:46 AM
robogeek robogeek is offline
Sage Expert
 
Join Date: Apr 2003
Location: Appleton, WI USA
Posts: 568
I may be seeing the issue now in SageTV with the following error in the SageTV debug log:

Code:
Tue 10/4 2:01:40.116 [EPG@22be2e09] SDEPG Exception thrown: Server returned HTTP response code: 403 for URL: https://json.schedulesdirect.org/20141201/schedules/md5
Tue 10/4 2:01:40.117 [EPG@22be2e09] java.io.IOException: Server returned HTTP response code: 403 for URL: https://json.schedulesdirect.org/20141201/schedules/md5
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.reflect.GeneratedConstructorAccessor506.newInstance(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at java.lang.reflect.Constructor.newInstance(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at java.security.AccessController.doPrivileged(Native Method)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
Tue 10/4 2:01:40.117 [EPG@22be2e09] 	at sage.epg.sd.SDUtils.getStream(SDUtils.java:109)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSageSession.post(SDSageSession.java:161)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSageSession.post(SDSageSession.java:157)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSageSession.post(SDSageSession.java:107)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSession.post(SDSession.java:475)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSession.postAuth(SDSession.java:453)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSession.postAuthJson(SDSession.java:653)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDSession.getSchedulesMd5(SDSession.java:1159)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDRipper.extractGuide(SDRipper.java:1576)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.EPGDataSource.expand(EPGDataSource.java:709)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.EPG.run(EPG.java:773)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at java.lang.Thread.run(Unknown Source)
Tue 10/4 2:01:40.118 [EPG@22be2e09] Caused by: java.io.IOException: Server returned HTTP response code: 403 for URL: https://json.schedulesdirect.org/20141201/schedules/md5
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at java.net.HttpURLConnection.getResponseCode(Unknown Source)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	at sage.epg.sd.SDUtils.getStream(SDUtils.java:95)
Tue 10/4 2:01:40.118 [EPG@22be2e09] 	... 11 more
Tue 10/4 2:01:40.119 [EPG@22be2e09] EPGDS Local Over the Air Broadcast  - 54914 (sdepg) found a capture device to start data scanning with:Silicondust HDHomeRun Tuner 107734D8-3 Digital TV Tuner
and and then followed up with this error:
Code:
Tue 10/4 2:03:40.746 [EPG@22be2e09] ERROR Updating EPG Source Local Over the Air Broadcast  - 54914 (sdepg)
Tue 10/4 2:03:40.747 [EPG@22be2e09] ErrorText:expand called on Local Over the Air Broadcast  - 54914 (sdepg) at Tue 10/4 2:00:39.536 expandedUntil=Tue 10/4 1:56:35.215 scannedUntil=Tue 10/4 2:00:00.000
EPG Expanding Local Over the Air Broadcast  - 54914 (sdepg) at Tue 10/4 2:00:39.537
I'm not sure if this error is just a temporary error on the SD website or if this is related to the new token requirement. From the SD website homepage:

Quote:
October 1st 2022

SD-JSON images now require tokens
Effective 2022-10-01, the Schedules Direct service will be requiring that the user token be presented for most interaction with our servers. If you are running NextPVR v6 or EPG123 v1.7.1.8 or higher then this will re-enable image downloads.

If you are a developer, please check the updated API documentation. You may also contact grabber@schedulesdirect.org if you would like to have your requests steered to a ¬ďdebug¬Ē server while you are testing the addition of the token to your code.
Two local OTA networks shuffled some subchannels around and add a couple of new subchannels over this past weekend and I can't get new guide data for these new and moved subchannels. Maybe it's due to the SD feed not having the new channel lineup changes integrated yet. I have guide data in SageTV for my other local OTA channels out to 7pm October 20th, so I'll keep an eye the logs and the guide to see what happens.
__________________
--Jason

Server Hardware: GIGABYTE GA-EP45-UD3R, Intel Q9550 CPU 2.83GHz, 11GB RAM, 1xHDHR, 1xHVR1600, 1xHVR2250
29TB Server Storage: 1TB SSD (OS), 1TB (data), 2x6TB+2x10TB (22TB FlexRaid storage pool), 2x2TB (recordings), 1x750GB (VMs).
Server Software: Win10 Pro x64 OS, SageTV 64bit v9.2.0.441, Java 1.8 u241, PlayOn, Comskip (Donator) v0.82.003, WampServer v2.5.
Clients: 3xHD300s, 2xHD100, 2xPlaceshifters
Reply With Quote
  #19  
Old 10-04-2022, 09:25 AM
emveepee emveepee is offline
Sage Aficionado
 
Join Date: Nov 2006
Posts: 408
I know in addition to the artwork changes we tested with NextPVR SD introduced blocking for multiple uses of user credentials. So you have various SD clients, if the token isn't re-authenticated on failure things won't work.

Previous behaviour was all tokens were valid for 24 hours, and I'm not sure how SageTV deals with this. If you have multiple servers calling SD definitely don't run EPG updates at the same time.

Martin
Reply With Quote
  #20  
Old 10-04-2022, 05:49 PM
TGsell TGsell is offline
Sage Advanced User
 
Join Date: Mar 2011
Location: Glen Head
Posts: 108
The token requirement could explain why updating to EPG123 v1.7.1.8 seems to completely remedy my issue. So far it's good.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with program guide data updating sflamm SageTV EPG Service 4 02-19-2017 01:56 AM
Existing Program Information Not Updating on Some Channels ptzink SageTV EPG Service 6 10-29-2013 07:50 AM
STV Import: Alternative Program Guide & Mini Guide for Default STV wado1971 SageTV Customizations 24 09-13-2009 01:32 PM
SageTV V6 Program Guide empty and not updating JasonEngel SageTV EPG Service 2 03-20-2007 08:40 PM
How to disable the popup window in the program guide? How to keep the program guide? metropole SageTV Software 8 05-18-2006 06:25 PM


All times are GMT -6. The time now is 12:38 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.