SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-18-2008, 09:27 PM
willieb willieb is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: Philadelphia
Posts: 173
Playback Error in Playback

Well, my buddy and I are both longtime BTV users and we have ended up here. I installed the trial and so far I am liking it a lot. My friend already paid for Sage and I am going to be right behind him. One nagging problem we both seem to be having that none of you seem to have had is this: we can't play our BTV recorded files in Sage. I am not talking about getting them to show up as tv recordings. I saw Brent's method and it looks to work great. Our problem is that Sage, and only Sage, won't play the .tp files (I added .tp as a recognized file in sage.properties file, and it sees them). When we click on we get an error that says "Ther was a playback error in Playback. Details: sage.PlaybackException: ERROR (-4,0x80004005): There was a problem rendering the video portion of the content for playback." Interestingly, Sage can make a thumbnail of the file fine, so I know it can see it.

Can any of you have have made the switch give us a clue? Thanks in advance.

Edit: Just noticed this is the general forum, not the software support forum. I searched and found the thread, and didn't realize where I was. I can start a new thread if this post bugs people....

* split from original topic & merged here *

Last edited by willieb; 02-18-2008 at 09:35 PM.
Reply With Quote
  #2  
Old 02-18-2008, 09:36 PM
cmcquistion cmcquistion is offline
Sage User
 
Join Date: Sep 2007
Posts: 10
Quote:
Originally Posted by willieb View Post
Well, my buddy and I are both longtime BTV users and we have ended up here. I installed the trial and so far I am liking it a lot. My friend already paid for Sage and I am going to be right behind him. One nagging problem we both seem to be having that none of you seem to have had is this: we can't play our BTV recorded files in Sage. I am not talking about getting them to show up as tv recordings. I saw Brent's method and it looks to work great. Our problem is that Sage, and only Sage, won't play the .tp files (I added .tp as a recognized file in sage.properties file, and it sees them). When we click on we get an error that says "Ther was a playback error in Playback. Details: sage.PlaybackException: ERROR (-4,0x80004005): There was a problem rendering the video portion of the content for playback." Interestingly, Sage can make a thumbnail of the file fine, so I know it can see it.

Can any of you have have made the switch give us a clue? Thanks in advance.

Edit: Just noticed this is the general forum, not the software support forum. I searched and found the thread, and didn't realize where I was. I can start a new thread if this post bugs people....
I think all you need to do is rename the files to .ts, instead of .tp
Reply With Quote
  #3  
Old 02-18-2008, 09:41 PM
Brent Brent is offline
SageTVaholic
 
Join Date: May 2006
Location: KC, Missouri
Posts: 3,695
Quote:
Originally Posted by willieb View Post
Our problem is that Sage, and only Sage, won't play the .tp files (I added .tp as a recognized file in sage.properties file, and it sees them). When we click on we get an error that says "Ther was a playback error in Playback. Details: sage.PlaybackException: ERROR (-4,0x80004005): There was a problem rendering the video portion of the content for playback." Interestingly, Sage can make a thumbnail of the file fine, so I know it can see it. Can any of you have have made the switch give us a clue? Thanks in advance.
It should be able to play those .tp files. Have you tried different video/audio settings in the detailed settings? I'd try a few different decoder filters to see if any worked for the tp files.
Reply With Quote
  #4  
Old 02-19-2008, 07:23 AM
willieb willieb is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: Philadelphia
Posts: 173
Quote:
Originally Posted by Brent View Post
It should be able to play those .tp files. Have you tried different video/audio settings in the detailed settings? I'd try a few different decoder filters to see if any worked for the tp files.
Thanks for the reply Brent. Yes, we have both tried all the decoders we can. We both have Nvidia Purevideo decoders we bought for Btv and I also tried the cyberlink decoders. I also tried setting everything to default and letting Directshow handle it (graphedit makes an all-Nvidia graph and plays fine), but no luck. Same error.

Two more points: I tried Sage about 8 months ago and I did not have this problem but wasnt ready to switch yet. Also, I found ONE tp file that wil play fine last night. as far as I can tell there is no real difference between this one and the others, which suggests it isnt decoders. Do you think recent Sage versions may have somehow broken this ability? Does anyone have any tp files they can try with Sage 6.3.5 or later?
Reply With Quote
  #5  
Old 02-21-2008, 05:51 PM
gtdave gtdave is offline
Sage User
 
Join Date: Jan 2008
Posts: 33
Exclamation Playback error when playing BeyondTV-recorded shows

My friend and I are working hard to make the switch from BeyondTV to Sage, and we are both running into the same problem with playing shows recorded with BeyondTV. We both have very different hardware and server-client setups, so this is definitely pointing to a problem with Sage.

We can't play our BTV recorded transport stream files in Sage. Our problem is that Sage, and only Sage, won't play the .tp files (we added .tp as a recognized file in sage.properties file, and it sees them, so no problem there). We have both tried all the decoders we can. We both have Nvidia Purevideo decoders that we bought for BTV, and we have both tried the cyberlink decoders. (We have both unregistered the Sage decoder as it broke DVD playback, so that's not an option.) He also tried setting everything to default and letting Directshow handle it (graphedit makes an all-Nvidia graph and plays fine), but no luck. Same error.

When we try to play the transport stream files we get the following somewhat circular error:

"There was a playback error in Playback. Details: sage.PlaybackException: ERROR (-4,0x80004005): There was a problem rendering the video portion of the content for playback." Interestingly, Sage can make thumbnails of each of the files just fine, so we know it can see them.

Can any of you have have made the switch from BTV to Sage give us a clue? We are both running 6.3.5 servers, and I have 2 clients--the files won't play on any of our machines.

Thanks for your help!
Reply With Quote
  #6  
Old 02-24-2008, 09:24 PM
mrwolf mrwolf is offline
Sage Advanced User
 
Join Date: Jan 2008
Posts: 79
I renamed my .tp files to .mpg and dropped them into the videos folder and they worked fine. I was using BTV 4.7 and I'm now on SageMC 6.3.5. In fact, I watched a bunch of them today and seen no issues.
Reply With Quote
  #7  
Old 02-26-2008, 07:01 AM
willieb willieb is offline
Sage Advanced User
 
Join Date: Jan 2008
Location: Philadelphia
Posts: 173
thanks. I will give it a try when I get home today.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How To: Convert BTV Recorded Shows to SageTV Recorded Shows Brent SageTV Customizations 55 11-25-2016 08:36 AM
There is no MediaPlayer that can playback the selected file while it's being recorded spacecadet SageTV Beta Test Software 5 09-10-2007 04:20 PM
Recorded shows freeze on playback Ghost Hardware Support 4 11-22-2004 08:04 AM
Can recorded shows be cued up for playback? tabletsage SageTV Beta Test Software 5 02-10-2004 01:16 PM


All times are GMT -6. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.