SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Media Extender

Notices

SageTV Media Extender Discussion related to any SageTV Media Extender used directly by SageTV. Questions, issues, problems, suggestions, etc. relating to a SageTV supported media extender should be posted here. Use the SageTV HD Theater - Media Player forum for issues related to using an HD Theater while not connected to a SageTV server.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-19-2009, 06:54 AM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
HD200 stutter on channel change

Hi, I'm new to the whole SageTV thing. Took the plunge recently and got the HD200 + SageTV software bundle.

My problem is a series of stutters whenever I change channel viewing live tv using the HD200.

When I change channel the picture and sound appear, then within the first second or two it will stutter/pause, then continue. It will often stutter a second, and sometimes a third time. This happens in the first 30 seconds after changing channel. After this it settles down and all is good

If I hit pause as soon as it changes channel, wait a couple seconds, then hit play all is good.

It feels like it's starting playback too soon after changing channel and not giving the server a chance to buffer enough to disk.

I've tried three server setups, all exhibit the problem:

Core 2 E6550, WinXP Pro, 64k block size on HDD
AMD AthlonXP 2500+, WinXP pro, 64k block size on HDD
Core 2 T8400, Ubuntu 9.04, default ext3 block size (I've also purchased a license for the Linux OEM version of SageTV).

I've tried three tuners:

Asus My Cinema U3100 Mini.
Hauppauge Nova-T USB stick (I think thats what it's called, borrowed it from a friend).
HDHomerun (borrowed from work).

The content is DVB-T with a mixture of SD (576i) and HD (720p and 1080i) content.

Any thoughts/ideas?

Thanks,

Dylan
Reply With Quote
  #2  
Old 09-19-2009, 04:41 PM
Hunter69 Hunter69 is offline
Sage Aficionado
 
Join Date: Oct 2008
Posts: 301
I am interested if something could be done, because I experience the same problem. I have a HDPVR with a HD200.
__________________
Server: Antec 300, AMD Phenom 9750, 4 gig ram, 4 tb-with pooled recording , Lite on Blu-ray drive
Tuners: 2 HD-PVR, 1 HDHR
Clients: 2 HD200
Reply With Quote
  #3  
Old 09-25-2009, 11:41 AM
Beefcake550 Beefcake550 is offline
Sage Expert
 
Join Date: Oct 2004
Posts: 706
fopr the HD-PVR, you coudl either force your STB to output a constant resolution like 720p., or you can add "delay_to_wait = 4000" in your sage.properties file. It'll allow your STB to settle it's output before trying to encode it.
Reply With Quote
  #4  
Old 10-15-2009, 03:31 AM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
I've found a fix.

There is a delay you can configure in the client properties, e.g:

clients/<client id>.properties

videoframe/local_encoding_to_playback_delay=4000

The default value is 0.

With a delay of 4000 the problem appears to be fixed, or at least occuring
infrequently. Lowering the value, e.g. 2000 or 500 speeds up the channel
change but the stuttering issues return getting worse the lower the value.

Dylan
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New HD200 setup with a random problem and slow channel change Hunter69 SageTV Media Extender 8 05-06-2009 06:10 AM
Audio Stutter on one Channel RBTConsultants SageTV Software 0 01-23-2008 08:53 AM
Studder after multipath, channel change, & show change TBacker SageTV Software 1 01-05-2008 09:01 AM
chapter change stutter footmasta SageTV Beta Test Software 0 10-14-2005 06:54 AM


All times are GMT -6. The time now is 03:03 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.