SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-09-2010, 04:18 PM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
Prevent sage server from mounting external disks

I'm running the sagetv server on ubuntu 9.10 and I've noticed a very annoying behaviour. Everytime I connect an external (USB or eSATA) disk sage mounts the disk under /var/media/external.

Does anyone know how to prevent this behaviour?

There are two situation where this is a nuisance.

1. I have a external disk I do backups too once a week. My scripts mount the disk, do the backups, then unmount the disk. With sage running I end up with the disk mounted twice. When the backup completes I unplug the disk. I'm not sure what affect removing a disk that is still mounted has.

2. When I plug my ipod in to copy files over I rely on the gnome auto mount magic to mount the disk with the correct perms/ownership. With sage running the ipod ends up mounted twice with the gnome auto mount thing getting confused and mounting the ipod with root perms meaning I can't write to it.

Thanks,

Dylan
Reply With Quote
  #2  
Old 02-09-2010, 04:21 PM
kbyrd kbyrd is offline
Sage Aficionado
 
Join Date: Sep 2008
Location: SF Bay Area, CA
Posts: 282
I had this problem too...

http://forums.sagetv.com/forums/showthread.php?t=38657

setting:
notify_on_new_drive=false

fixed it.
__________________
Current Server: Sage v7.1.9.1 beta w/ Diamond UI on Ubuntu 11.10 x86_64 | Storage: Linux md's raid10,f2 | Client: HD300 extender | Tuner: HDHomeRun for QAM
Reply With Quote
  #3  
Old 02-11-2010, 03:08 AM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
Not a lot of luck there

I've got "ui/notify_on_new_drive=false" in the properties file for both of my HD200's.

I've added "ui/notify_on_new_drive=false", then "notify_on_new_drive=false", and finally both to the Sage.properties file (restarting between each attempt).

Sage is still auto-mounting my external disks.

Any ideas what I've overlooked?

I'm using Sage 6.6.2 on Ubuntu 9.10.
Reply With Quote
  #4  
Old 02-11-2010, 11:23 AM
MitchSchaft MitchSchaft is offline
Sage Expert
 
Join Date: Jan 2008
Posts: 717
Maybe turn off autoplay under gpedit.msc?

Start/run/type gpedit.msc and hit enter
Navigate to Computer Configuration/Admin Templates/System, then enable "turn Off Autoplay" for all drives.
Reply With Quote
  #5  
Old 02-11-2010, 02:59 PM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
Quote:
Originally Posted by MitchSchaft View Post
Maybe turn off autoplay under gpedit.msc?

Start/run/type gpedit.msc and hit enter
Navigate to Computer Configuration/Admin Templates/System, then enable "turn Off Autoplay" for all drives.
Thanks for the suggestion, but it won't help

gpedit is a Microsoft Windows utility (thanks google, I'd not heard of it before). I'm using the Sage Linux edition which appears to have a built-in auto mounter.

Dylan
Reply With Quote
  #6  
Old 02-13-2010, 07:40 AM
kbyrd kbyrd is offline
Sage Aficionado
 
Join Date: Sep 2008
Location: SF Bay Area, CA
Posts: 282
In that other post I referenced, the problem turned to be that SageMC needed a fix. Are you using a recent version (a pre-release one, I think) of SageMC?

If you're using the default interface, this doesn't apply.
__________________
Current Server: Sage v7.1.9.1 beta w/ Diamond UI on Ubuntu 11.10 x86_64 | Storage: Linux md's raid10,f2 | Client: HD300 extender | Tuner: HDHomeRun for QAM
Reply With Quote
  #7  
Old 02-28-2010, 07:07 PM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
Quote:
Originally Posted by kbyrd View Post
In that other post I referenced, the problem turned to be that SageMC needed a fix. Are you using a recent version (a pre-release one, I think) of SageMC?

If you're using the default interface, this doesn't apply.
Using the default interface

I'll drop a message to the official support people and see what they say.

Thanks for you help

Dylan
Reply With Quote
  #8  
Old 03-04-2010, 05:43 AM
DylanHall DylanHall is offline
Sage User
 
Join Date: Sep 2009
Location: Wellington, New Zealand
Posts: 32
Response from the SageTV support people:

----

There's 2 ways you could do this in your Sage.properties file. Just make
sure to close Sage when making the changes.

First; you can edit the property "linux/protected_devices" and give it a
semicolon delimited list of device partition names to not mount (i.e.
sda1;sda2;sda3;sdb1).

Second; you can edit the property "linux/new_dev_scan_wait_period" and set
it to a very high value (its a 64-bit integer, millisecond units) so that
any devices newly added while SageTV is running won't be mounted. But it
would still automount existing USB/eSATA drives at startup.

----

I chose the first option, using the linux/protected_devices setting and it's working perfectly

Dylan
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Prevent Client users from changing settings on Server? eehtpc SageTV Software 2 11-09-2007 09:43 PM
Prevent SageTV from Minimizing when External Prgram is launched? ikarus79m SageTV Software 1 11-18-2006 06:59 AM
How Do I Prevent WinTV2000 From Disabling Sage TV Audio? clevo SageTV Software 2 10-09-2006 03:38 PM
Sage 2.2 afraid of large disks? jhkoenig SageTV Software 5 01-12-2006 07:23 AM
ISO mounting & external DVD players Grey_Goose SageTV Customizations 0 05-14-2005 12:10 PM


All times are GMT -6. The time now is 02:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.