SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-27-2008, 02:41 PM
talvey talvey is offline
Sage User
 
Join Date: Feb 2008
Posts: 5
PlaybackException - Linux Server, Windows Client

Server: Linux Fedora 6- V6.3.5.1
Client: Windows XP - V.6.3.5.159

I'm having problems with my sageTv windows client when attempting to watch TV or video using my Linux sageTv server. I receive the following error:

Code:
There was a Playback Error in playback. Details:
sage.PlaybackException: ERROR
(-3,0x80040154): There was a problem accessing the filesystem for playback
This error occurs on any of the windows machines on my network. However, I am able to watch tv/video using my Media MVP extender and using the Linux placeshifter client (on the server machine). Oddly, I get the same error even trying to view a video file locally on the windows machine with the client (Media Center -> Browse Media Files -> Play a Selected Media File). Photos and online content work correctly. I've tried all the video renders, adjusting permissions, different java versions, etc...Any help here would be greatly appreciated.

Below is the debug client console log..

Code:
Sat 12/27 12:56:21.378 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\VideoArt.png
Sat 12/27 12:56:21.387 Creating DirectX9 Texture from nio buffer w=380 h=380
Sat 12/27 12:56:21.673 Creating DirectX9 Texture from nio buffer w=128 h=128
[GC 86358K->81725K(89180K), 0.0048919 secs]
Sat 12/27 12:56:21.679 Creating DirectX9 Texture from nio buffer w=128 h=128
Sat 12/27 12:56:21.680 Creating DirectX9 Texture from nio buffer w=128 h=128
Sat 12/27 12:56:21.682 Creating DirectX9 Texture from nio buffer w=128 h=128
Sat 12/27 12:56:21.682 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDChUp.png
Sat 12/27 12:56:21.683 Creating DirectX9 Texture from nio buffer w=29 h=26
Sat 12/27 12:56:21.683 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDChDisplay.png
Sat 12/27 12:56:21.683 Creating DirectX9 Texture from nio buffer w=35 h=26
Sat 12/27 12:56:21.684 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDChDown.png
Sat 12/27 12:56:21.684 Creating DirectX9 Texture from nio buffer w=29 h=26
Sat 12/27 12:56:21.685 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDStatusPause.png
Sat 12/27 12:56:21.685 Creating DirectX9 Texture from nio buffer w=6 h=8
Sat 12/27 12:56:21.685 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDVolOn.png
Sat 12/27 12:56:21.686 Creating DirectX9 Texture from nio buffer w=16 h=13
Sat 12/27 12:56:21.686 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDVolBar.png
Sat 12/27 12:56:21.686 Creating DirectX9 Texture from nio buffer w=64 h=4
Sat 12/27 12:56:21.687 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDVolSlider.png
Sat 12/27 12:56:21.687 Creating DirectX9 Texture from nio buffer w=13 h=15
Sat 12/27 12:56:21.687 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDReplay.png
Sat 12/27 12:56:21.688 Creating DirectX9 Texture from nio buffer w=29 h=26
Sat 12/27 12:56:21.688 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDRew.png
Sat 12/27 12:56:21.689 Creating DirectX9 Texture from nio buffer w=30 h=26
Sat 12/27 12:56:21.689 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDStop.png
Sat 12/27 12:56:21.690 Creating DirectX9 Texture from nio buffer w=30 h=26
Sat 12/27 12:56:21.690 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDPlay.png
Sat 12/27 12:56:21.690 Creating DirectX9 Texture from nio buffer w=30 h=26
Sat 12/27 12:56:21.691 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDFwd.png
Sat 12/27 12:56:21.691 Creating DirectX9 Texture from nio buffer w=30 h=26
Sat 12/27 12:56:21.691 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\OSDSkip.png
Sat 12/27 12:56:21.692 Creating DirectX9 Texture from nio buffer w=29 h=26
Sat 12/27 12:56:23.709 DShowPlayer setVideoRendererFilter0({CD8743A1-3736-11D0-9
E69-00C04FD7C15B}) called
Sat 12/27 12:56:23.711 DShowPlayer setVideoDecoderFilter0(SageTV MPEG Video Deco
der) called
Sat 12/27 12:56:23.711 Using legacy SageTV MPEG Video Decoder
Sat 12/27 12:56:23.711 Could not add specified video decoder filter to graph hr=
0x80040154
Sat 12/27 12:56:23.711 DShowPlayer setAudioDecoderFilter0(SageTV MPEG Audio Deco
der) called
Sat 12/27 12:56:23.712 Could not add specified audio decoder filter to graph hr=
0x80040154
Sat 12/27 12:56:23.712 DShowPlayer setTimeshift=1 buffer=0
Sat 12/27 12:56:23.712 Exception from line: 666
Sat 12/27 12:56:23.712 VideFrame had an error loading the file. It must abort th
e file load.
Sat 12/27 12:56:23.712 Tearing down playback graph
Sat 12/27 12:56:23.712 NATIVE Deallocating the CPlayerData object
Sat 12/27 12:56:23.712 NATIVE Finished destroying the playback graph
Sat 12/27 12:56:23.732 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\Themes\Standard SDTV\DialogBG.png
Sat 12/27 12:56:23.736 Creating DirectX9 Texture from nio buffer w=595 h=186
Sat 12/27 12:56:23.738 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\Themes\Standard SDTV\ButtonHighlight.png
Sat 12/27 12:56:23.738 Creating DirectX9 Texture from nio buffer w=248 h=43
Sat 12/27 12:56:23.739 Loading 0x0 image from file D:\apps\SageTV\SageTV\STVs\Sa
geTV3\Themes\Standard SDTV\ButtonBG.png
Sat 12/27 12:56:23.740 Creating DirectX9 Texture from nio buffer w=248 h=43
Sat 12/27 12:56:23.740 Creating new render target surface 1680 x 1050
Thanks,
Travis
Reply With Quote
  #2  
Old 12-27-2008, 06:30 PM
bcjenkins bcjenkins is offline
SageTVaholic
 
Join Date: Jan 2006
Posts: 3,760
What permissions does the XP user have? Can you post a server log from the same time frame?

B
__________________
Running SageTV on unRAID via Docker
Tuning handled by HDHR3-6CC-3X2 using OpenDCT
Reply With Quote
  #3  
Old 12-27-2008, 08:37 PM
talvey talvey is offline
Sage User
 
Join Date: Feb 2008
Posts: 5
Thanks for the reply. The XP user has admin rights, and I've given the world full permissions on the linux media directories...

Below is the server log from the same timeframe. The client(s) worked in the past. I don't often use the windows clients to view media, so I don't know exactly when they quit working. The only change to the linux server I've made is to add another hard drive.


Code:
Sat 12/27 12:56:21.499 setInput0 1 0 1 1
Sat 12/27 12:56:21.499 setting standard to 0x3000
Sat 12/27 12:56:21.549 updateColors0 b=128 c=128 h=128 s=128
Sat 12/27 12:56:21.566 DTVSerial Valid Command Recognized for handle 24^M
Sat 12/27 12:56:21.583 DTVSerial Set Top is Processing Request for handle 24^M
Sat 12/27 12:56:21.583 DTVSerial Command Successful for handle 24^M
Sat 12/27 12:56:21.595 DTVSerial Valid Command Recognized for handle 24^M
Sat 12/27 12:56:21.609 DTVSerial Set Top is Processing Request for handle 24^M
Sat 12/27 12:56:21.609 DTVSerial Command Successful for handle 24^M
Sat 12/27 12:56:21.621 DTVSerial Valid Command Recognized for handle 24^M
Sat 12/27 12:56:21.637 DTVSerial Set Top is Processing Request for handle 24^M
Sat 12/27 12:56:21.637 DTVSerial Command Successful for handle 24^M
Sat 12/27 12:56:21.637 DTVSerial channel change worked^M
Sat 12/27 12:56:21.638 setEncodingProperties0 Great
Sat 12/27 12:56:21.638 Set encoding property audiooutputmode to 0^M
Sat 12/27 12:56:21.638 Set encoding property audiocrc to 0^M
Sat 12/27 12:56:21.638 Set encoding property gopsize to 15^M
Sat 12/27 12:56:21.638 Set encoding property videobitrate to 3800000^M
Sat 12/27 12:56:21.638 Set encoding property inversetelecine to 0^M
Sat 12/27 12:56:21.638 Set encoding property closedgop to 0^M
Sat 12/27 12:56:21.638 Set encoding property vbr to 0^M
Sat 12/27 12:56:21.638 Set encoding property outputstreamtype to 10^M
Sat 12/27 12:56:21.638 Set encoding property width to 720^M
Sat 12/27 12:56:21.638 Set encoding property height to 480^M
Sat 12/27 12:56:21.638 Set encoding property audiobitrate to 384^M
Sat 12/27 12:56:21.638 Set encoding property audiosampling to 48000^M
Sat 12/27 12:56:21.638 Set encoding property disablefilter to 1^M
Sat 12/27 12:56:21.639 Set encoding property medianfilter to 3^M
Sat 12/27 12:56:21.639 Set encoding property fps to 30^M
Sat 12/27 12:56:21.639 Set encoding property ipb to 0^M
Sat 12/27 12:56:21.639 Set encoding property deinterlace to 0^M
Sat 12/27 12:56:21.655 Set encoding property aspectratio to 1^M
Sat 12/27 12:56:21.655 setEncoding0NewInterface
Sat 12/27 12:56:21.762 setup encoding /opt2/media/tv/CNNSpecialInvestigationsUnit-7517549-0.mpg
Sat 12/27 12:56:22.786 Found next seq hdr code!
Sat 12/27 13:00:00.028 DTVSerial Valid Command Recognized for handle 24^M
Sat 12/27 13:00:00.040 DTVSerial Set Top is Processing Request for handle 24^M
Sat 12/27 13:00:00.040 DTVSerial Command Successful for handle 24^M
Sat 12/27 13:00:00.051 DTVSerial Valid Command Recognized for handle 24^M
Reply With Quote
  #4  
Old 12-28-2008, 04:52 AM
bcjenkins bcjenkins is offline
SageTVaholic
 
Join Date: Jan 2006
Posts: 3,760
When you use a Linux server and an XP client, the server has to send everything to the client because the client can't access the directory paths on the server directly. This has changed in Vista fwiw due to the availability of symlinks.

In the example you provided, it looks like this is a live TV playback. It also looks like you're using the SageTV MPEG decoders. Do you have a different decoder installed which you could try as well? Do you have a firewall running on the XP client, can you disable to see if it resolves? Do you have the same issue running placeshifter on the XP client?

Lastly, how are the two machines connected?

B
__________________
Running SageTV on unRAID via Docker
Tuning handled by HDHR3-6CC-3X2 using OpenDCT
Reply With Quote
  #5  
Old 12-29-2008, 01:57 PM
talvey talvey is offline
Sage User
 
Join Date: Feb 2008
Posts: 5
Yep, the provided example was from live tv playback. The same error occurs when I try to access previously recorded media as well. I've tried different codecs (I think I currently have the K-Lite codecs installed). I can navigate to the linux media directories (samba) and play all the files with WMP or WinAmp from my windows machine. I've tried turning off the firewall and antivirus software to no avail. The XP Placeshifter client works fine.

The machines are are on the same wired 100T subnet (single switch).

From the evidenced behavior is seems that the XP client is still trying to access the filesystem instead of receiving everything from the client, but that's just a guess....

Thanks,
T
Reply With Quote
  #6  
Old 12-29-2008, 02:01 PM
bcjenkins bcjenkins is offline
SageTVaholic
 
Join Date: Jan 2006
Posts: 3,760
At this point you should send an email to support. I'd be more than happy to take a further look if you could send a complete log and properties files from the client and the server.

B
__________________
Running SageTV on unRAID via Docker
Tuning handled by HDHR3-6CC-3X2 using OpenDCT
Reply With Quote
  #7  
Old 12-29-2008, 05:35 PM
talvey talvey is offline
Sage User
 
Join Date: Feb 2008
Posts: 5
Thanks for your help, I appreciate it. I've sent support a request for help. If they are unable help resolve my issue, I'll package up the logs and properties files and attach them...

Thanks again,
T
Reply With Quote
  #8  
Old 03-14-2009, 10:07 AM
talvey talvey is offline
Sage User
 
Join Date: Feb 2008
Posts: 5
Fix was simple

I've been remiss in my duty updating the thread with my solution. I've never been able to explain the cause of the issue, but upgrading to the most recent client software version solved the problem. It wasn't even necessary to upgrade the server version to match, although I probably will at some point.

Sorry for the delayed update...

T.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SageTV V6.5.5 Release Candidate is Here! Narflex SageTV Beta Test Software 0 12-23-2008 12:01 PM
SageTV V6.5.4 Beta is Ready Narflex SageTV Beta Test Software 0 12-17-2008 01:50 PM
Linux Server Windows Network Encoder Problem harrijay SageTV Linux 8 06-15-2008 07:20 PM
Migrating from windows to linux. dnlmln SageTV Linux 8 12-20-2007 08:34 AM
copying a customized STV from a server to a client Homebuilder SageTV Customizations 1 12-19-2005 11:39 PM


All times are GMT -6. The time now is 11:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.