SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations

Notices

SageTV Customizations This forums is for discussing and sharing user-created modifications for the SageTV application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss customizations for SageTV version 6 and earlier, or for the SageTV3 UI.

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-07-2010, 11:27 AM
Spartan's Avatar
Spartan Spartan is offline
Sage Advanced User
 
Join Date: Nov 2007
Location: Michigan, USA
Posts: 109
SageTCPServer -- configuration problems...

Maybe I am just an idiot, but I cannot figure out how to configure SageTCPServer.

In my setup, I have a WHS SageTV Server, an HD200, and an MVP that I would like to control via the iHome iPhone remote.

So, I install the software on the server and add this to my sage.properties file:

Code:
sageTCPServer/clients=local.9250
...and the startup-runnable classes.

Via the logfile I can see that the class is getting loaded -- happy time.

Now, I want to get the client going on the server, just for basic testing so I add this to the sageclient.properties file:

Code:
sageTCPServer/clients=local.9251
...and, nothing. I get this in the server logfile (when I telnet to 9250 and issue a command):

Code:
Tue 9/7 12:58:53.287 [Thread-6@1d5047e] [[SageTCPServer-SageServer(local:9250)]]: Now 1 incoming message(s) in list.
Tue 9/7 12:58:53.288 [Thread-6@1d5047e] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) There is now 1 incoming message.
Tue 9/7 12:58:53.288 [Thread-6@1d5047e] [[SageTCPServer-SageServer(local:9250)]]: The following UI context are available: 
Tue 9/7 12:58:53.289 [Thread-6@1d5047e] [[SageTCPServer-SageServer(local:9250)]]: EXCEPTION java.lang.NullPointerException AT sagetcpserver.messages.Message.toString(Message.java:51)

Tue 9/7 12:58:53.289 [Thread-6@1d5047e] sagetcpserver.SageServer.processIncomingMessages(SageServer.java:287)

Tue 9/7 12:58:53.289 [Thread-6@1d5047e] sagetcpserver.SageServer.run(SageServer.java:172)
Now, what I don't understand is why the client needs a port number -- what's going on with that? I understand that the SageTCPServer is listening on 9250, but what is 9251 for and how do I get the Sage Client UI to register its context with the SageTCPServer?
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SageTCPServer - @Fonceur Osler SageTV Customizations 12 07-12-2010 09:02 PM
Video Configuration problems crarbo1 SageTV Software 29 09-05-2008 04:59 AM
transferring configuration fuzzymath10 SageTV Software 2 10-31-2004 09:03 PM
Problems with configuration kpaske SageTV Software 5 01-04-2004 03:36 PM
Installation and configuration problems ejr SageTV Software 2 01-04-2004 05:08 AM


All times are GMT -6. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.