SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-09-2017, 09:32 PM
skyeclad skyeclad is offline
Sage Aficionado
 
Join Date: Nov 2007
Location: NY DMA
Posts: 441
HEVC Encoded MKV - Playback Error

I've encoded a bunch of my movies in HEVC with Handbrake and have no issues playing them back using Windows Media after installing Sharky's Codecs and setting up LAV filters. Assuming that Directshow is all set, I told Sage to use Directshow on any non-mpeg files.

Except when I try to play a movie, I get a sage.playbackexception: Error (-4,0X80004005). No idea why but here is the sageclient log where the failure takes place. Anyone else have better luck?

PHP Code:
Mon 1/9 22:22:03.320 [AWT-EventQueue-0@564f50processOptionsMenu optionsMenu=default:BASE-49276|OptionsMenu:Ask whether to Resume Video or Restart
Mon 1
/9 22:22:04.941 [AWT-EventQueue-0@564f50VF.submitJob(VFJob[CloseMF r=0.0 t=0 file=null ifn=null])
Mon 1/9 22:22:04.946 [VideoFrame-SAGETV_PROCESS_LOCAL_UI@1e01346VF processing job VFJob[CloseMF r=0.0 t=0 file=null ifn=nullnPlayin=false
Mon 1
/9 22:22:04.950 [AWT-EventQueue-0@564f50CloseAndWait is executing the close job synchronously now
Mon 1
/9 22:22:04.954 [AWT-EventQueue-0@564f50VF processing on UI Thread VFJob[CloseMF r=0.0 t=0 file=null ifn=null]
Mon 1/9 22:22:04.957 [VideoFrame-SAGETV_PROCESS_LOCAL_UI@1e01346VF processing job null nPlayin=false
Mon 1
/9 22:22:04.962 [AsyncWatch@1b5b869VideoFrame.watch(A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103])
Mon 1/9 22:22:04.966 [VideoFrame-SAGETV_PROCESS_LOCAL_UI@1e01346VF thread is now waiting for 0:00:00.000
Mon 1
/9 22:22:04.969 [AsyncWatch@1b5b869watchThisFile=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]]
Mon 1/9 22:22:04.973 [AsyncWatch@1b5b869Watch airing is a file over, do that instead dvd=false
Mon 1
/9 22:22:04.981 [AsyncWatch@1b5b869VF.submitJob(VFJob[WatchMF r=0.0 t=0 file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] ifn=null])
Mon 1/9 22:22:04.985 [VideoFrame-SAGETV_PROCESS_LOCAL_UI@1e01346VF processing job VFJob[WatchMF r=0.0 t=0 file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] ifn=null] nPlayin=false
Mon 1/9 22:22:04.989 [AsyncWatch@1b5b869setUI(sage.cb@afaf59[MediaPlayer OSD]) histIdx=9 uiHistory=[sage.cb@1cfd90a[Detailed Setup], sage.cb@30f287[Main Menu], sage.cb@684767[Browser Videos], sage.cb@fee853[Detailed Info Recording], sage.cb@30f287[Main Menu], sage.cb@1cfd90a[Detailed Setup], sage.cb@30f287[Main Menu], sage.cb@684767[Browser Videos], sage.cb@fee853[Detailed Info Recording], sage.cb@afaf59[MediaPlayer OSD]] redo=false
Mon 1
/9 22:22:04.992 [AWT-EventQueue-0@564f50VF processing on UI Thread VFJob[WatchMF r=0.0 t=0 file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] ifn=null]
Mon 1/9 22:22:05.001 [VideoFrame-SAGETV_PROCESS_LOCAL_UI@1e01346VF processing job VFJob[LoadMF r=0.0 t=0 file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] ifn=null] nPlayin=false
Mon 1/9 22:22:05.005 [AWT-EventQueue-0@564f50VF processing on UI Thread VFJob[LoadMF r=0.0 t=0 file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] ifn=null]
Mon 1/9 22:22:05.008 [AWT-EventQueue-0@564f50VideoFrame creating new media player for file:MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]]
Mon 1/9 22:22:05.012 [AWT-EventQueue-0@564f50VF file=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]] targetTime = Mon 12/5 23:23:31.248
Mon 1/9 22:22:05.016 [AWT-EventQueue-0@564f50VideoFrame.timeSelected(Mon 12/5 23:23:31.248truecurrFile=MediaFile[id=37150958 A[37175893,37150959,"10 Cloverfield Lane",0@1205.23:23,103mask=V host=DamatoHTPC encodedByformat=MATROSKA 1:43:34 640 kbps [#0 Video[0X0000 23.98 fps 1920x800 12:5 progressive]#1 Audio[AC3 48000 Hz 6 channels 640 kbps idx=1 eng]] P:\Video\Blu Ray\10 Cloverfield Lane.mkv, Seg0[Mon 12/5 23:23:31.248-Tue 12/6 1:07:06.118]]
Mon 1/9 22:22:05.020 [AWT-EventQueue-0@564f50DShowPlayer createGraph0 called
Mon 1
/9 22:22:05.022 [AWT-EventQueue-0@564f50Creating GraphPluginHandler...
Mon 1/9 22:22:05.022 [AWT-EventQueue-0@564f50Done creating GraphPluginHandler
Mon 1
/9 22:22:05.022 [AWT-EventQueue-0@564f50DShowPlayer setVideoRendererFilter0({FA10746C-9B63-4B6C-BC49-FC300EA5F256}) called
Mon 1
/9 22:22:05.022 [AWT-EventQueue-0@564f50Using EVR for video render
Mon 1
/9 22:22:05.047 [AWT-EventQueue-0@564f50Using 3 input pins on the EVR
Mon 1
/9 22:22:05.047 [AWT-EventQueue-0@564f50Finished with EVR configuration OK
Mon 1
/9 22:22:05.047 [AWT-EventQueue-0@564f50DShowPlayer setAudioRendererFilter0(SAMSUNG-(NVIDIA High Definition Audio)) called
Mon 1
/9 22:22:05.051 [AWT-EventQueue-0@564f50DShowPlayer setTimeshift=0 buffer=0
Mon 1
/9 22:22:05.051 [AWT-EventQueue-0@564f50Using the default source filter
Mon 1
/9 22:22:05.051 [AWT-EventQueue-0@564f50NATIVE Loading the source file
Mon 1
/9 22:22:05.056 [AWT-EventQueue-0@564f50NATIVE setting up the SageTV Stream Demuxer
Mon 1
/9 22:22:05.133 [AWT-EventQueue-0@564f50Calling GraphCreated for the PluginHandler
Mon 1
/9 22:22:05.133 [AWT-EventQueue-0@564f50Done calling GraphCreated for the PluginHandler
Mon 1
/9 22:22:05.133 [AWT-EventQueue-0@564f50Audio Stream #1 format AC3 channels 6 freq 48000
Mon 1/9 22:22:05.133 [AWT-EventQueue-0@564f50NATIVE RenderAudio called stream=1
Mon 1
/9 22:22:05.134 [AWT-EventQueue-0@564f50NATIVE RenderAudio step 1
Mon 1
/9 22:22:05.134 [AWT-EventQueue-0@564f50NATIVE RenderAudio step 2
Mon 1
/9 22:22:05.134 [AWT-EventQueue-0@564f50NATIVE RenderAudio step 3
Mon 1
/9 22:22:05.194 [ActiveRender-SAGETV_PROCESS_LOCAL_UI@10ed410VideoFrame got registration of a subtitle UI componentsage.q[loc=java.awt.Point[x=377,y=1161size=java.awt.Dimension[width=1761,height=306]]
Mon 1/9 22:22:05.198 [ActiveRender-SAGETV_PROCESS_LOCAL_UI@10ed410VideoFrame got registration of a cc UI componentsage.q[loc=java.awt.Point[x=251,y=152size=java.awt.Dimension[width=2013,height=1224]]
Mon 1/9 22:22:05.211 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading RawImage of size 8x150 for C:\SageTV\SageTV\STVs\SageTV7\Themes\Serenity V7\OSDBGTop.png
Mon 1
/9 22:22:05.215 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading 0x0 image from file C:\SageTV\SageTV\STVs\SageTV7\Themes\Serenity V7\OSDBGTop.png
Mon 1
/9 22:22:05.216 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Creating DirectX9 Texture from nio buffer w=8 h=150
Mon 1
/9 22:22:05.216 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading RawImage of size 4x64 for C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolBarVertical.png
Mon 1
/9 22:22:05.219 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading 0x0 image from file C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolBarVertical.png
Mon 1
/9 22:22:05.220 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Creating DirectX9 Texture from nio buffer w=4 h=64
Mon 1
/9 22:22:05.220 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading RawImage of size 15x13 for C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolSliderVertical.png
Mon 1
/9 22:22:05.223 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading 0x0 image from file C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolSliderVertical.png
Mon 1
/9 22:22:05.224 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Creating DirectX9 Texture from nio buffer w=15 h=13
Mon 1
/9 22:22:05.224 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading RawImage of size 16x13 for C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolOn.png
Mon 1
/9 22:22:05.228 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading 0x0 image from file C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\OSDVolOn.png
Mon 1
/9 22:22:05.229 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Creating DirectX9 Texture from nio buffer w=16 h=13
Mon 1
/9 22:22:05.229 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading RawImage of size 380x380 for C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\VideoArt.png
Mon 1
/9 22:22:05.233 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223Loading 0x0 image from file C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\VideoArt.png
Mon 1
/9 22:22:05.244 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119971840 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.248 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119906304 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.251 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119840768 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.255 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119775232 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.258 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119709696 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.262 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119644160 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.266 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119578624 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.270 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119513088 rtMemUse=0 availMem=4170186752 src=C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\Asterisk.png
Mon 1
/9 22:22:05.274 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119508992 rtMemUse=0 availMem=4170186752 src=C:\SageTV\SageTV\STVs\SageTV7\Themes\Serenity V7\BGMainMenuSubmenu.png
Mon 1
/9 22:22:05.277 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119443456 rtMemUse=0 availMem=4170186752 src=C:\SageTV\SageTV\STVs\SageTV7\Themes\Standard\right.png
Mon 1
/9 22:22:05.281 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119439360 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSanssize=103style=0height=120.0ascent=96.0descent=25.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.284 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119373824 rtMemUse=0 availMem=4170186752 src=http://icons.wxug.com/i/c/c/nt_clear.gif
Mon 1/9 22:22:05.288 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119357440 rtMemUse=0 availMem=4170186752 src=C:\SageTV\SageTV\STVs\SageTV7\Themes\Serenity V7\HeaderWeatherLeftBG.png
Mon 1
/9 22:22:05.291 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119324672 rtMemUse=0 availMem=4170186752 src=C:\SageTV\SageTV\STVs\SageTV7\Themes\Serenity V7\HeaderWeatherRightBG.png
Mon 1
/9 22:22:05.295 [FinalRender-SAGETV_PROCESS_LOCAL_UI@1b5b223DX9 is freeing texture memory to make room size=119291904 rtMemUse=0 availMem=4170186752 src=MetaFont[fonts\DejaVuSansMonosize=57style=0height=66.0ascent=53.0descent=14.0leading=-1.0, class=class sage.FreetypeFont]
Mon 1/9 22:22:05.299 [AWT-EventQueue-0@564f50NATIVE RenderVideo called
Mon 1
/9 22:22:05.299 [AWT-EventQueue-0@564f50Exception from line769
Mon 1
/9 22:22:05.299 [AWT-EventQueue-0@564f50Built:sage.PlaybackExceptionERROR (-4,0x80004005): There was a problem rendering the video portion of the content for playback
Reply With Quote
  #2  
Old 01-10-2017, 07:26 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,580
I'm pretty sure that only the Android MiniClient supports HEVC. This also required a change the server so it would require a v9 server as well.

It is likely that HEVC support could be added to the full client with a minimal amount of effort, provided you are running v9.

What versions are you running?
Reply With Quote
  #3  
Old 01-10-2017, 09:05 AM
panteragstk's Avatar
panteragstk panteragstk is offline
SageTVaholic
 
Join Date: Oct 2008
Location: New Braunfels, TX
Posts: 3,312
Quote:
Originally Posted by stuckless View Post
I'm pretty sure that only the Android MiniClient supports HEVC. This also required a change the server so it would require a v9 server as well.

It is likely that HEVC support could be added to the full client with a minimal amount of effort, provided you are running v9.

What versions are you running?
Would you be able to disable tin internal mkv splitter to allow hevc to work? I know there is a registry setting to do this, but I'm pretty sure it breaks live TV or something along that line. I believe that splitter is shared among a few things.
__________________
SageTV Server: unRAID Docker v9, S2600CPJ, Norco 24 hot swap bay case, 2x Xeon 2670, 64 GB DDR3, 3x Colossus for DirecTV, HDHR for OTA
Living room: nVidia Shield TV, Sage Mini Client, 65" Panasonic VT60
Bedroom: Xiomi Mi Box, Sage Mini Client, 42" Panasonic PZ800u
Theater: nVidia Shield TV, mini client, Plex for movies, 120" screen. Mitsubishi HC4000. Denon X4300H. 7.4.4 speaker setup.
Reply With Quote
  #4  
Old 01-10-2017, 08:24 PM
skyeclad skyeclad is offline
Sage Aficionado
 
Join Date: Nov 2007
Location: NY DMA
Posts: 441
Quote:
Originally Posted by stuckless View Post
I'm pretty sure that only the Android MiniClient supports HEVC. This also required a change the server so it would require a v9 server as well.

It is likely that HEVC support could be added to the full client with a minimal amount of effort, provided you are running v9.

What versions are you running?
I'm still on version 7.
Reply With Quote
  #5  
Old 01-11-2017, 07:24 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,580
Quote:
Originally Posted by skyeclad View Post
I'm still on version 7.
I do know that for the Android MiniClient I had to make a small tweak to the server... so not sure how that impacts a full client.
Reply With Quote
  #6  
Old 01-11-2017, 07:46 AM
skyeclad skyeclad is offline
Sage Aficionado
 
Join Date: Nov 2007
Location: NY DMA
Posts: 441
I thought I read somewhere that if Sage uses directshow and all the filters have been set-up, it would be able to play an HEVC file. Clearly it's not looking like that's working for me.

I'll be upgrading to version 9 shortly as I'll need to for the guide data in the future.
Reply With Quote
  #7  
Old 03-18-2017, 12:27 PM
frontlinegeek frontlinegeek is offline
Sage Advanced User
 
Join Date: Sep 2007
Location: NB, Canada
Posts: 183
I am running into this same issue too. SageTV7 client and LAV and FFDShow and I can't get it to play back HEVC at all. Just errors with the same one in this post.

Kind of frustrating as I like to keep all my BluRays on the server and if I can move to HEVC for them, then this will be massive.

Anyone have some hot tips on this?

And as always, HEVC plays perfectly on VLC...
__________________
My contribution to the internet: https://www.youtube.com/user/frontlinegeek
Reply With Quote
  #8  
Old 03-18-2017, 02:53 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,580
Quote:
Originally Posted by frontlinegeek View Post
I am running into this same issue too. SageTV7 client and LAV and FFDShow and I can't get it to play back HEVC at all. Just errors with the same one in this post.

Kind of frustrating as I like to keep all my BluRays on the server and if I can move to HEVC for them, then this will be massive.

Anyone have some hot tips on this?

And as always, HEVC plays perfectly on VLC...
I think if upgrade to V9 HEVC might work. I recall having to do a small change to the server so that it wouldn't fail, and then it could pass it along to the client. This works on the Android MiniClient where I've tested it. I don't think that on V7 it's going work.
Reply With Quote
  #9  
Old 03-18-2017, 06:37 PM
frontlinegeek frontlinegeek is offline
Sage Advanced User
 
Join Date: Sep 2007
Location: NB, Canada
Posts: 183
OK. Good to know.

I do have a migration to V9 on plan as many of us do with the change to the guide data looming near. I won't kill myself fiddling till I have upgraded.
__________________
My contribution to the internet: https://www.youtube.com/user/frontlinegeek
Reply With Quote
  #10  
Old 03-20-2017, 06:33 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,375
Quote:
Originally Posted by frontlinegeek View Post
OK. Good to know.

I do have a migration to V9 on plan as many of us do with the change to the guide data looming near. I won't kill myself fiddling till I have upgraded.
Don't keep putting it off, it was way easier for the most part than I had feared. I installed it easily on my Win8.1 machine running V7 and last weekend upgraded a buddies machine to V9 from a WHS 2011 V7 installation.
Both of those went flawlessly and they were up and running within a few minutes. It took more time to update the plugins to their V9 versions than it did to run the installer and be back up and running.

I did have a heck of a time getting it to upgrade on my WHS V1 machine. In the end I'm pretty convinced it was due to the service add in to the WHS console from the SageTV V7 installation.
Bottom line, make sure SageTV and/or SageTV Service is shut down. Make a backup copy of your entire SageTV directory structure (including the commons folder). Worst case, if you can't get it to install just make sure all the SageTV stuff is shut down and copy your backups back into their original locations.
__________________
Wayne Dunham
Reply With Quote
  #11  
Old 03-21-2017, 05:24 AM
frontlinegeek frontlinegeek is offline
Sage Advanced User
 
Join Date: Sep 2007
Location: NB, Canada
Posts: 183
Quote:
Originally Posted by waynedunham View Post
Bottom line, make sure SageTV and/or SageTV Service is shut down. Make a backup copy of your entire SageTV directory structure (including the commons folder). Worst case, if you can't get it to install just make sure all the SageTV stuff is shut down and copy your backups back into their original locations.
Oh, I work in midrange computing. I back up EVERYTHING before messing with it

The only concern I have is what you pointed out. WHS. I am on WHS 2011 with V7 installed as if it is on WHS1. Should be interesting to say the least. I have done a V9 install for my cottage system but this will be the first upgrade.

I just wish all this codec business was not such a pain.
__________________
My contribution to the internet: https://www.youtube.com/user/frontlinegeek
Reply With Quote
  #12  
Old 03-21-2017, 10:46 AM
skyeclad skyeclad is offline
Sage Aficionado
 
Join Date: Nov 2007
Location: NY DMA
Posts: 441
I did got through with the upgrade to V9 but HEVC still doesn't work for me. I'll play around with it a little more because I have been transcoding my backups to HEVC to save space but have to launch an external player to watch anything.
Reply With Quote
  #13  
Old 03-21-2017, 11:04 AM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,857
Quote:
Originally Posted by skyeclad View Post
I did got through with the upgrade to V9 but HEVC still doesn't work for me. I'll play around with it a little more because I have been transcoding my backups to HEVC to save space but have to launch an external player to watch anything.
Do you have an HEVC capable codec installed and selected in Sage?
I'm not sure whether LAV supports HEVC or not. Also not sure how to let Sage know which filter to use (there are separate settings for MPEG2, h.264, and VC-1, but nothing for HEVC).
__________________
Server: Athlon II X4 630 CPU, Gigabyte MA770T-UD3P (AM3) Motherboard, VisionTek Radeon HD4670 PCIe w/ Component output to 50" CRT Rear-Projection HDTV (Mitsubishi), Win7-64Bit (Home Premium), 4GB RAM
Capture Devices (8 tuners): Colossus (x1), HD-PVR (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250
Reply With Quote
  #14  
Old 03-21-2017, 01:03 PM
skyeclad skyeclad is offline
Sage Aficionado
 
Join Date: Nov 2007
Location: NY DMA
Posts: 441
Quote:
Originally Posted by Tiki View Post
Do you have an HEVC capable codec installed and selected in Sage?
I'm not sure whether LAV supports HEVC or not. Also not sure how to let Sage know which filter to use (there are separate settings for MPEG2, h.264, and VC-1, but nothing for HEVC).
I do have LAV Encoders installed and use them for HEVC. Windows Media is capable of playing HEVC once I updated LAV settings to render HEVC with DXVA. I then told Sage to use Directshow defaults for any non-mpeg media type. Clearly this wasn't enough. Maybe there are some native splitters at place that aren't compatible.

Stuckless, what did you change on your server to allow the Android Mini Client to work?
Reply With Quote
  #15  
Old 03-21-2017, 01:07 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,580
Quote:
Originally Posted by skyeclad View Post
I do have LAV Encoders installed and use them for HEVC. Windows Media is capable of playing HEVC once I updated LAV settings to render HEVC with DXVA. I then told Sage to use Directshow defaults for any non-mpeg media type. Clearly this wasn't enough. Maybe there are some native splitters at place that aren't compatible.

Stuckless, what did you change on your server to allow the Android Mini Client to work?
I had to make code changes to server... I think it failing on detection because it didn't know what it was on the server... I did this change a long time ago, but it was code, not configuration, so staying on v7 for this won't be an option.
Reply With Quote
  #16  
Old 03-21-2017, 07:44 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,375
Quote:
Originally Posted by frontlinegeek View Post
Oh, I work in midrange computing. I back up EVERYTHING before messing with it

The only concern I have is what you pointed out. WHS. I am on WHS 2011 with V7 installed as if it is on WHS1. Should be interesting to say the least. I have done a V9 install for my cottage system but this will be the first upgrade.

I just wish all this codec business was not such a pain.
The machine I upgraded for my buddy was a WHS 2011 setup. When he upgraded to WHS 2011 he installed SageTV as per normal, and then just plopped his sage.properties and wiz.bin into that new install.
That upgrade went very well.
__________________
Wayne Dunham
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Video playback - H.265/HEVC mlcarson SageTV Software 8 11-06-2016 12:21 AM
HEVC video codec and keeping SageTV alive cat6man General Discussion 21 02-17-2016 11:04 AM
Capture error in playback Error LoopyWolf SageTV Software 2 12-08-2010 09:10 AM
Playback Error (-4,0x80040217) SAGE 6 Error dealsdyker SageTV Software 5 01-02-2007 08:02 AM
Playback Error Capture Error in playback: TheraEdge Hardware Support 2 02-07-2006 04:36 PM


All times are GMT -6. The time now is 08:24 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.