SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux > SageTV for unRAID/Docker

Notices

SageTV for unRAID/Docker Discussion related to SageTV for unRAID/Docker. Questions, issues, problems, suggestions, etc. relating to SageTV for unRAID/Docker should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-31-2017, 07:14 AM
dstanley's Avatar
dstanley dstanley is offline
Sage Aficionado
 
Join Date: Sep 2008
Location: LaHave, Nova Scotia, Canada
Posts: 276
Manual Comskip in Docker

Just noticed this error recorded in sagetv_0.txt when I try to manually run comskip on a recording from the SageTV UI:

Wed 5/31 9:04:59.186 [Fork-JREkiwi-616107@3db73520] Caused by: java.io.IOException: Cannot run program "/opt/sagetv/server/STVs/SageTV7/Externals/comskip.cmd" (in directory "/opt/sagetv/server/STVs/SageTV7/Externals"): error=13, Permission denied

Any ideas as to what may be happening and how to fix!?

Thanks,
Dwight
__________________
SERVER: Intel Core i7-3770 CPU @ 3.40GHz - UnRaid Server 6.8.0/DVB LibreELEC with Docker stuckless-sagetv-server-java9 MOTHERBOARD: ASRock-Z77 Extreme4 / 32GB RAM CACHE DRIVE: SSD 1TB ARRAY: 24TB/7 DRIVES PARITY: 8TB
EXTERNAL DEVICES: 4x HD-PVR's Firewire Channel Changing
TUNERS:NO LONGER RECORDING LIVETV
CLIENTS: 2xHD300 2xHD200 SONY ANDROIDTV MINI-CLIENT
Reply With Quote
  #2  
Old 05-31-2017, 07:27 AM
Fuzzy's Avatar
Fuzzy Fuzzy is offline
SageTVaholic
 
Join Date: Sep 2005
Location: Jurupa Valley, CA
Posts: 9,957
Quote:
Originally Posted by dstanley View Post
Just noticed this error recorded in sagetv_0.txt when I try to manually run comskip on a recording from the SageTV UI:

Wed 5/31 9:04:59.186 [Fork-JREkiwi-616107@3db73520] Caused by: java.io.IOException: Cannot run program "/opt/sagetv/server/STVs/SageTV7/Externals/comskip.cmd" (in directory "/opt/sagetv/server/STVs/SageTV7/Externals"): error=13, Permission denied

Any ideas as to what may be happening and how to fix!?

Thanks,
Dwight
It is trying to run a windows batch file - not going to work. I'm thinking you are using the old Comskip Playback plugin. I think the CommerciaDetecter UI contains some fixes for this. Try installing it and see if it launches properly.
__________________
Buy Fuzzy a beer! (Fuzzy likes beer)

unRAID Server: i7-6700, 32GB RAM, Dual 128GB SSD cache and 13TB pool, with SageTVv9, openDCT, Logitech Media Server and Plex Media Server each in Dockers.
Sources: HRHR Prime with Charter CableCard. HDHR-US for OTA.
Primary Client: HD-300 through XBoxOne in Living Room, Samsung HLT-6189S
Other Clients: Mi Box in Master Bedroom, HD-200 in kids room
Reply With Quote
  #3  
Old 05-31-2017, 09:51 AM
dstanley's Avatar
dstanley dstanley is offline
Sage Aficionado
 
Join Date: Sep 2008
Location: LaHave, Nova Scotia, Canada
Posts: 276
Running the current SageTV Docker in Unraid
- under plugins it says the Commercial Detector and Commercial Detector UI are both installed as well as Comskip Playback.
So not sure what else to try - no big deal but curious why it doesn't work for me ...

EDIT - Just noticed under installed plugins the Detector UI was disabled - will check that out!

This is the error I am getting now:
Code:
Wed 5/31 11:55:29.209 [EventRouter-ac220b89f45c@2c13eacc] processUserEvent-UserEvent[anything] evtTime=Wed 5/31 11:55:29.208
Wed 5/31 11:55:29.215 [EventRouter-ac220b89f45c@2c13eacc] CD: SystemStatus: Number running = 1
Wed 5/31 11:55:29.216 [EventRouter-ac220b89f45c@2c13eacc] CD: SystemStatus: Jobs running = 1
Wed 5/31 11:55:29.216 [EventRouter-ac220b89f45c@2c13eacc] CD: SystemStatus:   MediaFileID = 30882080
Wed 5/31 11:55:29.216 [EventRouter-ac220b89f45c@2c13eacc] CD: SystemStatus:   Title : Episode = House Hunters International : Seeking the Center In Frankfurt, Germany
Wed 5/31 11:55:29.216 [EventRouter-ac220b89f45c@2c13eacc] CD: SystemStatus: No jobs in queue.
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] CD: ComskipJob.executeComskipLinux: comskip failed with return code = 2
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] java.lang.Exception
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] 	at tmiranda.cd.Log.write(Log.java:64)
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] 	at tmiranda.cd.ComskipJob.executeComskipLinux(ComskipJob.java:386)
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] 	at tmiranda.cd.ComskipJob.executeComskip(ComskipJob.java:173)
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] 	at tmiranda.cd.ComskipJob.executeUsingDefault(ComskipJob.java:187)
Wed 5/31 11:55:29.221 [Thread-77@1deb8866] 	at tmiranda.cd.ComskipJob.run(ComskipJob.java:130)
Wed 5/31 11:55:29.222 [Thread-77@1deb8866] 	at java.lang.Thread.run(Thread.java:745)
Wed 5/31 11:55:29.222 [Thread-77@1deb8866] CD: ComskipJob.adjustJobTime: Null Times.
Wed 5/31 11:55:29.222 [Thread-77@1deb8866] CD: ComskipJob.updateRatio: Old, Current and new Ratios 0.07721863:3.888889E-6:0.06949715
__________________
SERVER: Intel Core i7-3770 CPU @ 3.40GHz - UnRaid Server 6.8.0/DVB LibreELEC with Docker stuckless-sagetv-server-java9 MOTHERBOARD: ASRock-Z77 Extreme4 / 32GB RAM CACHE DRIVE: SSD 1TB ARRAY: 24TB/7 DRIVES PARITY: 8TB
EXTERNAL DEVICES: 4x HD-PVR's Firewire Channel Changing
TUNERS:NO LONGER RECORDING LIVETV
CLIENTS: 2xHD300 2xHD200 SONY ANDROIDTV MINI-CLIENT

Last edited by dstanley; 05-31-2017 at 09:58 AM.
Reply With Quote
  #4  
Old 05-31-2017, 06:32 PM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,826
Go to the Plugin configuration for CommercialDetector and make sure you have selected the option to run comskip natively. It looks to me that it's trying to run comskip the old way.

If that doesn't work please post more of the log so I can see what happened leading up to the error.

Edit: See next post. When I wrote this I didn't notice you were trying to run comskip from the UI.
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.

Last edited by tmiranda; 05-31-2017 at 06:36 PM.
Reply With Quote
  #5  
Old 05-31-2017, 06:34 PM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,826
Quote:
Originally Posted by Fuzzy View Post
It is trying to run a windows batch file - not going to work. I'm thinking you are using the old Comskip Playback plugin. I think the CommerciaDetecter UI contains some fixes for this. Try installing it and see if it launches properly.
I don't think I ever updated the UI to make the "Run Comskip" button run comskip natively under Linux
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #6  
Old 06-01-2017, 04:33 AM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,518
Quote:
Originally Posted by tmiranda View Post
I don't think I ever updated the UI to make the "Run Comskip" button run comskip natively under Linux
It has been working for me in the SageTV Docker container.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with OpenDCT on Docker willieb SageTV for unRAID/Docker 5 03-07-2017 07:36 AM
How are you running ComSkip in unRaid/Docker setups with v9? mgpaulus SageTV v9 Customizations 5 01-22-2017 05:53 PM
SageTV Server Linux with Comskip for Docker (and unRAID) Support Thread stuckless SageTV for unRAID/Docker 409 10-10-2016 07:22 AM
NASs? Docker? ThePaladinTech SageTV Github Development 10 08-16-2015 02:34 PM
Comskip Manual Skip not working ThePaladinTech SageTV Customizations 0 10-04-2010 11:33 AM


All times are GMT -6. The time now is 04:42 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.