SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #61  
Old 12-23-2010, 11:37 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by freewheeling View Post
Is there a better place, or perhaps an app, that discovers the tuning parameters of an online channel? Allinternettv seems sort of clunky.
Yes its not the best and it also contains much internet tv that is flash based with no accessible stream URL.

If anyone knows a better one I can add it.

Adding new sources is essentially a config change.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #62  
Old 12-24-2010, 02:17 PM
tombailey tombailey is offline
Sage User
 
Join Date: Nov 2007
Posts: 41
Can't find user guide

Sorry for a dumb question but I can't find the user guide for this. I've installed the plugin in SageTV v7 and have the 2 new tuners but don't know how to add channels. To be utterly frank, I'm not sure about the functionality this plugin adds, but it sounds very interesting. I think the user guide would help me understand this but the KeepandShare page says the document no longer exists.
Thanks for any help.
Reply With Quote
  #63  
Old 12-24-2010, 02:31 PM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
User guide

HI,

I obviously mucked it up.

Heres the user guide.

http://www.keepandshare.com/doc/2464...m-2-8-meg?da=y

It also should be available locally on your server box e.g.

http://<your server name or localhost if its the machine you are on>:8888/

Internet radio channels with EPG and now playing text, available in extenders, web cams , ip cameras, internet tv, management of online services are what it adds.

You may want to look at the video:

http://www.youtube.com/watch?v=SX3vvly-OL8

Merry Christmas,

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer

Last edited by michaeldjcox; 12-24-2010 at 02:35 PM.
Reply With Quote
  #64  
Old 12-24-2010, 05:03 PM
tombailey tombailey is offline
Sage User
 
Join Date: Nov 2007
Posts: 41
Thanks

Thank you Michael, that's a big help. And thanks for creating this addition to Sage.

Merry Christmas to you too.
Tom Bailey
Reply With Quote
  #65  
Old 12-29-2010, 06:09 PM
SomeWhatLost's Avatar
SomeWhatLost SomeWhatLost is offline
Sage Expert
 
Join Date: Jan 2009
Location: earth
Posts: 525
ok, why can't I get to the WFE web page/config thingy?
I tried localhost:8888 and 192.168.1.80:8888 (from a different PC on the network) neither worked...
I tried changing the port to 8889 just in case... that didn't work either...
here is a funny bit of logging that don't look right... I think... actually I have no reference point for what is right, so I guess it could be ok
Code:
Dec 29, 2010 5:53:45 PM Thread-11 uk.co.mdjcox.utils.OsUtils$StreamConsumer run INFO: Stream consumer start.err terminating 
Dec 29, 2010 5:53:45 PM SageTV uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Result is 0 for cmd.exe /c "C:\Program Files\SageTV\SageTV\webfeedencoder\wrapper\WebFeedEncoder.bat" start
Dec 29, 2010 5:53:45 PM SageTV uk.co.mdjcox.utils.WrapperUtils wrapperOperation INFO: Result is 0
Dec 29, 2010 5:53:56 PM Thread-14 uk.co.mdjcox.encoderplugin.EncoderPlugin$3 run SEVERE: Failed to send lineup to SageTV
java.rmi.ConnectException: Connection refused to host: localhost; nested exception is: 
	java.net.ConnectException: Connection refused: connect
	at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
	at sun.rmi.server.UnicastRef.newCall(Unknown Source)
	at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at uk.co.mdjcox.utils.RmiHelper.lookup(RmiHelper.java:154)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.getConfigDb(EncoderPlugin.java:285)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.access$300(EncoderPlugin.java:30)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin$3.run(EncoderPlugin.java:1353)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(Unknown Source)
	at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
	at java.net.PlainSocketImpl.connect(Unknown Source)
	at java.net.SocksSocketImpl.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown Source)
	at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown Source)
	... 11 more
Dec 29, 2010 5:53:58 PM Thread-14 uk.co.mdjcox.encoderplugin.EncoderPlugin$3 run SEVERE: Failed to send online services to SageTV
java.rmi.ConnectException: Connection refused to host: localhost; nested exception is: 
	java.net.ConnectException: Connection refused: connect
	at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
	at sun.rmi.server.UnicastRef.newCall(Unknown Source)
	at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at uk.co.mdjcox.utils.RmiHelper.lookup(RmiHelper.java:154)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.getConfigDb(EncoderPlugin.java:285)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.access$300(EncoderPlugin.java:30)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin$3.run(EncoderPlugin.java:1359)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(Unknown Source)
	at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
	at java.net.PlainSocketImpl.connect(Unknown Source)
	at java.net.SocksSocketImpl.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown Source)
	at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown Source)
	... 11 more
Dec 29, 2010 5:53:59 PM Thread-14 uk.co.mdjcox.encoderplugin.EncoderPlugin$3 run SEVERE: Failed to update EPG
java.rmi.ConnectException: Connection refused to host: localhost; nested exception is: 
	java.net.ConnectException: Connection refused: connect
	at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
	at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
	at sun.rmi.server.UnicastRef.newCall(Unknown Source)
	at sun.rmi.registry.RegistryImpl_Stub.lookup(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at uk.co.mdjcox.utils.RmiHelper.lookup(RmiHelper.java:154)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.getConfigDb(EncoderPlugin.java:285)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin.access$300(EncoderPlugin.java:30)
	at uk.co.mdjcox.encoderplugin.EncoderPlugin$3.run(EncoderPlugin.java:1365)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(Unknown Source)
	at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
	at java.net.PlainSocketImpl.connect(Unknown Source)
	at java.net.SocksSocketImpl.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.connect(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at java.net.Socket.<init>(Unknown Source)
	at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown Source)
	at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown Source)
	... 11 more
can anyone offer any insight into what is wrong?
__________________
NOTE: As one wise professional something once stated, I am ignorant & childish, with a mindset comparable to 9/11 troofers and wackjob conspiracy theorists. so don't take anything I say as advice...
Reply With Quote
  #66  
Old 12-29-2010, 06:23 PM
SomeWhatLost's Avatar
SomeWhatLost SomeWhatLost is offline
Sage Expert
 
Join Date: Jan 2009
Location: earth
Posts: 525
well, I guess things are worse than I thought...
should the wrapper log say:
Code:
ERROR  | wrapper  | 2010/12/29 17:53:16 | The WebFeedEncoder service is not installed - The specified service does not exist as an installed service. (0x424)
ERROR  | wrapper  | 2010/12/29 17:53:16 | The WebFeedEncoder service is not installed - The specified service does not exist as an installed service. (0x424)
STATUS | wrapper  | 2010/12/29 17:53:16 | Web Feed Encoder installed.
STATUS | wrapper  | 2010/12/29 17:53:43 | Starting the Web Feed Encoder service...
STATUS | wrapper  | 2010/12/29 17:53:43 | --> Wrapper Started as Service
STATUS | wrapper  | 2010/12/29 17:53:43 | Java Service Wrapper Community Edition 3.3.3
STATUS | wrapper  | 2010/12/29 17:53:43 |   Copyright (C) 1999-2009 Tanuki Software, Ltd.  All Rights Reserved.
STATUS | wrapper  | 2010/12/29 17:53:43 |     http://wrapper.tanukisoftware.org
STATUS | wrapper  | 2010/12/29 17:53:43 | 
STATUS | wrapper  | 2010/12/29 17:53:44 | Launching a JVM...
FATAL  | wrapper  | 2010/12/29 17:53:44 | Unable to execute Java command.  The system cannot find the file specified. (0x2)
FATAL  | wrapper  | 2010/12/29 17:53:44 |     "java" -Xms64m -Xmx256m -Djava.library.path="." -classpath "wrapper.jar;../libs/encoder.jar" -Dwrapper.key="IzXyk9BH11PTJDtp" -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=3524 -Dwrapper.version="3.3.3" -Dwrapper.native_library="wrapper" -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="10" -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp uk.co.mdjcox.webfeedencoder.Encoder
FATAL  | wrapper  | 2010/12/29 17:53:44 | Critical error: wait for JVM process failed
ERROR  | wrapper  | 2010/12/29 17:53:45 | The Web Feed Encoder service was launched, but failed to start.
that seems kind of, well, bad...
__________________
NOTE: As one wise professional something once stated, I am ignorant & childish, with a mindset comparable to 9/11 troofers and wackjob conspiracy theorists. so don't take anything I say as advice...
Reply With Quote
  #67  
Old 12-29-2010, 09:00 PM
robogeek robogeek is offline
Sage Expert
 
Join Date: Apr 2003
Location: Appleton, WI USA
Posts: 561
Quote:
Originally Posted by SomeWhatLost View Post
well, I guess things are worse than I thought...
should the wrapper log say:
Code:
ERROR  | wrapper  | 2010/12/29 17:53:16 | The WebFeedEncoder service is not installed - The specified service does not exist as an installed service. (0x424)
ERROR  | wrapper  | 2010/12/29 17:53:16 | The WebFeedEncoder service is not installed - The specified service does not exist as an installed service. (0x424)
STATUS | wrapper  | 2010/12/29 17:53:16 | Web Feed Encoder installed.
STATUS | wrapper  | 2010/12/29 17:53:43 | Starting the Web Feed Encoder service...
STATUS | wrapper  | 2010/12/29 17:53:43 | --> Wrapper Started as Service
STATUS | wrapper  | 2010/12/29 17:53:43 | Java Service Wrapper Community Edition 3.3.3
STATUS | wrapper  | 2010/12/29 17:53:43 |   Copyright (C) 1999-2009 Tanuki Software, Ltd.  All Rights Reserved.
STATUS | wrapper  | 2010/12/29 17:53:43 |     http://wrapper.tanukisoftware.org
STATUS | wrapper  | 2010/12/29 17:53:43 | 
STATUS | wrapper  | 2010/12/29 17:53:44 | Launching a JVM...
FATAL  | wrapper  | 2010/12/29 17:53:44 | Unable to execute Java command.  The system cannot find the file specified. (0x2)
FATAL  | wrapper  | 2010/12/29 17:53:44 |     "java" -Xms64m -Xmx256m -Djava.library.path="." -classpath "wrapper.jar;../libs/encoder.jar" -Dwrapper.key="IzXyk9BH11PTJDtp" -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=3524 -Dwrapper.version="3.3.3" -Dwrapper.native_library="wrapper" -Dwrapper.service="TRUE" -Dwrapper.cpu.timeout="10" -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp uk.co.mdjcox.webfeedencoder.Encoder
FATAL  | wrapper  | 2010/12/29 17:53:44 | Critical error: wait for JVM process failed
ERROR  | wrapper  | 2010/12/29 17:53:45 | The Web Feed Encoder service was launched, but failed to start.
that seems kind of, well, bad...
Looks like WFE can't find your Java executable. Are you running Windows Home Server? If so, you could manually install Java from java.com and it should start working (may need to reboot first). Alternatively, if using Windows Home Server, you can find the path to the folder where the Java executable is (somewhere in the SageTV\jre folder) and add that folder path to the PATH Windows environment variable.
__________________
--Jason

Server Hardware: GIGABYTE GA-EP45-UD3R, Intel Q9550 CPU 3.2GHz, 11GB RAM, 1xHDHR, 1xHVR1600, 1xHVR2250
29TB Server Storage: 1TB SSD (OS), 1TB (data), 2x6TB+2x10TB (22TB FlexRaid storage pool), 2x2TB (recordings), 1x750GB (VMs).
Server Software: Win10 Pro x64 OS, SageTV 64bit v9.2.0.441, Java 1.8 u201, PlayOn, Comskip (Donator) v0.82.003, WampServer v2.5.
Clients: 3xHD300s, 2xHD100, 2xPlaceshifters
Reply With Quote
  #68  
Old 12-30-2010, 02:31 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by robogeek View Post
Looks like WFE can't find your Java executable. Are you running Windows Home Server? If so, you could manually install Java from java.com and it should start working (may need to reboot first). Alternatively, if using Windows Home Server, you can find the path to the folder where the Java executable is (somewhere in the SageTV\jre folder) and add that folder path to the PATH Windows environment variable.
Yes agree with Jason - WFE cannot start because java cannot be found.

Must be there somewhere right - SageTV is using it.

The other exceptions posted earlier are just the plugin component looking for the web feed encoder service and not finding it.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #69  
Old 12-30-2010, 12:57 PM
SomeWhatLost's Avatar
SomeWhatLost SomeWhatLost is offline
Sage Expert
 
Join Date: Jan 2009
Location: earth
Posts: 525
yes it is WHS, and no, if you type java at the command prompt you get nothing...
so this sounds like it is the issue...
any idea where WHS hides the Java install? sage found it, so it must be somewhere...
__________________
NOTE: As one wise professional something once stated, I am ignorant & childish, with a mindset comparable to 9/11 troofers and wackjob conspiracy theorists. so don't take anything I say as advice...
Reply With Quote
  #70  
Old 12-30-2010, 01:31 PM
gplasky's Avatar
gplasky gplasky is offline
SageTVaholic
 
Join Date: Jul 2003
Location: Howell, MI
Posts: 9,201
Look in the SageTV directory for a directory called jre.

Gerry
__________________
Big Gerr
_______
Server - WHS 2011: Sage 7.1.9 - 1 x HD Prime and 2 x HDHomeRun - Intel Atom D525 1.6 GHz, Acer Easystore, RAM 4 GB, 4 x 2TB hotswap drives, 1 x 2TB USB ext Clients: 2 x PC Clients, 1 x HD300, 2 x HD-200, 1 x HD-100 DEV Client: Win 7 Ultimate 64 bit - AMD 64 x2 6000+, Gigabyte GA-MA790GP-DS4H MB, RAM 4GB, HD OS:500GB, DATA:1 x 500GB, Pace RGN STB.
Reply With Quote
  #71  
Old 12-30-2010, 03:36 PM
wayner wayner is offline
SageTVaholic
 
Join Date: Jan 2008
Location: Toronto, ON
Posts: 6,546
What's the recommended VLC version to run with WFE - is it still 1.0.5? I just installed 1.1.5 on one of my PCs - I guess that was a bad idea?
__________________
New Server - Sage9 on unRAID 2xHD-PVR, HDHR for OTA
Old Server - Sage7 on Win7Pro-i660CPU with 4.6TB, HD-PVR, HDHR OTA, HVR-1850 OTA
Clients - 2xHD-300, 8xHD-200 Extenders, Client+2xPlaceshifter and a WHS which acts as a backup Sage server
Reply With Quote
  #72  
Old 12-30-2010, 10:09 PM
SomeWhatLost's Avatar
SomeWhatLost SomeWhatLost is offline
Sage Expert
 
Join Date: Jan 2009
Location: earth
Posts: 525
Quote:
Originally Posted by gplasky View Post
Look in the SageTV directory for a directory called jre.

Gerry
yep, there it was... almost... well kinda... sorta... there was only a java-rmi.exe, no just plain java.exe... so I copied java-rmi.exe and renamed it to java.exe and that seems to work...

now on to the next problem... how do I get it to play something? note, by something, I mean video... podcasts seem to work just fine...
I tried NASA just cause I saw somewhere in one of the WFE threads that nasa should work, but looking at the log it says:
Code:
lua debug: Trying Lua playlist script C:\Program Files\VideoLAN\VLC\\lua\playlist\youtube_homepage.lua
lua debug: Trying Lua scripts in C:\Program Files\VideoLAN\VLC\\share\lua\playlist
avformat debug: couldn't guess format
vobsub debug: this doesn't seem to be a vobsub file
ps warning: this does not look like an MPEG PS stream, continuing anyway
main debug: using demux module "ps"
main debug: TIMER module_need() : 106.000 ms - Total 106.000 ms / 1 intvls (Avg 106.000 ms)
main debug: looking for a subtitle file in C:\Program Files\SageTV\SageTV\webfeedencoder\wrapper\
main debug: starting in sync mode
main debug: `http://www.youtube.com/NASATelevision' successfully opened
ps warning: garbage at input, trying to resync...
main debug: EOF reached
main debug: finished input
main debug: removing module "ps"
main debug: waitpipe: object killed
main debug: removing module "stream_filter_record"
main debug: removing module "access_http"
main debug: thread ended
main debug: dead input
main debug: destroying useless sout
I like this part: destroying useless sout WFE is such a violent plug in...

why is nasa going to youtube? I thought I read somewhere that WFE didn't like flash videos? or VLC didn't like flash? well I am pretty sure somebody didn't like flash...

could someone give me some pointers on what to try to get video to work?
is there a known good video feed I should be trying to debug with?
__________________
NOTE: As one wise professional something once stated, I am ignorant & childish, with a mindset comparable to 9/11 troofers and wackjob conspiracy theorists. so don't take anything I say as advice...
Reply With Quote
  #73  
Old 12-31-2010, 04:22 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by SomeWhatLost View Post
yep, there it was... almost... well kinda... sorta... there was only a java-rmi.exe, no just plain java.exe... so I copied java-rmi.exe and renamed it to java.exe and that seems to work...
hmmmm. Odd a jre normally contains a java.exe.

Quote:
Originally Posted by SomeWhatLost View Post
now on to the next problem... how do I get it to play something? note, by something, I mean video... podcasts seem to work just fine...
I tried NASA just cause I saw somewhere in one of the WFE threads that nasa should work, but looking at the log it says:
I like this part: destroying useless sout WFE is such a violent plug in...
Thats VLCs output in super verbose mode - I take no reponsibility for that :-)

Quote:
Originally Posted by SomeWhatLost View Post
why is nasa going to youtube? I thought I read somewhere that WFE didn't like flash videos? or VLC didn't like flash? well I am pretty sure somebody didn't like flash...
The Nasa feed is my most reliable feed I use for testing.

There are several ways to get to it. YouTube being one of them.

The URL offered by allinternettv is useless.

The sample channel I provide in the WFE distribution has a working URL:

http://playlist.yahoo.com/makeplaylist.dll?id=1368163

this also works:

http://www.nasa.gov/55644main_NASATV_Windows.asx

Using the config tool you can edit your existing Nasa channel and paste in the new URL into the "Tune URL" field.

Or you can delete your channel and choose File->Use Sample and select NASATV to use the working set up I test with.

Any further problems let me know.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #74  
Old 01-01-2011, 01:46 PM
deepz deepz is offline
New Member
 
Join Date: Dec 2010
Posts: 4
Thumbs up Can't get any station in guide ?

Hello thanks again for this good plug-in I'm not far to get it going.

i installed via the online installer for ver7 and got config tool ok
both sage en encoder green ok and get error on send epg to sage

Code:
1 janv. 2011 14:36:18 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder main INFO: Loading lib
1 janv. 2011 14:36:18 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder main INFO: Loading library C:\Program Files\SageTV\SageTV\webfeedencoder\libs\dsj.dll
1 janv. 2011 14:36:18 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder startup INFO: Web feed network encoder starting
1 janv. 2011 14:36:18 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder startup INFO: Version: 0.9.7 (400)
1 janv. 2011 14:36:18 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type allinternettv plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type audiodevice plugin=uk.co.mdjcox.configdb.AudioDeviceSeedPlugin
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type device plugin=uk.co.mdjcox.configdb.AudioVisualDeviceSeedPlugin
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type onlinefiles plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\onlinefiles.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type onlinepodcastdirectory plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type onlineservices plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\onlineservices.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type radio plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\radio.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type radiotime plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type tv plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\tv.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type tvmpeg plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\tvmpeg.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels INFO: Loading type tvsilent plugin=null
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb loadAllChannels ATTENTION: Cannot find seedsite config file C:\Program Files\SageTV\SageTV\webfeedencoder\seedsites\tvsilent.props
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb getImages INFO: 
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb getImages INFO: Caching image for France24
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb getImages INFO: Logo exists 
1 janv. 2011 14:36:19 WrapperSimpleAppMain uk.co.mdjcox.configdb.ConfigDb getImages INFO: Video image exists - do nothing
1 janv. 2011 14:36:20 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder startServer INFO: Starting management server (listening on port 1099)
1 janv. 2011 14:36:21 TuningThread uk.co.mdjcox.webfeedencoder.TuningThread listenForConnections INFO: WebFeedEncoder-0 Starting Tuning Thread (listening on port 5000)
1 janv. 2011 14:36:21 GrabberThread uk.co.mdjcox.webfeedencoder.GrabberThread run INFO: Starting EPG grabber thread
1 janv. 2011 14:36:21 TuningThread uk.co.mdjcox.webfeedencoder.TuningThread listenForConnections INFO: WebFeedEncoder-1 Starting Tuning Thread (listening on port 5001)
1 janv. 2011 14:36:21 GrabberThread uk.co.mdjcox.webfeedencoder.GrabberThread run INFO: Waiting for next EPG grab at Sun Jan 02 05:00:00 EST 2011
1 janv. 2011 14:36:21 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.PodcastServer start INFO: Starting the podcast server on port 8888
1 janv. 2011 14:36:21 WrapperSimpleAppMain uk.co.mdjcox.webfeedencoder.Encoder wakeupSageTv INFO: Looking for service //localhost:1100/EpgPlugin
1 janv. 2011 14:36:40 TuningThread uk.co.mdjcox.webfeedencoder.TuningThread listenForConnections INFO: WebFeedEncoder-0 Accepted connection
1 janv. 2011 14:36:40 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread run INFO: WebFeedEncoder-0 Connection Thread[ConnectionThread-WebFeedEncoder-0-14726901,5,main] encoding is Cp1252
1 janv. 2011 14:36:40 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-0 Command: VERSION
1 janv. 2011 14:36:40 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-0 Answer: 2.1
1 janv. 2011 14:36:41 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-0 Command: NOOP
1 janv. 2011 14:36:41 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-0 Answer: OK
1 janv. 2011 14:36:41 TuningThread uk.co.mdjcox.webfeedencoder.TuningThread listenForConnections INFO: WebFeedEncoder-1 Accepted connection
1 janv. 2011 14:36:41 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread run INFO: WebFeedEncoder-1 Connection Thread[ConnectionThread-WebFeedEncoder-1-12888787,5,main] encoding is Cp1252
1 janv. 2011 14:36:41 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-1 Command: VERSION
1 janv. 2011 14:36:41 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-1 Answer: 2.1
1 janv. 2011 14:36:42 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-1 Command: NOOP
1 janv. 2011 14:36:42 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-1 Answer: OK
1 janv. 2011 14:36:42 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-0 Command: NOOP
1 janv. 2011 14:36:42 ConnectionThread-WebFeedEncoder-0-14726901 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-0 Answer: OK
1 janv. 2011 14:36:43 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread process INFO: WebFeedEncoder-1 Command: NOOP
1 janv. 2011 14:36:43 ConnectionThread-WebFeedEncoder-1-12888787 uk.co.mdjcox.webfeedencoder.ConnectionThread answer INFO: WebFeedEncoder-1 Answer: OK
1 janv. 2011 14:37:05 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.configdb.ConfigDb sendLineupToSage GRAVE: Could not update sageTV
java.net.MalformedURLException: invalid authority: //pc_antonio:1100/EpgPlugin
	at java.rmi.Naming.intParseURL(Unknown Source)
	at java.rmi.Naming.parseURL(Unknown Source)
	at java.rmi.Naming.lookup(Unknown Source)
	at uk.co.mdjcox.utils.RmiHelper.lookup(RmiHelper.java:154)
	at uk.co.mdjcox.epgplugin.EpgPluginClient.<init>(EpgPluginClient.java:29)
	at uk.co.mdjcox.epgplugin.EpgPluginClient.instance(EpgPluginClient.java:24)
	at uk.co.mdjcox.configdb.ConfigDb.getSageTv(ConfigDb.java:460)
	at uk.co.mdjcox.configdb.ConfigDb.sendLineupToSage(ConfigDb.java:432)
	at uk.co.mdjcox.configdb.ConfigDb.sendLineupToSage(ConfigDb.java:557)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at sun.rmi.server.UnicastServerRef.dispatch(Unknown Source)
	at sun.rmi.transport.Transport$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.rmi.transport.Transport.serviceCall(Unknown Source)
	at sun.rmi.transport.tcp.TCPTransport.handleMessages(Unknown Source)
	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(Unknown Source)
	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildChannels INFO: Adding channel 1 France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: Processing channel 1 France 24of type uk.co.mdjcox.webepggrabber.GrabberDefault
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110101050000 +0000	20110102050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110102050000 +0000	20110103050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110103050000 +0000	20110104050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110104050000 +0000	20110105050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110105050000 +0000	20110106050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110106050000 +0000	20110107050000 +0000	24.0hrs	France 24	France 24
1 janv. 2011 14:37:07 RMI TCP Connection(4)-192.168.1.151 uk.co.mdjcox.webepggrabber.Grabber buildProgrammes INFO: 20110107050000 +0000	20110108050000 +0000	24.0hrs	France 24	France 24

Code:
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.epgplugin.EpgPlugin <init> INFO: Initialising webfeedencoder EPG plugin
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.epgplugin.EpgPlugin <init> INFO: Read sage properties
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Spawn cacls "C:\Program Files\SageTV\SageTV\ChannelLogos" /T /g Everyone:F
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Env=
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Command=[cacls, "C:\Program Files\SageTV\SageTV\ChannelLogos", /T, /g, Everyone:F]
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils captureStreams INFO: Setting up streams for setPermission
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Entering proc waitfor cacls "C:\Program Files\SageTV\SageTV\ChannelLogos" /T /g Everyone:F
1 janv. 2011 14:36:32 Thread-8 uk.co.mdjcox.utils.OsUtils$StreamConsumer run INFO: setPermission.err: Le mappage entre les noms de compte et les ID de s‚curit‚ n'a pas ‚t‚ effectu‚.
1 janv. 2011 14:36:32 Thread-8 uk.co.mdjcox.utils.OsUtils$StreamConsumer run INFO: setPermission.err: 
1 janv. 2011 14:36:32 Thread-8 uk.co.mdjcox.utils.OsUtils$StreamConsumer run INFO: Stream consumer setPermission.err terminating 
1 janv. 2011 14:36:32 Thread-9 uk.co.mdjcox.utils.OsUtils$StreamConsumer run INFO: Stream consumer setPermission.out terminating 
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Exiting proc waitfor cacls "C:\Program Files\SageTV\SageTV\ChannelLogos" /T /g Everyone:F
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.utils.OsUtils spawnProcess INFO: Result is 1332 for cacls "C:\Program Files\SageTV\SageTV\ChannelLogos" /T /g Everyone:F
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.epgplugin.EpgPlugin <init> INFO: WebFeedEncoder Directory = C:\Program Files\SageTV\SageTV\webfeedencoder\
1 janv. 2011 14:36:32 Thread-7 uk.co.mdjcox.epgplugin.EpgPlugin <init> INFO: Instatiating existing plugin uk.co.mdjcox.epgplugin.EpgPlugin

java.net.MalformedURLException: invalid authority: //pc_antonio:1100/EpgPlugin

and http://192.168.1.151:8888/ is running

no channel in guide and no other epg plug-in


any ideas ?

Thank's

Last edited by deepz; 01-01-2011 at 01:49 PM.
Reply With Quote
  #75  
Old 01-02-2011, 06:39 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by wayner View Post
What's the recommended VLC version to run with WFE - is it still 1.0.5? I just installed 1.1.5 on one of my PCs - I guess that was a bad idea?

Yeah 1.0.5.

With VLC 1.1.5 vlc.exe won't respond to remote commands, the aspect ratio is wrong, theres no sound on the PC, there no detectible support on the VLC forums.

Those VLC folks drive me crazy always breaking and changing stuff.

I had to do a major rewrite going from 0.9 to 1.0 and I do not yet have solutions for all the issues going from 1.0 to 1.1.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #76  
Old 01-02-2011, 06:46 AM
michaeldjcox michaeldjcox is offline
Sage Fanatic
 
Join Date: Nov 2006
Location: Ipswich, Suffolk, United Kingdom
Posts: 823
Quote:
Originally Posted by deepz View Post
any ideas ?
Very curious.

Could you run up the config tool please and under the help menu choose "Send Logs".

That should send me enough diagnostics.

Michael
__________________
Web Feed Encoder developer
SageTV Catchup developer
Reply With Quote
  #77  
Old 01-02-2011, 07:32 AM
dkopp dkopp is offline
Sage User
 
Join Date: Jan 2010
Posts: 13
I have the same issue as deepz, when I tried to "send logs" I get an error. Attached are the shots of the errors.

FYI: great job I look forward to using it.
Attached Images
File Type: png Capture.PNG (9.2 KB, 100 views)
File Type: png Capture2.PNG (84.9 KB, 97 views)
Reply With Quote
  #78  
Old 01-02-2011, 09:12 AM
deepz deepz is offline
New Member
 
Join Date: Dec 2010
Posts: 4
Smile logs send

i get the same error as dkopp when trying to send logs

so i zipped the lods dir in attachment here. for info i'm using vlc 1.05

tank-you and happy new year
Attached Files
File Type: zip logs.zip (91.2 KB, 84 views)
Reply With Quote
  #79  
Old 01-02-2011, 10:07 AM
robogeek robogeek is offline
Sage Expert
 
Join Date: Apr 2003
Location: Appleton, WI USA
Posts: 561
@deepz & dkopp,

I think I see the common denominator here... It looks like a bug in Java regarding the usage of the underscore character in your hostnames. The bug is documented here:

http://bugs.sun.com/bugdatabase/view...bug_id=6587184

Try renaming your PCs by replacing the underscore with a dash and see if that works.

<edit>
If you change the PC name, here is how I'd do it:
First, change the name in Windows Control Panel. Then be sure to stop SageTV, and do a search-and-replace on your sage.properties file to change any UNC pathnames to match the new server name. You may also need to do this on the client properties file if running the client on the server machine and also for any .properties files in the SageTV\clients directory.
</edit>
__________________
--Jason

Server Hardware: GIGABYTE GA-EP45-UD3R, Intel Q9550 CPU 3.2GHz, 11GB RAM, 1xHDHR, 1xHVR1600, 1xHVR2250
29TB Server Storage: 1TB SSD (OS), 1TB (data), 2x6TB+2x10TB (22TB FlexRaid storage pool), 2x2TB (recordings), 1x750GB (VMs).
Server Software: Win10 Pro x64 OS, SageTV 64bit v9.2.0.441, Java 1.8 u201, PlayOn, Comskip (Donator) v0.82.003, WampServer v2.5.
Clients: 3xHD300s, 2xHD100, 2xPlaceshifters

Last edited by robogeek; 01-02-2011 at 10:12 AM.
Reply With Quote
  #80  
Old 01-02-2011, 11:18 AM
deepz deepz is offline
New Member
 
Join Date: Dec 2010
Posts: 4
Quote:
I think I see the common denominator here
are the two same screen shot.

Ill try renaming the hostname , tank's for advice
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Utility: Web Radio and TV Encoder michaeldjcox SageTV Customizations 857 03-06-2016 09:59 AM
Plugin: SageTV Web Interface V2 for Jetty jreichen SageTV Customizations 256 02-09-2014 08:05 AM
Web Radio and TV encoder Announcement Thread michaeldjcox Customization Announcements 6 12-10-2010 03:56 PM
SageTV and web radio michaeldjcox SageTV Customizations 3 12-01-2008 11:09 AM
STV Import: Web Radio Plugin for SageMC v1.1b 7/31/06 Morgan111 SageMC Custom Interface 90 03-24-2008 08:17 AM


All times are GMT -6. The time now is 03:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.