SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-20-2019, 08:10 PM
hoosierengineer hoosierengineer is offline
Sage User
 
Join Date: Aug 2007
Posts: 18
Question CPU choice to stop SageTV Client from crashing

SageTV client crashes about every 100 or 1000 times I fast forward or rewind from my remote control. Up until a number of months ago, this required a restart of Windows (10) to get Sage functioning again. After a series of updates from Microsoft, it still crashes, but I can just re-launch Sage and all is well.

Now, it's time to upgrade my client machine. Has anybody experienced this problem and found a solution (I am hoping it is specific to my processor choice, I7-7700)?

At one point years ago I had built an AMD system, which did not crash, but 'locked up' for around 30 seconds every other time I used FF/RW. Perhaps it's time to move back to AMD?
Reply With Quote
  #2  
Old 01-20-2019, 08:46 PM
JustFred JustFred is online now
Sage Aficionado
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 367
Are you using the built-in graphics on the motherboard? If so, the crashes might be related to a known memory leak in many versions of the Intel graphics driver. Crashes more often when hardware acceleration is used. Especially obnoxious on Win10, which frequently updates the driver with another buggy driver. Possible solution and discussion. Please report back if this helps.
__________________
System #1: Win7-64, Core2-Quad Q9400, 8 GB Mem, 4TB HD. Java 1.8.0_131. Sage v9.1.6.747. ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB Mem, 1.5TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB Mem, 4TB HD. Java 1.8.0_131. Sage v9.1.6.747. ATSC: HVR2250; Time Warner Cable via HDPVR & USB-UIRT. 3x HD-200.
Reply With Quote
  #3  
Old 01-21-2019, 09:26 AM
belleaudb belleaudb is offline
Sage User
 
Join Date: Aug 2008
Posts: 49
You don't need a brand new high end CPU.

I'm playing back 4K HEVC videos without issues on a 4 year old Dell with Core i5 4460 processor and GTX 1050 video card.
Reply With Quote
  #4  
Old 03-03-2019, 02:38 AM
Galaxysurfer Galaxysurfer is offline
Sage Advanced User
 
Join Date: Jun 2009
Location: Calgary, AB CANADA
Posts: 229
If your client has an intel chip you need to go to intel website to download updates. https://downloadcenter.intel.com/ It can scan your setup to find the right drivers needed. As of Nov 2018 windows update will no longer take care of Intel drivers etc. I had to do that for my client.
I use an Asus Vivo MiniPC VM42 with Celeron CPU & a Minix air mouse for remote. It is similiar to a Nuc with Intel graphics chip. Once I got drivers updated, I also did a reinstall of win 10 & now everything runs great hooked up to the big tv in livingroom. I had issues before with my client but they were related to my network settings. I have a wifi router setup with vpn & Eset for Firewall & AV on Win 10. ( I prefer 3rd party control since I don't trust Microsoft & it allows me to block some of the unwanted phoning home.) I will admit playback isn't great when I have multiple tunners recording at the same time. Otherwise, it is sufficient for my needs.

Last edited by Galaxysurfer; 03-03-2019 at 02:47 AM.
Reply With Quote
  #5  
Old 03-03-2019, 07:26 PM
hoosierengineer hoosierengineer is offline
Sage User
 
Join Date: Aug 2007
Posts: 18
I got an error when trying to install the drivers, "Oops, something went wrong while trying to scan. Please try again, or see our FAQs for help". The FAQs are too general to be of any assistance. If I try to re-install the software, it asks me if I want to remove the program. Into the deep end I go...

...Software seemed to uninstall itself. Re-installed, and all seems well now, for the present... It found my motherboard (manufacturer and model), and is downloading...

Last edited by hoosierengineer; 03-03-2019 at 07:32 PM.
Reply With Quote
  #6  
Old 03-05-2019, 03:55 PM
hoosierengineer hoosierengineer is offline
Sage User
 
Join Date: Aug 2007
Posts: 18
Talking

Eureka!

Some time in the (fairly) recent past, SageTV MPEG Video Decoder became capable of displaying Captions. Using this decoder (possibly only with captions enabled) resulted in SageTV Crashing and Burning (or, more likely, Windows), requiring a reboot (re-launching Sage would result in the remote control being inoperable, as I recall). Some time in the more recent past, SageTV would not Crash and Burn, but simply Crash (re-launching Sage would then result in normal behavior). I suspect this was the result of a Microsoft 'push' of a Windows 10 update, I have no way to tell.

One of my clients was configured for the Video/Audio > MPEG2 Video Decoder Filter as SageTV MPEG Video Decoder with Video Render > Enhanced Video Renderer (EVR). This one crashed SageTV (no burning) randomly when FastForward or Rewind was pressed - on one occasion, twice in a row, more commonly once every 100-1000 attempts.

Another of my clients is configured with MPEG2 Video Decoder Filter as SageTV MPEG Video Decoder Filter, which properly displays captions. Setting Video Renderer to DirectX9 Video Mixing Renderer (VMR9) results in Crashless Viewing

Over the years, as SageTV has supported more features (e.g. CC), they only asked for money once, so I can't complain (I got what I was promised). Now, all seems to be working flawlessly

Now, let's see if it will play a blu-ray...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just upgraded from v7 to v9. Client crashing now valnar SageTV Github Development 9 04-19-2017 11:05 AM
Sage Windows client crashing on playback mgpaulus SageTV Beta Test Software 1 04-17-2011 04:21 PM
Sage Client Crashing to Desktop Skirge01 SageMC Custom Interface 0 05-18-2009 09:14 PM
Client Crashing Steve52 SageTV Software 3 10-06-2008 04:54 PM
Saget TV Client now crashing all the time edgley SageTV Software 0 09-27-2004 03:45 AM


All times are GMT -6. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.