SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Linux

Notices

SageTV Linux Discussion related to the SageTV Media Center for Linux. Questions, issues, problems, suggestions, etc. relating to the SageTV Linux should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-21-2014, 07:16 AM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
Ubuntu + HDHomerunPrime + Prime Encoder

Just installed a HDHomerunPrime (w/ cable card) on my setup, which required me to utilize the great prime_encoder script to get my installation to be able to interface with the unit.

I only got this setup last night, so I haven't done extensive testing, but I have noticed that something fails at about 15minutes in to a recording.

Code:
Fri Mar 21 00:00:00 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-SensationalSecondFloor-15290171-0.mpg
Fri Mar 21 00:17:54 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 00:17:54 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-SensationalSecondFloor-15290171-1.mpg
Fri Mar 21 00:29:59 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 00:30:00 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-KitchenBreakthrough-15290174-0.mpg
Fri Mar 21 00:46:39 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 00:46:39 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-KitchenBreakthrough-15290174-1.mpg
Fri Mar 21 00:59:59 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 03:00:00 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-BreakingtheWoodworkRules-15290165-0.mpg
Fri Mar 21 03:18:55 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 03:18:55 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-BreakingtheWoodworkRules-15290165-1.mpg
Fri Mar 21 03:29:59 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 03:30:00 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-FiveStarFoyer-15290168-0.mpg
Fri Mar 21 03:45:40 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Fri Mar 21 03:45:40 2014 Tuner 'HDHomerun Prime Tuner 1': Tuning channel 838 on device 131C22D1 tuner 1 filename: /var/media/tv/RehabAddict-FiveStarFoyer-15290168-1.mpg
Fri Mar 21 03:59:59 2014 Tuner 'HDHomerun Prime Tuner 1': Stopping recording
Additionally, i'm seeing hundreds (if not thousands) of these lines in the log:
Code:
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VIDEO FRAME EXCEPTION THROWN:java.lang.NullPointerException
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] java.lang.NullPointerException
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VF processing job VFJob[ReloadPrepareMF r=0.0 t=0 file=null ifn=null] nPlayin=false
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VF processing on UI Thread VFJob[ReloadPrepareMF r=0.0 t=0 file=null ifn=null]
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VIDEO FRAME EXCEPTION THROWN:java.lang.NullPointerException
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] java.lang.NullPointerException
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VF processing job VFJob[ReloadPrepareMF r=0.0 t=0 file=null ifn=null] nPlayin=false
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VF processing on UI Thread VFJob[ReloadPrepareMF r=0.0 t=0 file=null ifn=null]
Fri 3/21 0:33:48.715 [VideoFrame-0023a50004c5@1a7b9c6] VIDEO FRAME EXCEPTION THROWN:java.lang.NullPointerException
This all being said, things seems to be working OK. I can view these files and they seem OK (although Comskip didn't run on them, but that may be some other issue.)

Anyway, just wanted to see if anyone had any thoughts on this.

Thanks,
Matt
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
  #2  
Old 03-21-2014, 04:17 PM
jpwegas jpwegas is offline
Sage Aficionado
 
Join Date: May 2007
Posts: 497
Matt,
I haven't seen those Java errors on my setup - is that from sagetv_0.txt?

Does the Sage system page report that it thinks the video device became unavailable when recording?

Just to verify, the prime_encoder.log output is from recordings, not the preview channel setup screens or live TV?

What version of ffmpeg are you using? I had problems with some older versions but it was after 2+ hours of continuous recording of a single sports event. Compiling a version of the latest made those problems go away for me.

--John
Reply With Quote
  #3  
Old 03-23-2014, 03:46 PM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
John -

Yes, those errors were from the sagetv_0.txt log. After stopping/starting Sage a half-dozen times, they seem to have disappeared. I'm not sure what it was, but it doesn't seem to be in the log today, so i'll call that "fixed!"

As for the stopping/starting of the video files, sage does through an error when this happens. I did decide to compile a newer version of ffmpeg, and it seems OK today (I've recorded a few shows, and none of them get split into a XXX-0.mpg and XXX-1.mpg file, as was happening.)

So, fingers crossed, but things seem OK now.

thanks for the feedback.

Matt
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why no tuner 0 on HDHomeRunPrime? freewheeling Hardware Support 17 01-25-2012 02:30 PM
Can I get a client to choose SD encoder over HD encoder? gdippel SageTV Software 0 09-23-2011 01:26 PM
HD-PVR on Ubuntu 10.10 birkey SageTV Linux 8 06-23-2011 01:56 PM
Encoder number graphic shows wrong encoder being used jpaddock3000 SageMC Custom Interface 11 02-05-2009 02:29 PM
network encoder stutters but ok on the encoder pc stryker SageTV Software 4 01-09-2008 02:28 PM


All times are GMT -6. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.