SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Github Development

Notices

SageTV Github Development Discussion related to SageTV Open Source Development. Use this forum for development topics about the Open Source versions of SageTV, hosted on Github.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-09-2018, 04:39 AM
davidb's Avatar
davidb davidb is offline
Sage Advanced User
 
Join Date: Feb 2009
Posts: 118
What lowest java version should I target

I am testing some code I want to release on a “test” sage server. I took a windows machine that didn’t have sage installed on it and used the windows installer to install it. This worked fine expect for not setting the java heap to 400H. I don’t know why someone wouldn’t want that as the default now but that is another issue.

I put my release candidate test code on the sage server. My code is not in a plugin so I am using sagex.
The first issue I ran into is I compiled the code on my development machine with java 1.8.0_141 and when running the test machine I got a unsupported major, minor version error message.. The windows installer put java 1.7.0_79 on. A quick search on stackoverflow says I should just install the jdk for an older version of java on my development system and compile it with it. I can do that but my understanding is if someone already had java on their machine and then used the windows installer it wouldn’t update the java. What should I pick for the lowest version of java so I can install that jdk to build with? Is the version installed with the windows installer a reasonable lower limit?

My application starts with an exe but then runs some java code. I am programmatically building a batch file up with the appropriate directory names setup from prior information a user has set. And then executes the batch file. The batch is like this:

"java -classpath .;"c:\Program Files (x86)\SageTV\SageTV\JARs\sagex-api.jar";"c:\Program Files (x86)\SageTV\SageTV\JARs\phoenix.jar";log4j-1.2.15.jar;gson-2.3.1.jar;.\ GetSageMedia c:\SageRemote\img server1"

The java code is using phoenix to get the FanartArtifact. I check first that phoenix is installed by making sure the phoenix.jar is in the jar directory but just this morning I discovered there is a phoenix lite. If a user had this instead of the regular phoenix how can I handle this?

T
Reply With Quote
  #2  
Old 05-09-2018, 04:51 AM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,003
I would suggest you still use a plugin to do the install and then have it depend on sagex and phoenix etc. so you know for sure what the user has on the system.

k
Reply With Quote
  #3  
Old 05-09-2018, 04:56 AM
davidb's Avatar
davidb davidb is offline
Sage Advanced User
 
Join Date: Feb 2009
Posts: 118
I can't go the plugin approach as the majority of my code is in c# and not java.

Quote:
Originally Posted by jusjoken View Post
I would suggest you still use a plugin to do the install and then have it depend on sagex and phoenix etc. so you know for sure what the user has on the system.

k
Reply With Quote
  #4  
Old 05-09-2018, 06:19 AM
jusjoken jusjoken is offline
Sage Icon
 
Join Date: Dec 2005
Location: Minneapolis MN
Posts: 2,003
Plugins can be used to install nearly anything and have the added advantage of specifying dependencies such as java versions, sage versions etc.

Take a look at the docs here....

Look at some examples in the repo here....

k
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What version of Java? cncb SageTV Github Development 2 11-03-2015 01:40 PM
version of Java korben_dallas SageTV Software 4 10-04-2015 01:14 PM
What version of Java garmpe SageTV Software 2 06-04-2008 08:08 AM
Which Java version is stable with which SageTV version? reboot_this SageTV Software 2 04-27-2007 06:17 AM
Which version of Java and where to get it? brianblank SageTV Software 6 02-06-2005 10:14 AM


All times are GMT -6. The time now is 06:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.