SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations

Notices

SageTV v7 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 7 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 7 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-22-2010, 02:50 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Important note if you are upgrading Sage7 (ie, not a clean install)

In Sage7, the sagex-apis had a jar file name change. Basically the jar file used to be called sagex.api.jar, but in sage7 it's now called sagex-api.jar. (changed dot to dash). This was something that bothered me about the sagex-api jar file and I decided with a new Sage install that I wanted to changed the jar name.

This will cause some issues for some plugins that depend on sagex-api.jar, such as bmt and phoenix, and potentially any other plugin that is using newer Sage7 features in the sagex api jar file.

The solution is to remove the jar file named, "sagex.api.jar" from the JARs directory and then restart SageTV.

This ONLY affects people that are upgrading from Sage6 to Sage7. If you are doing a clean install of Sage7 then this is not an issue.

My apologies for the name change, since there wasn't a technical need to change the name, but rather a personal need

You can use this tool to clean out the jar files that may be causing the errors.

Last edited by stuckless; 05-27-2010 at 06:09 PM.
Reply With Quote
  #2  
Old 05-22-2010, 08:29 PM
Ericft Ericft is offline
Sage Advanced User
 
Join Date: Jul 2006
Posts: 249
i didn't find the sagex.api.jar file in my directory? would it have been removed by the installation or am i missing something? and i updated sv7 over sv6
Reply With Quote
  #3  
Old 05-22-2010, 10:24 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Quote:
Originally Posted by Ericft View Post
i didn't find the sagex.api.jar file in my directory? would it have been removed by the installation or am i missing something? and i updated sv7 over sv6
If you are not experiencing the issue described, then I think you are OK Sage would not have removed the jar... but bmt may have. It's random luck as to which jar would get loaded...if the correct gets loaded, then it will nuke the old one automatically. In you case, it seems the right jar was loaded, and did its job.
Reply With Quote
  #4  
Old 05-24-2010, 05:56 PM
alton987 alton987 is offline
Sage Advanced User
 
Join Date: Jan 2010
Location: Belton, TX
Posts: 135
Metadata Tools

I am having a issue with Sage Meta data

When I looked I had the old version of the jar file the post you linked to is talking about. I deleted the file and it stills said failed after restarting sagetv.

I then deleted every plugin and only installed the Metadata Tool.

I now only have the new jar but it still saying failed.
Reply With Quote
  #5  
Old 05-24-2010, 06:07 PM
Tomahawk51's Avatar
Tomahawk51 Tomahawk51 is offline
Sage Aficionado
 
Join Date: Oct 2005
Posts: 320
it sounds like this would be good to report as a bug, so that maybe it gets cleaned up during install? Would avoid some future hard to diagnose issues for those of us with poor memories (or are sleep deprived thanks to a <wonderful> newborn!).
Reply With Quote
  #6  
Old 05-24-2010, 06:29 PM
alton987 alton987 is offline
Sage Advanced User
 
Join Date: Jan 2010
Location: Belton, TX
Posts: 135
..

Quote:
Originally Posted by alton987 View Post
I am having a issue with Sage Meta data

When I looked I had the old version of the jar file the post you linked to is talking about. I deleted the file and it stills said failed after restarting sagetv.

I then deleted every plugin and only installed the Metadata Tool.

I now only have the new jar but it still saying failed.
I forgot to add this was a fresh install also.
Reply With Quote
  #7  
Old 05-24-2010, 06:30 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Quote:
Originally Posted by Tomahawk51 View Post
it sounds like this would be good to report as a bug, so that maybe it gets cleaned up during install? Would avoid some future hard to diagnose issues for those of us with poor memories (or are sleep deprived thanks to a <wonderful> newborn!).
BMT does actually clean it up... but, if the old jar is loaded first, then there isn't a chance to clean it up before it fails This isn't a sagetv issue, since they have no way to know that I've renamed a jar file. Again my apologies for this, since renaming the jar file wasn't a technical requirement
Reply With Quote
  #8  
Old 05-26-2010, 08:44 AM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
I followed the direction in this post and am still seeing FAILED even after removing the old jar file...

any ideas on what i should try? i upgraded to V7...

~Pix64
Reply With Quote
  #9  
Old 05-26-2010, 11:57 AM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
*bump*

Any thoughts on this Stuckless? or anyone else for that matter?
Reply With Quote
  #10  
Old 05-26-2010, 12:38 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Sorry I didn't see you post The other issue that I saw from someone was that someone had installed bmt plus some other plugins and they ended up with a commons-lang-2-2.jar file and a commons-lang-2.4 jar file, which caused bmt to fail. Could you send me a complete list of all your jar files int he JARs directory.
Reply With Quote
  #11  
Old 05-26-2010, 01:43 PM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
No worries. Yes I will send you the list ASAP.

Thanks,

~Pix64
Reply With Quote
  #12  
Old 05-26-2010, 01:57 PM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
I def. have 2.2 as well as 2.4 ver of the above mentioned jar installed... here is the list from BMT web

Code:
Duplicate JARs
JARs\commons-codec-1.3.jar
1.3
JARs\commons-dbutils-1.3.jar
1.3
JARs\commons-io-1.4.jar
1.4
JARs\commons-lang-2.2.jar
2.2
JARs\commons-lang-2.4.jar
2.4
JARs\h2.jar
1.2.128
JARs\htmlparser-1.6.jar
1.6
JARs\log4j-1.2.12.jar
1.2.12
JARs\log4j-1.2.15.jar
1.2.15
JARs\lucene-core-2.3.2.jar
2.3.2 652650 - buschmi - 2008-05-01 13:30:57
JARs\lucene-core-2.4.1.jar
2.4.1 750176 - 2009-03-04 21:56:52
Installed JARs
JARs\activation.jar
99.0
JARs\ant-1.6.5.jar
1.6.5
JARs\commons-codec-1.3.jar
1.3
JARs\commons-codec.jar
1.3
JARs\commons-collections-3.2.jar
3.2
JARs\commons-dbutils-1.3.jar
1.3
JARs\commons-dbutils.jar
1.3
JARs\commons-httpclient-3.0.1.jar
3.0.1
JARs\commons-io-1.4.jar
1.4
JARs\commons-io.jar
1.4
JARs\commons-jxpath-1.1.jar
1.1
JARs\commons-lang-2.2.jar
2.2
JARs\commons-lang-2.4.jar
2.4
JARs\commons-lang.jar
2.4
JARs\commons-logging-1.0.3.jar
99.0
JARs\commons-net-1.4.1.jar
1.4.1
JARs\commons-vfs-20070823.jar
1.1-SNAPSHOT
JARs\core-3.1.1.jar
3.1.1
JARs\df_sageutils.jar
99.0
JARs\flux.jar
99.0
JARs\gkusnick.sagetv.jar
99.0
JARs\h2-1.2.135.jar
1.2.135
JARs\h2.jar
1.2.128
JARs\htmlparser-1.6.jar
1.6
JARs\htmlparser.jar
99.0
JARs\imageutils.jar
99.0
JARs\jcifs-1.1.6.jar
1.1.6
JARs\jdic.jar
99.0
JARs\jetty-6.1.19.jar
99.0
JARs\jetty-ajp-6.1.19.jar
99.0
JARs\jetty-rewrite-handler-6.1.19.jar
99.0
JARs\jetty-sslengine-6.1.19.jar
99.0
JARs\jetty-starter.jar
1.7.5.22
JARs\jetty-util-6.1.19.jar
99.0
JARs\jflac-1.0.jar
1.0
JARs\jl1.0.jar
99.0
JARs\jnlp.jar
99.0
JARs\jogg-0.0.7.jar
0.0.7
JARs\jorbis-0.0.15.jar
0.0.15
JARs\jsch-20040429.jar
99.0
JARs\jsp-2.1-jetty-6.1.19.jar
99.0
JARs\jsp-2.1.jar
2.1
JARs\jsp-api-2.1.jar
2.1
JARs\log4j-1.2.12.jar
1.2.12
JARs\log4j-1.2.15.jar
1.2.15
JARs\log4j.jar
99.0
JARs\lucene-core-2.3.2.jar
2.3.2 652650 - buschmi - 2008-05-01 13:30:57
JARs\lucene-core-2.4.1.jar
2.4.1 750176 - 2009-03-04 21:56:52
JARs\lucene-core.jar
2.4.1 750176 - 2009-03-04 21:56:52
JARs\mail.jar
99.0
JARs\mailcheck.jar
99.0
JARs\metadata-updater.jar
4.0.27
JARs\mp3spi1.9.2.jar
99.0
JARs\nativeskin.jar
99.0
JARs\nativeskinlib.jar
99.0
JARs\nielm_getrssnews.jar
99.0
JARs\nielm_sageimdb.jar
99.0
JARs\nielm_sagemenureader.jar
99.0
JARs\nielm_sageutls.jar
1.4.1
JARs\nielm_sagexmlinfo.jar
1.4.1
JARs\phoenix.jar
1.73.2
JARs\razr.jar
99.0
JARs\sad.jar
99.0
JARs\sagemc.jar
99.0
JARs\sageortus.jar
99.0
JARs\sagex-api.jar
7.0.9.0
JARs\sagex-h2.jar
99.0
JARs\sbbi-upnplib-1.0.3.jar
1.0.3
JARs\servlet-api-2.5-6.1.19.jar
6.1.19
JARs\slimplayer.jar
99.0
JARs\SoftSqueeze.jar
99.0
JARs\tritonus_share.jar
99.0
JARs\vecmath.jar
1.3.0
JARs\vorbisspi1.0.2.jar
99.0
JARs\webharvest_all_1.jar
99.0
System Messages
Clear All
Reply With Quote
  #13  
Old 05-26-2010, 03:12 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Quote:
Originally Posted by PiX64 View Post
I def. have 2.2 as well as 2.4 ver of the above mentioned jar installed... here is the list from BMT web

Code:
Duplicate JARs
JARs\commons-codec-1.3.jar
1.3
JARs\commons-dbutils-1.3.jar
1.3
JARs\commons-io-1.4.jar
1.4
JARs\commons-lang-2.2.jar
2.2
JARs\commons-lang-2.4.jar
2.4
JARs\h2.jar
1.2.128
JARs\htmlparser-1.6.jar
1.6
JARs\log4j-1.2.12.jar
1.2.12
JARs\log4j-1.2.15.jar
1.2.15
JARs\lucene-core-2.3.2.jar
2.3.2 652650 - buschmi - 2008-05-01 13:30:57
JARs\lucene-core-2.4.1.jar
2.4.1 750176 - 2009-03-04 21:56:52
Installed JARs
JARs\activation.jar
99.0
JARs\ant-1.6.5.jar
1.6.5
JARs\commons-codec-1.3.jar
1.3
JARs\commons-codec.jar
1.3
JARs\commons-collections-3.2.jar
3.2
JARs\commons-dbutils-1.3.jar
1.3
JARs\commons-dbutils.jar
1.3
JARs\commons-httpclient-3.0.1.jar
3.0.1
JARs\commons-io-1.4.jar
1.4
JARs\commons-io.jar
1.4
JARs\commons-jxpath-1.1.jar
1.1
JARs\commons-lang-2.2.jar
2.2
JARs\commons-lang-2.4.jar
2.4
JARs\commons-lang.jar
2.4
JARs\commons-logging-1.0.3.jar
99.0
JARs\commons-net-1.4.1.jar
1.4.1
JARs\commons-vfs-20070823.jar
1.1-SNAPSHOT
JARs\core-3.1.1.jar
3.1.1
JARs\df_sageutils.jar
99.0
JARs\flux.jar
99.0
JARs\gkusnick.sagetv.jar
99.0
JARs\h2-1.2.135.jar
1.2.135
JARs\h2.jar
1.2.128
JARs\htmlparser-1.6.jar
1.6
JARs\htmlparser.jar
99.0
JARs\imageutils.jar
99.0
JARs\jcifs-1.1.6.jar
1.1.6
JARs\jdic.jar
99.0
JARs\jetty-6.1.19.jar
99.0
JARs\jetty-ajp-6.1.19.jar
99.0
JARs\jetty-rewrite-handler-6.1.19.jar
99.0
JARs\jetty-sslengine-6.1.19.jar
99.0
JARs\jetty-starter.jar
1.7.5.22
JARs\jetty-util-6.1.19.jar
99.0
JARs\jflac-1.0.jar
1.0
JARs\jl1.0.jar
99.0
JARs\jnlp.jar
99.0
JARs\jogg-0.0.7.jar
0.0.7
JARs\jorbis-0.0.15.jar
0.0.15
JARs\jsch-20040429.jar
99.0
JARs\jsp-2.1-jetty-6.1.19.jar
99.0
JARs\jsp-2.1.jar
2.1
JARs\jsp-api-2.1.jar
2.1
JARs\log4j-1.2.12.jar
1.2.12
JARs\log4j-1.2.15.jar
1.2.15
JARs\log4j.jar
99.0
JARs\lucene-core-2.3.2.jar
2.3.2 652650 - buschmi - 2008-05-01 13:30:57
JARs\lucene-core-2.4.1.jar
2.4.1 750176 - 2009-03-04 21:56:52
JARs\lucene-core.jar
2.4.1 750176 - 2009-03-04 21:56:52
JARs\mail.jar
99.0
JARs\mailcheck.jar
99.0
JARs\metadata-updater.jar
4.0.27
JARs\mp3spi1.9.2.jar
99.0
JARs\nativeskin.jar
99.0
JARs\nativeskinlib.jar
99.0
JARs\nielm_getrssnews.jar
99.0
JARs\nielm_sageimdb.jar
99.0
JARs\nielm_sagemenureader.jar
99.0
JARs\nielm_sageutls.jar
1.4.1
JARs\nielm_sagexmlinfo.jar
1.4.1
JARs\phoenix.jar
1.73.2
JARs\razr.jar
99.0
JARs\sad.jar
99.0
JARs\sagemc.jar
99.0
JARs\sageortus.jar
99.0
JARs\sagex-api.jar
7.0.9.0
JARs\sagex-h2.jar
99.0
JARs\sbbi-upnplib-1.0.3.jar
1.0.3
JARs\servlet-api-2.5-6.1.19.jar
6.1.19
JARs\slimplayer.jar
99.0
JARs\SoftSqueeze.jar
99.0
JARs\tritonus_share.jar
99.0
JARs\vecmath.jar
1.3.0
JARs\vorbisspi1.0.2.jar
99.0
JARs\webharvest_all_1.jar
99.0
System Messages
Clear All
Hang in there... I think the best thing for me to do is write an "upgrade" utility that cleans up the jar files. I'll try to do this tonight or tomorrow. BTW... Could I get a list of your installed plugins as well. There are conflicting jars in there, and I'm not sure where they are coming from.
Reply With Quote
  #14  
Old 05-26-2010, 03:12 PM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
Stuckless,

I am also trying to use this java -jar MetadataTool.jar --jarclean and i get the following command line output:

Exception in thread "main" java.lang.NoClassDefFoundError: sagx/iSageAPIProvider
caused by : java.land.ClassNotFoundException: sagex.ISageAPIProvider
.
.
.
could not find the main class: org.jdna.metadataupdates.MetadataUpdater. Program will exit.


Any ideas?
Reply With Quote
  #15  
Old 05-26-2010, 05:58 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Quote:
Originally Posted by PiX64 View Post
Stuckless,

I am also trying to use this java -jar MetadataTool.jar --jarclean and i get the following command line output:

Exception in thread "main" java.lang.NoClassDefFoundError: sagx/iSageAPIProvider
caused by : java.land.ClassNotFoundException: sagex.ISageAPIProvider
.
.
.
could not find the main class: org.jdna.metadataupdates.MetadataUpdater. Program will exit.


Any ideas?
That's a good thing... that cleaner is for version6 and it would not be good to run it for v7

I'll create a separate v7 upgrade tool that will be slightly different.
Reply With Quote
  #16  
Old 05-27-2010, 06:00 AM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
No problem. I have the following installed:

jetty,
webserver,
bmt,
phoneix for sagetv 7
phoneix for malore
malore (enabled)
Artifacts Deletion
uPnp
Serenity


~Pix64
Reply With Quote
  #17  
Old 05-27-2010, 01:52 PM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
*bump*

thought u may have missed this stuckless...
Reply With Quote
  #18  
Old 05-27-2010, 01:56 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Quote:
Originally Posted by PiX64 View Post
*bump*

thought u may have missed this stuckless...
Sorry... i did see it... thx. I'm at work right now, but I want to install those same ones on my server at home and see what if end up with any duplicate jars as well. I can't do that until later tonight though
Reply With Quote
  #19  
Old 05-27-2010, 02:03 PM
PiX64's Avatar
PiX64 PiX64 is offline
Sage Icon
 
Join Date: Dec 2008
Location: Illinois
Posts: 1,991
NO worries. just keepin it fresh in your mind and trying to help out wherever i can.

let me know what i can do if anything to hlep.

~Pix
Reply With Quote
  #20  
Old 05-27-2010, 06:09 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,626
Here's the upgrade tool.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clean Install gman4nj General Discussion 2 12-09-2007 05:36 PM
Clean Install - Which Licenses? Alwayslearnin SageTV Beta Test Software 3 11-26-2006 12:03 AM
Doing a clean install cummings66 SageTV Beta Test Software 5 11-25-2006 08:19 PM
Sage acts like a clean install after upgrading to .14 SageFL SageTV Beta Test Software 3 04-24-2006 04:37 PM
Clean Install of Sage... Stuntman SageTV Software 6 10-26-2004 01:43 PM


All times are GMT -6. The time now is 08:38 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.