SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v9 Customizations

Notices

SageTV v9 Customizations This forums is for discussing and sharing user-created modifications for the SageTV version 9 application created by using the SageTV Studio or through the use of external plugins. Use this forum to discuss plugins for SageTV version 9 and newer.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-28-2022, 02:06 PM
RBraverman's Avatar
RBraverman RBraverman is offline
Sage Advanced User
 
Join Date: Dec 2006
Posts: 230
SageAlert, don't know where to post

I use SageAlert to inform me (text message) on certain things. It just stopped and the log file is telling me that my name and password is not being accepted (they are correct).
YET, I can log in on the same machine, via Firefox and send to my hearts content.
I noticed there was/is an update to it and installed both of the "updates" and that just fondue'd everything - went back to a backup.
Ideas?
__________________
Core2Duo 3.0, 8gig Memory, Win7 x86, LOTS O' Storage tucked into an Antec Case.
OLD aTI Remote Wonder running RW Keymaster
Sage V9.2.2
2 Sage Clients V9.2.2
2 HD-100 Placeshifters - not connected.
Reply With Quote
  #2  
Old 02-28-2022, 02:19 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,649
What Java version are you using?

What version of Jetty Web server are you using.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #3  
Old 03-01-2022, 08:51 AM
RBraverman's Avatar
RBraverman RBraverman is offline
Sage Advanced User
 
Join Date: Dec 2006
Posts: 230
Quote:
Originally Posted by jusjoken View Post
What Java version are you using?

What version of Jetty Web server are you using.

K
Java Version 8.121
Jetty Version: 2.3.0.17

Nothing has changed.
__________________
Core2Duo 3.0, 8gig Memory, Win7 x86, LOTS O' Storage tucked into an Antec Case.
OLD aTI Remote Wonder running RW Keymaster
Sage V9.2.2
2 Sage Clients V9.2.2
2 HD-100 Placeshifters - not connected.
Reply With Quote
  #4  
Old 03-01-2022, 09:56 AM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,649
Quote:
Originally Posted by RBraverman View Post
Java Version 8.121
Jetty Version: 2.3.0.17

Nothing has changed.
Ok. Nothing to suggest then if you are not using the latest Jetty. As you know SageAlert has not been supported for a long time so not sure what to suggest.

Perhaps post the sage and sagealert logs and someone may have other suggestions

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #5  
Old 03-01-2022, 05:02 PM
RBraverman's Avatar
RBraverman RBraverman is offline
Sage Advanced User
 
Join Date: Dec 2006
Posts: 230
Quote:
Originally Posted by jusjoken View Post
Ok. Nothing to suggest then if you are not using the latest Jetty. As you know SageAlert has not been supported for a long time so not sure what to suggest.

Perhaps post the sage and sagealert logs and someone may have other suggestions

K
Yeah I didn't think anyone would have any ideas, it's just odd that an update showed up.
It's done this before, I've gone in unchecked something (pick one), saved it, then checked it/saved it and all was good - not this time.
__________________
Core2Duo 3.0, 8gig Memory, Win7 x86, LOTS O' Storage tucked into an Antec Case.
OLD aTI Remote Wonder running RW Keymaster
Sage V9.2.2
2 Sage Clients V9.2.2
2 HD-100 Placeshifters - not connected.
Reply With Quote
  #6  
Old 03-01-2022, 08:38 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,649
Quote:
Originally Posted by RBraverman View Post
Yeah I didn't think anyone would have any ideas, it's just odd that an update showed up.
It's done this before, I've gone in unchecked something (pick one), saved it, then checked it/saved it and all was good - not this time.
I updated sagealert so that it would work with the new Jetty server version. In theory, it should not have allowed you to update it if you were not running the latest jetty. The new version of sagealert is not going to work with the old version of jetty.

Ideally you need to restore the old version somehow as the plugin system really does not support multiple versions.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #7  
Old 03-01-2022, 09:05 PM
RBraverman's Avatar
RBraverman RBraverman is offline
Sage Advanced User
 
Join Date: Dec 2006
Posts: 230
Quote:
Originally Posted by jusjoken View Post
I updated sagealert so that it would work with the new Jetty server version. In theory, it should not have allowed you to update it if you were not running the latest jetty. The new version of sagealert is not going to work with the old version of jetty.

Ideally you need to restore the old version somehow as the plugin system really does not support multiple versions.

K
Does this help? I can't see what's wrong, other than the bad credentials (which would break it) but going to googles site is of no help:

at com.sun.mail.smtp.SMTPTransport$Authenticator.authenticate(SMTPTransport.java:648)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:583)
at javax.mail.Service.connect(Service.java:291)
at javax.mail.Service.connect(Service.java:172)
at javax.mail.Service.connect(Service.java:192)
at com.google.code.sagetvaddons.sagealert.server.m.c(SourceFile:43)
at com.google.code.sagetvaddons.sagealert.server.n.run(SourceFile:102)
2022-03-01 18:37:45,216 ERROR [m]: Email for 'An EPG update has completed' event FAILED to 'number@tmomail.net'
2022-03-01 18:59:32,578 INFO [f]: Event received: ClientConnected :: {MACAddress=null, IPAddress=127.0.0.1}
2022-03-01 18:59:32,578 INFO [af]: No SageAlert handlers registered for fired event: ClientConnected
2022-03-01 18:59:32,843 INFO [e]: Event received: RecordingScheduleChanged :: {}
2022-03-01 18:59:32,843 INFO [h]: Alert for 'Recording schedule updated' event written successfully to 'c:\sagetv.csv'
2022-03-01 19:00:17,052 INFO [f]: Event received: ClientDisconnected :: {MACAddress=null, IPAddress=127.0.0.1}
2022-03-01 19:00:17,052 INFO [af]: No SageAlert handlers registered for fired event: ClientDisconnected
2022-03-01 19:00:45,506 ERROR [m]: Error sending email
javax.mail.AuthenticationFailedException: 535-5.7.8 Username and Password not accepted. Learn more at
535 5.7.8 https://support.google.com/mail/?p=BadCredentials
u9-20020a056a00158900b004de90b164d0sm19970375pfk.9 - gsmtp
__________________
Core2Duo 3.0, 8gig Memory, Win7 x86, LOTS O' Storage tucked into an Antec Case.
OLD aTI Remote Wonder running RW Keymaster
Sage V9.2.2
2 Sage Clients V9.2.2
2 HD-100 Placeshifters - not connected.
Reply With Quote
  #8  
Old 03-01-2022, 09:46 PM
jusjoken jusjoken is offline
SageTVaholic
 
Join Date: Dec 2005
Location: Strathmore, AB
Posts: 2,649
Smile

Quote:
Originally Posted by RBraverman View Post
Does this help? I can't see what's wrong, other than the bad credentials (which would break it) but going to googles site is of no help:

at com.sun.mail.smtp.SMTPTransport$Authenticator.authenticate(SMTPTransport.java:648)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:583)
at javax.mail.Service.connect(Service.java:291)
at javax.mail.Service.connect(Service.java:172)
at javax.mail.Service.connect(Service.java:192)
at com.google.code.sagetvaddons.sagealert.server.m.c(SourceFile:43)
at com.google.code.sagetvaddons.sagealert.server.n.run(SourceFile:102)
2022-03-01 18:37:45,216 ERROR [m]: Email for 'An EPG update has completed' event FAILED to 'number@tmomail.net'
2022-03-01 18:59:32,578 INFO [f]: Event received: ClientConnected :: {MACAddress=null, IPAddress=127.0.0.1}
2022-03-01 18:59:32,578 INFO [af]: No SageAlert handlers registered for fired event: ClientConnected
2022-03-01 18:59:32,843 INFO [e]: Event received: RecordingScheduleChanged :: {}
2022-03-01 18:59:32,843 INFO [h]: Alert for 'Recording schedule updated' event written successfully to 'c:\sagetv.csv'
2022-03-01 19:00:17,052 INFO [f]: Event received: ClientDisconnected :: {MACAddress=null, IPAddress=127.0.0.1}
2022-03-01 19:00:17,052 INFO [af]: No SageAlert handlers registered for fired event: ClientDisconnected
2022-03-01 19:00:45,506 ERROR [m]: Error sending email
javax.mail.AuthenticationFailedException: 535-5.7.8 Username and Password not accepted. Learn more at
535 5.7.8 https://support.google.com/mail/?p=BadCredentials
u9-20020a056a00158900b004de90b164d0sm19970375pfk.9 - gsmtp
This could be related to Google forcing two factor authentication on all Gmail accounts. Sagealert cannot handle that directly if this is what it is but there is a way in your google account settings to create a third party app password that sagealert can use.

K
__________________
If you wish to see what I am up to and support my efforts visit my Patreon page
Reply With Quote
  #9  
Old 03-02-2022, 09:05 AM
RBraverman's Avatar
RBraverman RBraverman is offline
Sage Advanced User
 
Join Date: Dec 2006
Posts: 230
Quote:
Originally Posted by jusjoken View Post
This could be related to Google forcing two factor authentication on all Gmail accounts. Sagealert cannot handle that directly if this is what it is but there is a way in your google account settings to create a third party app password that sagealert can use.

K
Well I went through it one more time and popped over to g**gle's site and there is a section I missed on "insecure apps", which was turned off. Turned it on (to allow them) and it worked.
There's also a section that said (but I can't find it now to verify) that on May 30, they are going to stop - if I remember what I read - allowing either ANY app that logs in with ONLY a name/password, or just E-Mail.
Gotta find it.
Maybe this will help someone else.

THANK YOU VERY MUCH for helping me out here!
__________________
Core2Duo 3.0, 8gig Memory, Win7 x86, LOTS O' Storage tucked into an Antec Case.
OLD aTI Remote Wonder running RW Keymaster
Sage V9.2.2
2 Sage Clients V9.2.2
2 HD-100 Placeshifters - not connected.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
unRAID and SageAlert brb84 SageTV for unRAID/Docker 3 05-21-2019 08:51 PM
Plugin: SageAlert v2.x Slugger SageTV v7 Customizations 298 09-28-2016 12:26 PM
Can't install SageAlert phareous SageTV v9 Customizations 1 09-28-2016 11:55 AM
Plugin: SageAlert Slugger SageTV Customizations 201 06-28-2010 07:47 PM
SageAlert new release notifications Slugger Customization Announcements 2 03-06-2010 09:53 AM


All times are GMT -6. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.