SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV Software

Notices

SageTV Software Discussion related to the SageTV application produced by SageTV. Questions, issues, problems, suggestions, etc. relating to the SageTV software application should be posted here. (Check the descriptions of the other forums; all hardware related questions go in the Hardware Support forum, etc. And, post in the customizations forum instead if any customizations are active.)

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old 09-27-2012, 08:20 PM
sacrament055 sacrament055 is offline
Sage Aficionado
 
Join Date: Jul 2007
Posts: 431
I would suspect those other devices have official support for Youtube via an API where as Sage was likely parsing their webpage.

Just a guess though.
Reply With Quote
  #22  
Old 09-27-2012, 08:47 PM
Shield Shield is offline
Sage Aficionado
 
Join Date: Jun 2007
Posts: 402
Quote:
Originally Posted by tmiranda View Post
I took a quick look at this to see if there was an easy fix. I think YouTube changed the format uf the URL needed to retrieve videos but that's about as far as I got. I'll try to look at it a little more over the next few days but no promises.
What's strange is I have a Sony TV with a 2010 firmware that YouTube still works on as well as a WD playback device - with firmware at least 6 months old. Both play Youtube videos just fine. They must be accessing it a different way or something?
__________________
HD300/HD200 clients
Reply With Quote
  #23  
Old 09-27-2012, 09:16 PM
tvmaster2's Avatar
tvmaster2 tvmaster2 is offline
SageTVaholic
 
Join Date: Jun 2005
Location: tarana
Posts: 3,363
Quote:
Originally Posted by Shield View Post
What's strange is I have a Sony TV with a 2010 firmware that YouTube still works on as well as a WD playback device - with firmware at least 6 months old. Both play Youtube videos just fine. They must be accessing it a different way or something?
yes - that is interesting, isn't it? I too have a few old devices that access youtube just fine. have Google stuck some code in to deny Sage users on purpose?
__________________
Sage 7 server = Gigabyte AMD quad-core - 2 gigs - integrated ATI HD4200 chipset - Seagate/Hitachi Deskstar - HD-PVR - Colossus - Win7 32 bit. HD200 networked. "If you've given up on Weird Al, you've given up on life" - Homer Simpson
Reply With Quote
  #24  
Old 09-28-2012, 09:56 PM
cheekymonkey cheekymonkey is offline
Sage User
 
Join Date: Feb 2009
Posts: 43
I've had a bit of a look at this but have got a bit lost, I can see in the debugs where it has a problem, but have not been able to get it working playing around in SageTV7.xml


Sat 9/29 10:54:26.096 [AWT-EventQueue-0@73a34b] YouTube: VideoFinderLinkEnd of <&> not found in line, trying VideoFinderLinkEndAlt of <\u0026> instead.


Maybe this fix could be of some help to the gurus
https://github.com/facanferff/showti...c90a40944e4390
Reply With Quote
  #25  
Old 09-29-2012, 01:38 PM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
Exclamation Restored SageTV image back to Oct, 2011. Online videos not working

I had made a perfect image backup of a fully working SageTV installation of SageTV 7.1.9 final.

After I restored it, the first thing I did was update the STV to the latest version.. it was one version behind only.

After that, I tried playing youtube videos. When I press PLAY, they will all say:

"The media download failed". Error: The request media file was not found on the server"

How can I fix this? We use Youtube every day!

__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***
Reply With Quote
  #26  
Old 09-29-2012, 01:44 PM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
I've been beating my brains out trying to get youtube to work after I restored SageTV from back in October 2011. It looks like this problem started coincidentally right when I was restoring my server and sageTV. I had no idea that youtube broke again. I thought it was just Google weather that was broken.

Is there any way to patch this temporarily until there's a more official fix? We use youtube several times a day at our house hold.
__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***
Reply With Quote
  #27  
Old 09-29-2012, 07:47 PM
Thomas Wischgol's Avatar
Thomas Wischgol Thomas Wischgol is offline
Sage Aficionado
 
Join Date: Sep 2005
Posts: 256
It looks like YouTube changed its feeds so that they now point to a web page with their embedded player in it. Before it had a URL to the video instead of that web page URL so that Sage could just play that file. I looked at the YouTube API but I cannot see an easy way around that. You would pretty much have to process the web page with the embedded player and extract the links from there. This is of course possible but probably needs to be done within Sage since the standard way of using rss feeds in Sage does not handle something like this right now.
Reply With Quote
  #28  
Old 09-30-2012, 12:57 PM
tmiranda's Avatar
tmiranda tmiranda is offline
SageTVaholic
 
Join Date: Jul 2005
Location: Central Florida, USA
Posts: 5,805
Quote:
Originally Posted by Thomas Wischgol View Post
It looks like YouTube changed its feeds so that they now point to a web page with their embedded player in it. Before it had a URL to the video instead of that web page URL so that Sage could just play that file. I looked at the YouTube API but I cannot see an easy way around that. You would pretty much have to process the web page with the embedded player and extract the links from there. This is of course possible but probably needs to be done within Sage since the standard way of using rss feeds in Sage does not handle something like this right now.
I didn't get as far debugging this as you did, but if this is correct I may be able to use some of the code I developed for the NaviX plugin to parse the web page but it will be a lot of work....
__________________

Sage Server: 8th gen Intel based system w/32GB RAM running Ubuntu Linux, HDHomeRun Prime with cable card for recording. Runs headless. Accessed via RD when necessary. Four HD-300 Extenders.
Reply With Quote
  #29  
Old 09-30-2012, 01:58 PM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
Please forgive me if this sounds very naive. I'm sure I'm missing something very basic which, I guess, goes without saying for developers (unfortunately, I'm not a software developer). But, doesn't the Youtube API provide the java libraries and documentation examples for playing back these videos?

One interesting thing I noticed, all the websites that used to provide a direct FLV download for Youtube videos just recently switched to a requiring the need of a java applet (which I'm guessing is part of the java libraries provided in the API).

Im curious what method all the Youtube downloader Web browser plugins use. I'm guessing from browser cache? The most popular web browser video downloader plugins seem to have an update within a day.

Here are a couple of working javascripts (updated recently) which expose the full URL to the FLVs; and, seem to use the same method as other youtube downloader plugins (without java applets):
http://userscripts.org/scripts/review/30395
http://userscripts.org/scripts/review/98782
__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***

Last edited by mkanet; 09-30-2012 at 02:40 PM.
Reply With Quote
  #30  
Old 09-30-2012, 05:52 PM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Quote:
Originally Posted by mkanet View Post
Please forgive me if this sounds very naive. I'm sure I'm missing something very basic which, I guess, goes without saying for developers (unfortunately, I'm not a software developer). But, doesn't the Youtube API provide the java libraries and documentation examples for playing back these videos?

One interesting thing I noticed, all the websites that used to provide a direct FLV download for Youtube videos just recently switched to a requiring the need of a java applet (which I'm guessing is part of the java libraries provided in the API).

Im curious what method all the Youtube downloader Web browser plugins use. I'm guessing from browser cache? The most popular web browser video downloader plugins seem to have an update within a day.

Here are a couple of working javascripts (updated recently) which expose the full URL to the FLVs; and, seem to use the same method as other youtube downloader plugins (without java applets):
http://userscripts.org/scripts/review/30395
http://userscripts.org/scripts/review/98782
The Youtube APIs are for getting access to the youtube feeds, and user settings, they do not provide a means to getting the direct video url. They do provide the youtube url, but that's not the same thing as the video url. Typically getting the "real" video url requires a bit of scraping, and other magic. But like all magic, sometimes it doesn't work, and when it doesn't it means that people have to reengineer the solution all over again. Youtube doesn't want ANYONE scraping the videos, and as such, they don't make it trivial.
Reply With Quote
  #31  
Old 10-04-2012, 11:14 AM
Opus4's Avatar
Opus4 Opus4 is offline
Administrator
 
Join Date: Sep 2003
Location: NJ
Posts: 19,595
Yes, this update was more difficult than usual -- it took me a couple hours to get the links working again. I have to test more to see how solid this fix is before deciding to put it out.

- Andy
__________________
SageTV Open Source v9 is available.
- Read the SageTV FAQ. Older PDF User's Guides mostly still apply: SageTV V7.0 & SageTV Studio v7.1.
- Hauppauge remote help: 1) Basics/Extending it 2) Replace it 3) Use it w/o needing focus
- HD Extenders: A) FAQs B) URC MX-700 remote setup
Note: This is a users' forum; see the Rules. For official tech support fill out a Support Request.
Reply With Quote
  #32  
Old 10-04-2012, 11:21 AM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
Andy, I really envy your technical ability. In just two hours!? Thanks so much for all your effort.

Quote:
Originally Posted by Opus4 View Post
Yes, this update was more difficult than usual -- it took me a couple hours to get the links working again. I have to test more to see how solid this fix is before deciding to put it out.

- Andy
__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***
Reply With Quote
  #33  
Old 10-04-2012, 12:06 PM
checkbin checkbin is offline
Sage User
 
Join Date: Jun 2011
Location: Central NJ, USA
Posts: 66
Yes Andy is quite the Sage genius, being able to figure it out in a couple of hours. Where would we be without you? Looking forward to your fix. Thank you.

Checkbin
Reply With Quote
  #34  
Old 10-05-2012, 06:54 AM
JParedis's Avatar
JParedis JParedis is offline
Sage Aficionado
 
Join Date: Jan 2006
Location: Belgium
Posts: 262
Quote:
Originally Posted by Opus4 View Post
Yes, this update was more difficult than usual -- it took me a couple hours to get the links working again. I have to test more to see how solid this fix is before deciding to put it out.

- Andy
Where is the box for donations

If fixed, would that mean that the "Trailer search" would also work again? I use that a lot to remind we what a movie was about. That would be great

I have been looking for a future replacement of my Sage installation, as one day support will have to reduce to below workable. But haven't found any product matching up the ease of installation, use, functionality and active user community. I hope we'll get still this type of support for some while.
__________________
If we knew what we were doing, it wouldn't be called research, would it? Albert Einstein (1879-1955)
Reply With Quote
  #35  
Old 10-05-2012, 09:54 AM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
Yes, the Movie Trailer plugin should work once Youtube Video playback is restored. Music video playback feature in Slimplayer will start to work as well. I would be more than happy to donate generously if I could; especially, with all the use my family gets out of it.

Quote:
Originally Posted by JParedis View Post
Where is the box for donations

If fixed, would that mean that the "Trailer search" would also work again? I use that a lot to remind we what a movie was about. That would be great

I have been looking for a future replacement of my Sage installation, as one day support will have to reduce to below workable. But haven't found any product matching up the ease of installation, use, functionality and active user community. I hope we'll get still this type of support for some while.
__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***
Reply With Quote
  #36  
Old 10-05-2012, 10:06 AM
Opus4's Avatar
Opus4 Opus4 is offline
Administrator
 
Join Date: Sep 2003
Location: NJ
Posts: 19,595
The downloadable STV updates for v7's SageTV7 and SageTV3 STVs and v6's SageTV3 STV are now available.

- Andy
__________________
SageTV Open Source v9 is available.
- Read the SageTV FAQ. Older PDF User's Guides mostly still apply: SageTV V7.0 & SageTV Studio v7.1.
- Hauppauge remote help: 1) Basics/Extending it 2) Replace it 3) Use it w/o needing focus
- HD Extenders: A) FAQs B) URC MX-700 remote setup
Note: This is a users' forum; see the Rules. For official tech support fill out a Support Request.
Reply With Quote
  #37  
Old 10-05-2012, 11:23 AM
Oddity Oddity is offline
Sage Aficionado
 
Join Date: Nov 2010
Location: London
Posts: 281


Thank you family now happy again, and myself of course.

Appreciate your continued support
Reply With Quote
  #38  
Old 10-05-2012, 11:36 AM
mkanet's Avatar
mkanet mkanet is offline
SageTVaholic
 
Join Date: Feb 2004
Posts: 3,359
It works great!!! I just tried it from work via placeshifter to playback movie trailers. The MKANET family is very thankful!!
__________________
Upgraded to Comcast X1 + Netflix/Amazon Video streaming

***RIP SageTV***
Reply With Quote
  #39  
Old 10-05-2012, 02:58 PM
gilded07's Avatar
gilded07 gilded07 is offline
Sage Aficionado
 
Join Date: Sep 2007
Posts: 412
Quote:
Originally Posted by Opus4 View Post
The downloadable STV updates for v7's SageTV7 and SageTV3 STVs and v6's SageTV3 STV are now available.

- Andy


Thanks so much!!
__________________
Headless Server: Q8400 2.66ghz / MSI P45 Neo2-FR / 4GB
Storage: 120 SSD for SageTV / 3TB for TV recordings / atom-based NAS Ubuntu 12.04 4TB in RAID 5 for movies & music
Tuners: HDHR3 x 2
Extenders: Nvidia Shield / HD300 / HD200 / 3 placeshifters
SageTV Client: G620, Win 10 64, 4GB, ML03B, MCE remote & EventGhost, K400 KB
Server Software: Win 10 64, SageTV 9.1.5.683, Java 7_71, Real VNC
Other: Commercial Detector UI, Sage Recording Extender
Reply With Quote
  #40  
Old 10-05-2012, 07:16 PM
cheekymonkey cheekymonkey is offline
Sage User
 
Join Date: Feb 2009
Posts: 43
Thanks heaps
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Youtube videos working ChrisNH SageTV Software 0 02-03-2013 10:42 PM
problem with online videos / youtube sflamm Phoenix 4 07-27-2011 02:57 PM
Youtube videos not working again! wayner SageTV Software 39 08-15-2010 11:23 AM
Online Videos (Youtube/Google) wayne5w SageTV v7 Customizations 25 07-14-2010 07:13 PM
Online Favorites? Music Videos from Google and YouTube. happyfirst SageTV Software 0 10-21-2007 05:27 PM


All times are GMT -6. The time now is 01:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.