SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV Customizations > SageMC Custom Interface

Notices

SageMC Custom Interface This forum is for discussing the user-created SageMC custom interface for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old 04-27-2009, 11:17 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
I never knew my video allow enter to go directly to play. For me it takes me to AMIs or program info screen.

Are you using list view or folder view? In list view there is an option to make enter play but that option doesn't exist in folder view.
Reply With Quote
  #42  
Old 04-27-2009, 11:23 AM
toby toby is offline
Sage User
 
Join Date: Nov 2008
Posts: 25
Quote:
Originally Posted by PLUCKYHD View Post
I never knew my video allow enter to go directly to play. For me it takes me to AMIs or program info screen.

Are you using list view or folder view? In list view there is an option to make enter play but that option doesn't exist in folder view.
I'm using folder view. What button on keyboard do I need to press to invoke "Play" while in folder view.

I'm stuck this way until my pennies are enough for an HD-200
Reply With Quote
  #43  
Old 04-27-2009, 11:31 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Play

Keyboard shortcut is ctrl+d
Reply With Quote
  #44  
Old 04-27-2009, 01:10 PM
toby toby is offline
Sage User
 
Join Date: Nov 2008
Posts: 25
Quote:
Originally Posted by PLUCKYHD View Post
Play

Keyboard shortcut is ctrl+d
Thanks, I will try this tonight. Is there anyway to change it to "Enter"?
Reply With Quote
  #45  
Old 04-27-2009, 01:30 PM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Sure I will put it in as a feature request as well. That is an easy coding

For now the list view has that option to make enter play I didn't feel the wall in it's current state had enough info but that is soon changing as well.
Reply With Quote
  #46  
Old 04-27-2009, 03:17 PM
Peter_h Peter_h is offline
Sage Fanatic
 
Join Date: May 2008
Location: Kailua, HI
Posts: 798
Quote:
Originally Posted by PLUCKYHD View Post
Well the weekend is over almost 900 views I don't know how many downloads but I am going to guess no news is good news

Just for those interested I am starting work on the sage music and picture walls as well.
I have some requests/suggestions for the Sage Music. Do you want me to list, a new thread, or PM you?
Reply With Quote
  #47  
Old 04-27-2009, 04:03 PM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Quote:
Originally Posted by Peter_h View Post
I have some requests/suggestions for the Sage Music. Do you want me to list, a new thread, or PM you?
Let's keep that talk here
http://forums.sagetv.com/forums/showthread.php?t=41257

if you don't mind.
Reply With Quote
  #48  
Old 04-27-2009, 05:45 PM
Quazeye Quazeye is offline
Sage Advanced User
 
Join Date: Dec 2007
Posts: 81
I love movie wall. I do have an issue I just ran into though. I have been updating all my fanart and posters. After doing about 25 or 30 of these I have found that the movie wall has slowed to a crawl. Is there something I am doing wrong?

Q
________
RSV1000R

Last edited by Quazeye; 01-26-2011 at 12:23 AM.
Reply With Quote
  #49  
Old 04-27-2009, 05:49 PM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
What size is your java heap?

What view folder or list?

Is caching enabled?
Is it a pc or extender?
Reply With Quote
  #50  
Old 04-27-2009, 07:05 PM
Quazeye Quazeye is offline
Sage Advanced User
 
Join Date: Dec 2007
Posts: 81
How do I find the java heap size? What should it be?

It is folder view.

Caching is not enabled. Actually I am not sure.. where is this located?

I am currently testing on SageTV client before putting this on my server for 3 HD200's

Thank you for your help,
Q
________
vapir air one vaporizer

Last edited by Quazeye; 01-26-2011 at 12:24 AM.
Reply With Quote
  #51  
Old 04-27-2009, 07:33 PM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
a

In sagemc mc settings make sure cache at startup is enabled as wells as set the cache limit to -1 for no limit

Check babg app's in the download section his app allows you to easily adjust the heap siZe although I doubt that is your issue

When putting on you server make sure the extenders have caching enabled as well and make sure the sage properites file is setto enable hardware scaling=true

There is a link somewhere that tells you how to do all this sorry I can't provide details I am not on computer right now

You should not notice a slow down but could if bmi is still fetching in the backgound sometimes the easiest fix is to restart sage and service
Reply With Quote
  #52  
Old 04-27-2009, 10:48 PM
Quazeye Quazeye is offline
Sage Advanced User
 
Join Date: Dec 2007
Posts: 81
Hi again,

I did some testing and the slowdown (moving from movie to movie takes about 5 seconds) occurs on the server as well. I also tested by removing some of the fanart directories. When I do that the speed comes right back to normal. As soon as I add enough fanart directories back the speed slows down again. I have noticed that moviewall uses the posters (if there are any) as the folder picture instead of folder.jpg in each of the movies directories. Could this be an issue?

Thanks,
Q
________
Aprilia SL1000

Last edited by Quazeye; 01-26-2011 at 12:24 AM.
Reply With Quote
  #53  
Old 04-28-2009, 05:04 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Could yoou elaborate on what you mean by fanatt directories? You should only have one main fanart directory

Also by design yes it should use fanart poster over folder.jpeg as it is my understanding those are going away for fanart

I am not sure why you are seeing this slowdown I have over 200 movies loaded so far into sage all with fanart and don't see these issues

Is anyone else seeing this?
Are you seeing slowdown in the normal my videos with the same number of rows/columns?
Reply With Quote
  #54  
Old 04-28-2009, 07:13 AM
Quazeye Quazeye is offline
Sage Advanced User
 
Join Date: Dec 2007
Posts: 81
Sorry, I didn't say it very well. I have 1 fanart directory and what I did was move some of the movies out of that directory to test. When I moved the movies the speed came back. When I put the movies back the slow down occured.

One other thing I noticed is that if I delete the posters directories and use the fanart.jpg in the movies folder the speed seems to be fine. I don't know why that would be.

I found how to increase the Java Heap but that didn't help.

I also set the cache as you indicated. I could only find the cache called album art which is the one I set up.

Thank you for your help and for this very cool add-on... my wife loves it when I show her and she wants it on the HD200's as soon as I figure out this issue.

Q
________
KTM 65SX

Last edited by Quazeye; 01-26-2011 at 12:24 AM.
Reply With Quote
  #55  
Old 04-28-2009, 07:17 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Quote:
Originally Posted by Quazeye View Post
Sorry, I didn't say it very well. I have 1 fanart directory and what I did was move some of the movies out of that directory to test. When I moved the movies the speed came back. When I put the movies back the slow down occured.

One other thing I noticed is that if I delete the posters directories and use the fanart.jpg in the movies folder the speed seems to be fine. I don't know why that would be.

I found how to increase the Java Heap but that didn't help.

I also set the cache as you indicated. I could only find the cache called album art which is the one I set up.

Thank you for your help and for this very cool add-on... my wife loves it when I show her and she wants it on the HD200's as soon as I figure out this issue.

Q
I am curios why you are seeing this. Do you still have folder.jpegs in the video folders if so that might be why.

Is anyone else seeing this.

I may have some sample code I want to send your way to see if it resolves it if you don't mind.
Reply With Quote
  #56  
Old 04-28-2009, 07:23 AM
Quazeye Quazeye is offline
Sage Advanced User
 
Join Date: Dec 2007
Posts: 81
I do have folder.jpgs in the video folders. I will remove and see if that helps.

It would be fine to send me the code... I have to head to work now but I can try it later tonight.

Q
________
growing marijuana

Last edited by Quazeye; 01-26-2011 at 12:24 AM.
Reply With Quote
  #57  
Old 04-28-2009, 08:10 AM
matt91's Avatar
matt91 matt91 is offline
Sage Icon
 
Join Date: Feb 2005
Location: Washington, DC
Posts: 1,185
what size are your posters? Are they the "normal" size that get grabbed via the metadata tools? Or do you have 1MB + size files?
__________________
Server: Ubuntu 16.04 running Sage for Linux v9
Reply With Quote
  #58  
Old 04-28-2009, 08:40 AM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
That is a good point Matt

That may be the case but won't matter soon if I can get the new code down. I am going to use the new fanart scaling to scale them all the the size my app needs and cache them. They should then retrieve faster but I am trying to finish someother touchup-changes right now.

Quote:
Originally Posted by matt91 View Post
what size are your posters? Are they the "normal" size that get grabbed via the metadata tools? Or do you have 1MB + size files?
Reply With Quote
  #59  
Old 04-28-2009, 09:23 AM
Dravor Dravor is offline
Sage User
 
Join Date: Mar 2009
Location: Ashburn, Va
Posts: 24
Quote:
Originally Posted by PLUCKYHD View Post
That is a good point Matt

That may be the case but won't matter soon if I can get the new code down. I am going to use the new fanart scaling to scale them all the the size my app needs and cache them. They should then retrieve faster but I am trying to finish someother touchup-changes right now.
Hmmm I have around 450-470 or so movies in my library and don't have any issues. The local folder.jpg file in each movie folder would only slow things down if the fanart folder does not have the cover art.

I would check the following:

1) Ensure Caching is turned on.
2) Ensure Fanart and all relevent settings are enabled <although if you are seeing them they should be anyways>
3) Give us the versions of the settings page for Sage MC, and all the other components.


-Dravor
Reply With Quote
  #60  
Old 04-28-2009, 02:42 PM
PLUCKYHD PLUCKYHD is offline
SageTVaholic
 
Join Date: Dec 2007
Posts: 6,257
Hey guys I added this screenshot to the main post but wanted to share here for those of you subscribed to this thread

Detailed Poster view screencap

This is simply accessed by hitting the info button while in folder view. Plus you might want to check out the second post to see other new features coming in the next build.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STV Import: Video Editing for Sage BobPhoenix SageTV Customizations 279 03-07-2013 01:35 PM
STV Import: MovieTimes Movie Listings Import v0.57 Beta aperry SageTV Customizations 670 10-02-2010 12:07 AM
STV Import: SageMC MovieTimes Movie Listings v0.64 Morgan111 SageMC Custom Interface 419 10-01-2010 11:06 PM
STV Import: Movie Info Screen V.1.0 jaminben SageMC Custom Interface 398 01-17-2010 02:40 PM
STV IMPORT: Exit Sage plugin (1.1 12/Jan/2006) nielm SageTV Customizations 8 10-06-2006 07:11 AM


All times are GMT -6. The time now is 07:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.