SageTV Community  

Go Back   SageTV Community > SageTV Products > SageTV EPG Service

Notices

SageTV EPG Service Discussion related to the SageTV EPG Service used within SageTV. Questions about service area coverage, channel lineups, EPG listings, XMLTV, or anything else related to the service or programming guide data for SageTV should be posted here.

Reply
 
Thread Tools Search this Thread Display Modes
  #461  
Old 03-11-2019, 04:05 PM
sflamm sflamm is offline
Sage Icon
 
Join Date: Mar 2009
Posts: 1,650
NO DATA - EPG

Just installed a brand new standalone version of 9.1.10 and configured SD EPG... getting same "NO DATA" on the EPG. (see attached)

Please advise....
Attached Images
File Type: jpg no data epg.JPG (115.5 KB, 36 views)
Reply With Quote
  #462  
Old 03-11-2019, 04:15 PM
sflamm sflamm is offline
Sage Icon
 
Join Date: Mar 2009
Posts: 1,650
turned on the SD debug:

debug_sd=true

found it loading data... and it finally finished properly (see attached)

my main installation also seems to be loading some info... but not the whole EPG..?
Attached Images
File Type: jpg epg data.JPG (187.5 KB, 110 views)
Reply With Quote
  #463  
Old 03-11-2019, 04:41 PM
wnjj wnjj is offline
Sage Icon
 
Join Date: Jan 2009
Posts: 1,051
Quote:
Originally Posted by Tiki View Post
I don’t think the Sage version should matter - no changes in Sage related to SD in a long time. More likely a problem with Schedules Direct. I’ve seen a few posts here from time to time where SD drops or renames a particular lineup to something slightly different. This of course only affects the handful of people using that particular lineup. You may have to tell Sage to use a “new” lineup and then go through the process of setting up the lineup in Sage again.
From that old of a version (9.0.14) there have been some SD changes, one in particular that was causing null pointer exceptions.

Try an EPG update, then look in the sagetv_0.txt log file for errors (or post it on here).

EDIT: Didn't see the OP's later posts before writing this. Disregard.
Reply With Quote
  #464  
Old 03-11-2019, 06:23 PM
EnterNoEscape's Avatar
EnterNoEscape EnterNoEscape is offline
SageTVaholic
 
Join Date: Jun 2010
Location: Harrisburg, PA
Posts: 2,504
Quote:
Originally Posted by sflamm View Post
turned on the SD debug:

debug_sd=true

found it loading data... and it finally finished properly (see attached)

my main installation also seems to be loading some info... but not the whole EPG..?
SageTV doesn't do some activities until after the EPG update such as filling in all of the gaps with No Data. What stations are missing? I should be able to tell what's happening from the sdmd5sched file. sd_epg.log could also be helpful, but based on what you're saying about it finishing successfully, it's probably not going to reveal anything I can't reproduce myself.
__________________
SageTV v9 Server: ASRock Z97 Extreme4, Intel i7-4790K @ 4.4Ghz, 32GB RAM, 6x 3TB 7200rpm HD, 2x 5TB 7200rpm HD, 2x 6TB 7200rpm HD, 4x 256GB SSD, 4x 500GB SSD, unRAID Pro 6.7.2 (Dual Parity + SSD Cache).
Capture: 1x Ceton InfiniTV 4 (ClearQAM), 2x Ceton InfiniTV 6, 1x BM1000-HDMI, 1x BM3500-HDMI.

Clients: 1x HD300 (Living Room), 1x HD200 (Master Bedroom).
Software: OpenDCT :: WMC Live TV Tuner :: Schedules Direct EPG
Reply With Quote
  #465  
Old 03-12-2019, 02:01 AM
sflamm sflamm is offline
Sage Icon
 
Join Date: Mar 2009
Posts: 1,650
Thanks for the quick responses.

The EPG data remained at "No data" for almost 24 hours... During that time I attempted to force multiple manual EPG updates (toggling the channel assignments)... I also completely removed the old SD lineup and redid it ... but nothing seemed to resolve the issue.

I ended up purging my 9.0.14 installation then installing 9.1.10 and reloading my configuration. That seems to have worked fine. Now the EPG data is complete. When I imported my old wiz.bin it initially showed "no data" but it quickly resolved itself...

I have a second installation on 9.0.14... it too started suddenly is encountering the same issue at the same time. If I install 9.1.10 directly over it (upgrade) will / should that achieve the same result as starting from scratch?
Reply With Quote
  #466  
Old 03-12-2019, 06:26 PM
waynedunham waynedunham is offline
Sage Icon
 
Join Date: Sep 2004
Posts: 1,362
Quote:
Originally Posted by sflamm View Post
Thanks for the quick responses.

The EPG data remained at "No data" for almost 24 hours... During that time I attempted to force multiple manual EPG updates (toggling the channel assignments)... I also completely removed the old SD lineup and redid it ... but nothing seemed to resolve the issue.

I ended up purging my 9.0.14 installation then installing 9.1.10 and reloading my configuration. That seems to have worked fine. Now the EPG data is complete. When I imported my old wiz.bin it initially showed "no data" but it quickly resolved itself...

I have a second installation on 9.0.14... it too started suddenly is encountering the same issue at the same time. If I install 9.1.10 directly over it (upgrade) will / should that achieve the same result as starting from scratch?
Just an FYI, but EPG updates take several hours to filter into the scheduled recordings on my system and have for a long time, probably longer than I remember since I wasn't looking for it.
For instance I'll get a notice shortly after an EPG update saying that 'xx' manual recording will no longer record program 'yy', the new program is 'zz', be it either a different program or even something that doesn't say what it is since the manual times don't match the EPG. However if I go to the recordings schedule and call up the program info it will show the new program name, however if it was for a favorite it will still show the favorite icon as well as if you go to the recording options it will still show the "favorite" even though the EPG data shows the correct new program.
After an hour or two everything will settle down and the EPG data and recordings schedule will agree.
__________________
Wayne Dunham
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugin: Schedules Direct EPG (not for v9) Slugger SageTV v7 Customizations 851 07-19-2017 07:48 AM
Schedules Direct Plugin Issue rickgillyon SageTV v9 Customizations 20 09-25-2016 12:03 PM
Schedules Direct EPG Plugin: Call for private beta testers Slugger SageTV v7 Customizations 11 01-19-2013 11:59 AM
Schedules Direct EPG Plugin PoC Completed Slugger SageTV EPG Service 71 12-04-2011 12:12 PM
Schedules Direct or what? Ryel SageTV EPG Service 6 01-25-2008 03:03 PM


All times are GMT -6. The time now is 07:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.