SageTV Community  

Go Back   SageTV Community > Information & Announcements > SageTV Downloads & Instructions

Notices

SageTV Downloads & Instructions This forum is for discussions containing Downloads and Instructions related to the Open Source version of SageTV. Please do not post questions in this forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-22-2019, 01:15 PM
doodeedoo doodeedoo is offline
Sage User
 
Join Date: Apr 2007
Location: Romeoville, IL
Posts: 19
EventGhost, USB UIRT and 64bit not working

Does anyone have EventGhost working with USB UIRT and SageTV 64 bit?

Fresh install of STV 9.2.1 64 bit on Windows 10

USB UIRT installed and working with STV only, both receiving and sending, after copying the 2 files

EG both versions 4 R1722 and 5 RC6. UUIRT works with both versions if STV is not running

Cannot get both STV and EG to use UUIRT at same time. Whichever program starts first grabs control of UUIRT (send and receive) and the other can't use. STV just does not respond via UUIRT if EG is started first. If STV is started first, EG log states 'Error starting plugin' and 'Device not found'.

Fresh install of STV 9.2.1 32 bit on same system works correctly with UUIRT and EvenGhost at the same time.

Last edited by doodeedoo; 06-22-2019 at 01:26 PM.
Reply With Quote
  #2  
Old 06-24-2019, 05:48 AM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,801
You said you have both transmitting and receiving working at the same time in Sage 64-Bit for Windows? Were you using Sage in service mode (where the recording engine runs as a separate process from the UI), or in stand-alone mode (where closing the UI stops the recording engine)?

I am guessing you were using stand-alone mode. Because I could not get this to work in Service mode.

I don't use Event Ghost, but I would guess that the same issue that prevents the USBUIRT from working correctly with Sage in Service Mode would also prevent it from working with two different programs at the same time.
__________________
Server: Athlon II X4 630 CPU, Gigabyte MA770T-UD3P (AM3) Motherboard, VisionTek Radeon HD4670 PCIe w/ Component output to 50" CRT Rear-Projection HDTV (Mitsubishi), Win7-64Bit (Home Premium), 4GB RAM
Capture Devices (8 tuners): Colossus (x1), HD-PVR (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250
Reply With Quote
  #3  
Old 06-24-2019, 01:26 PM
JustFred JustFred is offline
Sage Aficionado
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 415
Quote:
Originally Posted by doodeedoo View Post
Cannot get both STV and EG to use UUIRT at same time. Whichever program starts first grabs control of UUIRT (send and receive) and the other can't use. STV just does not respond via UUIRT if EG is started first. If STV is started first, EG log states 'Error starting plugin' and 'Device not found'.

Fresh install of STV 9.2.1 32 bit on same system works correctly with UUIRT and EvenGhost at the same time.
Is EventGhost a 32-bit program?

I just discovered that attempting to use USB-UIRT by other programs fails whenever Sage-x64 is running. But accessing USB-UIRT from a 32-bit program while running Sage-x86 works fine.

I've built a new uu_irsage.dll for Sage-x64 with a fix that looks like it works in my test cases. Send me a PM if you'd like to test it out.
__________________
System #1: Win7-64, Core2-Quad Q9400, 8 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB Mem, 2TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HVR2250; Spectrum Cable via HDPVR & USB-UIRT. 3x HD-200.

Last edited by JustFred; 06-24-2019 at 02:45 PM.
Reply With Quote
  #4  
Old 06-24-2019, 05:28 PM
Tiki's Avatar
Tiki Tiki is offline
Sage Icon
 
Join Date: Feb 2005
Location: Southwest Florida, USA
Posts: 1,801
Quote:
Originally Posted by JustFred View Post
Is EventGhost a 32-bit program?

I just discovered that attempting to use USB-UIRT by other programs fails whenever Sage-x64 is running. But accessing USB-UIRT from a 32-bit program while running Sage-x86 works fine.

I've built a new uu_irsage.dll for Sage-x64 with a fix that looks like it works in my test cases. Send me a PM if you'd like to test it out.
Will this also fix the problem with not being able to use transmitter and receiver at same time with 64-bit Sage in service mode?
__________________
Server: Athlon II X4 630 CPU, Gigabyte MA770T-UD3P (AM3) Motherboard, VisionTek Radeon HD4670 PCIe w/ Component output to 50" CRT Rear-Projection HDTV (Mitsubishi), Win7-64Bit (Home Premium), 4GB RAM
Capture Devices (8 tuners): Colossus (x1), HD-PVR (x1), HDHR Prime (x2)
,USBUIRT (multi-zone)
Source:
Comcast Cable
Primary Client: Server Other Clients: (1) HD200, (1) HD300
Retired Equipment: MediaMVP, PVR150 (x2), PVR150MCE,
HDHR, HVR-2250
Reply With Quote
  #5  
Old 06-24-2019, 05:48 PM
JustFred JustFred is offline
Sage Aficionado
 
Join Date: May 2015
Location: Sunnyvale, Ca
Posts: 415
Quote:
Originally Posted by Tiki View Post
Will this also fix the problem with not being able to use transmitter and receiver at same time with 64-bit Sage in service mode?
Unknown. I've always been able to both Tx & Rx from within the Sage-x64 server in service mode. Never was able to duplicate the problem you refer to. PM me if you'd like to try my uu_irsage.dll. No harm to try it.
__________________
System #1: Win7-64, Core2-Quad Q9400, 8 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HDHR-US (1st gen white) tuners. HD-200.
System #2: Win7-64, I7-920, 8 GB Mem, 2TB HD. Java 1.8.0_131. Sage v9.1.6.747. ClearQAM: 2x HDHR3-US tuners. HD-200.
System #3: Win7-64, I7-920, 12 GB Mem, 4TB HD. Java-64 1.8.0_141. Sage-64 v9.2.1 ATSC: 2x HVR2250; Spectrum Cable via HDPVR & USB-UIRT. 3x HD-200.
Reply With Quote
  #6  
Old 06-25-2019, 06:12 PM
doodeedoo doodeedoo is offline
Sage User
 
Join Date: Apr 2007
Location: Romeoville, IL
Posts: 19
JustFred, thanks for sharing the dll. Unfortunately did not allow EG and SageTV to share the UUIRT.

Tiki, yes, stand alone mode.
Reply With Quote
  #7  
Old 07-31-2019, 03:03 PM
Malfunction Malfunction is offline
Sage Advanced User
 
Join Date: Sep 2004
Location: Willoughby, Ohio
Posts: 198
Quote:
Originally Posted by doodeedoo View Post
Does anyone have EventGhost working with USB UIRT and SageTV 64 bit?

Fresh install of STV 9.2.1 64 bit on Windows 10

USB UIRT installed and working with STV only, both receiving and sending, after copying the 2 files

EG both versions 4 R1722 and 5 RC6. UUIRT works with both versions if STV is not running

Cannot get both STV and EG to use UUIRT at same time. Whichever program starts first grabs control of UUIRT (send and receive) and the other can't use. STV just does not respond via UUIRT if EG is started first. If STV is started first, EG log states 'Error starting plugin' and 'Device not found'.

Fresh install of STV 9.2.1 32 bit on same system works correctly with UUIRT and EvenGhost at the same time.
If you're running an HD-PVR2, try using the IR blaster that ships with it. I got that working with Sage 64, unfortunately my video isn't usable.
__________________
ASUS P7H55D-EVO LGA 1156 Motherboard, Intel Core I5-661, 2X Crucial Ballistix XMS3 2GB RAM, 2x Mushkin Blackline 4G RAM, HIS 6570 Silent, 1x Samsung 250g SSD, 1x WD80EFAX 8TB, 2x WDBH2D0040HNC 4TB, USB-UIRT, ASUS Blu-Ray SATA drive, HD-PVR2, WinTV dualHD, Windows 7 64bit
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows 64bit Installer Not Working on Windows 7 will SageTV Downloads & Instructions 8 01-23-2019 04:59 PM
Linux 64bit MiniClient (issues with JTux on 64bit) stuckless SageTV Github Development 23 08-19-2015 12:54 PM
Windows 8 Pro 64bit + Vbox DTA-150 not working laberet Hardware Support 4 12-31-2012 07:50 PM
Wake Up my HTPC with USB-UIRT/Eventghost/W7/MSI board THX-UltraII Hardware Support 1 06-08-2011 02:14 AM
Sharing USB-UIRT w/ SageTV and Eventghost? peternm22 Hardware Support 3 04-03-2011 10:45 PM


All times are GMT -6. The time now is 10:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.