SageTV Community  

Go Back   SageTV Community > SageTV Development and Customizations > SageTV v7 Customizations > Batch Metadata Tools

Notices

Batch Metadata Tools This forums is for discussing the user-created Batch Metadata Tools for SageTV.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-25-2017, 12:34 AM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 607
BMT Adding Extra Space In Meta Data Lookup

I'm having a little trouble getting BMT to recognize a certain title/series. The file name is: DCs.Legends.of.Tomorrow.S01E04.mkv

When I click Discover Defaults in Find Metadata, the title comes up as "D Cs Legends of Tomorrow". The extra space in "D Cs" causes the lookup to fail on tvdb. If that space is removed, the search works properly. I'm guessing BMT is adding an extra space in there due to the capital letters, it assumes they are separate words.

I'm guessing this can be fixed by using Add Matcher, but I'm not sure what to put in for Match Filename Pattern. I did a quick read of that section of the manual, but my various attempts at Regex failed (I think that field uses regex, but maybe that's just the mediatitles.xml file?).

Any ideas?

Thanks.
Reply With Quote
  #2  
Old 01-25-2017, 05:22 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Typically you shows will be organized by folder, so use the foldername as the matcher.
Reply With Quote
  #3  
Old 01-25-2017, 08:01 PM
peternm22 peternm22 is offline
Sage Expert
 
Join Date: Jan 2005
Posts: 607
Hi Stuckless,

I'm still not having much luck. The folder the file is in is named "DCs Legends of Tomorrow". So the path is "D:\Sage\Imports\DCs Legends of Tomorrow\DCs.Legends.of.Tomorrow.S01E04.mkv"

These are the matchers I've tried:

Code:
  <match>
    <regex>[\\/]DCsLegends-.*</regex>
    <title>DC's Legends of Tomorrow</title>
    <metadata type="TV" name="tvdb">295760</metadata>
  </match>
  <match>
    <regex>[\\/]Legends</regex>
    <metadata type="TV" name="tvdb">295760</metadata>
  </match>
  <match>
    <regex>[\\/]DCs[\\/]</regex>
    <metadata type="TV" name="tvdb">295760</metadata>
  </match>
And still not matching automatically. Any other ideas? If I rename the MKV file and change all of the periods to spaces, it is matched correctly. Is there anyway to have BMT treat periods like spaces?

Thanks.
Reply With Quote
  #4  
Old 01-26-2017, 05:57 AM
stuckless's Avatar
stuckless stuckless is offline
SageTVaholic
 
Join Date: Oct 2007
Location: London, Ontario, Canada
Posts: 9,541
Did you add these using the "Add Matcher" button in BMT? In bmt, once you find the correct metadata for 1 item, use "Add Matcher" select the "match foldername pattern" option and enter the EXACT (copy it from the file path in the dialog) directory name (since that's never going to change), and then select remove duplicate entries, and save.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ways to add extra meta data that will appear in recording details? michaeldjcox SageTV v7 Customizations 1 12-08-2014 09:35 AM
How to get Meta Data with WHS? richs SageTV v7 Customizations 1 11-28-2010 06:08 AM
How to refresh meta data? bits SageMC Custom Interface 3 12-26-2009 11:11 PM
lookup.xml for Radio Times data? Alfiegerner SageTV United Kingdom 2 09-09-2007 03:27 PM
Adding extra data to favorites wakebdr SageTV Studio 3 03-16-2007 04:42 PM


All times are GMT -6. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2003-2005 SageTV, LLC. All rights reserved.